1053 Path of Equal Weight (30 分)

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

解析:用vector存树,按照weight从大到小排序,再dfs中记录路径。

#include<set>
#include<map>
#include<list>
#include<queue>
#include<deque>
#include<cmath>
#include<stack>
#include<cstdio>
#include<string>
#include<bitset>
#include<vector>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<bits/stdc++.h>
using namespace std;#define e exp(1)
#define p acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b) {return b?gcd(b,a%b):a;
}struct node{int weight;vector<int> children;
};
vector<node> tree;
vector<int> path;
int n,m,w;bool cmp(int a,int b)
{return tree[a].weight>tree[b].weight;
}void dfs(int s,int sum)
{if(sum>w)return ;if(sum==w){if(tree[s].children.size()!=0)return ;printf("%d",tree[0].weight);for(int i=0; i<path.size(); i++){printf(" %d",path[i]);}printf("\n");}for(int i=0; i<tree[s].children.size(); i++){int now=tree[s].children[i];path.push_back(tree[now].weight);dfs(now,sum+tree[now].weight);path.pop_back();}
}
int main()
{scanf("%d%d%d",&n,&m,&w);tree.resize(n);for(int i=0; i<n; i++){scanf("%d",&tree[i].weight);}int id,k;for(int i=0; i<m; i++){scanf("%d%d",&id,&k);tree[id].children.resize(k);for(int j=0; j<k; j++){scanf("%d",&tree[id].children[j]);}sort(tree[id].children.begin(),tree[id].children.end(),cmp);}dfs(0,tree[0].weight);return 0;
}

1053 Path of Equal Weight相关推荐

  1. PAT甲级1053 Path of Equal Weight (30分) :[C++题解]dfs求树的路径长度、邻接表

    文章目录 题目分析 题目链接 题目分析 输入样例: 20 9 24 10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2 00 4 01 02 03 04 02 1 ...

  2. PAT (Advanced Level) Practice 1053 Path of Equal Weight (30 分)

    1053 Path of Equal Weight (30 分) Given a non-empty tree with root R, and with weight Wi assigned to ...

  3. 1053 Path of Equal Weight (30分)

    1053 Path of Equal Weight (30分) Given a non-empty tree with root R, and with weight W​i​​ assigned t ...

  4. PAT甲级 -- 1053 Path of Equal Weight (30 分)

    Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weig ...

  5. 1053 Path of Equal Weight(超级无敌详细注释+45行代码)

    分数 30 全屏浏览题目 切换布局 作者 CHEN, Yue 单位 浙江大学 Given a non-empty tree with root R, and with weight Wi​ assig ...

  6. 1053 Path of Equal Weight (30 分)

    题目 Given a non-empty tree with root R, and with weight WiW_iWi​ assigned to each tree node TiT_iTi​. ...

  7. PAT:1053. Path of Equal Weight (30) AC

    #include<stdio.h> #include<vector> #include<queue> #include<algorithm> using ...

  8. 1053 Path of Equal Weight

    1. 以下两组关系很大的概念 树的深度优先搜索 - 先根遍历 - 递归 树的广度优先搜索 - 层序遍历 - 非递归 本题考察的是前者,我设置了这样一个结构体 struct Prestruct{int ...

  9. 1053 Path of Equal Weigh(甲级)

    1053 Path of Equal Weight (30分) Given a non-empty tree with root R, and with weight W ​i ​​ assigned ...

最新文章

  1. 利用java打印正三角形_JAVA一层for循环实现打印正三角形和到三角形
  2. hive与hbase整合方式和优劣
  3. linux驱动静态分配内存,Linux驱动设计——内存与IO访问
  4. 前端学习(3340):ant design中icon图标的使用
  5. Copying to tmp table Problem Solving
  6. 【excel技巧读书笔记001】清除打开过的文件记录
  7. java 调用dll 方法 postmessage实现后台模拟按键_VB实现模拟键盘及模拟鼠标(后台操作)...
  8. 【资料分享】《建筑照明设计标准》(GB50034-2013)
  9. 苹果怎么用计算机解锁,苹果ios10密码解锁设置图文教程 怎么用密码解锁
  10. 用增广矩阵的秩判断N线性方程的解的个数
  11. 为什么平方损失函数不适应于分类问题?——从概率论的角度
  12. 【学习笔记】STM32hal库开发入门笔记
  13. 找出1000瓶牛奶中有毒的牛奶
  14. C#中{0}表示什么意思?
  15. 三代组装软件Canu使用
  16. 13-mac中插入SD卡无法格式化,无法删除文件,只读
  17. 教你简单学会用Python画长草颜团子
  18. java 文件 模板 替换_JAVA 处理Word模板文件,替换其中的占位符
  19. 2021-01-25广州大学ACM寒假训练赛解题心得
  20. 计算机到未识别网络有个叹号,上网异常:出现黄色感叹号不能上网的两种解决方案...

热门文章

  1. java的for循环的几种写法
  2. 针对监控摄像机(海康、大华等)进行手动录像的录像文件播放器功能设计
  3. CentOS 下安装
  4. Unity UGUI - Canvas / Camera
  5. 使用 WordPress 插件模板开发高质量插件
  6. (转)Python 用hashlib求中文字符串的MD5值
  7. LINUX下的文件结构介绍
  8. springboot1——第一个springboot程序
  9. 以LeNet为例分析CNN中的参数量
  10. 博客积分规则 博客等级