1053 Path of Equal Weight (30分)
Given a non-empty tree with root R, and with weight W
​i
​​ assigned to each tree node T
​i
​​ . The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.
Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2
​30
​​ , the given weight number. The next line contains N positive numbers where W
​i
​​ (<1000) corresponds to the tree node T
​i
​​ . Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.
Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.
Note: sequence {A
​1
​​ ,A
​2
​​ ,⋯,A
​n
​​ } is said to be greater than sequence {B
​1
​​ ,B
​2
​​ ,⋯,B
​m
​​ } if there exists 1≤k<min{n,m} such that A
​i
​​ =B
​i
​​ for i=1,⋯,k, and A
​k+1
​​ >B
​k+1
​​ .
Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
思路:
步骤1:
一颗普通性质树,以结构体node存放数据域和指针域,其中指针域使用vector存放孩子节点编号,考虑到最后输出需要按权值从大到小排序,因此在数据读入时就进行节点排序。
步骤2:
用vector path对路径进行记录,接下来进行dfs,
如果weight>输入的权重num,返回;
如果weight==输入的权重num,进行节点判断,如果为叶子节点,输出路径,否则return;
如果weight<输入的权重num,进入下一层递归

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn = 101;
int n, m, num;
struct info
{int data;//数据域,存储节点的weightvector<int>v;//指针域,存储孩子节点
}node[maxn];//节点数组
vector<int>path;
bool cmp(int  a, int b)//节点数据域从大到小排序
{return node[a].data > node[b].data;
}
void dfs(int root,int weight)
{if (weight > num)return;//当前总重量大于numif (weight == num)//{if (node[root].v.size() > 0)return;//存在叶子节点for (int i = 0; i < path.size(); i++)//为叶子节点{if (i == 0)cout << node[path[i]].data;else cout << " " << node[path[i]].data;}cout << endl;return;}for (int i = 0; i < node[root].v.size(); i++){path.push_back(node[root].v[i]);//用path存储路径dfs(node[root].v[i], weight + node[node[root].v[i]].data);path.pop_back();//回溯时记得弹出}
}
int main()
{cin >> n >> m >> num;for (int i = 0; i < n; i++){cin >> node[i].data;}for (int i = 0; i < m; i++){int parent,k,child;cin >> parent >> k;for (int j = 0; j < k; j++){cin >> child;node[parent].v.push_back(child);}sort(node[parent].v.begin(), node[parent].v.end(),cmp);}path.push_back(0);//将节点0先存入路径dfs(0, node[0].data);
}

1053 Path of Equal Weigh(甲级)相关推荐

  1. PAT甲级1053 Path of Equal Weight (30分) :[C++题解]dfs求树的路径长度、邻接表

    文章目录 题目分析 题目链接 题目分析 输入样例: 20 9 24 10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2 00 4 01 02 03 04 02 1 ...

  2. 1053 Path of Equal Weight

    1053 Path of Equal Weight (30 分) Given a non-empty tree with root R, and with weight W​i​​ assigned ...

  3. PAT (Advanced Level) Practice 1053 Path of Equal Weight (30 分)

    1053 Path of Equal Weight (30 分) Given a non-empty tree with root R, and with weight Wi assigned to ...

  4. 1053 Path of Equal Weight (30分)

    1053 Path of Equal Weight (30分) Given a non-empty tree with root R, and with weight W​i​​ assigned t ...

  5. PAT甲级 -- 1053 Path of Equal Weight (30 分)

    Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weig ...

  6. 1053 Path of Equal Weight(超级无敌详细注释+45行代码)

    分数 30 全屏浏览题目 切换布局 作者 CHEN, Yue 单位 浙江大学 Given a non-empty tree with root R, and with weight Wi​ assig ...

  7. 1053 Path of Equal Weight (30 分)

    题目 Given a non-empty tree with root R, and with weight WiW_iWi​ assigned to each tree node TiT_iTi​. ...

  8. PAT:1053. Path of Equal Weight (30) AC

    #include<stdio.h> #include<vector> #include<queue> #include<algorithm> using ...

  9. 1053 Path of Equal Weight

    1. 以下两组关系很大的概念 树的深度优先搜索 - 先根遍历 - 递归 树的广度优先搜索 - 层序遍历 - 非递归 本题考察的是前者,我设置了这样一个结构体 struct Prestruct{int ...

最新文章

  1. SiamNet: 全卷积孪生网络用于视频跟踪
  2. python tfidf特征变换_Python机器学习之“特征工程”
  3. RequestDispatcher.forward() 与 HttpServletResponse.sendRedirect()的区别
  4. 迁移SVN注意事项及操作方法
  5. CodeForces - 1200C——小模拟
  6. ntr模式_ntr什么意思?求详细解释。。。
  7. 代码版本管理 GitLab介绍
  8. java cache教程_Java 中常用缓存Cache机制的实现
  9. HTML section 标签
  10. 17秋 软件工程 团队作业 同学录
  11. [UE4]关闭自动曝光
  12. nginx工作原理及配置
  13. 财商第2课笔记_复利
  14. STM32F407单片机移植ADS1115驱动程序
  15. QTP网管自动化测试框架
  16. 一些计算机u口无法使用的原因,电脑USB接口不能使用的原因分析
  17. php电商开发系统shopnc,shopnc二次开发(一),shopnc二次开发(_PHP教程
  18. jdk1.8 在綫英文+有道翻譯版
  19. GitHub中开启二次验证Two-factor authentication,如何在命令行下更新和上传代码
  20. 格式化磁盘重装ubuntn18.04系统后恢复timeshift备份文件

热门文章

  1. 陈华钧 | 知识图谱构建,将成为智能金融的突破口
  2. Jq将字符串复制粘贴到剪贴板
  3. C++ 空字符('\0')和空格符(' ')
  4. SpringCloud03 Ribbon知识点、 Feign知识点、利用RestTemplate+Ribbon调用远程服务提供的资源、利用feign调用远程服务提供的资源、熔断...
  5. 【HAOI2010】工厂选址题解
  6. ABP文档翻译--值对象
  7. python_递归原理
  8. 第二阶段个人工作总结08
  9. 状态压缩 之 UVA 10944 - Nuts for nuts..
  10. 博文视点大讲堂36期——让Oracle跑得更快 成功举办