1053 Path of Equal Weight (30 分)

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti
​​ . The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230, the given weight number. The next line contains N positive numbers where W​i (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1,A2,⋯,An} is said to be greater than sequence {B​1,B2,⋯,Bm} if there exists 1≤k<min{n,m} such that Ai =Bi for i=1,⋯,k, and Ak+1>Bk+1.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

我感觉这题目测试点还可以更难,这个好像只有一级相同,如果二级也相同呢。

#include <string>
#include <iostream>
#include <vector>
#include <algorithm>
#include <math.h>
#define max_size 101
using namespace std;
int n, m, s, total;
struct node
{int w;vector<int> sons;
};
node tree[max_size];
vector<int> path;
bool isRoot[max_size];
bool cmp(int a, int b)
{if (tree[a].w != tree[b].w){return tree[a].w > tree[b].w;}else{return false;}
}
void dfs(int root)
{total += tree[root].w;path.push_back(tree[root].w);if (total > s){total -= tree[root].w;path.pop_back();return;}else if (total == s){if (tree[root].sons.size() == 0)for (int i = 0; i < path.size(); i++){cout << path[i];if (i == path.size() - 1){cout << endl;}elsecout << " ";}total -= tree[root].w;path.pop_back();return;}sort(tree[root].sons.begin(), tree[root].sons.end(), cmp);for (int i = 0; i < tree[root].sons.size(); i++){dfs(tree[root].sons[i]);}total -= tree[root].w;path.pop_back();
}
int main()
{cin >> n >> m >> s;fill(isRoot, isRoot + n, true);for (int i = 0; i < n; i++){cin >> tree[i].w;}for (int i = 0; i < m; i++){int a, b, c;string sa, sc;cin >> sa >> b;a = (sa[0] - '0') * 10 + sa[1] - '0';for (int j = 0; j < b; j++){cin >> sc;c = (sc[0] - '0') * 10 + sc[1] - '0';tree[a].sons.push_back(c);isRoot[c] = false;}}int root;for (root = 0; root < n; root++){if (isRoot[root])break;}dfs(root);return 0;
}

Special thanks to Zhang Yuan and Yang Han for their contribution to the judge’s data.

PAT (Advanced Level) Practice 1053 Path of Equal Weight (30 分)相关推荐

  1. PAT甲级1053 Path of Equal Weight (30分) :[C++题解]dfs求树的路径长度、邻接表

    文章目录 题目分析 题目链接 题目分析 输入样例: 20 9 24 10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2 00 4 01 02 03 04 02 1 ...

  2. 1053 Path of Equal Weight (30分)

    1053 Path of Equal Weight (30分) Given a non-empty tree with root R, and with weight W​i​​ assigned t ...

  3. PAT甲级 -- 1053 Path of Equal Weight (30 分)

    Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weig ...

  4. PAT:1053. Path of Equal Weight (30) AC

    #include<stdio.h> #include<vector> #include<queue> #include<algorithm> using ...

  5. 【PAT (Advanced Level) Practice】1086 Tree Traversals Again (25 分)

    众所周知只有前序遍历和后序遍历是不可能推出中序遍历的,所以我就不废话了 由树的前序遍历和中序遍历可以推后序遍历 由树的中序遍历和后序遍历可以推前序遍历 #include <cstdio> ...

  6. 【PAT (Advanced Level) Practice】1149 Dangerous Goods Packaging (25 分)

    1149 Dangerous Goods Packaging (25 分) When shipping goods with containers, we have to be careful not ...

  7. 【PAT (Advanced Level) Practice】1054 The Dominant Color (20 分)

    1054 The Dominant Color (20 分) Behind the scenes in the computer's memory, color is always talked ab ...

  8. 【PAT (Advanced Level) Practice】1113 Integer Set Partition (25 分)

    #include<iostream> #include<cstdio> #include<string> #include<cstring> #incl ...

  9. 【PAT (Advanced Level) Practice】1005 Spell It Right (20 分)

    #include<iostream> #include<cstdio> #include<cstdlib> #include<string> #incl ...

最新文章

  1. mac os mysql 命令_如何在Mac OS上安装“mysql”命令?
  2. git merge 回退_Git项目开发必备命令
  3. 高级指引——自定义节点
  4. jQuery实现文字向上滚动
  5. java简易扑克牌_简易扑克牌游戏(java)
  6. 软件工程(2019)第二次作业
  7. 做好产品的孵化器 淘特上线10元店、淘特100
  8. php中数组的指针函数参数传递参数,循环语句、函数的参数及作用域、数组键值及指针操作函数(8月23日作业)...
  9. 个人项目需求与分析——点菜系统App
  10. 达观杯文本智能处理挑战赛冠军解决方案
  11. 二叉树转为单链表——Flatten Binary Tree to Linked List
  12. 面试丨求职时这样回答问题你就输了!来自IT面试官视角的深度解读
  13. python进程池apply与apply_async的区别
  14. 服务器cpu型号各个数字,服务器cpu型号 数字
  15. oop部分,构造方法,this的使用。
  16. 基于STM32F407使用ADC采集电压实验
  17. 偏最小二乘回归(PLSR)和主成分回归(PCR)
  18. Varian OBI几个奇葩之处
  19. Quantinuum将与三井物产开展量子计算研究合作
  20. C Primer Plus 第九章 大二第二学期 第二天学习

热门文章

  1. (立下flag)每日10道前端面试题-15 关于【高级技巧】十问
  2. 【Windows程序设计】模拟时钟
  3. 【微电网优化】基于matlab粒子群算法求解微网经济调度和环境友好调度优化问题【含Matlab源码 2283期】
  4. Win10安装不上VC++2008错误1935解决方法
  5. 看图说话:从图片到文字
  6. 总之,总而言之的不同英文表达方式
  7. shell脚本(一)批量修改图片名称
  8. 踏山河各种版本,求各位小伙伴点个关注
  9. sqlserver broker远端端点证书认证
  10. 敷完面膜后要擦水乳吗_贴完面膜要不要涂水乳