1053 Path of Equal Weight (30分)

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

Special thanks to Zhang Yuan and Yang Han for their contribution to the judge's data.

#include "iostream"

#include "vector"

#include "algorithm"

using namespace std;

const int maxn=100;

int path[maxn];

struct node{

int data;

int weight;

vector<int> child;

}Node[maxn];

bool comp(int x,int y){

return Node[x].weight>Node[y].weight;

}

void dfs(int node,int layer,int weight){

path[layer]=node;

weight=weight-Node[node].weight;

if (weight<0) {

return;

}

if (weight==0) {

if (Node[node].child.size()!=0) {

return;

}

else{

for (int i=0; i<=layer; i++) {

if (i!=layer) {

printf("%d ",Node[path[i]].weight);

}

else{

printf("%d",Node[path[i]].weight);

}

}

printf("\n");

}

}

for (int i=0; i<Node[node].child.size(); i++) {

dfs(Node[node].child[i], layer+1, weight);

}

}

int main(){

int sum,Noleaf,aim;

scanf("%d %d %d",&sum,&Noleaf,&aim);

for (int i=0; i<sum; i++) {

int weight;

scanf("%d",&weight);

Node[i].weight=weight;

}

for (int i=0; i<Noleaf; i++) {

int current;

int number;

scanf("%d",&current);

scanf("%d",&number);

for (int j=0; j<number; j++) {

int s;

scanf("%d",&s);

Node[current].child.push_back(s);

}

sort(Node[current].child.begin(), Node[current].child.end(),comp);

}

dfs(0, 0, aim);

}

1053 Path of Equal Weight (30分)相关推荐

  1. PAT甲级1053 Path of Equal Weight (30分) :[C++题解]dfs求树的路径长度、邻接表

    文章目录 题目分析 题目链接 题目分析 输入样例: 20 9 24 10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2 00 4 01 02 03 04 02 1 ...

  2. PAT (Advanced Level) Practice 1053 Path of Equal Weight (30 分)

    1053 Path of Equal Weight (30 分) Given a non-empty tree with root R, and with weight Wi assigned to ...

  3. PAT甲级 -- 1053 Path of Equal Weight (30 分)

    Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weig ...

  4. PAT:1053. Path of Equal Weight (30) AC

    #include<stdio.h> #include<vector> #include<queue> #include<algorithm> using ...

  5. 1053 Path of Equal Weight

    1053 Path of Equal Weight (30 分) Given a non-empty tree with root R, and with weight W​i​​ assigned ...

  6. 1053 Path of Equal Weight (30 分)

    题目 Given a non-empty tree with root R, and with weight WiW_iWi​ assigned to each tree node TiT_iTi​. ...

  7. 1053 Path of Equal Weight(超级无敌详细注释+45行代码)

    分数 30 全屏浏览题目 切换布局 作者 CHEN, Yue 单位 浙江大学 Given a non-empty tree with root R, and with weight Wi​ assig ...

  8. 1053 Path of Equal Weight

    1. 以下两组关系很大的概念 树的深度优先搜索 - 先根遍历 - 递归 树的广度优先搜索 - 层序遍历 - 非递归 本题考察的是前者,我设置了这样一个结构体 struct Prestruct{int ...

  9. 1053 Path of Equal Weigh(甲级)

    1053 Path of Equal Weight (30分) Given a non-empty tree with root R, and with weight W ​i ​​ assigned ...

最新文章

  1. RHEL6网络相关配置
  2. linux sudo命令错误 is not in the sudoers file
  3. Python看程序执行时间(time模块)
  4. 逆转线性单链表 c语言,单链表的逆转,不会做啊
  5. mysqlperformanceblog
  6. 音视频技术开发——还有什么不能讲的?
  7. LiveVideoStack线上交流分享 ( 四 ) —— 面向QoE的感知视频编码
  8. 《管理转型》——读书随笔
  9. 数字IC验证学习(一)
  10. python3.6 websocket异步高并发_在Python3.6上的websocket客户端中侦听传入消息时出现问题...
  11. React Hooks的使用(一)——useState、useEffect解析
  12. 好玩的网页小游戏源码《星球防御战射击》
  13. linux改变时间 find,Find命令查找最近几天修改的文件
  14. python爬取阳光问政
  15. nyoj素数环(dfs)
  16. js获取注册表中应用程序的路径,并通过注册表打开
  17. mocha测试框架使用
  18. Diffusion Models和GANs结合
  19. SpringBoot使用Word导出表格
  20. 按键精灵post请求_按键精灵安卓版能发送post和get请求吗

热门文章

  1. 【元宇宙欧米说】一个科幻 NFT,一场关于创作者经济的探索
  2. 自然语言处理的一些算法研究和实现(NLTK)
  3. 解决 Ubuntu 11.10 在 RTL8111/8168B 网卡下速度慢的问题
  4. 使用vueAdmin-template,java后台不能接收到参数
  5. 山西初中计算机考试题,山西中考信息技术试题
  6. 关联规则--Apriori算法
  7. 矩阵求导(一)-- 求导的定义和布局约定
  8. arduino 读取模拟电压_MQ2气体/烟雾传感器如何工作及其与Arduino接口
  9. Dplayer直播m3u8流
  10. 关于记忆宫殿的一些思考