题干:

Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: ``If my child was a son and if only he was a sound king.'' After nine months her child was born, and indeed, she gave birth to a nice son. 
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers had to be written in a sequence and he was able to sum just continuous subsequences of the sequence.

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son's skills he decided that every problem the king had to decide about had to be presented in a form of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions.

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong.

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, ..., aSi+ni} of a sequence S = {a1, a2, ..., an}. The king thought a minute and then decided, i.e. he set for the sum aSi + aSi+1 + ... + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + ... + aSi+ni < ki or aSi + aSi+1 + ... + aSi+ni > ki resp.) and declared these constraints as his decisions.

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not.

Input

The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king's decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100 is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described above. The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0
0

Sample Output

lamentable kingdom
successful conspiracy

题目大意:

n个数的一个序列,m个约束,si, ni, oi, ki, 代表了序列中第si个数到第si+ni、个数的和大于或小于ki,gt = 大于,lt = 小于

解题报告:

跟【POJ - 1201】Intervals,这题差不多。同样是注意判无解的时候要建一个超级源点和所有点连边,因为这样的话,只需要跑一遍SPFA就可以了。不然的话你需要枚举每一个点为起点进行SPFA,因为图不一定是个连通图。比如没有对1号点的约束,那么1号点就是单独一个连通块的。

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define F first
#define S second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
const int MAX = 2000 + 5;
const int INF = 0x3f3f3f3f;
int n,m;
int tot,head[MAX];
struct Edge {int v,ne,w;
} e[MAX<<4];
void add(int u,int v,int w) {e[++tot].v = v;e[tot].w = w;e[tot].ne = head[u];head[u] = tot;
}
int vis[MAX],dis[MAX],cnt[MAX];
int spfa(int st) {for(int i = 0; i<=n+1; i++) dis[i]=-INF,vis[i]=cnt[i]=0;queue<int> q;q.push(st);vis[st]=1,dis[st]=0;while(q.size()) {int cur = q.front();q.pop();vis[cur] = 0;for(int i = head[cur]; ~i; i = e[i].ne) {int v = e[i].v;if(dis[v] < dis[cur] + e[i].w) {dis[v] = dis[cur] + e[i].w;if(vis[v] == 0) {vis[v] = 1;cnt[v]++;if(cnt[v] > n) return 0;q.push(v);}}}}return 1;
}
int main()
{char op[4];while(~scanf("%d",&n)) {if(n == 0) break;scanf("%d",&m);tot=0;memset(head,-1,sizeof head);for(int x,y,z,i = 1; i<=m; i++) {scanf("%d%d%s%d",&x,&y,op,&z);if(op[0] == 'g') add(x-1,x+y,z+1); else add(x+y,x-1,1-z);}for(int i = 0; i<=n; i++) {add(n+1,i,0);}if(spfa(n+1) == 0) printf("successful conspiracy\n");else printf("lamentable kingdom\n");}return 0 ;
}

AC代码:

【POJ - 1364】King(差分约束判无解)相关推荐

  1. [poj 1364]King[差分约束详解(续篇)][超级源点][SPFA][Bellman-Ford]

    题意 有n个数的序列, 下标为[1.. N ], 限制条件为: 下标从 si 到 si+ni 的项求和 < 或 > ki. 一共有m个限制条件. 问是否存在满足条件的序列. 思路 转化为差 ...

  2. POJ 1364 King 差分约束系统

    Description Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen p ...

  3. King(差分约束)

    题目链接:King 题意:给你几个限制条件,问你是否能构建出来一个序列(a1,a2,a3--an)满足这些条件. 样例: 输入 4 2 1 2 gt 0 2 2 lt 2 1 2 1 0 gt 0 1 ...

  4. POJ 3159 Candies 差分约束dij

    分析:设每个人的糖果数量是a[i] 最终就是求a[n]-a[1]的最大值 然后给出m个关系 u,v,c 表示a[u]+c>=a[v] 就是a[v]-a[u]<=c 所以对于这种情况,按照u ...

  5. HDU 4598 Difference 差分约束 + 判奇圈

    题意:给你一个无向图 这个图是difference的如果存在一个正实数T使得图中所有的点的绝对值|ai|<T 并且点i j构成一条边当且仅当|ai-aj|>=T 问你是否存在一个这样的图 ...

  6. poj 1201 Intervals 差分约束

    真 .读题杀,英文题一脸懵逼,看来以后还要多读读英文题,不过读完了就能发现这其实是一道很裸的差分约束,按照题意建边即可,但还要注意的就是后一个要大于等于前一个,并且每个位置不能超过一个元素.求一边最大 ...

  7. POJ 1364 King (差分约束系统)

    题目描述有点复杂,前面讲了一大堆废话. 题目大意:对一个含n个整数的序列进行一些约束: 1.整数序列中连续的一段的和大于某个整数: 2.整数序列中连续的一段的和小于某个整数. 问满足以上约束的整数序列 ...

  8. POJ 1932 XYZZY (差分约束+传递闭包)

    题目链接 题意 有NNN个屋子,走进每个屋子血量都会发生改变,开始生命值100100100.问是否可以从111号屋子走到NNN号屋子中间血量保持大于000 思路 按照给定的顺序建图,因为要让血量尽可能 ...

  9. O - Layout POJ - 3169(差分约束)

    O - Layout POJ - 3169 参考 思路: 限制条件 : 最大距离不超过w d[v] - d[u] <= w; 最小距离超过w d[v] - d[u] >= w; 移项得 d ...

最新文章

  1. qt同时两个动画执行_Qt实现数字滚动动画效果
  2. django之ORM查询操作(二)
  3. php windows 操作文件,Windows开启审核功能来记录文件删除操作的详解
  4. esp32 cam工作电流_我如何在家工作:Cam的生产力之痛
  5. mysql统计各部门人数_2021各省份电网报名人数统计!会不会比考研还难?有些省份人数还就多的离谱了。。。...
  6. Javascript -- 二叉树(查找删除功能实现)
  7. python 开源框架学习
  8. 关于jquery跨域请求方法
  9. 用域控制禁止本地存盘禁止使用移动磁盘以防止图纸泄密的解决方案
  10. python能和java一起编程吗_C如何能和Python一起编程,那么它们已经无敌了!Java靠边站!...
  11. mysql ( )=,(mysql)
  12. Theano 编程核心
  13. Linux虚拟机设置Samba服务
  14. 86版五笔-拆字规则
  15. mysql todate日期格式写法_MYSQL的日期格式date_format用法
  16. 堆和栈内存扩展方向问题
  17. fpga+ADS1256
  18. 大体积、多数量excel文件排版转换为印刷版:pdf文件中标志图片模糊问题的解决
  19. 车载人机交互语音android,手机与车机如何实现语音智能交互?
  20. 如何在VC中加减日期及 CTime COleDateTime的常用操作和比较

热门文章

  1. 【啃不完的算法导论】- 动态规划 - 最长公共子序列(概念篇)
  2. intent几种传值数组、对象、集合(Array,Object,List)
  3. Powershell 最大值堆栈实现
  4. lucene中对不同的域使用不同的分析器
  5. 论文发表在什么期刊上_医学论文发表期刊论文范文
  6. 子网掩码相关教学 子网掩码快速算法 沉睡不醒blog
  7. rs232串口驱动_电脑主板RS232串口硬件设计
  8. java mask_Java 三大属性:
  9. 什么电脑的牌子好用_扬州诚招电动牙刷代理有什么牌子比较好用
  10. Java设计模式笔记(2)工厂方法模式