Description

Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: “If my child was a son and if only he was a sound king.” After nine months her child was born, and indeed, she gave birth to a nice son.
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers had to be written in a sequence and he was able to sum just continuous subsequences of the sequence.

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son’s skills he decided that every problem the king had to decide about had to be presented in a form of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions.

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong.

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, …, aSi+ni} of a sequence S = {a1, a2, …, an}. The king thought a minute and then decided, i.e. he set for the sum aSi + aSi+1 + … + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + … + aSi+ni < ki or aSi + aSi+1 + … + aSi+ni > ki resp.) and declared these constraints as his decisions.

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not.

Input

The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king’s decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100 is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described above. The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last “null” block of the input.

Sample Input

4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0
0

Sample Output

lamentable kingdom
successful conspiracy


题目大意:现在有个国王的儿子,他很笨,只会回答一些关于一个序列的问题,现在对于这个序列有m个约束条件,其中每个约束条件被表示为l,r,opt,k,如果opt为lt表示小于号,opt为gt表示大于号,表示a[l]到a[r]中所有数的和opt一个k值,然后问是否有这样的一个数列,其实就是SPFA判一下环就好了,如果有环,则说明约束条件有问题,矛盾,就好比说A比B大,B比C大,C比A大,这是矛盾的
这道题get到一个新细节,就是我们查分约束都是要大于等于或者小于等于,所以我们如果要求A>B则可以转化为A >= B + 1


#include <cstdio>
#include <cstring>
#include <queue>
#include <iostream>
using namespace std;const int MAXN = 100;
int tail, head[MAXN], dis[MAXN], cnt[MAXN];
struct Line{ int to, nxt, flow; }line[ MAXN * MAXN ];
bool vis[MAXN];
void init() {tail = 0; memset( head, 0, sizeof( head ) );memset( dis, 0, sizeof( dis ) );
}void add_line( int from, int to, int flow ) {line[++tail].nxt = head[from];line[tail].to = to;line[tail].flow = flow;head[from] = tail;
}
bool SPFA( int S, int n ) {queue<int>q; while( !q.empty() ) q.pop();memset( dis, 0x3f, sizeof( dis ) );memset( cnt, 0, sizeof( cnt ) );memset( vis, false, sizeof( vis ) );dis[S] = 0; q.push( S ); cnt[S]++;vis[S] = true; while( !q.empty() ) {int u = q.front(); q.pop(); vis[u] = false;for( register int i = head[u]; i; i = line[i].nxt ) {int v = line[i].to;if( dis[v] > dis[u] + line[i].flow ) {dis[v] = dis[u] + line[i].flow;if( vis[v] ) continue;vis[v] = true;q.push(v);cnt[v]++;if( cnt[v] > n ) {return false;}}}}return true;
}
int main( ) { int n, m;while( scanf( "%d", &n ), n ) {scanf( "%d", &m ); int ff, tt, ww; char opt[10];init();for( register int i = 1; i <= m; i++ ) {scanf( "%d%d%s%d", &ff, &tt, opt, &ww );if( opt[0] == 'g' ) add_line( ff + tt + 1, ff,  - ww - 1 );else                add_line( ff, ff + tt + 1, ww - 1 );}for( register int i = 1; i <= n + 1; i++ ) add_line( 0, i, 0 );if( !SPFA( 0, n + 2 ) ) puts("successful conspiracy");else                    puts("lamentable kingdom");}return 0;
}

POJ 1364 King 差分约束系统相关推荐

  1. [poj 1364]King[差分约束详解(续篇)][超级源点][SPFA][Bellman-Ford]

    题意 有n个数的序列, 下标为[1.. N ], 限制条件为: 下标从 si 到 si+ni 的项求和 < 或 > ki. 一共有m个限制条件. 问是否存在满足条件的序列. 思路 转化为差 ...

  2. POJ 1364 King (差分约束系统)

    题目描述有点复杂,前面讲了一大堆废话. 题目大意:对一个含n个整数的序列进行一些约束: 1.整数序列中连续的一段的和大于某个整数: 2.整数序列中连续的一段的和小于某个整数. 问满足以上约束的整数序列 ...

  3. POJ 2983(差分约束系统)

    POJ 2983 (1)题意: 有两种信息, P A B X表示A在B点的北边的准确距离为X V A B表示A在B的北边,但是具体的距离不确定,但是距离一定大于1. 询问是否存在一种情况使N个据点满足 ...

  4. POJ 1364 King

    题目大意: 国王有一个傻儿子,只会判断在给出的序列S={a1,a2,a3,a4...ai...at}中,ai+a(i+1)+a(i+2)+...+a(i+n)<ki或ai+a(i+1)+a(i+ ...

  5. POJ 1364:King(差分约束)

    题目大意:判断是否存在一个长度为n的序列满足给出的不等关系. 分析: 将序列和转化成用两个前缀和之差来表示即可变为差分约束系统. 需要注意的是不能忘记n要加+1,因为还有一个特殊源点,自己因为n:=n ...

  6. POJ 2983 浅谈差分约束系统处理严格等价性问题

    世界真的很大 差分约束系统,基于SPFA算法的复数不等关系判别及求值的系统 但是如果是完全等价的关系呢?或者说是混合式的等价关系? 当然是可以处理的,只不过需要恰恰转化一下,这个等价转不等算是差分约束 ...

  7. POJ 2983 Is the Information Reliable?(差分约束系统)

    题目大意:已知关于在一条直线上的n个点的m条信息,信息分为两类, 1.准确信息:P A B X 表示A在B的北方X光年: 2.模糊信息:V A B 表示A在B的北方1光年以北. 问所给信息是否自相矛盾 ...

  8. 提高篇 第三部分 图论 第4章 差分约束系统

    差分约束系统_我的ACM,我的梦!!!-CSDN博客_差分约束系统 差分约束系统详解 - hr_whisper - 博客园 最短路径算法:Bellman和差分约束系统_算法导论视频课程_其他视频-51 ...

  9. 图论 —— 差分约束系统

    [概述] 如果一个系统由 n 个变量 m 个约束条件组成,形成 m 个形如  的不等式,其中 ,k 是常数,则称这 m 个不等式为差分约束系统(system of difference constra ...

最新文章

  1. 微服务时代组件化和服务化的抉择
  2. 几个C++问题提示的莫名其妙,附录解决方法
  3. No transaction aspect-managed TransactionStatus in scope
  4. boost::interprocess::interprocess_condition用法的测试程序
  5. 微软官方上线的Python教程,7个章节就把Python说通了!
  6. Refactoring Connection To Sql
  7. python 的作用
  8. 计算机数制和运算的一点总结.
  9. HiveServer2入门到熟悉
  10. mysql中的concat和group_concat的用法
  11. TCP接收到重叠数据(overlap)后的行为解析-附带一个有关Delay ACK和超时重传的优化
  12. 基于XPDL2.0的过程定义
  13. 程序员期望月薪那些事儿
  14. 求函数在x0处的增量_设函数y=2x^2,已知其在点x0处自变量增量时,对应函数增量的线性主部为-0.6,则x0=()A.0B.1C.-0....
  15. OpenCV:二值化函数cv2.threshold
  16. 最简洁的解释动态语言中的鸭子类型和闭包
  17. 最近火爆的外卖分销小程序搭建及推广秘籍
  18. Unity 动态添加烘焙贴图
  19. vue 转换成 html,Vue/Vue中Html和Markdown互相转换/README.md · cyh90/LearningNotes - Gitee.com...
  20. Android之TextToSpeech类

热门文章

  1. 2022年计算机视觉产业链全景图谱,一文读懂计算机视觉产业链全局
  2. 国产LIN收发器芯片SIT1028,PIN to PIN替代TJA1028
  3. 你可以这样学习C语言
  4. BT 网站海盗湾(The Pirate Bay)不屈的精神
  5. 记录一次Git解决CONFLICT冲突
  6. 两步开发.NET Core剪裁器,并且开源它
  7. 2019年初面试题汇总
  8. 【转载】间谍新高度:间谍组织​Turla利用卫星通信隐藏CC服务器
  9. AI大语音(一)——语音识别基础(深度解析)
  10. 2021-06-01-《图解HTTP》笔记