网络规划综合实验(思科模拟器)

应用技术

VLAN

DHCP服务

DNS服务

WEB服务

路由协议

静态路由

动态路由(RIP)

HSRP

NAT

SSH

生成树协议

ACL

链路聚合

拓扑规划


具体配置

DNS服务器


DHCP服务器


WEB服务器


IP配置

各主机IP凡是写网段号,均为本网段第一个地址。路由器之间,左边为.1,右边为.2

sw1配置

hostname sw1
!
no ip domain-lookup
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1switchport mode trunk
!
interface FastEthernet0/2switchport mode trunk
!
interface FastEthernet0/3switchport access vlan 10
!
interface FastEthernet0/4switchport access vlan 10
!
interface FastEthernet0/5switchport access vlan 20

SW2配置

hostname sw2
!
no ip domain-lookup
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1switchport mode trunk
!
interface FastEthernet0/2switchport mode trunk
!
interface FastEthernet0/3switchport access vlan 30
!
interface FastEthernet0/4switchport access vlan 40
!

SW3配置

hostname sw3
!
no ip domain-lookup
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface Port-channel1switchport mode trunk
!
interface FastEthernet0/1switchport mode trunk
!
interface FastEthernet0/2switchport mode trunk
!
interface FastEthernet0/3switchport access vlan 50
!interface FastEthernet0/10switchport mode trunkchannel-group 1 mode on
!
interface FastEthernet0/11switchport mode trunkchannel-group 1 mode on
!
interface FastEthernet0/12switchport mode trunkchannel-group 1 mode on

SW6

hostname sw6
!
no ip domain-lookup
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface Port-channel1switchport mode trunk
!
interface FastEthernet0/1switchport access vlan 50
!
interface FastEthernet0/2switchport access vlan 50
!
interface FastEthernet0/10switchport mode trunkchannel-group 1 mode on
!
interface FastEthernet0/11switchport mode trunkchannel-group 1 mode on
!
interface FastEthernet0/12switchport mode trunkchannel-group 1 mode on
!

三层交换机S1(左边)

hostname s1
!
enable secret 5 $1$mERr$MNp8Yo5Mas8GUpxpr0GfR1(明文密码为123.com)
!
ip routing
!
username xiaoqi password 0 1234.com
!
no ip domain-lookup
ip domain-name xiaoqi.com
!
spanning-tree mode pvst
spanning-tree vlan 1 priority 4096
!
interface FastEthernet0/1no switchportip address 192.168.8.2 255.255.255.0duplex autospeed auto
!
interface FastEthernet0/2switchport access vlan 60
!
interface FastEthernet0/3switchport access vlan 60
!
interface FastEthernet0/4switchport trunk encapsulation dot1qswitchport mode trunk
!
interface FastEthernet0/5switchport trunk encapsulation dot1qswitchport mode trunk
!
interface FastEthernet0/6switchport trunk encapsulation dot1qswitchport mode trunk
!
interface FastEthernet0/7switchport trunk encapsulation dot1qswitchport mode trunk
!
interface Vlan10mac-address 00e0.b0ba.3201ip address 192.168.1.253 255.255.255.0ip helper-address 192.168.5.1standby 1 ip 192.168.1.254standby 1 priority 192standby 1 preemptstandby 1 track FastEthernet0/2
!
interface Vlan20mac-address 00e0.b0ba.3202ip address 192.168.2.253 255.255.255.0ip helper-address 192.168.5.1standby 2 ip 192.168.2.254standby 2 priority 192standby 2 preemptstandby 2 track FastEthernet0/2
!
interface Vlan30mac-address 00e0.b0ba.3203ip address 192.168.3.253 255.255.255.0ip helper-address 192.168.5.1standby 3 ip 192.168.3.254standby 3 priority 192standby 3 preemptstandby 3 track FastEthernet0/2
!
interface Vlan40mac-address 00e0.b0ba.3204ip address 192.168.4.253 255.255.255.0ip helper-address 192.168.5.1standby 4 ip 192.168.4.254standby 4 priority 192standby 4 preemptstandby 4 track FastEthernet0/2
!
interface Vlan50mac-address 00e0.b0ba.3205ip address 192.168.5.253 255.255.255.0standby 5 ip 192.168.5.254standby 5 priority 192standby 5 preemptstandby 5 track FastEthernet0/2
!
interface Vlan60mac-address 00e0.b0ba.3206ip address 192.168.6.254 255.255.255.0
!
ip classless
ip route 192.168.0.0 255.255.0.0 192.168.8.1
ip route 172.16.0.0 255.255.0.0 192.168.8.1
ip route 10.0.0.0 255.0.0.0 192.168.8.1
ip route 0.0.0.0 0.0.0.0 192.168.6.250
!
ip flow-export version 9

三成交换机S2(右边)

hostname s2
!
enable secret 5 $1$mERr$MNp8Yo5Mas8GUpxpr0GfR1(这个明文密码为123.com)
!
ip routing
!
username xiaoqi password 0 1234.com
!
no ip domain-lookup
ip domain-name xiaoqi.com
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1no switchportip address 192.168.9.2 255.255.255.0duplex autospeed auto
!
interface FastEthernet0/2switchport access vlan 70
!
interface FastEthernet0/3switchport access vlan 70
!
interface FastEthernet0/4switchport trunk encapsulation dot1qswitchport mode trunk
!
interface FastEthernet0/5switchport trunk encapsulation dot1qswitchport mode trunk
!
interface FastEthernet0/6switchport trunk encapsulation dot1qswitchport mode trunk
!
interface FastEthernet0/7switchport trunk encapsulation dot1qswitchport mode trunk
!
interface Vlan10mac-address 0002.177a.db01ip address 192.168.1.252 255.255.255.0standby 1 ip 192.168.1.254standby 1 priority 190standby 1 preempt
!
interface Vlan20mac-address 0002.177a.db02ip address 192.168.2.252 255.255.255.0standby 2 ip 192.168.2.254standby 2 priority 190standby 2 preempt
!
interface Vlan30mac-address 0002.177a.db03ip address 192.168.3.252 255.255.255.0standby 3 ip 192.168.3.254standby 3 priority 190standby 3 preempt
!
interface Vlan40mac-address 0002.177a.db04ip address 192.168.4.252 255.255.255.0standby 4 ip 192.168.4.254standby 4 priority 190standby 4 preempt
!
interface Vlan50mac-address 0002.177a.db05ip address 192.168.5.252 255.255.255.0standby 5 ip 192.168.5.254standby 5 priority 190standby 5 preempt
!
interface Vlan70mac-address 0002.177a.db06ip address 192.168.7.254 255.255.255.0
!
ip classless
ip route 192.168.0.0 255.255.0.0 192.168.9.1
ip route 172.16.0.0 255.255.0.0 192.168.9.1
ip route 10.0.0.0 255.0.0.0 192.168.9.1
ip route 0.0.0.0 0.0.0.0 192.168.7.250

路由器R1

hostname r1
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface FastEthernet0/0ip address 192.168.6.1 255.255.255.0ip access-group zonggongsi inip nat insideduplex autospeed autostandby 6 ip 192.168.6.250standby 6 priority 195standby 6 preemptstandby 6 track FastEthernet1/0
!
interface FastEthernet0/1ip address 192.168.7.1 255.255.255.0ip access-group zonggongsi inip nat insideduplex autospeed autostandby 7 ip 192.168.7.250standby 7 priority 195standby 7 preemptstandby 7 track FastEthernet1/0
!
interface FastEthernet1/0ip address 100.1.1.1 255.255.255.0ip nat outsideduplex autospeed auto
!
interface FastEthernet1/1no ip addressduplex autospeed autoshutdown
!
ip nat inside source list 1 interface FastEthernet1/0 overload
ip nat inside source static tcp 192.168.5.2 80 100.1.1.1 80
ip classless
ip route 192.168.0.0 255.255.0.0 192.168.6.254
ip route 172.16.0.0 255.255.0.0 192.168.6.254
ip route 10.0.0.0 255.0.0.0 192.168.6.254
ip route 192.168.0.0 255.255.0.0 192.168.7.254 2
ip route 172.16.0.0 255.255.0.0 192.168.7.254 2
ip route 10.0.0.0 255.0.0.0 192.168.7.254 2
ip route 0.0.0.0 0.0.0.0 100.1.1.2
!
access-list 1 permit 192.168.0.0 0.0.255.255
access-list 1 permit 172.16.0.0 0.0.255.255
access-list 1 permit 10.0.0.0 0.255.255.255
ip access-list standard zonggongsideny 192.168.3.0 0.0.0.255permit any
!

路由器R4

hostname r4
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface FastEthernet0/0ip address 192.168.6.2 255.255.255.0ip nat insideduplex autospeed autostandby 6 ip 192.168.6.250standby 6 priority 193standby 6 preempt
!
interface FastEthernet0/1ip address 192.168.7.2 255.255.255.0ip nat insideduplex autospeed autostandby 7 ip 192.168.7.250standby 7 priority 191standby preempt
!
interface FastEthernet1/0ip address 110.1.1.1 255.255.255.0ip nat outsideduplex autospeed auto
!
interface FastEthernet1/1no ip addressduplex autospeed autoshutdown
!
ip nat inside source list 1 interface FastEthernet1/0 overload
ip classless
ip route 192.168.0.0 255.255.0.0 192.168.6.254
ip route 192.168.0.0 255.255.0.0 192.168.7.254 2
ip route 172.16.0.0 255.255.0.0 192.168.6.254
ip route 172.16.0.0 255.255.0.0 192.168.7.254 2
ip route 10.0.0.0 255.0.0.0 192.168.6.254
ip route 10.0.0.0 255.0.0.0 192.168.7.254 2
ip route 0.0.0.0 0.0.0.0 110.1.1.2
!
access-list 1 permit 192.168.0.0 0.0.255.255
access-list 1 permit 172.16.0.0 0.0.255.255
access-list 1 permit 10.0.0.0 0.255.255.255
!

路由器R5

hostname r5
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface FastEthernet0/0ip address 10.3.3.2 255.255.255.0ip access-group zonggongsi inip access-group zonggongsi outduplex autospeed auto
!
interface FastEthernet0/1no ip addressduplex autospeed autoshutdown
!
interface FastEthernet1/0ip address 192.168.8.1 255.255.255.0duplex autospeed auto
!
interface FastEthernet1/1ip address 192.168.9.1 255.255.255.0duplex autospeed auto
!
router ripversion 2network 10.0.0.0network 192.168.8.0network 192.168.9.0no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.8.2
ip route 0.0.0.0 0.0.0.0 192.168.9.2 2
ip route 172.16.2.0 255.255.255.0 10.3.3.1
!
ip flow-export version 9
!
ip access-list extended zonggongsipermit ip 172.16.0.0 0.0.255.255 host 192.168.1.1permit ip 172.16.0.0 0.0.255.255 192.168.5.0 0.0.0.255deny ip 172.16.0.0 0.0.255.255 192.168.0.0 0.0.255.255permit ip any any

路由器R6

hostname r6
!
no ip cef
no ipv6 cef
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface FastEthernet0/0ip address 10.2.2.2 255.255.255.0duplex autospeed auto
!
interface FastEthernet0/1ip address 10.1.1.2 255.255.255.0duplex autospeed auto
!
interface FastEthernet1/0ip address 10.3.3.1 255.255.255.0ip access-group fengongsi outduplex autospeed auto
!
interface FastEthernet1/1no ip addressduplex autospeed autoshutdown
!
router ripversion 2network 10.0.0.0no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.3.3.2
ip route 172.16.2.0 255.255.255.0 10.2.2.1

路由器R7

hostname r7
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface FastEthernet0/0no ip addressduplex autospeed auto
!
interface FastEthernet0/0.1encapsulation dot1Q 10ip address 172.16.1.254 255.255.255.0
!
interface FastEthernet0/1ip address 10.1.1.1 255.255.255.0duplex autospeed auto
!
router ripversion 2network 10.0.0.0network 172.16.0.0no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.1.2

路由器R8

hostname r8
!
ip dhcp excluded-address 172.16.2.20 172.16.2.220
!
ip dhcp pool v10network 172.16.2.0 255.255.255.0default-router 172.16.2.254dns-server 140.1.1.1
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface FastEthernet0/0ip address 172.16.2.254 255.255.255.0duplex autospeed auto
!
interface FastEthernet0/1ip address 10.2.2.1 255.255.255.0duplex autospeed auto
!
router ripversion 2network 10.0.0.0network 172.168.0.0no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.2.2.2
!

路由器R2

hostname r2
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
interface FastEthernet0/0ip address 100.1.1.2 255.255.255.0duplex autospeed auto
!
interface FastEthernet0/1ip address 110.1.1.2 255.255.255.0duplex autospeed auto
!
interface FastEthernet1/0ip address 120.1.1.254 255.255.255.0duplex autospeed auto
!
interface FastEthernet1/1ip address 130.1.1.1 255.255.255.0duplex autospeed auto
!
interface Vlan1no ip addressshutdown
!
ip classless
ip route 140.1.1.0 255.255.255.0 130.1.1.2

路由器R3

hostname r3
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface FastEthernet0/0ip address 130.1.1.2 255.255.255.0duplex autospeed auto
!
interface FastEthernet0/1ip address 140.1.1.254 255.255.255.0duplex autospeed auto
!
interface Vlan1no ip addressshutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 130.1.1.1
!

外网DNS服务器


注意事项和大致思路


相关资源

链接:https://pan.baidu.com/s/1scws6nlZaLLg3t1j52Emng
提取码:745x

网络规划综合实验(思科模拟器)相关推荐

  1. 实验:数通之静态路由、ospf、vrrp、nqa综合实验(华为模拟器)

    一.实验拓扑 二.实验要求 拓扑如上所示,请完成以上需求: 1.设备互联地址如拓扑所示: 2.R1与R3之间:R2与R4之间,R3与R4之间运行OSPF,互联地址建邻,协议号100: 3.R1上loo ...

  2. 计算机网络实验---思科模拟器

    文章目录 1. 组建小型局域网 2. 交换机的配置与管理 实验3:交换机划分 Vlan 实验4:路由器的基本配置 实验5:静态路由 实验7:动态路由 1. 组建小型局域网 需要一台交换机,两台PC,连 ...

  3. 计算机网络——第二次实验——思科模拟器组网实验

    选择网络设备,在交换机中选择2960型号的交换机拖入面板 选择端设备,在端设备选项中选择PC并拖入到面板中 选择连接选项,选择直通线,将两台PC的FastEthernet口连接到交换机 点击PC2,进 ...

  4. 计算机网络实验(思科模拟器Cisco Packet Tracer)——路由器配置

    目录 前言 实验 结语 前言 本次实验将使用思科模拟器Cisco Packet Tracer来完成路由器配置的实验,将通过几个例子来讲述. 实验 例.使用以下设备完成两个校区的相互通讯,共享资源,每个 ...

  5. 计算机网络实验(思科模拟器Cisco Packet Tracer)——交换机配置以及虚拟局域网VLAN

    目录 前言 实验一 实验二 总结 前言 本次实验将使用思科模拟器Cisco Packet Tracer来完成交换机配置以及虚拟局域网的实验,将通过几个例子来讲述. 实验一 例.有交换机Switch_2 ...

  6. 华为模拟器-三次交换机、链路捆绑、单臂路由综合实验

    华为模拟器-三次交换机.链路捆绑.单臂路由综合实验 交换机SW1命令 交换机SW2命令 交换机SW3命令 交换机SW4命令 路由器R1命令 交换机SW1命令 划分vlan [Huawei]vlan b ...

  7. 思科模拟器划分子网实验报告_模拟多子网群集以设置SQL Server Always On可用性组–实验设置

    思科模拟器划分子网实验报告 In this article, we are going to see how to create a multi subnet cluster spanning acr ...

  8. 【计算机网络】思科实验(4):综合实验作业之办公室的跨VLAN通信

    系列文章目录 [计算机网络]思科实验(1):交换机的VLAN划分 [计算机网络]思科实验(2):交换机间的VLAN通信 [计算机网络]思科实验(3):使用三层交换机实现跨VLAN间的通信 [计算机网络 ...

  9. 基于eNSP中大型校园/企业网络规划与设计_ensp综合大作业(ensp综合实验)

    作者:BSXY_19计科_陈永跃 BSXY_信息学院 注:未经允许禁止转发任何内容 基于eNSP中大型校园/企业网络规划与设计_综合大作业(ensp综合实验) 前言及技术/资源下载说明( **未经允许 ...

最新文章

  1. Error Correction and DeNovo Genome Assembly for the MinION Sequencing Reads mixing Illumina Short Re
  2. 脚踏板USB接口与无线遥控连接方案论证
  3. postgresql 9.1 暂停 stream 后使用 rsync 异机同步文件
  4. java游戏_java开发的七个金典游戏你小时候肯定玩过
  5. 启动万维网发布服务(W3SVC)
  6. 使用python进行数据清洗常用的库_python3常用的数据清洗方法(小结)
  7. 毕业2年,我的工作小结
  8. 208.实现Trie(前缀树)
  9. 【华为云技术分享】Linux内核发展史 (2)
  10. 时钟服务器地址_时钟同步 Chrony 教程
  11. mysql异构迁移_如何利用数据异构实现多级缓存和数据迁移
  12. 绘制曲线 matlab,matlab绘制曲线图文
  13. [论文评析]人体脉搏波速与血压之间关系探索新突破
  14. 3dmax su 简单_sketchup导入3Dmax技巧
  15. 使用FreeCAD进行零件建模
  16. Python基础入门知识(2)
  17. Linux查看CPU型号、物理CPU个数、核数、逻辑CPU个数
  18. 热爱,对待人生的首要态度
  19. MATLABnbsp;nbsp;median函数amp;nbs…
  20. Android 插件化学习 加载apk并调用类的函数

热门文章

  1. 考研复试英语介绍计算机专业,2018计算机考研复试英语自我介绍范本及重点
  2. 逻辑思维训练——排除法
  3. 将百度富文本编辑器(ueditor)中的内容转化为word文档格式
  4. 【今日头条】【实习】放出一大波职位
  5. L1-036 A乘以B Python
  6. 研究生开学第一周Week01
  7. JavaScript入门 轮播/表单验证 Day17
  8. GIS空间分析 数字地形分析2 基本地形因子的提取
  9. 2019NOIP算法复健+学习
  10. Java+MySQL基于Springboot+vue的化妆品美妆销售商城网站——计算机毕业设计