题目描述

Piggy-Bank
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 6816   Accepted: 3272

Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

测试点数目T

背包为空时重量为E,满载为F

一共有N种物品,给出N种物品的价值V[i]和重量W[i],求出背包装满时最小价值。

解题报告

解题过程一波三折,代码修修补补,状态转移方程修改了两次,终于过了...

第一,我还是没有计算复杂度的习惯;

第二,完全背包思想还没有深刻理解!

首先,这道题是完全背包无疑。需要注意的是要求最小值,也就是求出背包装满的时候。那么在数组赋初值时,我们赋值成正无穷。

第一次,我使用的二维数组保存状态,对应的方程f[i][o]=min{f[i-1][o-k*w[i]]+k*v[i]}(k>=0,(o-k*w[i])>0)。

每次枚举出可能的k,再求出其中最小的,并赋值给f[i][o]。然后,MLE。

第二次,试用一维滚动数组DP,完全套用01背包方程。竟然,TLE。

的确,每一次枚举K的时候,需要Σ(o/w[i]),总的时间复杂度O(N*F*Σ(o/w[i])),太容易超时。

最后,改成f[o]=min{f[o],f[o-w[i]]+v[o]}...终于通过。

这个方程,刚开始还不太理解。

内层循环的含义其实是指,利用k-1个i物品的背包总价值计算出k个的总价值,再与不放物品i比较,取较优解。

这样就避免了上面方法对每个背包容量都穷举一次K造成的重复计算。

如样例2,i=2,o=50时k枚举了0和1。o=100时k=0,1,2;这里的k=0,1的情况可以通过找到f[50]的决策避免计算。

对应更改以后,总算是通过了。

代码

TLE代码:

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <math.h>using namespace std;
int dp[10020][510];
int v[510],w[510];
void print(int n,int m)
{for(int i=0;i<=n;i++){for(int o=0;o<=m;o++)printf("%d ",dp[i][o]);printf("\n");}
}
int main()
{int T,N,MAXW,empty;scanf("%d",&T);for(int t=1;t<=T;t++){memset(dp,127,sizeof(dp));scanf("%d%d",&empty,&MAXW);scanf("%d",&N);MAXW-=empty;if(MAXW<0){printf("This is impossible.\n");continue;}for(int i=1;i<=N;i++)scanf("%d%d",&v[i],&w[i]);dp[0][0]=0;for(int i=1;i<=N;i++)for(int o=0;o<=MAXW;o++){int min=2139062143;for(int k=0;(o-k*w[i])>=0;k++)if((dp[i-1][o-k*w[i]]+k*v[i])<min)min=dp[i-1][o-k*w[i]]+k*v[i];dp[i][o]=min;}//  print(N,MAXW);if(dp[N][MAXW]<2000000000)printf("The minimum amount of money in the piggy-bank is %d\n",dp[N][MAXW]);elseprintf("This is impossible.\n");}return 0;}
#include <iostream>
#include <stdio.h>
#include <cstring>
#include <math.h>using namespace std;
int dp[50020];
int v[510],w[510];
void print(int n,int m)
{printf("**********************\n");{for(int o=0;o<=m;o++)printf("%d ",dp[o]);printf("\n");}printf("**********************\n");
}int main()
{int T,N,MAXW,empty;scanf("%d",&T);for(int t=1;t<=T;t++){memset(dp,127,sizeof(dp));scanf("%d%d",&empty,&MAXW);scanf("%d",&N);MAXW-=empty;for(int i=1;i<=N;i++)scanf("%d%d",&v[i],&w[i]);if(MAXW<=0){printf("This is impossible.\n");continue;}dp[0]=0;for(int i=1;i<=N;i++){for(int o=w[i];o<=MAXW;o++){if((dp[o-w[i]]+v[i])<2139062143)dp[o]=min(dp[o-w[i]]+v[i],dp[o]);}//print(N,MAXW);}// printf("maxw=%d",MAXW);//print(N,MAXW);if(dp[MAXW]!=2139062143)printf("The minimum amount of money in the piggy-bank is %d.\n",dp[MAXW]);elseprintf("This is impossible.\n");}   return 0;}

POJ1384-PiggyBank相关推荐

  1. poj-1384 Piggy-Bank

    poj-1384 Piggy-Bank 地址:http://poj.org/problem?id=1384 题意: 知道盒子里面的物体的总重量,得到每一种硬币的价格和重量,求最少钱构成盒子物体总重量的 ...

  2. POJ-1384 Piggy-Bank 多重背包变形

    题意 给我们一个容器的容量m n个物品 每个物品有不同的花费和价值 问我们再每个物品无限个的情况下 最后正好装满最后得到的最小价值是多少 如果装不满 就输出impossible 分析 目标状态:最小价 ...

  3. HDU1114 Piggy-Bank 【全然背包】

    HDU1114 Piggy-Bank [全然背包] Piggy-Bank Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/3 ...

  4. 完全背包问题 POJ1384

    完全背包即物品的数量不收限制, 根据01背包的思想,因为每件物品只能选1个,则要求我们不能依赖已选择物品i的选项的时候,所以需要逆序遍历 则在完全背包问题中,我们需要正序遍历. 此题时要求求出最小价值 ...

  5. HD Piggy-Bank完全背包

    #include <stdio.h> #include <string.h> #define min(a,b) a<b? a:b int dp[1000005]; int ...

  6. Piggy-Bank POJ - 1384(完全背包+背包放满)

    题意: 给出一个存钱罐的重量和没存钱之前存钱罐的重量,然后给出几种硬币的重量和币值,计算存钱罐里至少有多少钱. 题目: Before ACM can do anything, a budget mus ...

  7. hdu-1114 Piggy-Bank

    文章目录 Problem Description 题意: 题解: 代码: hdu-1114 Problem Description Before ACM can do anything, a budg ...

  8. HDU1114 Piggy-Bank 完全背包

    题意: 给出一个存钱罐的空罐时的质量和装了钱之后的质量,再给出一些硬币的质量和相应的价值,问存钱罐里的钱最少可能为多少. 这道题就是完全背包的问题,注意初始化. 完全背包与01背包不同的是第二次遍历的 ...

  9. HDU 1114 Piggy-Bank 简单DP

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1114 题目大意:完全背包问题,不过这次是求的最小值. 解题思路:首先是初始化问题,其次就是状态转移的时 ...

  10. hdoj 1114 Piggy-Bank(完全背包+dp)

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1114 思路分析:该问题要求为多重背包问题,使用多重背包的解法即可:假设dp[v]表示容量为v的背包中能 ...

最新文章

  1. 【运筹学】指派问题、匈牙利法总结 ( 指派问题 | 克尼格定理 | 匈牙利法 | 行列出现 0 元素 | 试指派 | 打 √ | 直线覆盖 ) ★★★
  2. JAVA Junit error java.lang.SecurityException: class junit.framework.JUnit4TestCaseFacade
  3. 前端学习(537):多列布局4横跨多列
  4. 那些花儿,从零构建Vue工程(webpack4 Eslint git hooks...)
  5. 搭建邮件服务器 linux,Linux局域网邮件服务器搭建
  6. 新视野大学英语第三版3课后翻译
  7. android换肤的实现方案,Android换肤技术总结
  8. java代码如何整合_Java如何合并两个PPT文档?
  9. centos安装MySQL到指定盘_Centos下安装mysql 和挂载硬盘
  10. TI基于DSP+ARM的双核架构如何相互通信
  11. 你们都以落第为耻,我却以落第动心为耻
  12. MysqlWorkbench中无法显示表[tables could not be fetched]
  13. Python-pytest、unittest
  14. python全栈开发什么意思_如何快速的学习Python全栈开发?这是腾讯大佬给你的建议!...
  15. 乐橙育儿机器人 众筹_乐橙智能生活发布育儿机器人“小乐”
  16. 【厚积薄发系列】C++项目总结12—函数调用约定导致的崩溃问题分析
  17. C++智能指针之shared_ptr
  18. java-php-python-ssm室内游戏俱乐部系统计算机毕业设计
  19. maven打包java项目为可执行jar文件,资源文件放在外面
  20. 实验方法怎么写_科研小白进阶路(二)之实验计划怎么写

热门文章

  1. CUDA编程之常用技巧与方法
  2. Numpy ravel和flatten区别
  3. SpringCloud源码学习笔记之Eureka客户端——DiscoveryClient接口的层级结构
  4. WinCHM Pro入门及注意事项(.chm帮助文件制作)
  5. CSS:链接外部css样式时候link标签使用方法
  6. 软阈值(Soft Thresholding)函数解读
  7. 在全系1000学生中,征集慈善捐募,当总数达到十万时就结束,统计捐款人数和平均捐款数目
  8. Powershell 中 报错Set-Location : 找不到接受实际参数
  9. 笔记 Power BI 动态帕累托图制作
  10. 一行代码使TextView变成打字机模式或更改字体。