3.4.1EtherChannel及其作用

交换机允许将多个端口聚合成一个逻辑端口或者称为EtherChannel。

通过端口聚合,可大大提高端口间链路的通信速度。比如,当用2个100Mbit/s的端口进行聚合时,所形成的逻辑端口的通信速度为200Mbit/s;若用4个,则为400Mbit/s。当EtherChannel内的某条链路出现故障时,该链路的流量将自动转移到其余链路上,自动提供冗余和负载均衡。

PAgP是Cisco专有的端口聚合协议,LACP(Link Aggregation Control Protocol,链路聚合控制协议)则是一种标准的协议。

3.4.2 EtherChannel配置

 参与聚合的端口必须具备相同的属性,如相同的速度、单双工模式、trunk模式、trunk封装方式和VLAN等。端口配置模式下使用命令:

channel-group number mode [active|auto|desirable |on|passive]

进行配置。

参数说明:

active     只使用LACP协议(Enable LACP unconditionally)

auto      使用PAgP仅当对端设备使用PagP时( Enable PAgP only if a PAgP device is detected)

desirable  只使用PAgP(Enable PAgP unconditionally)

on       只进行端口聚合,默认使用PAgP(Enable Etherchannel only)

passive   使用LACP仅当对端设备使用LACP 时(Enable LACP only if a LACP device is detected)

两端设备对应端口聚合应该使用同样的协议,否则至少有一端的聚合不会成功。

1.配置实例

比如在如图所示的网络中,两核心交换机之间的链路采用两个端口的EtherChannel。

配置步骤:

Sw0(config)#interface range G0/1-2          //配置G0/1和G0/2口

Sw0 (config-if)#channel-group 10 mode on   //可理解为把G0/1-2加入10号逻辑端口组(通道组)

Sw0(config-if)#exit

Sw1(config)#interface range G0/1-2

Sw1(config-if)#channel-group 10 mode on

Sw1(config-if)#exit

2. 查看配置:

SW1#show etherchannel summary

Flags:  D - down        P - in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3      S - Layer2

U - in use      f - failed to allocate aggregator

u - unsuitable for bundling

w - waiting to be aggregated

d - default port

Number of channel-groups in use: 1

Number of aggregators:         1

Group  Port-channel  Protocol    Ports

------+-------------+-----------+----------------------------------------------

10     Po10(SU)      PAgP     Gig0/1(P)Gig0/2(P)

显示这两个接口已经捆绑成为一个通道组接口Port-channel 10,Po10(SU)中的“S”说明这个通道组接口工作在第二层,U表示已在使用,使用的协议为PAgP,通道组聚合了两个接口Gig0/1和Gig0/2。

Cisco 3560交换机支持48个EtherChannel 配置,每组最多支持8个端口聚合。

3.负载均衡配置

EtherChannel可以自动执行负载均衡,当EtherChannel执行负载均衡时,按照默认策略进行。

可以根据不同条件来决定和配置负载均衡策略。如MAC地址、IP地址等都可以作为负载均衡策略的参数。但是不是每种交换机都能支持所有这些参数,越高端的交换机支持的参数就越多。

例如,Cisco 3560的负载均衡配置

Switch(config)#port-channel load-balance ?

dst-ip       Dst IP Addr

dst-mac      Dst Mac Addr

src-dst-ip   Src XOR Dst IP Addr

src-dst-mac  Src XOR Dst Mac Addr

src-ip       Src IP Addr

src-mac      Src Mac Addr

支持多种策略

===============================

**************** 链路聚合 ****************
SW1:2960
interface Port-channel 1
description Channel group member f0/1-2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk

int ran f0/1 - 2
description Connect to SW5 on port f0/1-2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
switchport trunk allowed vlan all

SW2:2960
interface Port-channel 2
description Channel group member f0/1-2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk

int ran f0/1 - 2
description Connect to SW5 on port f0/3-4
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode desirable
switchport trunk allowed vlan all

SW3:2960
interface Port-channel 3
description Channel group member f0/1-2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk

int ran f0/1 - 2
description Connect to SW5 on port f0/5-6
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 3 mode desirable
switchport trunk allowed vlan all

SW4:2960
interface Port-channel 4
description Channel group member f0/1-2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk

int ran f0/1 - 2
description Connect to SW5 on port f0/7-8
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 4 mode desirable
switchport trunk allowed vlan all

SW5: 3560
interface Port-channel 1
description Channel group member SW1 f0/1-2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk

int ran f0/1 - 2
description Connect to SW1 on port f0/1-2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode auto
switchport trunk allowed vlan all

interface Port-channel 2
description Channel group member SW2 f0/1-2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk

int ran f0/3 - 4
description Connect to SW2 on port f0/1-2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode auto
switchport trunk allowed vlan all

interface Port-channel 3
description Channel group member SW3 f0/1-2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk

int ran f0/5 - 6
description Connect to SW3 on port f0/1-2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 3 mode auto
switchport trunk allowed vlan all

interface Port-channel 4
description Channel group member SW4 f0/1-2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk

int ran f0/7 - 8
description Connect to SW4 on port f0/1-2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 4 mode auto
switchport trunk allowed vlan all

sh ip int bri

本文转自 qq8658868 51CTO博客,原文链接:http://blog.51cto.com/hujizhou/1040026,如需转载请自行联系原作者

cisco 以太通道(端口聚合)配置样例相关推荐

  1. Cisco思科交换机端口聚合配置和实验(图文)

    一.技术原理 端口聚合(Aggregate-port)又称链路聚合,是指两台交换机之间在物理上将多个端口连接起来,将多条链路聚合成一条逻辑链路.从而增大链路带宽,解决交换网络中因带宽引起的网络瓶颈问题 ...

  2. 2012 windows 端口聚合_windows 2012 NIC组合 端口聚合和cisco 以太通道

    windows 2012 端口聚合和cisco 以太通道 1. 打开服务器管理器,选择本地服务器,可以看到NIC Teaming是禁用的.点击Disable启用功能. 2. 在组任务中选择新建组,或者 ...

  3. 04. 交换机的端口聚合配置

    转自:http://7c0bab95.wiz03.com/share/s/1Y2WKl218k5e2gpBCl2BeEsq1-Xe2N3SrAA-2emxLy1Q_Hk2 交换机的端口聚合配置 技术原 ...

  4. HP C7000刀片服务器北电GbE2c刀片背板网络交换机配置样例

    HP C7000刀片服务器使用的GbE2c刀片背板网络交换机和传统的华为.思科等交换机配置方式很不一样,配置起来比较复杂,本文是作为虚拟化环境中的典型应用的一个配置样例 . 一.环境介绍 本例HP C ...

  5. 3 交换机的端口聚合配置

    借鉴网址:(23条消息) Packet Tracer 思科模拟器入门教程 之四 交换机的端口聚合配置_柚子君.的博客-CSDN博客_思科模拟器如何配置聚合端口 姓 名 彭彭头 实验日期 2022-03 ...

  6. esxi虚拟化服务器端口聚合,配置ESXi的端口聚合.docx

    配置ESXi的端口聚合 配置ESXi6.0的端口聚合由于本人只有华为S5700-48TP-SI的交换机,所以请根据实际情况配置交换机,本例中ESXi服务器的网卡3连接交换机的3端口,网卡4连接交换机的 ...

  7. H3C交换机和华为交换机端口聚合配置

    一.H3C交换机端口聚合配置 建立汇聚组1 [H3C]interface bridge-aggregation 1(建立聚合口1) [H3C-Bridge-Aggregation1]quit(退出聚合 ...

  8. cisco理论---以太通道端口会聚协议(PAgP)与LACP的区别

    pagp 端口聚集协议(PAgP)帮助在快速以太通道链接中联系自动生成.PAgP 分组为了商议一个通道的形成在快速以太通道可能的端口发送. PAgP是Cisco的专有协议  PAgP的工作模式 on( ...

  9. cisco端口聚合配置

    实验目标 理解端口聚合基本原理: 掌握一般交换机端口聚合的配置方法: 实验背景 端口聚合(又称为链路聚合),将交换机上的多个端口在物理上连接起来,在逻辑上捆绑在一起,形成一个拥有较大宽带的端口,可以实 ...

  10. 思科模拟器Cisco Packet Tracer交换机的端口聚合配置

    版权声明:如果对大家有帮助,大家可以自行转载的.https://blog.csdn.net/qq_37992321/article/details/84668480 1.技术原理: 端口聚合使用的是 ...

最新文章

  1. 健康日志之口腔粘膜----7-13
  2. 今天下午接到阔总编的电话
  3. Yolov5系列AI常见数据集(1)车辆,行人,自动驾驶,人脸,烟雾
  4. tplink连接服务器失败_管家婆财贸双全连接失败,服务器端没有找到加密狗
  5. xp电脑怎么取消开机密码
  6. java继承数组实例_【Java】理解封装、继承、多态和对象数组的综合实例(简易的租车系统,附代码)...
  7. 同一个电脑安装几个MATLAB,同一个版本的matlab、同一个.m文件,为何一个顺利执行、另一个出错?...
  8. 输入一个链表,按链表值从尾到头的顺序返回一个ArrayList。
  9. mysql的pdb文件在哪里_pdb是什么文件?pdb数据库文件怎么打开?
  10. 科学电子计算机百分数怎么弄,计算器上的百分比怎么用
  11. Ubuntu深度学习环境配置(2):Ubuntu18.04安装N卡驱动+anaconda3
  12. Windows 11 21H2正式版镜像
  13. HTML+CSS项目总结(建议学习三周后)
  14. Kubernetes详解
  15. Linux下ps命令
  16. Windows2016 L2TP配置(预共享密钥模式)
  17. 做自媒体视频剪辑怎么赚钱呢?
  18. 软件技术部python培训
  19. linux+创建一个v文件共享,win10与Ubantu双系统:Linux下开启FTP服务器与创建无线热点(实现文件共享)...
  20. xbox sdk_因此,您只是获得了Xbox Xbox。 怎么办?

热门文章

  1. 2021-09-15频繁项集的评估标准
  2. C++ 基础 弱类型语言是指不需要进行变量/对象类型声明的语言。Python属于弱类型语言
  3. jupyter notebook添加conda虚拟环境
  4. 服务器设置客户端网页安装,在Windows 7环境下安装并配置web、SSH、E-mail、FTP等服务器...
  5. spring 注解_Spring 注解编程之 AnnotationMetadata
  6. 【POJ1276】【多重背包】凑货币问题
  7. 一些Euclid空间上的定义
  8. 能力提升综合题单 Part 8.4 生成树Part 8.5 拓扑排序Part 8.6 差分约束
  9. 在Ubuntu下安装ros
  10. 拦截导弹问题(Noip1999)