Treasure Exploration
Time Limit: 6000MS   Memory Limit: 65536K
Total Submissions: 7611   Accepted: 3126

Description

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you. 
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure. 
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point. 
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars. 
As an ICPCer, who has excellent programming skill, can your help EUC?

Input

The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.

Output

For each test of the input, print a line containing the least robots needed.

Sample Input

1 0
2 1
1 2
2 0
0 0

Sample Output

1
1
2

题意:有很多机器人和1个图,每个机器人从该图的一个点出发,然后现在要求机器人走遍所有的点,求最小的机器人的数量。(2个机器人可以从不同方向走过同一点)。

思路:显然相当于求最路径覆盖嘛,只不过就是最小路径覆盖是每个点不能被走两次的,而现在可以走两次了,所以想一个办法就是把本身不能走的点连起来,比如一个机器人能从a->b->c,可是现在b已经被另一个机器人走过了,最短路径覆盖又不能让一个点被两个人走,可是该机器人必须从a->c才是最优解,所有用floyd将所有点有联系的都连接起来,这样子仍然是原来的最小路径覆盖的问题了。

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
using namespace std;
typedef long long ll;
const int N=555;
bool tu[N][N];
int from[N];///记录右边的点如果配对好了它来自哪里
bool use[N];///记录右边的点是否已经完成了配对
int color[N];
int n,m;
bool dfs(int x)
{for(int i=1; i<=m; i++) ///m是右边,所以这里上界是mif(!use[i]&&tu[x][i]){use[i]=1;if(from[i]==-1||dfs(from[i])){from[i]=x;return 1;}}return 0;
}
int hungary()
{int tot=0;memset(from,-1,sizeof(from));for(int i=1; i<=n; i++) ///n是左边,所以这里上界是n{memset(use,0,sizeof(use));if(dfs(i))tot++;}return tot;
}
int main()
{int k;while(cin>>n>>k&&n+k){m=n;memset(tu,0,sizeof(tu));while(k--){int a,b;cin>>a>>b;tu[a][b]=1;}for(int k=1; k<=n; k++)for(int i=1; i<=n; i++)for(int j=1; j<=n; j++)if(tu[i][k]&&tu[k][j])tu[i][j]=1;printf("%d\n",n-hungary());}return 0;
}

转载于:https://www.cnblogs.com/martinue/p/5490459.html

poj2594(二分图,最小路径覆盖变形)相关推荐

  1. 洛谷 - P2764 最小路径覆盖问题(最大流+二分图最小路径覆盖+路径打印)

    题目链接:点击查看 题目大意:给出一个由n个点和m条边组成的有向无环图,现在需要我们求最少可以将n个点分为多少条简单路径,并打印出每一条路径 题目分析:题意挺难懂的..简单来说就是让求二分图最小路径覆 ...

  2. POJ 3216 Repairing Company【二分图最小路径覆盖】

    题意: 告诉你 Q 格街区,一共有 M d 个任务分布在这Q 个街区里面,知道了每个任务的开始时间和需要一个人的完成时间,   问最少需要派多少人才能做完所有的任务. 分析: 求二分图的最小路径覆盖, ...

  3. POJ3020深度解析(二分图--最小路径覆盖)

    题目:Antenna Placement 题意: 一个矩形中,有N个城市'*',现在这n个城市都要覆盖无线,若放置一个基站,那么它至多可以覆盖相邻的两个城市. 问至少放置多少个基站才能使得所有的城市都 ...

  4. CodeForcesGym 100753B Bounty Hunter II 二分图最小路径覆盖

    关键在建图 题解:http://www.cnblogs.com/crackpotisback/p/4856159.html 学习:http://www.cnblogs.com/jackiesteed/ ...

  5. 二分图大讲堂——彻底搞定最大匹配数(最小覆盖数)、最大独立数、最小路径覆盖、带权最优匹配

    二分图匹配 二分图大讲堂--彻底搞定最大匹配数(最小覆盖数).最大独立数.最小路径覆盖.带权最优匹配(转) 文本内容框架: §1图论点.边集和二分图的相关概念和性质 §2二分图最大匹配求解 匈牙利算法 ...

  6. 二分图专题系列各大知识点总结(匈牙利,染色法,最大独立集,最小点覆盖,最小路径覆盖)

    本文概论 二分图的判断方法:图中不存在奇数环----->染色法判断二分图不存在矛盾 二分图: 设G=(V,E)是一个无向图,如果顶点V可分割为两个互不相交的子集(A,B),并且图中的每条边(i, ...

  7. DAG的最小路径覆盖和二分图的最大匹配

    DAG的最小路径覆盖和二分图的最大匹配 DAG的最小路径覆盖是指找最小数目的互相不相交的有向路径,满足DAG的所有顶点都被覆盖. 首先给出公式:DAG的最小路径覆盖数=DAG图中的节点数-相应二分图中 ...

  8. POJ - 2594 Treasure Exploration(最小路径覆盖-二分图最大匹配+传递闭包)

    题目链接:点击查看 题目大意:给出一个有向图,现在需要让最少的机器人沿着图遍历所有点,求出最少需要机器人的数量,注意每个点可以重复遍历 题目分析:因为要遍历所有点,所以还是变成了二分图的最小路径覆盖问 ...

  9. HDU - 1151 Air Raid(最小路径覆盖-二分图最大匹配)

    题目链接:点击查看 题目大意:给出一个有向图,现在需要在不同的地方空降伞兵,保证所有伞兵沿着道路可以走完所有城市,求出最少伞兵的数量 题目分析:我们的目的是要用最少的路径覆盖所有顶点,换句话说就是二分 ...

最新文章

  1. CSS Animations vs Web Animations API
  2. PHP中可变变量和php可变函数到底有什么用?
  3. wordpress上传主题错误解决方法
  4. android 常用 style,Android中 Styles和Themes
  5. Uni-Java_Java全栈必备之Uni-App
  6. 女人护肤品可与男人共用! - 健康程序员,至尚生活!
  7. 【LeetCode笔记】剑指Offer 37. 序列化二叉树(Java、二叉树、序列化、BFS、队列)
  8. 数据库函数..........
  9. jmeter_linux下运行
  10. 七天LLVM零基础入门(Linux版本)------总结
  11. win10开启虚拟化服务器,win10怎么开启virtualization technology虚拟化技术
  12. vue axois 封装请求 | vue 解决跨域问题
  13. 计算机无法用u盘重装系统,最简单不用U盘电脑重装系统教程
  14. 使用Selenium对QQ邮箱登录页面进行自动化测试
  15. MySQL服务器配置优化(读书笔记)
  16. CTF 实验吧 变异凯撒 writeup
  17. 教你玩转Word教程-刘青-专题视频课程
  18. 炒股赚钱最重要的是炒股心态和纪律
  19. 十年一剑,股票自动交易实验(寻找股海宝藏之旅—解锁股市交易更多姿势)
  20. kNN算法解析及应用【内附详细代码和数据集】

热门文章

  1. Linux软件包管理的知识点,Linux基础知识之软件包管理(二)
  2. numpy的深复制与浅复制的区别_Python之Numpy基础,强大到让你五体投地
  3. 洛谷P1122 最大子树和 树形DP初步
  4. springmvc ztree 实现权限菜单的展示
  5. 如何解决Qt程序在其他电脑上无法运行的问题(Qt程序打包发布)
  6. 【Tensorflow】tf.map_fn() 使用过程中遇到【inf, NaN】报错问题
  7. 【OpenPose-Windows】OpenPose+VS2015+Windows+CUDA8+cuDNN5.1 官方配置教程
  8. MySQL 中 AUTO_INCREMENT 的“坑” --重复值问题
  9. 感知算法论文(四):Mask Scoring R-CNN (2019)译文
  10. 机器学习基本算法的sklearn接口