每次移动都是一个群龙珠移动到另一群龙珠所在的城市里面。所以这两个城市之间都不会空。

用并查集表示,每一个祖先节点的序号和他们所在城市的序号相同。

无论路径如何压缩,子结点的移动次数=父节点的移动次数+1;

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4943    Accepted Submission(s): 1864

Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
Input
The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
Sample Input
2 3 3 T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1
Sample Output
Case 1: 2 3 0 Case 2: 2 2 1 3 3 2
Author
possessor WC
Source
2010 ACM-ICPC Multi-University Training Contest(19)——Host by HDU
/**==========================================*   This is a solution for ACM/ICPC problem**   @source£o*   @type:*   @author: wust_ysk*   @blog:  http://blog.csdn.net/yskyskyer123*   @email: 2530094312@qq.com*===========================================*/
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
typedef long long ll;
const int INF =0x3f3f3f3f;
const int maxn=  10000   ;
int n,q,pre[maxn+4],cnt[maxn+4],num[maxn+4];
//const int maxV=12    ;int find(int x,int &s)
{if(pre[x]==x){s=x;return x;}pre[x]=find(pre[x],s);cnt[x]+=cnt[s];s=x;return pre[x];}void init()
{for(int i=1;i<=n;i++){pre[i]=i;cnt[i]=0;num[i]=1;}
}void addto()
{int ball1,ball2;int s;scanf("%d%d",&ball1,&ball2);int root1=find(ball1,s);int root2=find(ball2,s);pre[root1]=root2;num[root2]+=num[root1];num[root1]=0;cnt[root1]++;}void query()
{int x,s;scanf("%d",&x);int root=find(x,s);printf("%d %d %d\n",root,num[root],cnt[x]);
}
void work()
{char ch;scanf(" %c",&ch);if(ch=='T')  addto();else  query();}
int main()
{int T,kase=0;scanf("%d",&T);while(T--){scanf("%d%d",&n,&q);printf("Case %d:\n",++kase);init();for(int i=1;i<=q;i++){work();}}return 0;
}

不用子结点的移动次数=父节点的移动次数+1   而用比较暴力的方法似乎也可以过。

hdu 3635 Dragon Balls 龙珠 带权并查集相关推荐

  1. 【HDU】3635 Dragon Balls (带权并查集 一)

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3635 [问题描述] 有标号为1到n的n个龙珠,分别放在对应标号为1到n的n个城市里.  下面有两种操作 ...

  2. HDU(1856),裸的带权并查集

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1856 题意:朋友圈问题,A和B是朋友,B和C是朋友则A和C也是朋友,依次类推,题目的意思就是求最大的朋 ...

  3. How Many Answers Are Wrong HDU - 3038(带权并查集经典题,满满的都是注释)

    How Many Answers Are Wrong HDU - 3038  点击打开链接 题意:现在有n个数(你并不知道这n个数是什么),m次查询,每次查询给出u,v,w.表示从第u个数到第v个数的 ...

  4. Valentine's Day Round hdu 5176 The Experience of Love [好题 带权并查集 unsigned long long]

    传送门 The Experience of Love Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Ja ...

  5. HDU 3047 Zjnu Stadium (带权并查集)

    链接: http://acm.hdu.edu.cn/showproblem.php?pid=3047 题目: Problem Description In 12th Zhejiang College ...

  6. How Many Answers Are Wrong HDU - 3038(带权并查集)

    TT and FF are - friends. Uh- very very good friends -________-b FF is a bad boy, he is always wooing ...

  7. HDU 5176 The Experience of Love 带权并查集

    The Experience of Love Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/O ...

  8. 带权并查集 HDU - 3047

    题意: 一圈座位有n个,给出m组序号之间的关系,比如,1 2 150 代表2号坐在1号位置序号+150,看m组数据有多少组冲突的. 思路: 带权并查集模板. #include<stdio.h&g ...

  9. 【POJ - 1703】Find them, Catch them(带权并查集之--种类并查集 权为与父节点关系)

    题干: Find them, Catch them Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 36176   Accep ...

最新文章

  1. 小议ASP.NET模板引擎技术的使用
  2. Cloud for Customer元数据的加载
  3. 微信小程序开发系列教程三:微信小程序的调试方法
  4. 罗德里格斯(Rodrigues)旋转向量与矩阵的变换
  5. java assert语句未执行_Java陷阱之assert关键字
  6. Java 基于javaMail的邮件发送(支持附件)
  7. 12.看板方法---度量和管理报告
  8. docker privileged作用_docker容器性能监控cAdvisor+influxDB+grafana监控系统安装部署
  9. 【Python】爬取xici和快代理的免费代理ip
  10. html旅游网站设计与实现——绿色古典旅游景区 HTML+CSS+JavaScript
  11. 如何使用fiddler抓取APP接口
  12. 基于OpenCV的PHP图像人脸检测识别…
  13. 计算机组成原理学习笔记(3.存储系统 4.指令系统)
  14. Java扫码点餐小程序源码 SaaS系统源码 微信、支付宝扫码点餐小程序源代码
  15. python 3 爬取12306余票:升级版-----图形化界面
  16. open3d使用知识拾遗
  17. 500+分区Mini LED,海信电视E8H让画质更纯净
  18. Java — 内部类存在意义
  19. 【C语言程序设计】实验 2
  20. 上海计算机专业哪个中专最好,上海有什么比较好的中专?

热门文章

  1. 2017淘宝怎么变?商家要抓住这些机会!
  2. rfm模型的matlab实现,基于客户价值的客户分类模型.docx
  3. 股票软件开发技术之个股的选择功能设计思路101
  4. MapReduce实现改进版WordCount词频统计
  5. video使用canvas截图黑屏
  6. 常用在线工具网站整理
  7. 下班回家后,肝到凌晨1点,终于完成老婆的数据需求
  8. Python基础+数据科学入门(七)
  9. Spring 3.x企业应用开发实战
  10. Activity的生命周期与跳转