原题链接:http://www.lydsy.com/JudgeOnline/problem.php?id=1646
一本通链接:http://ybt.ssoier.cn:8088/problem_show.php?pid=1253

抓住那头牛

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 <= N <= 100,000) on a number line and the cow is at a point K (0 <= K <= 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X-1 or X+1 in a single minute * Teleporting: FJ can move from any point X to the point 2*X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

农夫约翰被通知,他的一只奶牛逃逸了!所以他决定,马上幽发,尽快把那只奶牛抓回来.

他们都站在数轴上.约翰在N(O≤N≤100000)处,奶牛在K(O≤K≤100000)处.约翰有两种办法移动,步行和瞬移:步行每秒种可以让约翰从z处走到x+l或x-l处;而瞬移则可让他在1秒内从x处消失,在2x处出现.然而那只逃逸的奶牛,悲剧地没有发现自己的处境多么糟糕,正站在那儿一动不动.

那么,约翰需要多少时间抓住那只牛呢?

Input

Line 1: Two space-separated integers: N and K

仅有两个整数N和K.

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

最短的时间.

Sample Input

5 17

Farmer John starts at point 5 and the fugitive cow is at point 17.

Sample Output

4

OUTPUT DETAILS:

The fastest way for Farmer John to reach the fugitive cow is to

move along the following path: 5-10-9-18-17, which takes 4 minutes.

题解

bfs裸题,巨水不解释。

代码
#include<bits/stdc++.h>
using namespace std;
const int M=1e5+5;
int p1=1,p2=1;
int n,k;
bool sq[M];
int step[M][2];
int main()
{scanf("%d%d",&n,&k);sq[n]=1;step[1][1]=n;int maxn=max(n,k)+1;if(n==k)printf("0"),exit(0);while(p1<=p2){int a;for(int i=1;i<=3;i++){if(i==1)a=step[p1][1]-1;if(i==2)a=step[p1][1]+1;if(i==3)a=step[p1][1]*2;if(a<0||a>maxn)continue;if(sq[a]==0){p2++;sq[a]=1;step[p2][1]=a;step[p2][0]=step[p1][0]+1;if(a==k){printf("%d\n",step[p2][0]);return 0;}}}p1++;}return 0;
}

凯老师神奇的dp版

#include<cstdio>
#include<queue>
using namespace std;
int dp[100005];
int n,k;
struct no{int pl,step;
};
queue<no> q;
void BFS(){q.push((no){n,1});dp[n]=1;while(!q.empty()){if(dp[k]!=0) {printf("%d",dp[k]-1);return;}no u=q.front();q.pop();if(u.pl+1<=100000&&dp[u.pl+1]==0){dp[u.pl+1]=u.step+1;q.push((no){u.pl+1,u.step+1});}if(u.pl-1>=0&&dp[u.pl-1]==0){dp[u.pl-1]=u.step+1;q.push((no){u.pl-1,u.step+1});}if((u.pl<<1)<=100000&&dp[u.pl<<1]==0){dp[u.pl<<1]=u.step+1;q.push((no){u.pl<<1,u.step+1});}}
}
int main(){scanf("%d%d",&n,&k);BFS();return 0;
}

BZOJ1646[Usaco2007 Open] 抓住那头牛相关推荐

  1. 信息学奥赛一本通(1253:抓住那头牛)

    1253:抓住那头牛 时间限制: 1000 ms         内存限制: 65536 KB 提交数: 14146     通过数: 5444 [题目描述] 农夫知道一头牛的位置,想要抓住它.农夫和 ...

  2. 广度优先搜索(BFS)——抓住那头牛(POJ 4001)

    本文将以(POJ 4001)抓住那头牛 为例,讲解经典算法广度优先搜索(BFS)的STL写法 在实际写算法中,怎么能不使用更快.更方便.更准确.更高效的C++ STL模板呢 相信很多人都了解过广度优先 ...

  3. 【信奥赛一本通】1253:抓住那头牛(详细代码)

    [广度优先搜索算法]1253:抓住那头牛 1.[题目描述] 2.[代码] 1.[题目描述] [题目描述] 农夫知道一头牛的位置,想要抓住它.农夫和牛都位于数轴上,农夫起始位于点N(0≤N≤100000 ...

  4. Catch That Cow(抓住那头牛C++)

    Catch That Cow Farmer John has been informed of the location of a fugitive cow and wants to catch he ...

  5. C++广度优先搜索算法之抓住那头牛(Catch that cow)

    抓住那头牛: 农夫知道一头牛的位置,想要抓住它.农夫和牛都位于数轴上,农夫起始位于点N(0<=N<=100000),牛位于点K(0<=K<=100000).农夫有两种移动方式: ...

  6. 抓住那头牛(POJ NO.2971)

    抓住那头牛(POJ NO.2971) 总时间限制: 2000ms 内存限制: 65536kB Question 描述 农夫知道一头牛的位置,想要抓住它.农夫和牛都位于数轴上,农夫起始位于点N(0< ...

  7. 抓住那头牛(宽搜bfs)

    Description 农夫知道一头牛的位置,想要抓住它.农夫和牛都位于数轴上,农夫起始位于点N,牛位于点K. 农夫有两种移动方式: 1.从X移动到X−1或X+1,每次移动花费一分钟. 2.从X移动到 ...

  8. 抓住那头牛(BFS广搜)

    描述 农夫知道一头牛的位置,想要抓住它.农夫和牛都位于数轴上,农夫起始位于点N(0≤N≤100000),牛位于点K(0≤K≤100000).农夫有两种移动方式: 1.从X移动到X-1或X+1,每次移动 ...

  9. 萌新做点小玩意儿DAY-9 利用队列式分支限界解决抓住那头牛问题

    回溯法采用的是是深度优先搜索的策略,一般被用在找到一个问题的所有解.但是当问题只需要找到一个最优解的时候,可以使用分支限界的算法思想.分支限界算法思想就是以广度优先的策略对解空间树进行遍历,每个活结点 ...

  10. 抓住那头牛(信息学奥赛一本通-T1253)

    [题目描述] 农夫知道一头牛的位置,想要抓住它.农夫和牛都位于数轴上,农夫起始位于点N(0≤N≤100000),牛位于点K(0≤K≤100000).农夫有两种移动方式: 1.从X移动到X-1或X+1, ...

最新文章

  1. xwpftemplate的时间设置_java poi设置生成的word的图片为上下型环绕以及其位置
  2. python程序员最害怕的东西,面试!恭喜你收到了offer,来看下吧
  3. 让你的系统“坚挺不倒”的最后一个大招——「降级」
  4. mysql 创建job_MySQL 索引创建
  5. 全国计算机等级考试题库二级C操作题100套(第40套)
  6. 两点(51Nod-1416)
  7. 10 分钟入门 Less 和 Sass
  8. python文件是否存在_Python判断文件是否存在的三种方法
  9. 关于二分限制最短路的题的总结
  10. 数据库系统概论总结(第五版)
  11. ftp中转服务器,bat实现的ftp中转
  12. 无人机——磁力计/电子罗盘 学习及校准
  13. 技嘉z77主板msata速度_z77-d3h_技嘉z77d3h说明书_技嘉z77 d3h msata
  14. Android判断世界各国手机号码合法性
  15. 计算机网络 --- IP地址的详细分类
  16. 蓝牙耳机连接笔记本电脑音量直接爆棚
  17. 类设计原则及设计模式(一篇就够)
  18. 零基础怎么系统学习大数据?
  19. Hexo-Theme-Sakura 实践记录
  20. add_metrology_object_circle_measure (对齐测量模型)

热门文章

  1. java使用io上传文件_文件传输基础——Java IO流
  2. Raki的读paper小记:FastText:Enriching Word Vectors with Subword Information
  3. 共享usb接口给虚拟机_多网卡虚拟机如何设置?收藏绝对有用
  4. mysql 更新删除数据,MYSQL数据的插入、删除、更新
  5. golang日志收集方案之ELK
  6. 关于java调用Dll文件的异常 Native library (win32-x86-64/CtrlNPCDLL.dll) not found in resource pat...
  7. Mybatis中的update动态SQL语句
  8. 科工网大数据有力促进机器人制造业发展
  9. 性能分析:处理器、磁盘I/O、进程、网络分析方法 http://www.cnblogs.com/fnng/archive/2012/10/30/2747246.html...
  10. 用于查询当前数据库中所有表格的记录条数的脚本