题目链接
A Corrupt Mayor’s Performance Art
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 100000/100000 K (Java/Others)
Total Submission(s): 4094 Accepted Submission(s): 1418

Problem Description
Corrupt governors always find ways to get dirty money. Paint something, then sell the worthless painting at a high price to someone who wants to bribe him/her on an auction, this seemed a safe way for mayor X to make money.

Because a lot of people praised mayor X’s painting(of course, X was a mayor), mayor X believed more and more that he was a very talented painter. Soon mayor X was not satisfied with only making money. He wanted to be a famous painter. So he joined the local painting associates. Other painters had to elect him as the chairman of the associates. Then his painting sold at better price.

The local middle school from which mayor X graduated, wanted to beat mayor X’s horse fart(In Chinese English, beating one’s horse fart means flattering one hard). They built a wall, and invited mayor X to paint on it. Mayor X was very happy. But he really had no idea about what to paint because he could only paint very abstract paintings which nobody really understand. Mayor X’s secretary suggested that he could make this thing not only a painting, but also a performance art work.

This was the secretary’s idea:

The wall was divided into N segments and the width of each segment was one cun(cun is a Chinese length unit). All segments were numbered from 1 to N, from left to right. There were 30 kinds of colors mayor X could use to paint the wall. They named those colors as color 1, color 2 … color 30. The wall’s original color was color 2. Every time mayor X would paint some consecutive segments with a certain kind of color, and he did this for many times. Trying to make his performance art fancy, mayor X declared that at any moment, if someone asked how many kind of colors were there on any consecutive segments, he could give the number immediately without counting.

But mayor X didn’t know how to give the right answer. Your friend, Mr. W was an secret officer of anti-corruption bureau, he helped mayor X on this problem and gained his trust. Do you know how Mr. Q did this?

Input
There are several test cases.

For each test case:

The first line contains two integers, N and M ,meaning that the wall is divided into N segments and there are M operations(0 < N <= 1,000,000; 0<M<=100,000)

Then M lines follow, each representing an operation. There are two kinds of operations, as described below:

  1. P a b c
    a, b and c are integers. This operation means that mayor X painted all segments from segment a to segment b with color c ( 0 < a<=b <= N, 0 < c <= 30).

  2. Q a b
    a and b are integers. This is a query operation. It means that someone asked that how many kinds of colors were there from segment a to segment b ( 0 < a<=b <= N).

Please note that the operations are given in time sequence.

The input ends with M = 0 and N = 0.

Output
For each query operation, print all kinds of color on the queried segments. For color 1, print 1, for color 2, print 2 … etc. And this color sequence must be in ascending order.

Sample Input
5 10
P 1 2 3
P 2 3 4
Q 2 3
Q 1 3
P 3 5 4
P 1 2 7
Q 1 3
Q 3 4
P 5 5 8
Q 1 5
0 0

Sample Output
4
3 4
4 7
4
4 7 8

Source
2014 ACM/ICPC Asia Regional Guangzhou Online

考虑到题目说的颜色只有30种,我们可以用一个二进制数来表示演的二进制数的第k位是一就代表它是第k种颜色。
说是线段树染色,但是具体跟线段树求和没什么太大区别,就是把
push_up中的 + 号变成了 | 符号

#include<iostream>
#include<cstdio>
#define mid ((l + r) >> 1)//宏定义的mid注意最外面要有括号
#define lson rt << 1, l, mid//左子树
#define rson rt << 1 | 1, mid + 1, r//右子树
#define ls rt << 1//左子树下标
#define rs rt << 1 | 1//右子树下标
#define tag tree[rt].lazy//简化lazy标记
using namespace std;
const int N = 4e6 + 10;
struct Tree {int color, lazy;
}tree[N];
int n, m;
void push_down(int rt) {if(tag) {tree[ls].color = tree[rs].color = tag;tree[ls].lazy = tree[rs].lazy = tag;tag = 0;}
}
void push_up(int rt) {tree[rt].color = tree[ls].color | tree[rs].color;
}
void build(int rt, int l, int r) {tree[rt].lazy = 0;//注意lazy标记位0if(l == r) {tree[rt].color = 1 << 1;//初始化1 << (2 - 1)return ;}build(lson);build(rson);push_up(rt);
}
void update(int rt, int l, int r, int L, int R, int k) {if(l >= L && r <= R) {tree[rt].color = 1 << (k - 1);tree[rt].lazy = 1 << (k - 1);return ;}push_down(rt);if(L <= mid)  update(lson, L, R, k);if(R > mid)    update(rson, L, R, k);push_up(rt);
}
int query(int rt, int l, int r, int L, int R) {if(l >= L && r <= R)return tree[rt].color;push_down(rt);int a = 0;if(L <= mid)  a |= query(lson, L, R);if(R > mid)  a |= query(rson, L, R);return a;
}
int main() {char op;int x, y, k;while(scanf("%d %d", &n, &m) && (n + m)) {build(1, 1, n);for(int i = 0; i < m; i++) {getchar();scanf("%c", &op);if(op == 'P') {scanf("%d %d %d", &x, &y, &k);update(1, 1, n, x, y, k);}else {scanf("%d %d", &x, &y);int state = query(1, 1, n, x, y);//得到当前询问段落的颜色二进制数int ans = 0;bool isfirst = false;//输出格式每行最后面没有空格for(int i = 0; i < 30; i++)//从小到大开始判断位数是不是1if(state >> i & 1)if(isfirst)printf(" %d", i + 1);//输出应该是位数 i + 1else {isfirst = true;printf("%d", i + 1);}puts("");//文段输出换行}}}return 0;
}

hdu 5023 线段树染色问题相关推荐

  1. POJ 2777 ZOJ 1610 HDU 1698 --线段树--区间更新

    直接将这3题 放一起了  今天在做线段树的东西 这3个都是区间更新的 查询方式互相不同 反正都可以放到一起吧 直接先上链接了 touch me touch me touch me 关于涉及到区间的修改 ...

  2. poj 2528 离散化+线段树 hdu 1698 线段树 线段树题目类型一:染色计数 外加离散化

    第一次听到离散化是今年省赛的时候,一道矩形并的题,很水,就两个矩形... 今天再去做线段树已经发现离散化忘得差不多了...水逼的悲哀啊... 先看简单点的hdu 1698 http://acm.hdu ...

  3. poj 2777 AND hdu 5316 线段树

    区间染色问题,用线段树可以解决.颜色总类不多,故考虑用二进制数的每一位表示一种颜色,然后父节点的颜色就是孩子节点颜色"或"起来,加上lazy标记,轻松AC. poj 2777: 1 ...

  4. hdu 5367(线段树+区间合并)

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5367 官方题解: 对于求"高山脉"长度,可以利用线段树.树节点中保存左高度连续长度 ...

  5. hdu 5266(线段树+LCA)

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5266 解题思路: 考虑dfs序,通过在简单的证明可知L~R的LCA为L ~R 中dfs序较小的那个位置 ...

  6. hdu 5124(线段树区间更新+lazy思想)

    http://acm.hdu.edu.cn/showproblem.php?pid=5124 题意:区间覆盖次数问题. 解题思路:线段树水之. #include<iostream> #in ...

  7. HDU - 4578Transformation——线段树+区间加法修改+区间乘法修改+区间置数+区间和查询+区间平方和查询+区间立方和查询

    [题目描述] HDU - 4578Transformation Problem Description Yuanfang is puzzled with the question below: The ...

  8. HDU-5023 线段树染色问题+延时标记

    题意 给我们1-n的区间段 两种操作 P a b c 表示把a到b染成c颜色 Q a b 表示求a到b的颜色种类数量 注意初始全部先染成颜色2 分析 线段树经典染色问题 可以用二进制来表示颜色数量 一 ...

  9. 贴海报 (线段树染色-离散化

    n(n<=10000) 个人依次贴海报,给出每张海报所贴的范围li,ri(1<=li<=ri<=10000000) .求出最后还能看见多少张海报. 虽然之前学过离散化,但用的时 ...

最新文章

  1. SAP智能机器人流程自动化解决方案
  2. 使用data-自定义数据及如何获取该值
  3. DQL查询语句内容整理
  4. CodeForces 877C
  5. 戴机械手表有哪些事情就不能做了?
  6. SpringBoot(尚硅谷)
  7. 第五节 comware概述
  8. 【图神经网络】图神经网络(GNN)学习笔记:GraphSAGE
  9. 【程序员节】1024程序员节专属程序员的浪漫
  10. 2016十月新番简介
  11. 一项采用MasimoO3(R)的前瞻性研究就通气抢救疗法对COVID-19患者脑氧合的效应进行了深入探查
  12. 【华为OD机试真题 JAVA】竖直四子棋
  13. PAJ7620u2手势模块
  14. 汇编idiv带符合除法指令。。。。
  15. python 拼音库_python有没有拼音库python进阶之socket详解
  16. 用java创建person类_创建一个Person类,有以下属性:名字、身高、性别、年龄,创建10个对象,用java程序...
  17. moviepy中视频时长修改
  18. Windows 11 安装的那些事
  19. 使用DESeq2进行两组间的差异分析
  20. java 实现atof函数

热门文章

  1. 3部世界顶级宇宙纪录片,献给对宇宙万物充满好奇的你~
  2. 下班以后看什么,决定你人生的高度
  3. 超线程_超线程加核显 i310100+梅捷H410超值爆款组合
  4. java继承接口和泛型,JavaSE习题 继承接口和泛型
  5. linux检查系统硬件信息命令,Linux查看系统信息(硬件信息, 系统设置信息等) 命令 | Soo Smart!...
  6. 计算机管理无法连接虚拟磁盘服务,虚拟磁盘服务错误怎么操作【图文教程】
  7. linux编程两个子进程,Linux中fork同时创建多个子进程的方法
  8. java导入导出excel_Java导入导出Excel工具 easyexcel
  9. cheatengine找不到数值_彩票中奖500万,领了还不到一半?这些问题不解决,钱都拿不走...
  10. 435. 无重叠区间(贪心经典题+思路+详解)