题意:

n * n的正方形格子(每个格子均放了奶酪),老鼠从(0,0)开始,每次最多移动k步,可以选择上下左右四个方向移动,下一个移动点奶酪块数量必须要大于当前点。

整理模板ing…

题目:

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input

There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

分析:

记忆化搜索入门,当采用记忆化搜索时,不必事先确定各状态的计算顺序,但需要记录每个状态“是否已经计算过”。
总结一下记忆化搜索是啥:
1.不依赖任何 外部变量(调用函数内的变量也没有变化)
2.答案以返回值的形式存在, 而不能以参数的形式存在(就是不能将 dfs 定义成 dfs(pos ,tleft , nowans ) , 这里面的 nowans 不符合要求).
3.对于相同一组参数, dfs 返回值总是相同的(参见第一条)
就这道题复杂度为:O(n2n^{2}n2):每个点只遍历了一次,从O(2n2^{n}2n)~O(n2n^{2}n2)这是记忆化搜索算法在时间复杂度上的优越性

AC代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,m;
int dp[110][110],a[110][110];
int c[4][2]= {0,1,0,-1,1,0,-1,0};
int dfs(int u,int v)
{if(dp[u][v]!=-1)return dp[u][v];dp[u][v]=a[u][v];for(int i=0; i<4; i++)for(int j=1; j<=m; j++){int x=u+c[i][0]*j;int y=v+c[i][1]*j;if(x<0||y<0||x>=n||y>=n||a[u][v]>=a[x][y])continue;dp[u][v]=max(dp[u][v],dfs(x,y)+a[u][v]);}return  dp[u][v];
}
int main()
{while(~scanf("%d%d",&n,&m)){if(n==-1&&m==-1)break;for(int i=0; i<n; i++)for(int j=0; j<n; j++)scanf("%d",&a[i][j]);memset(dp,-1,sizeof(dp));printf("%d\n",dfs(0,0));}return 0;
}

FatMouse and Cheese HDU - 1078(记忆化搜索入门模板)相关推荐

  1. hdu 1078 记忆化搜索

    题意:给出n*n的格子,每个各自里面有些食物,问一只老鼠每次走最多k步所能吃到的最多的食物 虽然是做过的老题了,但是1A的感觉好爽,对搜索认识更深了 1 #include<cstdio> ...

  2. 动态规划训练21 [FatMouse and Cheese HDU - 1078 ]

    FatMouse and Cheese HDU - 1078 这道题需要说一说,定义dp[x][y]表示从点(x,y)出发,每次走不超过k步,所能吃到的最大量. 有点难搞的是,这里递归的顺序不好确定, ...

  3. hdu 4722(记忆化搜索)

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4722 思路:简单的记忆化搜索,留意一下A==0时的情况就可以了. 1 #include<iost ...

  4. hdu 1142 记忆化搜索

    题目是这样的,貌似一开始我这个英语搓的人还理解错了...orz http://acm.hdu.edu.cn/showproblem.php?pid=1142 就是最短路,只不过用dijkstra是从终 ...

  5. hdu 1514 记忆化搜索

    题意是给4堆(堆的高度小于等于40)有颜色(颜色的种类小于等于20)的物品,你有一个篮子最多能装5件物品,每次从这4堆物品里面 任取一件物品放进篮子里,但是取每堆物品时,必须先取上面的物品,才能取下面 ...

  6. HDU1937How many ways(记忆化搜索)入门

    Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission ...

  7. 记忆化搜索,FatMouse and Cheese

    题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1107 http://acm.hdu.edu.cn/showpro ...

  8. HDU 1078 FatMouse and Cheese【记忆化搜索】

    <题目链接> 题目大意: 给你一个n*n的矩阵,每个矩阵上有相应数量的奶酪,老鼠一次最多走K步,且每次只能横着走或者竖着走,并且每一次停留位置上的奶酪数一定要多余它刚才的奶酪数,求这只老鼠 ...

  9. hdu 1078(记忆化搜索)

    题意: 老鼠每次最多走k步停下来,停下的这个位置只能比上一个停留的位置大,并获取其价值,每次只能水平或垂直走,问最大能得到的价值 解题思路:这道题可以用记忆化搜索解决,dp[i][j]表示老鼠在位置( ...

最新文章

  1. 在撤销“本地修改”之后再恢复
  2. 1151 LCA in a Binary Tree (含求LCA的通法)
  3. 商业实战第三场 电视直销好记星
  4. VS 2013 with update安装失败(kb2829760)解决方案
  5. Linux系统编程之Vim使用小技巧---代码自动对齐,智能提示
  6. 简单的复数运算(类和对象)_JAVA
  7. 【面向对象】泛化与继承
  8. GitHub 发布中文版帮助文档,这翻译也是醉了~
  9. 编写java判断闰年_编写java程序判断闰年。
  10. SugarNMS分布式网络运维部署攻略
  11. arduino安卓手机版_剥离安卓!华为鸿蒙系统手机版正式发布:这两大机型率先升级...
  12. 随机梯度下降(SGD)和批量梯度下降(BGD)的区别
  13. nginx access日志log_format优化之request_time 和upstream_response_time差别
  14. 前端项目如何做测试?
  15. Java retainAll抛错UnsupportedOperationException记录
  16. 基于51单片机的模拟信号检测系统
  17. 微信内置浏览器禁止调整字体大小的方法
  18. 检索策略(抓取策略)
  19. 黑客余弦——我的世界观(一)【转】
  20. 52单片机四种方法实现流水灯

热门文章

  1. php Trait 基础应用讲解
  2. 一维数组和二维数组的区别_数组指针和指针数组的区别
  3. opencv 平面法向量_在OpenCV中绘制平面的法向量
  4. 这个被称为20世纪最伟大人物的最强理科生,到底有多强,你根本不了解
  5. 下班以后看什么,决定你人生的高度
  6. Prim 算法及其高效实现
  7. 一文读懂 AVL 树
  8. 《SAS编程与数据挖掘商业案例》学习笔记之六
  9. java.lang.illegalagr_spring – java.lang.IllegalArgumentException:环境不能为null
  10. linux7为nginx添加服务,CentOS7添加Nginx为系统服务