---恢复内容开始---

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13003    Accepted Submission(s): 6843

Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 5
8 97 93
23 84 62
64 33 83 27
0

Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题目链接:HDU 1069

题意:给出n种块的尺寸,用坐标x、y、z表示,当某一个块的两个比下面的块中某个两个坐标小的时候就可以把这个块叠上去,可以把块旋转一下使得三个坐标互相转变……

块的数量是无限的其实是吓唬人的,由于是要严格上升,显然三个已经把所有情况考虑了,四个肯定会跟某一种重复,然后每一个块都假设有三个,用O(n2)的方法求一种可以说是带权LIS的东西就行了

代码:

#include <stdio.h>
#include <bits/stdc++.h>
using namespace std;
#define INF 0x3f3f3f3f
#define CLR(arr,val) memset(arr,val,sizeof(arr))
#define LC(x) (x<<1)
#define RC(x) ((x<<1)+1)
#define MID(x,y) ((x+y)>>1)
typedef pair<int,int> pii;
typedef long long LL;
const double PI=acos(-1.0);
const int N=190;
struct info
{int x;int y;int z;bool operator<(const info &t)const{if(x!=t.x)return x<t.x;return y<t.y;}info(int xx,int yy,int zz):x(xx),y(yy),z(zz){}info(){}
};
vector<info>arr;
int dp[N];
int main(void)
{int n,i,j,x,y,z;int q=1;while (~scanf("%d",&n)&&n){CLR(dp,0);arr.clear();for (i=0; i<n; ++i){scanf("%d%d%d",&x,&y,&z);arr.push_back(info(x,y,z));arr.push_back(info(x,z,y));arr.push_back(info(y,x,z));arr.push_back(info(y,z,x));arr.push_back(info(z,x,y));arr.push_back(info(z,y,x));}sort(arr.begin(),arr.end());int SZ=arr.size();for (i=0; i<SZ; ++i){int pre_max=0;for (j=0; j<i; ++j){if(arr[j].x<arr[i].x&&arr[j].y<arr[i].y&&dp[j]>pre_max)pre_max=dp[j];}dp[i]=pre_max+arr[i].z;}printf("Case %d: maximum height = %d\n",q++,*max_element(dp,dp+SZ));//n^2算法这里就要取max,之前搞混了直接输出最后一个导致WA}return 0;
}

转载于:https://www.cnblogs.com/Blackops/p/5930755.html

HDU 1069 Monkey and Banana(二维偏序LIS的应用)相关推荐

  1. HDU 1069 Monkey and Banana 最长上升子序列进阶(动态规划)

    HDU 1069(动态规划) Monkey and Banana Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K ...

  2. HDU 1069 Monkey and Banana(简单图解,经典DP,最大上升子序列变形)

    题目链接 今天做的第二题,感觉比较经典,详细记录一下吧! Monkey and Banana Time Limit: 2000/1000 MS (Java/Others) Memory Limit: ...

  3. 三维最长上升子序列问题——HDU 1069 Monkey and Banana

    题目: A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a ...

  4. hdu 1069 Monkey and Banana (LIS)

    Problem - 1069 随便找到的一道题目. 题意是给出一些的长方体,长方体可以用任意次数,可以任意翻转.如果一个长方体可以叠在另一个长方体上,条件是这个长方体的长和宽严格小于另一个长方体的长和 ...

  5. hdu(1069)——Monkey and Banana(LIS变形)

    题意: 如今给你n个石块,然后它由坐标来表示(x,y,z).可是它能够有不同的方法,也就是说它的三个坐标能够轮换着来的. 石块的数量不限,可是每次都必须保持上底面的长和宽严格递减,然后问你用这些石块所 ...

  6. HDU 1069 Monkey and Banana

    传送门 #include<iostream> #include<algorithm> #include<map> #include<set> #incl ...

  7. hdu 1069 Monkey and Banana 【动态规划】

    题目 题意:研究人员要测试猴子的IQ,将香蕉挂到一定高度,给猴子一些不同大小的箱子,箱子数量不限,让猩猩通过叠长方体来够到香蕉. 现在给你N种长方体, 要求:位于上面的长方体的长和宽  要小于  下面 ...

  8. hdu 1069 Monkey and Banana dp

    题意:给你n种个长方体,告诉你每种长方体的长,宽,高,并且每种长方体个数不限 问:把它们堆起来的最大高度 限制条件:上面一个长方体a的底面积,必须比它下面一个长方体b的底面积大,而且,a的底面的长宽也 ...

  9. HDU6681 二维偏序计算贡献值 树状数组 离散化

    http://acm.hdu.edu.cn/showproblem.php?pid=6681 交点个数加1就是答案 使用二维偏序计算横竖射线的交点 #include <bits/stdc++.h ...

  10. BZOJ 2131 免费的馅饼(DP,二维偏序问题 / 旋转坐标轴转化问题)【BZOJ 修复工程】

    整理的算法模板合集: ACM模板 点我看算法全家桶系列!!! 实际上是一个全新的精炼模板整合计划 题目链接 https://hydro.ac/d/bzoj/p/2131 是 hydro 的 BZOJ ...

最新文章

  1. php中操作mysql的函数库
  2. 大数据时代,谁的眼神锁定你?
  3. 华三交换机ping不通用户但用户_H3C故障常见故障及解决方案
  4. zookeeper安装包_构建高可用ZooKeeper集群
  5. 2.5.jieba分词工具、Jieba安装、全模式/精确模式、添加自定义词典、关键词抽取、词性标注、词云展示
  6. MySQL前缀索引与覆盖索引:前缀索引对于索引精简 覆盖索引对于查询数据索引化
  7. TCP 连接中的TIME_WAIT
  8. 硬件平台选型(1)---SDM 660 VS SDM670
  9. codeforces 1221 A B C D
  10. mysql change column_Modify column Vs change column
  11. C语言函数一章教学,c语言案例教程:函数教学讲义.ppt
  12. 【总结】树状数组讲解+例题
  13. 封装方法-数字转大写(一)——将数字金额转换为大写金额
  14. [Linux] 添加清华镜像
  15. 优炫软件中标西南民族大学项目,护航教育行业主机安全
  16. 中南大学计算机博士就业,求救!中南大学博士毕业要求
  17. java发送图片邮件_使用javamail发送包含图片的html格式邮件详解
  18. MyEclipse个性设置
  19. 1.8w 字 | 初中级前端 JavaScript 自测清单 - 2
  20. Linux做服务器搭建ngrok服务器

热门文章

  1. C语言四川麻将算法,四川麻将胡牌算法
  2. 一文带你认清云服务器和轻量应用服务器的区别
  3. 【机器学习】实验一 实验报告
  4. 推荐一款安卓手机一键Root工具
  5. 计算机组装与维护参考文献,计算机的组装与维护毕业论文.doc
  6. 像素是计算机图像处理的最小单元,图像处理复习
  7. 【Redis核心原理和应用实践】应用 1:千帆竞发 —— 分布式锁
  8. C盘爆满,你的专属清道夫来啦
  9. 360云盘上传 计算机文件格式,360云盘怎么上传文件 360云盘上传文件方法
  10. 人人都应该开个公众号