通过MPLS ×××技术,使得客户A的两个站点可以互访,客户A和客户B之间是不能互访的,现在有需求客户A-1站点要跟客户B互访,可以使用export map给他们分配相同的BGP extented community RT来达到目的。

客户A之间可以互相看到路由

现在要求客户A-1和客户B之间可以互访,但客户A-2和客户B之间不能互访

使用export map后客户A-1可以收到客户B路由

客户B也可以收到客户A-1路由

客户A-2不能收到客户B的路由

配置:

R1:

interface Loopback0
ip address 192.168.0.1 255.255.255.0
!
interface Loopback1
ip address 192.168.1.1 255.255.255.0
!
interface Loopback2
ip address 192.168.2.1 255.255.255.0
!
interface Loopback3
ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet1/0
ip address 12.1.1.1 255.255.255.0
duplex auto
speed auto
!
router bgp 65000
bgp router-id 1.1.1.1
bgp log-neighbor-changes
network 192.168.0.0
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
neighbor 12.1.1.2 remote-as 1

R2:

ip vrf A 
rd 1:1
 export map AtoB
route-target export 1:2
route-target import 1:1
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet1/0
ip vrf forwarding A
ip address 12.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 23.1.1.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
!
router eigrp 1
network 2.2.2.2 0.0.0.0
network 23.1.1.2 0.0.0.0
!
router bgp 1
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 1
neighbor 3.3.3.3 update-source Loopback0
!
address-family ***v4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community extended
exit-address-family
!
address-family ipv4 vrf A
  neighbor 12.1.1.1 remote-as 65000
  neighbor 12.1.1.1 activate
  neighbor 12.1.1.1 as-override
exit-address-family
!
route-map AtoB permit 10
set extcommunity rt 1:6 additive
!
route-map AtoB permit 20

R3:

ip vrf A 
rd 1:2
route-target export 1:1
route-target import 1:2
!
ip vrf B
rd 1:6
 export map BtoA
route-target export 1:5
route-target import 1:6
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet1/0
ip address 23.1.1.3 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/1
ip vrf forwarding A
ip address 34.1.1.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
ip vrf forwarding B
ip address 35.1.1.3 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 3.3.3.3 0.0.0.0
network 23.1.1.3 0.0.0.0
!
router bgp 1
bgp router-id 3.3.3.3
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 1
neighbor 2.2.2.2 update-source Loopback0
!
address-family ***v4
  neighbor 2.2.2.2 activate
  neighbor 2.2.2.2 send-community extended
exit-address-family
!
address-family ipv4 vrf A
  neighbor 34.1.1.4 remote-as 65000
  neighbor 34.1.1.4 activate
  neighbor 34.1.1.4 as-override
exit-address-family
!
address-family ipv4 vrf B
  neighbor 35.1.1.5 remote-as 65001
  neighbor 35.1.1.5 activate
exit-address-family
!
route-map BtoA permit 10
set extcommunity rt 1:1 additive
!
route-map BtoA permit 20

R4:

interface Loopback0
ip address 10.1.0.1 255.255.255.0
!
interface Loopback1
ip address 10.1.1.1 255.255.255.0
!
interface Loopback2
ip address 10.1.2.1 255.255.255.0
!
interface Loopback3
ip address 10.1.3.1 255.255.255.0
!
interface FastEthernet1/0
ip address 34.1.1.4 255.255.255.0
duplex auto
speed auto
!
router bgp 65000
bgp router-id 4.4.4.4
bgp log-neighbor-changes
network 10.1.0.0 mask 255.255.255.0
network 10.1.1.0 mask 255.255.255.0
network 10.1.2.0 mask 255.255.255.0
network 10.1.3.0 mask 255.255.255.0
neighbor 34.1.1.3 remote-as 1

R5:

interface Loopback0
ip address 172.16.0.1 255.255.255.0
!
interface Loopback1
ip address 172.16.1.1 255.255.255.0
!
interface Loopback2
ip address 172.16.2.1 255.255.255.0
!
interface Loopback3
ip address 172.16.3.1 255.255.255.0
!
interface FastEthernet1/0
ip address 35.1.1.5 255.255.255.0
duplex auto
speed auto
!
router bgp 65001
bgp router-id 5.5.5.5
bgp log-neighbor-changes
network 172.16.0.0 mask 255.255.255.0
network 172.16.1.0 mask 255.255.255.0
network 172.16.2.0 mask 255.255.255.0
network 172.16.3.0 mask 255.255.255.0
neighbor 35.1.1.3 remote-as 1

转载于:https://blog.51cto.com/q3322095/927329

Extranet MPLS ×××相关推荐

  1. 华为ENSP之 MPLS V Extranet

    实验目的 MPLS VPN Extranet场景 实验过程 1.AS345底层ospf连通,LSP使能MPLS LDP 2.R3.R4分别和R5建立IBGP邻居,和MP-IBGP邻居,VPNv4隧道 ...

  2. mpls ***简介

    在研究了基于mpls的***技术的原理和工作的基础上,给出了基于bgp扩展实现的mpls ***的一个网络组成模型,同时描述了这个模型中的各个设备及其功能.最后分析了mpls ***的技术优势及其应用 ...

  3. 华为数通HCIE面试看这个就够了系列——MPLS V*N

    文章目录 一.***基础. 1.***中路由器的角色. 2.MPLS ***. (1)如何解决不同site连接到同一个PE后,私网路由冲突问题? (2)如何在不同的PE之间传递路由信息? (3)RD在 ...

  4. 2023-01-20 网工进阶(三十九)MPLS 虚拟专用网络---概述、路由交互、CE接入PE方法、基本组网方案详解、团体属性、防环、MCE组网、伪连接方案、跨域组网详解、各种组网方案配置举例

    概述 VPN(Virtual Private Network,虚拟专用网络)指的是在一个公共网络中实现虚拟的专用网络,从而使得用户能够基于该专用网络实现通信的技术.MPLS VPN也是VPN技术中的一 ...

  5. 华为数通笔记-MPLS virtual private network

    简介 BGP MPLS VPN是一种L3VPN,它使用BGP在服务提供商骨干网发布VPN路由,使用MPLS,在骨干网中传递VPN路由. CE:用户边缘设备,与PE有相连的接口,感知不到VPN路由的存在 ...

  6. 跨区域MPLS TE

    拓扑: R1配置: mpls label range 100 199 mpls traffic-eng tunnels interface Loopback0 ip address 192.168.1 ...

  7. MPLS LDP随堂笔记1

    LDP 的使用原因(对于不同协议来说) LDP的四大功能 发现邻居 hello 5s 15s 224.0.0.2 发现邻居关系 R1 UDP 646端口 R2 UDP 646端口 此时形成邻居 建立邻 ...

  8. mpls 保留标签值_MPLS 标签模式/分发行为/保留模式/标签空间

    Technorati 标签: MPLS,LDP,标签,label,分发 LDP协议的"标签行为" LDP协议使用的是:独立分配模式,主动分发,自由保留模式.标签空间是基于平台的,也 ...

  9. MPLS ××× 的基本配置(五)

    检验 本节讲述了如何检查你的配置是否工作正常. · show ip vrf - Verifies that the correct VRF exists. · show ip vrf interfac ...

最新文章

  1. 阿士比亚:搜索团队智能内容生成实践
  2. 图像的线性变换的原理及OpenCV代码实现~
  3. Zookeeper 服务注册中心
  4. linux qt5.9 下载,在Ubuntu17.04上安装QT5.9.0(下载、安装、问题解决)
  5. python运算符中用来计算整商的是什么_零基础学python,看完这篇文章,你的python基础就差不多了...
  6. matlab 功率谱密度 汉宁窗_[振动与测试 2] 什么是PSD(功率谱密度)
  7. 转:判断Caps Lock键是否打开,如果打开则关闭
  8. FFmpeg AVFMT_NOFILE宏定义剖析
  9. 【原创】3大主流的移动应用方式APP开发姿势解读
  10. 脏数据-数据量纲差异
  11. python作者_Python
  12. 用C语言实现猜数游戏
  13. 学生成绩管理系统(Java)
  14. 程序员学英语之如何优雅的将单词本导出的txt文本转换为Excel
  15. 服务器位置异常饿了么,饿了么定位失败怎么办 饿了么无法定位解决办法
  16. Android 屏蔽Power键 Home键
  17. Encoded password does not look like BCrypt最新异常处理
  18. (Xcode)ipa上传APP Store鉴定报错
  19. 被修饰成单栋的倾斜摄影处理思路
  20. 四川公办计算机专业大学排名,2018年各地区计算机专业大学排名

热门文章

  1. centos 查看mysql 服务器配置_在CentOS上MySQL数据库服务器配置方法
  2. 分享Kali Linux 2016.2第46周镜像文件
  3. Xamarin Forms启动自带模拟器缓慢
  4. Xamarin iOS教程之编辑界面编写代码
  5. Kali Linux 安全渗透教程第二更Linux安全渗透简介
  6. Linux的load导入语句,LOAD DATA INFILE语句导入数据进入MySQL的一些注意事项
  7. 纵向表格_Excel如何把横向数据变纵向?教你一键快速实现
  8. php索引数组转键数组,php索引数组和关联数组
  9. linux nfs 读写性能,linux – Debian上的NFS性能问题
  10. 中科大博士带头搬砖!这家上市公司其实是最隐秘的AI高手