题目描述

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:

    3   1   2   44   3   67   916

Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities.

Write a program to help FJ play the game and keep up with the cows.

有这么一个游戏:

写出一个1~N的排列a[i],然后每次将相邻两个数相加,构成新的序列,再对新序列进行这样的操作,显然每次构成的序列都比上一次的序列长度少1,直到只剩下一个数字位置。下面是一个例子:

3 1 2 4

4 3 6

7 9 16 最后得到16这样一个数字。

现在想要倒着玩这样一个游戏,如果知道N,知道最后得到的数字的大小sum,请你求出最初序列a[i],为1~N的一个排列。若答案有多种可能,则输出字典序最小的那一个。

[color=red]管理员注:本题描述有误,这里字典序指的是1,2,3,4,5,6,7,8,9,10,11,12

而不是1,10,11,12,2,3,4,5,6,7,8,9[/color]

输入输出格式

输入格式:

两个正整数n,sum。

输出格式:

输出包括1行,为字典序最小的那个答案。

当无解的时候,请什么也不输出。(好奇葩啊)

输入输出样例

输入样例#1: 复制

4 16

输出样例#1: 复制

3 1 2 4

说明

对于40%的数据,n≤7;

对于80%的数据,n≤10;

对于100%的数据,n≤12,sum≤12345。

又是一道深搜题,又写了一份无任何优化的代码,哭。才20分。

无脑思路:枚举每个位置然后求和。果然TLE

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;int n, sum;
int ans[14];
int nnn[14];
bool book[11];
int Pascal_trangle[14][14];bool check()
{for (int j = 1; j <= n-1; j++)nnn[j] = ans[j] + ans[j + 1];for (int m = n - 2; m >= 1; m--){for (int j = 1; j <= m; j++)nnn[j] = nnn[j] + nnn[j + 1];}if (nnn[1] == sum)return true;elsereturn false;
}void dfs(int step)
{if (step > n){//for (int i = 1; i <= n; i++)//cout << ans[i] << ' ';//cout << '\n';if (check()){for (int i = 1; i <= n; i++)cout << ans[i] << ' ';exit(0);}}else{for (int i = 1; i <= n;i++)if (!book[i]){ans[step] = i;book[i] = true;dfs(step + 1);book[i] = false;ans[step] = 0;}}
}int main()
{//freopen("1.txt","r",stdin);cin >> n >> sum;dfs(1);return 0;
}

正确思路:

参考题解:https://www.luogu.org/blog/Chanis/solution-p1118

首先计算出来杨辉三角的第n行的系数,用一个二重循环即可。然后dfs(int step,int tmp) 此处的tmp是一个排列根据杨辉三角的系数计算的和,tmp是随着深度增加而增加的,所以一旦tmp大于目标的和,就可以判定不对(这是一个剪枝)。

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;
int n, sum;
int ans[14];
bool book[14];
int Pascal_trangle[14][14];void count_Pascal_trangle()//计算杨辉三角的系数
{Pascal_trangle[1][1] = 1;for (int i = 2; i <= n;i++)for (int j = 1; j <= i; j++)Pascal_trangle[i][j] = Pascal_trangle[i - 1][j - 1] + Pascal_trangle[i - 1][j];
}void dfs(int step,int tmp)
{if (tmp > sum)return;if (step > n){if (tmp == sum){for (int i = 1; i <= n; i++)cout << ans[i] << ' ';exit(0);}}for (int i = 1; i <= n;i++)if (!book[i]){ans[step] = i;book[i] = true;dfs(step + 1, tmp + ans[step] * Pascal_trangle[n][step]);book[i] = false;ans[step] = 0;}
}int main()
{//freopen("1.txt", "r", stdin);cin >> n >> sum;count_Pascal_trangle();dfs(1, 0);return 0;
}

洛谷P1118 [USACO06FEB]数字三角形Backward Digit Su…相关推荐

  1. 洛谷—— P1118 [USACO06FEB]数字三角形Backward Digit Su…

    https://www.luogu.org/problem/show?pid=1118#sub 题目描述 FJ and his cows enjoy playing a mental game. Th ...

  2. 洛谷 P1118 [USACO06FEB]数字三角形Backward Digit Su…

    题目描述 FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N ...

  3. 洛谷P1118 [USACO06FEB]数字三角形 Backward Digit Su(dfs剪枝)

    题目描述 FJ and his cows enjoy playing a mental game. They write down the numbers from 11 toN(1 \le N \l ...

  4. P1118 [USACO06FEB]数字三角形Backward Digit Su…

    P1118 [USACO06FEB]数字三角形Backward Digit Su- 题目描述 FJ and his cows enjoy playing a mental game. They wri ...

  5. P1118 [USACO06FEB]数字三角形`Backward Digit Su`…

    题目描述 FJ and his cows enjoy playing a mental game. They write down the numbers from 11 toN(1 \le N \l ...

  6. P1118 [USACO06FEB]数字三角形`Backward Digit Su`… 回溯法

    有这么一个游戏: 写出一个11至NN的排列a_iai​,然后每次将相邻两个数相加,构成新的序列,再对新序列进行这样的操作,显然每次构成的序列都比上一次的序列长度少11,直到只剩下一个数字位置.下面是一 ...

  7. P1118 [USACO06FEB]数字三角形`Backward Digit Su`…(C++_DFS)

    题目描述 FJ and his cows enjoy playing a mental game. They write down the numbers from 11 toN(1 \le N \l ...

  8. 杨辉三角 [USACO06FEB]数字三角形Backward Digit Su…

    杨辉三角 简单的说一下就是两个未知数和的幂次方运算后的系数问题,比如(x+y)的平方=x的平方+2xy+y的平方,这样系数就是1,2,1这就是杨辉三角的其中一行,立方,四次方,运算的结果看看各项的系数 ...

  9. [USACO06FEB]数字三角形Backward Digit Su…

    题目描述 3 1 2 44 3 67 916 有这么一个游戏: 写出一个1-N的排列a[i],然后每次将相邻两个数相加,构成新的序列,再对新序列进行这样的操作,显然每次构成的序列都比上一次的序列长度少 ...

最新文章

  1. 5.1Python函数(一)
  2. C语言实现上三角蛇形矩阵不用数组,蛇形矩阵c语言实现
  3. mysql从库夯住_MySQL从库维护经验分享
  4. nginx的学习(配置文件,以及部署的疑惑)
  5. Hibernate继承(2)子类属性生成在自己的一张表中,父类的属性一张表
  6. android 手机内存uri_android 的各种目录详解
  7. 说明是有两个虚拟机的HTML5
  8. MongoDB中的索引操作
  9. 数据库开发 - 事务 死锁分析与解决
  10. #C语言#警告:隐式声明函数‘xxx’ [-Wimplicit-function-declaration]
  11. js语法、关键保留字、变量、数据类型
  12. 动态修改UINavigationBar的背景色
  13. 2022-05 - 英语语法 - 16种时态终极详解
  14. Android端FMODSoundTouch音频变声解决方案
  15. 这几款超实用办公神器,让你的工作省心省时又省力!
  16. PHP实现常用设计模式之观察者模式
  17. JAVA下载和安装详细过程
  18. python算法(基础)----无序列表抽象数据类型
  19. 面试自我介绍如何介绍呢?
  20. 基于深度学习的遥感应用

热门文章

  1. lotus 开源C2优化版本
  2. html基础 vscode写代码
  3. 企业公司网站模板 免费下载
  4. 硬盘低级格式化全攻略
  5. 60天引爆学习力总结
  6. 2018年AI圈八大造假事件:罗生门此起彼伏,比娱乐圈精彩
  7. DataX系列4-TxtFileWriter介绍
  8. 关于CTRL+Z失效的问题
  9. 雷达系统 学习笔记(四)——脉冲多普勒雷达1
  10. PADS——PCB的制作