1.在基于IOS的交换机上设置主机名/系统名:
switch(config)# hostname hostname
在基于CLI的交换机上设置主机名/系统名:
switch(enable) set system name name-string
2.在基于IOS的交换机上设置登录口令:
switch(config)# enable password level 1 password
在基于CLI的交换机上设置登录口令:
switch(enable) set password
switch(enable) set enalbepass

3.在基于IOS的交换机上设置远程访问:
switch(config)# interface vlan 1
switch(config-if)# ip address ip-address netmask
switch(config-if)# ip default-gateway ip-address
在基于CLI的交换机上设置远程访问:
switch(enable) set interface sc0 ip-address netmask broadcast-address
switch(enable) set interface sc0 vlan
switch(enable) set ip route default gateway

4.在基于IOS的交换机上启用和浏览CDP信息:
switch(config-if)# cdp enable
switch(config-if)# no cdp enable
为了查看Cisco邻接设备的CDP通告信息:
switch# show cdp interface [type modle/port]
switch# show cdp neighbors [type module/port] [detail]
在基于CLI的交换机上启用和浏览CDP信息:
switch(enable) set cdp {enable|disable} module/port
为了查看Cisco邻接设备的CDP通告信息:
switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]

5.基于IOS的交换机的端口描述:
switch(config-if)# description description-string
基于CLI的交换机的端口描述:
switch(enable)set port name module/number description-string

6.在基于IOS的交换机上设置端口速度:
switch(config-if)# speed{10|100|auto}
在基于CLI的交换机上设置端口速度:
switch(enable) set port speed moudle/number {10|100|auto}
switch(enable) set port speed moudle/number {4|16|auto}

7.在基于IOS的交换机上设置以太网的链路模式:
switch(config-if)# duplex {auto|full|half}
在基于CLI的交换机上设置以太网的链路模式:
switch(enable) set port duplex module/number {full|half}

8.在基于IOS的交换机上配置静态VLAN:
switch# vlan database
switch(vlan)# vlan vlan-num name vla

switch(vlan)# exit
switch# configure teriminal
switch(config)# interface interface module/number
switch(config-if)# switchport mode access
switch(config-if)# switchport access vlan vlan-num
switch(config-if)# end
在基于CLI的交换机上配置静态VLAN:
switch(enable) set vlan vlan-num [name name]
switch(enable) set vlan vlan-num mod-num/port-list

9. 在基于IOS的交换机上配置VLAN中继线:
switch(config)# interface interface mod/port
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk encapsulation {isl|dotlq}
switch(config-if)# switchport trunk allowed vlan remove vlan-list
switch(config-if)# switchport trunk allowed vlan add vlan-list
在基于CLI的交换机上配置VLAN中继线:
switch(enable) set trunk module/port [on|off|desirable|auto|nonegotiate]
Vlan-range [isl|dotlq|dotl0|lane|negotiate]

10.在基于IOS的交换机上配置VTP管理域:
switch# vlan database
switch(vlan)# vtp domain domain-name
在基于CLI的交换机上配置VTP管理域:
switch(enable) set vtp [domain domain-name]

11.在基于IOS的交换机上配置VTP 模式:
switch# vlan database
switch(vlan)# vtp domain domain-name
switch(vlan)# vtp {sever|cilent|transparent}
switch(vlan)# vtp password password
在基于CLI的交换机上配置VTP 模式:
switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password password]
12. 在基于IOS的交换机上配置VTP版本:
switch# vlan database
switch(vlan)# vtp v2-mode
在基于CLI的交换机上配置VTP版本:
switch(enable) set vtp v2 enable

13. 在基于IOS的交换机上启动VTP剪裁:
switch# vlan database
switch(vlan)# vtp pruning
在基于CL I 的交换机上启动VTP剪裁:
switch(enable) set vtp pruning enable

14.在基于IOS的交换机上配置以太信道:
switch(config-if)# port group group-number [distribution {source|destination}]
在基于CLI的交换机上配置以太信道:
switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}

15.在基于IOS的交换机上调整根路径成本:
switch(config-if)# spanning-tree [vlan vlan-list] cost cost
在基于CLI的交换机上调整根路径成本:

switch(enable) set spantree portcost moudle/port cost
switch(enable) set spantree portvlancost moudle/port [cost cost][vlan-list]
http://www.vlan9.com/huawei-cert/h009009661.html

S2016与 S3016一样的,我给一个S3016给你

<cu>sys
Enter system view , return user view with Ctrl+Z.
[cu]dis ver
Huawei Versatile Routing Platform Software
VRP (R) Software, Version 3.10, RELEASE 0015
Copyright (c) 2000-2003 HUAWEI TECH CO., LTD.
Quidway S3026 uptime is 36 weeks,1 day,23 hours,38 minutes

Quidway S3026 with 62.5M Arm7 Processor
24M bytes SDRAM
8192K bytes Flash Memory
Config Register points to FLASH

Hardware Version is REV.A
Bootrom Version is 140
[Subslot 0] 24 100BASET   Hardware Version is REV.A

[cu]dis cu
#
sysname cu
#
radius scheme system
server-type huawei
primary authentication 127.0.0.1 1645
primary accounting 127.0.0.1 1646
user-name-format without-domain

domain system
radius-scheme system
access-limit disable
state active
idle-cut disable

domain default enable system
#
local-server nas-ip 127.0.0.1 key huawei

local-user 123
password simple 123
service-type telnet level 3
#
interface Aux0/0
#
vlan 1
#
vlan 6
description weihuwangguan
#
vlan 7
description neiwang
#
vlan 9
description zhuanxian-ip
#
vlan 12
description weihuneiwang
#
vlan 14
description weihuneiwang-jiankong
#
vlan 15
#
vlan 64
#
vlan 90
#
vlan 201
description pppoe
#
vlan 400
description zx-nms
#
vlan 401
description pppoe-zte
#
vlan 500
#
vlan 2000
description vlan2000-OA-Office
#
vlan 2001
description B-wangguan
#
vlan 2002
#
vlan 3000
#
interface Vlan-interface14
ip address 100.0.0.100 255.255.255.0
#
interface Ethernet0/1
description to-6509
duplex full
speed 100
port link-type trunk
port trunk permit vlan 9 201 401 2002
#
interface Ethernet0/2
description to-6509-back
duplex full
speed 100
port access vlan 6
#
interface Ethernet0/3
port access vlan 6
#
interface Ethernet0/4
port access vlan 14
#
interface Ethernet0/5
port access vlan 14
#
interface Ethernet0/6
port access vlan 14
#
interface Ethernet0/7
port access vlan 14
#
interface Ethernet0/8
description T0-2-lou
duplex full
speed 100
port link-type trunk
port trunk permit vlan 6 13 to 14
#
interface Ethernet0/9
description link_to_Cisco7206
port link-type trunk
port trunk permit vlan 14 to 15 2000
#
interface Ethernet0/10
port access vlan 14
#
interface Ethernet0/11
port access vlan 14
#
interface Ethernet0/12
port access vlan 14
#
interface Ethernet0/13
description OA-port1
#
interface Ethernet0/14
description OA-port2
#
interface Ethernet0/15
description OA-port3
port access vlan 2000
#
interface Ethernet0/16
description OA-port4
#
interface Ethernet0/17
port access vlan 15
#
interface Ethernet0/18
port access vlan 14
#
interface Ethernet0/19
port access vlan 14
#
interface Ethernet0/20
description to-100.16.0.100
port access vlan 14
#
interface Ethernet0/21
port access vlan 14
#
interface Ethernet0/22
port access vlan 14
#
interface Ethernet0/23
port access vlan 14
#
interface Ethernet0/24
port access vlan 14
#
interface NULL0
#
snmp-agent
snmp-agent local-engineid 800007DB00E0FC1D93046877
snmp-agent community read   public
snmp-agent sys-info contact HuaWei BeiJing China
snmp-agent sys-info location BeiJing China
snmp-agent sys-info version v1 v3
snmp-agent trap enable standard
#
user-interface aux 0
user-interface vty 0 4
authentication-mode none
user privilege level 3
#
return

47. 要检验MLS-RP的配置情况:
router# show mls rp
48. 检验特定接口上的MLS配置:
router# show mls rp interface interface number

49. 为了在MLS-SE上设置流掩码而又不想在任一个路由处理器接口上设置访问列表:

set mls flow [destination|destination-source|full]

50. 为使MLS和输入访问列表可以兼容,可以在全局模式下使用下列命令:
router(config)# mls rp ip input-acl

51. 当某个交换机的第3层交换失效时,可在交换机的特权模式下输入下列命令:
switch(enable) set mls enable

52. 若想改变老化时间的值,可在特权模式下输入以下命令:
switch(enable) set mls agingtime agingtime

53. 设置快速老化:
switch(enable) set mls agingtime fast fastagingtime pkt_threshold

54. 确定那些MLS-RP和MLS-SE参与了MLS,可先显示交换机引用列表中的内容再确定:
switch(enable) show mls include

55. 显示MLS高速缓存记录:
switch(enable) show mls entry

56. 用命令show in arp显示ARP高速缓存区的内容。

57. 要把路由器配置为HSRP备份组的成员,可以在接口配置模式下使用下面的命令:
router(config-if)# standby group-number ip ip-address

58. 为了使一个路由器重新恢复转发路由器的角色,在接口配置模式下:
router(config-if)# standy group-number preempt

59. 访问时间和保持时间参数是可配置的:
router(config-if)# standy group-number timers hellotime holdtime

60. 配置HSRP跟踪:
router(config-if)# standy group-number track type-number interface-priority

61. 要显示HSRP路由器的状态:
router# show standby type-number group brief

62. 用命令show ip igmp确定当选的查询器。

63. 启动IP组播路由选择:
router(config)# ip muticast-routing

64. 启动接口上的PIM:
dalllasr1>(config-if)# ip pim {dense-mode|sparse-mode|sparse-dense-mode}

65. 启动稀疏-稠密模式下的PIM:
router# ip multicast-routing
router# interface type number
router# ip pim sparse-dense-mode

66. 核实PIM的配置:
dallasr1># show ip pim interface[type number] [count]

67. 显示PIM邻居:
dallasr1># show ip neighbor type number

68. 为了配置RP的地址,命令如下:
dallasr1># ip pim rp-address ip-address [group-access-list-number][override]

69. 选择一个默认的RP:
dallasr1># ip pim rp-address
通告RP和它所服务的组范围:
dallasr1># ip pim send-rp-announce type number scope ttl group-list access-list-number
为管理范围组通告RP的地址:
dallasr1># ip pim send-rp-announce ethernet0 scope 16 group-list1
dallasr1># access-list 1 permit 266.0.0.0 0.255.255.255
设定一个RP映像代理:
dallasr1># ip pim send-rp-discovery scope ttl
核实组到RP的映像:
dallasr1># show ip pim rp mapping
dallasr1># show ip pim rp [group-name|group-address] [mapping]

70. 在路由器接口上用命令ip multicast ttl-threshold ttl-value设定TTL阀值:
dallasr1>(config-if)# ip multicast ttl-threshold ttl-value

71. 用show ip pim neighbor显示PIM邻居表。

72. 显示组播通信路由表中的各条记录:
dallasr1>show ip mroute [group-name|group-address][scoure][summary][count][active kbps]

73. 要记录一个路由器接受和发送的全部IP组播包:
dallasr1> #debug ip mpacket [detail] [access-list][group]

74. 要在CISCO路由器上配置CGMP:
dallasr1>(config-if)# ip cgmp

75.配置一个组播路由器,使之加入某一个特定的组播组:
dallasr1>(config-if)# ip igmp join-group group-address

76. 关闭 CGMP:

dallasr1>(config-if)# no ip cgmp

77. 启动交换机上的CGMP:
dallasr1>(enable) set cgmp enable

78. 核实Catalyst交换机上CGMP的配置情况:
catalystla1>(enable) show config
set prompt catalystla1>
set interface sc0 192.168.1.1 255.255.255.0
set cgmp enable

79. CGMP离开的设置:
Dallas_SW(enable) set cgmp leave

80. 在Cisco设备上修改控制端口密码:
R1(config)# line console 0
R1(config-line)# login
R1(config-line)# password Lisbon
R1(config)# enable password Lilbao
R1(config)# login local
R1(config)# username student password cisco

81. 在Cisco设备上设置控制台及vty端口的会话超时:
R1(config)# line console 0
R1(config-line)# exec-timeout 5 10
R1(config)# line vty 0 4
R1(config-line)# exec-timeout 5 2

82. 在Cisco设备上设定特权级:
R1(config)# privilege configure level 3 username
R1(config)# privilege configure level 3 copy run start
R1(config)# privilege configure level 3 ping
R1(config)# privilege configure level 3 show run
R1(config)# enable secret level 3 cisco

83. 使用命令privilege 可定义在该特权级下使用的命令:
router(config)# privilege mode level level command

84. 设定用户特权级:
router(config)# enable secret level 3 dallas
router(config)# enable secret san-fran
router(config)# username student password cisco

85. 标志设置与显示:
R1(config)# banner motd ‘unauthorized access will be prosecuted!’

86. 设置vty访问:
R1(config)# access-list 1 permit 192.168.2.5
R1(config)# line vty 0 4
R1(config)# access-class 1 in

87. 配置HTTP访问:
Router3(config)# access-list 1 permit 192.168.10.7
Router3(config)# ip http sever
Router3(config)# ip http access-class 1
Router3(config)# ip http authentication local
Router3(config)# username student password cisco

88. 要启用HTTP访问,请键入以下命令:
switch(config)# ip http sever

89. 在基于set命令的交换机上用setCL1启动和核实端口安全:
switch(enable) set port security mod_num/port_num…enable mac address
switch(enable) show port mod_num/port_num
在基于CiscoIOS命令的交换机上启动和核实端口安全:
switch(config-if)# port secure [mac-mac-count maximum-MAC-count]
switch# show mac-address-table security [type module/port]

90. 用命令access-list在标准通信量过滤表中创建一条记录:
Router(config)# access-list access-list-number {permit|deny} source-address [source-address]

91. 用命令access-list在扩展通信量过滤表中创建一条记录:
Router(config)# access-list access-list-number {permit|deny{protocol|protocol-keyword}}{source source-wildcard|any}{destination destination-wildcard|any}[protocol-specific options][log]

92. 对于带内路由更新,配置路由更新的最基本的命令格式是:
R1(config-router)#distribute-list access-list-number|name in [type number]

93. 对于带外路由更新,配置路由更新的最基本的命令格式是:
R1(config-router)#distribute-list access-list-number|name out [interface-name] routing-process| autonomous-system-number

94. set snmp命令选项:
set snmp community {read-only|ready-write|read-write-all}[community_string]

95. set snmp trap 命令格式如下:
set snmp trap {enable|disable}
[all|moudle|classis|bridge|repeater| auth|vtp|ippermit|vmps|config|entity|stpx]
set snmp trap rvcr_addr rcvr_community

96. 启用SNMP chassis 陷阱:
Console>(enable) set snmp trap enable chassis

97. 启用所有SNMP chassis 陷阱:
Console>(enable) set snmp trap enable

转载于:https://blog.51cto.com/liangjintao/283079

交换机命令---华为路由器配置相关推荐

  1. 华为最新全系列交换机命令手册、配置指南下载

    华为最新全系列交换机命令手册.配置指南下载 最近经常有午饭上来求华为交换机的命令手册.特别是S9300系列华为是不对普通用户提供下载的.为方便广大午饭小侠特下载和整理了华为最新全系列交换机命令手册.配 ...

  2. 计算机网络自顶向下方法华为路由器配置OSPFv3路由协议实现端到端的通信

    一 实验目的 掌握OSPFv3 的基本配置功能,在 R1.R2 和 R3 上启用OSPFv3 路由协议.R1 和R2 引入外部直连路由来与 PC 互联,要求PC1 与能够与PC2 互访. 二 实验原理 ...

  3. 华为路由器ws5200虚拟服务器,华为路由器配置dhcp怎么弄?华为路由WS5200设置DHCP服务器方法...

    华为路由器配置dhcp怎么操作,对于这个网友们并不了解,为了让大家更好的了解华为路由WS5200怎么设置DHCP服务器功能相关信息,本站就为大家带来了华为路由WS5200怎么设置DHCP服务器功能的具 ...

  4. arp 华为 查看 路由器_华为路由器 配置arp

    华为路由器 配置arp Quidway Eudemon 100/100E/200/200S 配置指南 网际互联分册 目 录文档版本 04 2008-01-25 华为技术有限公司 i目目 录录 9 配置 ...

  5. 华为路由器配置NTP服务端和客户端

    华为路由器配置NTP服务端和客户端 基础配置 R1: <Huawei>sys-view #进入系统配置模式 Enter system view, return user view with ...

  6. 华为路由器 配置telent

    华为路由器 配置telent 1.密码登录 2.aaa认证 密码登录 首先认证之间的路由器互通 [Huawei]user-interface vty 0 4 配置vty [Huawei-ui-vty0 ...

  7. linux 交换机实例,华为路由器和交换机实例配置

    华为路由器和交换机实例配置命令 (文章转载有错误的地请指点,以便改正) 一.   端口: 路由器--ethernet(以太口).Serial(串口).loopback(虚拟端口) 交换机--ether ...

  8. 华为路由器配置命令汇总

    VRP系统基本使用,与交换机基本相同 信息中心配置 Log.Trap.Debug信息的输出,对设备的维护与监管至关重要 配置Log信息输出,即配置指定模块的Log信息输出到Log缓冲区.日志文件.控制 ...

  9. 你一个网管连华为路由器配置都搞不定?

    01 场景 你是公司的网络管理员,现在公司购买了两台华为AR G3系列路由器.路由器在使用之前,需要先配置路由器的设备名称.系统时间及登录密码等管理信息. 02 学习目标 · 掌握设备系统参数的配置方 ...

  10. key位置 win10生成的ssh_华为路由器配置SSH远程登录,就这么简单

    SSH(Secure Shell)是一套协议标准,可以用来实现两台机器之间的安全登录以及安全的数据传送,其保证数据安全的原理是非对称加密. SSH远程登录华为路由器 SSH是在传统的Telnet协议之 ...

最新文章

  1. 【Zookeeper系列】ZooKeeper管理分布式环境中的数据(转)
  2. lua 的正则表达式之坑
  3. Java中的异常全面讲解
  4. 近期知识图谱顶会论文推荐,你都读过哪几篇?
  5. 如何将CSDN的博客同步到网易号平台上去
  6. 数据结构与算法--链表实现以及应用
  7. python安装不了怎么办_python安装运行时提示不是内部或外部命令怎么办
  8. 牛逼!只需 3 步,Java 也能做图片识别!
  9. jeecg框架 弹出框问题
  10. 数据分析需要学习哪些课程?
  11. [文摘20090201]男女朋友~~需记住亦舒的77句话
  12. 最新YGBOOK小说站源码/全自动采集+已修BUG
  13. 新电脑怎么把计算机放在桌面,新安装的Win10怎么将“我的电脑”放在桌面
  14. 月嫂APP开发可以实现哪些功能?
  15. 转载--成功应聘Intel的真实经历
  16. 一个html5表格代码
  17. 元宇宙是什么,如何看待未来元宇宙的发展?
  18. Kafka生产者消费者模型
  19. 统一身份管理平台IAM单点登录流程及第三方接口设计方案
  20. Inception v1~v4和Inception-ResNet v1~v2总结

热门文章

  1. python程序写完怎么保存_python程序如何进行保存
  2. Ros安装过程及sudo rosdep init失败解决方法
  3. Eclipse — 如何快速生成servlet类和配置文件(web里)
  4. 1015 德才论 (25 分)—PAT (Basic Level) Practice (中文)
  5. RK3288_Android7.1调试以太网ethernet
  6. 编译android7.0出现的错误ninja: build stopped: subcommand failed.
  7. 数据库事务的四大特性以及事务的隔离级别-与-Spring事务传播机制隔离级别
  8. 和大家分享一下我最近的编程心得!!!
  9. Python3.2官方文档翻译--迭代器
  10. Latex中参考文献排序