Jungle Roads丛林道路 POJ - 1251

目录

Jungle Roads丛林道路

题意描述

Kruskal算法解题思路

Kruskal AC代码

Prim 解题思路

AC代码


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

热带岛屿拉格里山的首席长老有问题。几年前,大量外援资金被用于修建村庄之间的额外道路。但丛林无情地超越道路,因此大型道路网络的维护成本太高。长老议会必须选择停止维护一些道路。左上方的地图显示了所有正在使用的道路以及每月维护这些道路的成本(以 aacms 为单位)。当然,即使路线不像以前那么短,也需要通过某种方式在维护的道路上到达所有村庄。首席长老想告诉长老委员会,他们每个月可以在 aacms 上花费的最少金额来维护连接所有村庄的道路。在上面的地图中,村庄被标记为 A 到 I。右边的地图显示了可以最便宜地维护的道路,每月 216 aacms。你的任务是编写一个程序来解决这些问题。

输入

输入由1到100个数据集组成,最后一行只包含0。 每个数据集以一行开始,只包含一个数字n,它是村庄的数量,1 < n < 27,村庄被标记字母表的前 n 个字母大写。每个数据集都由 n-1 行完成,这些行以字母顺序以村庄标签开头。最后一个村庄没有线路。一个村庄的每条线都以村庄标签开始,然后是从这个村庄到字母表中带有标签的村庄的道路数量 k。如果 k 大于 0,则该行继续包含 k 条道路中每条道路的数据。每条道路的数据是道路另一端的村庄标签,然后是道路的每月维护成本(以 aacms 为单位)。维护成本将是小于 100 的正整数。行中的所有数据字段都由单个空格分隔。公路网将始终允许在所有村庄之间通行。该网络的道路永远不会超过 75 条。没有一个村庄有超过 15 条通往其他村庄的道路(字母表中的之前或之后)。在下面的示例输入中,第一个数据集与上面的地图一致。

输出

每个数据集的每行输出一个整数:维护连接所有村庄的道路系统的每月最低成本(以 aacms 为单位)。警告:检查每组可能的道路的蛮力解决方案不会在一分钟的时间限制内完成。

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

题意描述:

给你多个村庄,接下来每个是与其他相连的村庄路数,以及那些村庄的编号和两个路之间的每年维修的成本

Kruskal算法解题思路:

因为村庄的编号是abc,所以我们需要把它转化成数字形式,我刚开始用了kruskal算法,其中会用到结构体排序和并查集来写。

Kruskal AC代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,cnt,fa[30];
struct Node
{int a,b,len;
}p[100];
void init()//初始化
{int i;for(int i=1;i<=27;i++){fa[i]=i;}
}
int cmp(Node x,Node y)
{return x.len<y.len;//结构体排序
}
int find(int x)//并查集寻找祖先
{if(x==fa[x])return x;elsereturn fa[x]=find(fa[x]);//路径压缩
}
int kruskal()
{int rec=0;sort(p,p+cnt,cmp);double ans=0;//for(int i=1;i<=cnt;i++){if(rec==n-1)break;//直到选用了n-1条边之后退出循环int x=find(p[i].a),y=find(p[i].b);if(x!=y){fa[x]=y;ans+=p[i].len;rec++;} }return ans;
}
int main(void)
{while(~scanf("%d",&n)){if(n==0)break;init();//初始化 char str[10];cnt=1;int a,b; for(int i=1;i<n;i++){scanf("%s %d",str,&a);int u=str[0]-'A'+1;for(int i=1;i<=a;i++){scanf("%s %d",str,&b);int v=str[0]-'A'+1;p[cnt].a=u;//城市序号u p[cnt].b=v;//另一个城市序号 vp[cnt].len=b; //它俩之间的费用 cnt++;}}printf("%d\n",kruskal());}return 0;
}

Prim 解题思路:

和kruskal差不多,把字符转换成数字形式,然后把村庄的距离存入二维数组里面,利用prim求最短路并相加,最后输出即可,注意字符串和二维数组初始化

AC代码

#include<stdio.h>
#include<string.h>
#define N 100
int inf=999999;
int e[N][N],book[N],dis[N];
int main(void)
{int n,ans,min,u,v,a,b;while(~scanf("%d",&n)){char s[N];memset(dis,0,sizeof(dis));memset(s,0,sizeof(s));ans=0;if(n==0)break;for(int i=1;i<=n;i++)for(int j=1;j<=n;j++)if(i==j) e[i][j]=0;else e[i][j]=inf;for(int i=1;i<n;i++){scanf("%s %d",s,&a);int x=s[0]-'A'+1;for(int j=1;j<=a;j++){scanf("%s %d",s,&b);int y=s[0]-'A'+1;e[x][y]=e[y][x]=b;}}for(int i=1;i<=n;i++){dis[i]=e[1][i];book[i]=0;}book[1]=1;for(int i=1;i<n;i++){int min=inf;for(int j=1;j<=n;j++){if(dis[j]<min&&book[j]==0){min=dis[j];u=j;}}book[u]=1;ans+=dis[u];for(v=1;v<=n;v++){if(book[v]==0&&dis[v]>e[u][v])dis[v]=e[u][v];}}printf("%d\n",ans);}return 0;
}

Jungle Roads丛林道路(最小生成树PrimKruskal算法)相关推荐

  1. HDU 1301 - Jungle Roads( Prim求最小生成树 )

    题意 给出n个编号为A~A+n的节点,和某些节点之间的距离,求最小生成树的总权值 思路 裸的Prim算法求最小生成树 算法细节: 最小生成树-Prim算法和Kruskal算法 AC代码 #includ ...

  2. 【HDU - 1301】Jungle Roads(并查集+最小生成树)(内附最小生成树两种算法 克鲁斯特尔算法amp;amp;普里姆算法)

    题干: Jungle Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) ...

  3. HDU 1301 Jungle Roads(裸最小生成树)

    题目链接 今天做了好几个模版最小生成树...贴一个kurskral. 1 /* 2 HDU 1301 Jungle Roads 3 最小生成树Kurskal模版 4 */ 5 #include < ...

  4. Jungle Roads//最小生成树kruskal

    题目: Jungle Roads Time Limit: 2 Seconds      Memory Limit: 65536 KB The Head Elder of the tropical is ...

  5. bzoj 1626: [Usaco2007 Dec]Building Roads 修建道路(最小生成树)

    1626: [Usaco2007 Dec]Building Roads 修建道路 Time Limit: 5 Sec  Memory Limit: 64 MB Submit: 1709  Solved ...

  6. [BZOJ1626][Usaco2007 Dec]Building Roads 修建道路

    1626: [Usaco2007 Dec]Building Roads 修建道路 Time Limit: 5 Sec  Memory Limit: 64 MB Submit: 1730  Solved ...

  7. 最小生成树--Boruvka算法

    参考文章 介绍 第一次听说这个算法.. 对于最小生成树一定学过prim和krusal,prim复杂度是O(n2)或者O(elogn)O(n^2)或者O(elogn)O(n2)或者O(elogn),kr ...

  8. 【数据结构与算法】图结构最小生成树Kruskal算法的Java实现

    Kruskal算法 Kruskal算法是图论中用于求解最小生成树的算法,算法时间复杂度为O(eloge) 比较起Prim算法,Kruskal算法虽然同求最小生成树,却更适合稀疏网. 这里图的储存结构建 ...

  9. 最小生成树 Kruskal算法 Prim算法

    文章目录 Kruskal算法 模板: Prim算法 模板: Kruskal算法 模板: https://blog.csdn.net/Rain722/article/details/65642992 K ...

最新文章

  1. xmpp协议抓包_开源网络抓包与分析框架学习-Packetbeat篇
  2. windows下安装Python virtualenvwrapper-win
  3. POI读入excel文件到Java中
  4. Linux/CentOS下安装Apache/SVN/Subversion图文详解教程
  5. FPGA 状态机设计
  6. angular--Observable总结
  7. Vnc-server——linux远程桌面配置
  8. 深入探究VC —— 资源编译器rc.exe(3)
  9. c#语言经典程序100例,C#入门必看的实例程序100个 - 源码下载|Windows编程|其他小程序|源代码 - 源码中国...
  10. C# 实现程序只启动一次(多次运行激活第一个实例,使其获得焦点,并在最前端显示)...
  11. MyBatis官方文档——XML配置部分
  12. keras-yolo3遇到的一些注意点与解决思路
  13. 北京计算机专业考研录取分数线,2018北京航空航天大学计算机考研复试分数线_计算机考研分数线...
  14. 开关三极管的导通和截止条件
  15. 南大周志华、俞扬、钱超最新力作:演化学习:理论与算法进展一书导读
  16. 游戏服务器 配置文件,游戏服务器应用配置文件
  17. Android 手机号输入格式化 3-3-4
  18. 大学英语(第一册)复习(原文及全文翻译)——Unit 5 - A Miserable, Merry Christmas(又悲又喜的圣诞节)
  19. 【linux虚拟机使用yum安装MySQL+修改密码】
  20. linux下kegg注释软件,工具篇丨GO和KEGG富集不到通路?快试试这个超赞的功能分析工具吧...

热门文章

  1. 75个顶级开源安全应用(1)
  2. Wordpress建站流程-最新手把手详细教程
  3. 办理公司经营贷款需要什么条件呢?-民兴商学院
  4. 使用jquery获取url及url参数的方法
  5. 卡尔曼滤波matlab程序实现
  6. 学习笔记 -- 证明旋转矩阵为正交阵
  7. 支小蜜智慧食堂刷脸就餐让学生不再刷卡吃饭
  8. 年龄 计算 php,php简单计算年龄的方法(周岁与虚岁)
  9. C语言练习题:厘米换算英尺英寸
  10. take sth. with a grain of salt