1131. Subway Map (30)

时间限制
400 ms

内存限制
65536 kB

代码长度限制
16000 B

判题程序
Standard

作者
CHEN, Yue

In the big cities, the subway systems always look so complex to the visitors. To give you some sense, the following figure shows the map of Beijing subway. Now you are supposed to help people with your computer skills! Given the starting position of your user, your task is to find the quickest way to his/her destination.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (< =100), the number of subway lines. Then N lines follow, with the i-th (i = 1, ..., N) line describes the i-th subway line in the format:

M S[1] S[2] ... S[M]

where M (<= 100) is the number of stops, and S[i]'s (i = 1, ... M) are the indices of the stations (the indices are 4-digit numbers from 0000 to 9999) along the line. It is guaranteed that the stations are given in the correct order -- that is, the train travels between S[i]and S[i+1] (i = 1, ..., M-1) without any stop.

Note: It is possible to have loops, but not self-loop (no train starts from S and stops at S without passing through another station). Each station interval belongs to a unique subway line. Although the lines may cross each other at some stations (so called "transfer stations"), no station can be the conjunction of more than 5 lines.

After the description of the subway, another positive integer K (<= 10) is given. Then K lines follow, each gives a query from your user: the two indices as the starting station and the destination, respectively.

The following figure shows the sample map.

Note: It is guaranteed that all the stations are reachable, and all the queries consist of legal station numbers.

Output Specification:

For each query, first print in a line the minimum number of stops. Then you are supposed to show the optimal path in a friendly format as the following:

Take Line#X1 from S1 to S2.
Take Line#X2 from S2 to S3.
......

where Xi's are the line numbers and Si's are the station indices. Note: Besides the starting and ending stations, only the transfer stations shall be printed.

If the quickest path is not unique, output the one with the minimum number of transfers, which is guaranteed to be unique.

Sample Input:

4
7 1001 3212 1003 1204 1005 1306 7797
9 9988 2333 1204 2006 2005 2004 2003 2302 2001
13 3011 3812 3013 3001 1306 3003 2333 3066 3212 3008 2302 3010 3011
4 6666 8432 4011 1306
3
3011 3013
6666 2001
2004 3001

Sample Output:

2
Take Line#3 from 3011 to 3013.
10
Take Line#4 from 6666 to 1306.
Take Line#3 from 1306 to 2302.
Take Line#2 from 2302 to 2001.
6
Take Line#2 from 2004 to 1204.
Take Line#1 from 1204 to 1306.
Take Line#3 from 1306 to 3001.
自己写了各种麻烦。写到一半懒得写了,直接看别人的了。发现人家思路和我最初一模一样,开个[10000][10000]的数组记录几号线。问题是。。居然不会爆栈???
神奇。如果怕爆栈,可以建个struct edge,里面包含这条边的路线,存起来就好。
不过DFS这个思路很赞,因为每一条边的长度都相当于是1,DFS深度就是距离。

题目大意:找出一条路线,使得对任何给定的起点和终点,可以找出中途经停站最少的路线;如果经停站一样多,则取需要换乘线路次数最少的路线~
分析:【很简单的,别跑^_^】一遍DFS即可~DFS过程中要维护两个变量:minCnt-中途经停的最少的站; minTransfer-需要换乘的最小次数~
0.可以这样计算出一条线路的换乘次数:在line[10000][10000]的数组中保存每两个相邻站中间的线路是几号线~从头到尾遍历最终保存的路径,preLine为前一小段的线路编号,如果当前的结点和前一个结点组成的这条路的线路编号和preLine不同,说明有一个换乘,就将cnt+1,最后遍历完累加的cnt即是换乘的次数~
1.可以这样计算出一条线路中途停站的次数:在dfs的时候有个变量cnt,表示当前路线是所需乘的第几个站,每次dfs时候将cnt+1表示向下遍历一层~cnt就是当前中途停站的次数~
2.可以这样输出结果:和计算线路换乘次数的思路一样,每当preLine和当前Line值不同的时候就输出一句话~保存preTransfer表示上一个换乘站,最后不要忘记输出preTransfer和最后一个站之间的路即使最后一个站并不是换乘站~

#include <cstdio>
#include <vector>
using namespace std;
vector<vector<int>> v(10000);
int line[10000][10000], visit[10000];
vector<int> path, tempPath;
int transferCnt(vector<int> a) {int cnt = -1, preLine = 0;for (int i = 1; i < a.size(); i++) {if (line[a[i-1]][a[i]] != preLine) cnt++;preLine = line[a[i-1]][a[i]];}return cnt;
}
void dfs(int node, int end, int cnt, int &minCnt, int &minTransfer) {if (node == end && (cnt < minCnt || (cnt == minCnt && transferCnt(tempPath) < minTransfer))) {minCnt = cnt;minTransfer = transferCnt(tempPath);path = tempPath;}if (node == end) return;for (int i = 0; i < v[node].size(); i++) {if (visit[v[node][i]] == 0) {visit[v[node][i]] = 1;tempPath.push_back(v[node][i]);dfs(v[node][i], end, cnt + 1, minCnt, minTransfer);visit[v[node][i]] = 0;tempPath.pop_back();}}
}
int main() {int n, m, k, pre, temp, a, b;scanf("%d", &n);for (int i = 0; i < n; i++) {scanf("%d%d", &m, &pre);for (int j = 1; j < m; j++) {scanf("%d", &temp);v[pre].push_back(temp);v[temp].push_back(pre);line[pre][temp] = line[temp][pre] = i + 1;pre = temp;}}scanf("%d", &k);for (int i = 0; i < k; i++) {scanf("%d%d", &a, &b);int minCnt = 99999, minTransfer = 99999;tempPath.clear();tempPath.push_back(a);visit[a] = 1;dfs(a, b, 0, minCnt, minTransfer);visit[a] = 0;printf("%d\n", minCnt);int preLine = 0, preTransfer = a;for (int j = 1; j < path.size(); j++) {if (line[path[j-1]][path[j]] != preLine) {if (preLine != 0) printf("Take Line#%d from %04d to %04d.\n", preLine, preTransfer, path[j-1]);preLine = line[path[j-1]][path[j]];preTransfer = path[j-1];}}printf("Take Line#%d from %04d to %04d.\n", preLine, preTransfer, b);}return 0;
}

PAT 1131. Subway Map (30) DFS相关推荐

  1. PAT甲级1131 Subway Map (30分):[C++题解]堆优化dijkstra、单源最短路、地铁地图、巧妙地建图套dijkstra模板!!

    文章目录 题目分析 题目链接 题目分析 原题: 来源:acwing 分析: 建图:所有能走到的点之间建立一条边,比如下面一条地铁线路有4站,它们是相通的,两两之间建一条边,边权是经过的站点数. 下面考 ...

  2. 1131. Subway Map (30)-PAT甲级真题 (DFS or 堆优化dij or SPFA)

    题意 给出地铁线路数n,分别给出每条线的站点数m,再依次列出站点id.然后询问k次从启点sv到终点ev的最短路径,如果最短路径相同,要求换乘最少的路径.最后按条件输出. 思路 1.用unordered ...

  3. 1131 Subway Map (30分)/最短路径问题

    题目描述 In the big cities, the subway systems always look so complex to the visitors. To give you some ...

  4. 1131 Subway Map (30 分)

    做不出来,一开始打算和Online map一样,用邻接表的dij做,但是发现这个交叉站点不好表示(用了二维数组存但不理想,超时超限). 没想到10e5竟然能用dfs做. 本题细节: 1.关于两站位于的 ...

  5. 1131 Subway Map (30 分)【难度: 难 / Dijkstra最短路】

    https://pintia.cn/problem-sets/994805342720868352/problems/994805347523346432 一会儿补题

  6. PAT甲级 1131 - Subway Map

    Each station interval belongs to a unique subway line.这句话比较重要,所以在进行dfs的时候记录区间,会方便很多. #include<bit ...

  7. 【PAT甲级】1131 Subway Map

    ✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343

  8. 1131 Subway Map

    题目 题意: 找出一条路线,使得对任何给定的起点和终点,可以找出中途经停站最少的路线:如果经停站一样多,则取需要换乘线路次数最少的路线 tip:DFS + map 分析:0.可以这样计算出一条线路的换 ...

  9. 1131. Subway Map 引用

    参考了这位大神的思路.http://blog.csdn.net/bendaai/article/details/63253277 注释了下代码,方便看了.PS:这个题想了好久好久好久好久..感觉自己太 ...

最新文章

  1. web前端学习day_04:jQuery框架
  2. 大名鼎鼎的红黑树,你get了么?2-3树 绝对平衡 右旋转 左旋转 颜色反转
  3. docker公共存储库_Docker Hub公共镜像仓库的使用
  4. OpenCV中重映射
  5. 原生Java高仿抖音短视频APP双端源码
  6. 为什么要使用Elasticsearch?
  7. 在一个软件开发项目中进行实际日程安排的十二点提示(转)
  8. crontab计划任务的失败记录查找
  9. 有软件测试台式电脑电源供电不足吗,台式机电源供电不足的原因
  10. win10系统下SQL2012下载及安装
  11. BMP测试图片及显示源码
  12. 阿里云对象存储OSS简介
  13. 基于S3c2440的多种显示屏测试方案
  14. 实现将exe格式的软件重新打包为msi格式的静默安装软件,方便域控使用策略分发软件
  15. eclipse 启动失败,出现hs_err_pid972.log类文件,文件中含JavaThread Bundle File Closer daemon类内容
  16. HTML基础常识问答(二)
  17. 【无标题】阿里滑块 通过 x82y接口、dll、源码 返回x5sec,可解决!
  18. 【百度AI开放平台】植物识别
  19. android安全问题(八)伪造短信(利用原生android4.0漏洞)
  20. 不到最后,你永远不知道会发生什么

热门文章

  1. 简单的C语言宏定义结合全局变量的方法实现单片机串口实现透传模式
  2. Windows下用ndk编译ffmpeg
  3. table表头和首列的表格固定-CSS实现的Table表头固定
  4. 【转】详细解析电源滤波电容的选取与计算
  5. 一串数字怎么拆分成单个数字
  6. c4droid用c语言画爱心,【图片】[自学C语言第五天]发一个作品【c4droid吧】_百度贴吧...
  7. Linux文件目录层级结构
  8. cgb2110-day01
  9. 【飞行器】基于matlab四旋翼无人机几何跟踪控制【含Matlab源码 2270期】
  10. Back-off restarting failed container报错