#####################
frame-reday底层配置##
R1为DR   主接口    ##
#####################

FRSWITCH

conf ter
fram sw
end

conf ter
interface Serial0/1
encapsulation frame-relay
frame-relay route 102 interface Serial0/2 201
frame-relay route 103 interface Serial0/3 301
frame-relay intf-type dce
clock rate 64000
no shut
end

conf ter
interface Serial0/2
encapsulation frame-relay
frame-relay route 201 interface Serial0/1 102
frame-relay intf-type dce
clock rate 64000
no shut
end

conf ter
interface Serial0/3
no ip address
encapsulation frame-relay
frame-relay route 301 interface Serial0/1 103
frame-relay intf-type dce
clock rate 64000
no shut
end

#############################################
R1

conf ter
interface Serial0/0
ip address 202.101.100.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 202.101.100.2 102
frame-relay map ip 202.101.100.3 103
no shut
end
#################
R2

conf ter
interface Serial0/0
ip address 202.101.100.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 202.101.100.1 201
no shut
end
#################
R3

conf ter
interface Serial0/0
ip address 202.101.100.3 255.255.255.0
encapsulation frame-relay
frame-relay map ip 202.101.100.1 301
no shut
end

#####################################
方法一:RIP                        ##
在R1 R2 R3配置loopback接口运行RIPv2##
#####################################
R1

conf ter
interface Loopback0
ip address 1.1.1.1 255.255.255.0
no shutdown
router rip
version 2
network 1.1.1.1
network 202.101.100.0
no auto-summary
###############
R2

conf ter
interface Loopback0
ip address 2.2.2.2 255.255.255.0
no shutdown
router rip
version 2
network 2.2.2.2
network 202.101.100.0
no auto-summary
##############
R3

conf ter
interface Loopback0
ip address 3.3.3.3 255.255.255.0
no shutdown
router rip
version 2
network 3.3.3.3
network 202.101.100.0
no auto-summary

############################################################################
没有理由表原因是frame-relay不支持广播的多路访问链路而RIPv2是基于组播的协议##
             修改frame-relay底层配置加broadcast使其支持广播               ##
              默认水平分割已关闭所以可以R2、R3可以互学路由                ##
############################################################################
R1

conf ter
interface Serial0/0
frame-relay map ip 202.101.100.2 102 broadcast
frame-relay map ip 202.101.100.3 103 broadcast
#################
R2

interface Serial0/0
frame-relay map ip 202.101.100.1 201 broadcast
#################
R3

interface Serial0/0
frame-relay map ip 202.101.100.1 301 broadcast

###############################################
方法二:ospf                                 ##
在R1 R2 R3配置loopback接口运行OSPF           ##
###############################################
R1

conf ter
interface Loopback0
ip address 1.1.1.1 255.255.255.0
no shutdown
router ospf 1
network 1.1.1.1 0.0.0.0 area 0
network 202.101.100.0 0.0.0.0 area 0

###############
R2

conf ter
interface Loopback0
ip address 2.2.2.2 255.255.255.0
no shutdown
router ospf 1
network 2.2.2.2 0.0.0.0 area 0
network 202.101.100.2 0.0.0.0 area 0

##############
R3

conf ter
interface Loopback0
ip address 3.3.3.3 255.255.255.0
no shutdown
router ospf 1
network 3.3.3.3 0.0.0.0 area 0
network 202.101.100.3 0.0.0.0 area 0

###############################################################################################################
没有收到邻居的hello包,ospf邻居关系没有建立,1.由于frame-relay不支持广播的多路访问链路 2.由于ospf基于网络类型##
###############################################################################################################
情况1.frame-relay主接口上 默认ospf为非广播
采用单播指定邻居及优先级(DR BDR BDRother) 可单向指定也可双向
R1

conf ter
int s 0/0
ip ospf priority 10
router ospf 1
neighbor 202.101.100.2 priority 1
neighbor 202.101.100.3 priority

情况2.frame-relay子接口上 子接口为点到点的 ospf是点到点的类型
修改frame-relay底层配置加broadcast使其支持广播
ospf默认是non-broadcast手动修改ospf的网络类型为broadcast
R1

conf ter
interface Serial0/0
ip ospf network broadcast
ip ospf priority 100
frame-relay map ip 202.101.100.2 102 broadcast
frame-relay map ip 202.101.100.3 103 broadcast

#################
R2
conf ter
interface Serial0/0
ip ospf network broadcast
frame-relay map ip 202.101.100.1 201 broadcast
#################
R3

conf ter
interface Serial0/0
ip ospf network broadcast
frame-relay map ip 202.101.100.1 301 broadcast

情况3.frame-relay子接口上 子接口为点到多点的 ospf是非广播
在情况二的基础上可以把网络类型broadcast修改为Point-to-multipoint这样就无需选举DR BDR BDRORTHER

#####################
frame-reday底层配置##
R1为DR   子接口    ##
#####################
FRSWITCH

conf ter
fram sw
end

conf ter
interface Serial0/1
encapsulation frame-relay
frame-relay route 102 interface Serial0/2 201
frame-relay route 103 interface Serial0/3 301
frame-relay intf-type dce
clock rate 64000
no shut
end

conf ter
interface Serial0/2
encapsulation frame-relay
frame-relay route 201 interface Serial0/1 102
frame-relay intf-type dce
clock rate 64000
no shut
end

conf ter
interface Serial0/3
no ip address
encapsulation frame-relay
frame-relay route 301 interface Serial0/1 103
frame-relay intf-type dce
clock rate 64000
no shut
end

#############################################
定义子接口网络类型 类型一致都为点到点
R1

conf ter
interface Serial0/0
encapsulation frame-relay
no shutdown
exit

interface serial 0/0.12 point-to-point
ip address 202.101.12.1 255.255.255.0
no shutdown
frame-relay interface-dlci 102

interface serial 0/0.13 point-to-point
ip address 202.101.13.1 255.255.255.0
no shutdown
frame-relay interface-dlci 103

#################
R2

conf ter
interface Serial0/0
ip address 202.101.12.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 202.101.12.1 201 broadcast
ip ospf network point-to-point
no shut
end
#################
R3

conf ter
interface Serial0/0
ip address 202.101.13.3 255.255.255.0
encapsulation frame-relay
frame-relay map ip 202.101.13.1 301 broadcast
ip ospf network point-to-point
no shut
end

###############################################
在R1 R2 R3配置loopback接口运行OSPF
R1

conf ter
interface Loopback0
ip address 1.1.1.1 255.255.255.0
no shutdown
exit
router ospf 1
router-id 1.1.1.1
network 1.1.1.1 0.0.0.0 area 0
network 202.12.1.0 0.0.0.0 area 0

###############
R2

conf ter
router ospf 1
router-id 2.2.2.2
network 2.2.2.2 0.0.0.0 area 0
network 202.101.12.2 0.0.0.0 area 0

##############
R3

conf ter
router ospf 1
router-id 3.3.3.3
network 3.3.3.3 0.0.0.0 area 0
network 202.101.13.3 0.0.0.0 area 0

frame-reday相关推荐

  1. Spring Security中文文档

    Spring Security中文文档 来源:https://www.springcloud.cc/spring-security.html#overall-architecture 作者 Ben A ...

  2. Android 逐帧动画(Frame)

    Android 逐帧动画(Frame)  很好理解就是将多张图片放到一个容器里面通过控制这些图片一帧一张图片从而形成动画 使用的使用通过AnimationDrawable 加载放好的图片 然后通过调用 ...

  3. FRAME与IFRAME

    FRAME与IFRAME 框架概念 : 所谓框架便是网页画面分成几个框窗,同时取得多个 URL.只需要 转载于:https://www.cnblogs.com/vibratea/archive/200 ...

  4. ORB_SLAM2帧Frame

      在追踪线程的一开始就会创建一个帧 cv::Mat Tracking::GrabImageMonocular(const cv::Mat &im,const double &time ...

  5. HTML动画 request animation frame

    在网页中,实现动画无外乎两种方式. 1. CSS3 方式,也就是利用浏览器对CSS3 的原生支持实现动画: 2. 脚本方式,通过间隔一段时间用JavaScript 来修改页面元素样式来实现动画. 接下 ...

  6. HTML教程-各窗口间相互操作(Frame Target)

    文章来源: 山西之窗 由Frames分出来的几个窗口的内容并不是静止不变的,往往一个窗口的内容随着另一个窗口的要求而不断变化,这就提高了Frames的利用价值.为了完成各窗口之间的相互操作,我们必须为 ...

  7. selenium之frame操作

    前言 很多时候定位元素时候总是提示元素定位不到的问题,明明元素就在那里,这个时候就要关注你所定位的元素是否在frame和iframe里面 frame标签包含frameset.frame.iframe三 ...

  8. iframe 自动适应高和宽问题 和 其他Frame操作技巧

    < DOCTYPE html PUBLIC -WCDTD XHTML TransitionalEN httpwwwworgTRxhtmlDTDxhtml-transitionaldtd> ...

  9. frame,iframe,frameset之间的关系与区别

    2019独角兽企业重金招聘Python工程师标准>>> ■ 框架概念 : 所谓框架便是网页画面分成几个框窗,同时取得多个 URL.只需要 <FRAMESET> <F ...

  10. 爬虫之switch_to切换frame标签

    爬虫之switch_to切换frame标签 iframe是html中常用的一种技术,即一个页面中嵌套了另一个网页,selenium默认是访问不了frame中的内容的,对应的解决思路是driver.sw ...

最新文章

  1. 机房重构(个人版)——类图
  2. Swift3.0语言教程使用指针创建和初始化字符串
  3. fedora16配制
  4. QT判断多级目录是否存在,不存在就创建
  5. python opencv SIFT,获取特征点的坐标位置
  6. Vue——整合与中文化Moment.js解决方案
  7. JAVA8之lambda表达式
  8. 【Hibernate】JDBC操作与hibernate的区别
  9. MySQL MHA配置常见问题
  10. flex 各组件对应的样式属性2
  11. Unity UGUI——Rect Transform包裹(Anchor Presets)
  12. vue init webpack vue-demo01复杂安装的详解
  13. openshift for linux
  14. WinForm中为按钮添加键盘快捷键,超简单,亲测有效
  15. 训练深度神经网络时验证损失可能低于训练损失的三个原因:
  16. 支持向量机_支持向量机(SVM)说明及示例
  17. ISO/IEC 20000 信息技术(IT)服务管理体系及全套最新标准资料
  18. 微信小程序推广多多进宝商品,微信小程序跳转拼多多小程序领券页面,微信小程序跳转多多进宝推广链接
  19. 最新四级联动数据json
  20. java 实现热搜_搜索推荐系统根据用户搜索频率(热搜)排序

热门文章

  1. 【PDF】java使用Itext生成pdf文档--详解
  2. 解忧云SMS短信服务平台系统 短信发送系统源码 全解密随时可以二开无后门
  3. luogu P1919 【模板】A*B Problem升级版(FFT快速傅里叶)
  4. C# 使用SQLite 错误 - 试图加载格式不正确的程序
  5. HCU混和动力控制器,HEV混动串并联 混动车辆
  6. AcrelCloud-9500电瓶车充电桩应用场景分析
  7. 二相混合式步进电机开环细分控制simulink仿真模型
  8. MEMS传感器领域关于薄膜性能的中国国家标准,“带状薄膜抗拉性能的试验方法”由北京智芯传感等单位发布并实施
  9. 恒源云GPU登录Linux实例使用记录
  10. bs客户端跨服务器管理文件,bs架构客户端和服务器