纵横字谜的答案

Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Submit  Status

Description

 Crossword Answers 

A crossword puzzle consists of a rectangular grid of black and white squares and two lists of definitions (or descriptions).

One list of definitions is for ``words" to be written left to right across white squares in the rows and the other list is for words to be written down white squares in the columns. (A word is a sequence of alphabetic characters.)

To solve a crossword puzzle, one writes the words corresponding to the definitions on the white squares of the grid.

The definitions correspond to the rectangular grid by means of sequential integers on ``eligible" white squares. White squares with black squares immediately to the left or above them are ``eligible." White squares with no squares either immediately to the left or above are also ``eligible." No other squares are numbered. All of the squares on the first row are numbered.

The numbering starts with 1 and continues consecutively across white squares of the first row, then across the eligible white squares of the second row, then across the eligible white squares of the third row and so on across all of the rest of the rows of the puzzle. The picture below illustrates a rectangular crossword puzzle grid with appropriate numbering.

An ``across" word for a definition is written on a sequence of white squares in a row starting on a numbered square that does not follow another white square in the same row.

The sequence of white squares for that word goes across the row of the numbered square, ending immediately before the next black square in the row or in the rightmost square of the row.

A ``down" word for a definition is written on a sequence of white squares in a column starting on a numbered square that does not follow another white square in the same column.

The sequence of white squares for that word goes down the column of the numbered square, ending immediately before the next black square in the column or in the bottom square of the column.

Every white square in a correctly solved puzzle contains a letter.

You must write a program that takes several solved crossword puzzles as input and outputs the lists of across and down words which constitute the solutions.

Input

Each puzzle solution in the input starts with a line containing two integers r and c (  and  ), where r (the first number) is the number of rows in the puzzle and c (the second number) is the number of columns.

The r rows of input which follow each contain c characters (excluding the end-of-line) which describe the solution. Each of those ccharacters is an alphabetic character which is part of a word or the character ``*", which indicates a black square.

The end of input is indicated by a line consisting of the single number 0.

Output

Output for each puzzle consists of an identifier for the puzzle (puzzle #1:puzzle #2:, etc.) and the list of across words followed by the list of down words. Words in each list must be output one-per-line in increasing order of the number of their corresponding definitions.

The heading for the list of across words is ``Across". The heading for the list of down words is ``Down".

In the case where the lists are empty (all squares in the grid are black), the Across and Down headings should still appear.

Separate output for successive input puzzles by a blank line.

Sample Input

2 2
AT
*O
6 7
AIM*DEN
*ME*ONE
UPON*TO
SO*ERIN
*SA*OR*
IES*DEA
0

Sample Output

puzzle #1:
Across1.AT3.O
Down1.A2.TOpuzzle #2:
Across1.AIM4.DEN7.ME8.ONE9.UPON11.TO12.SO13.ERIN15.SA17.OR18.IES19.DEA
Down1.A2.IMPOSE3.MEO4.DO5.ENTIRE6.NEON9.US10.NE14.ROD16.AS18.I20.A

题意:输入一个r行c列的网格,黑格用*号表示,每个白格都填有一个字母。如果一个白格的左边相邻位置或者上边相邻位置没有白格(可能是黑格,也可能出了网格边界),则称这个白格是一个起始格。首先把所有起始格从左到右,从上到下顺序编号1,2,3,。。。。要求找出所有横向单词。这些单词必须从一个起始格开始,向右延伸到一个黑格的左边或者整个网格的最右边。最后找出所有的竖向单词。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 105
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;struct St
{int x,y;int r,c;
}st[111];char mp[12][12];
int n,m;int main()
{int cas=0;while (scanf("%d",&n),n){scanf("%d",&m);
//        if (cas) printf("\n");for (int i=0;i<n;i++)scanf("%s",mp[i]);
//        for (int i=0;i<n;i++)
//            printf("%s\n",mp[i]);int num=1;for (int i=0;i<n;i++){for (int j=0;j<m;j++){if(mp[i][j]!='*'){if ((i-1)<0||(j-1)<0||mp[i-1][j]=='*'||mp[i][j-1]=='*'){st[num].x=i;st[num].y=j;if ((j-1)<0||mp[i][j-1]=='*')  st[num].r=1;  else  st[num].r=0;if ((i-1)<0||mp[i-1][j]=='*')  st[num].c=1;  else  st[num].c=0;num++;}}}}if (cas)printf("\n");
//        printf("num=%d\n",num);printf("puzzle #%d:\nAcross\n",++cas);for (int i=1;i<num;i++){if (st[i].r){printf("%3d.",i);for (int j=st[i].y;j<m;j++){if (mp[ st[i].x ][j]=='*')break;printf("%c",mp[ st[i].x ][j]);}printf("\n");}}
//        printf("num=%d\n",num);printf("Down\n");for (int i=0;i<num;i++){if (st[i].c){printf("%3d.",i);for (int j=st[i].x;j<n;j++){if (mp[j][ st[i].y ]=='*')break;printf("%c",mp[j][ st[i].y ]);}printf("\n");}}
//        printf("\n");}return 0;
}

纵横字谜的答案 (UVa232)相关推荐

  1. 习题3-6 纵横字谜的答案 UVa232

    算法竞赛入门经典(第2版)第3章 数组和字符串 习题3-6 纵横字谜的答案 UVa232 感悟. 1.决定自此,每做一道,必从网站下载该道的PDF文件,废弃从别处下载的PDF文件,因其错误太多. 2. ...

  2. 纵横字谜的答案(Uva232)

    纵横字谜的答案(Uva232) 题目UVa232,题目考察点时二维数组的使用.注意点是需要读懂题目意思,关键点是起始格需要用额外用一个数组存储.然后根据横向和纵向单词的定义,结合起始格,循环遍历打印输 ...

  3. UVa232纵横字谜的答案

    //纵横字谜的答案 #include <stdio.h> #include <ctype.h> int main (){int r,c;int count = 0; while ...

  4. 《算法竞赛入门经典》(第2版) 习题3-6 纵横字谜的答案

    题目 习题3-6 纵横字谜的答案(Cross Answers,ACM/ICPC World Final 1994, UVa232)ps: Final???!!!难道是1994年世界总决赛的第一题-哈哈 ...

  5. UVA232 纵横字谜的答案 Crossword Answers 题解

    题意翻译 输入一个r 行c 列(1<r,.c<10) 的网格,黑格用"*"每个白格都填有一个字母.如果一个白格的左边相邻位置或者上边相邻位置没有白格(可能是黑格,也可能 ...

  6. 习题3-6 纵横字谜的答案(Crossword Answers, ACM/ICPC World Finals 1994, UVa232)

    原题vjudge 输入一个r行c列(1≤r,c≤10)的网格,黑格用"*"表示,每个白格都填有一个字母. 如 果一个白格的左边相邻位置或者上边相邻位置没有白格(可能是黑格,也可能出 ...

  7. UVa232 Crossword Answers(纵横字谜的答案)

    题意: 输入一个r行c列的网格,*表示黑格,字母表示白格.若一个白格位于边界或上方是黑格或左方是黑格,则称其为起始格.找出所有横向单词和竖向单词,其必须从一个起始格开始,到黑格或网格边界为止. 思路: ...

  8. 纵横字谜的答案(Crossword Answers UVa232)

    做到这个题目的时候发现和前面的那个题目非常的像,都是字符都是表格.依然是用一个二维字符数组,储存表格的状况,然后进行搜索判断. 先写一下我犯的错误吧,读者看到我犯过的错误之后说不定就找到自己的方法了呢 ...

  9. 习题 3-6 纵横字谜的答案

    这道题网上有的答案是毒瘤啊,自己都写错了还发出来,题目虽然是英文的,但是也不至于题目都搞错了吧,害自己以为错了,debug半个多小时,╮(╯▽╰)╭ 题目 输入一个r行c列(1≤r,c≤10)的网格, ...

最新文章

  1. ceph bluestore 源码分析:ceph-osd内存查看方式及控制源码分析
  2. Codeforces数学1600day3[数学CodeForces - 1213D2, CodeForces - 1165E 数论,CodeForces - 1165D 因子分解]
  3. 《计算机组成原理》第04章在线测试
  4. 「微信小程序免费辅导教程」24,基础内容组件icon的使用探索与7月26日微信公众平台的更新解读...
  5. linux uboot启动流程分析,uboot启动流程分析
  6. UVa 11468 (AC自动机 概率DP) Substring
  7. python制作点亮图片_MicroPython拼插编程实例:点亮心形8x8点阵
  8. 为什么电脑安装不了python_windows电脑安装python教程
  9. Truncated Signed Distance Function: Experiments on Voxel Size
  10. 【毕业答辩】毕业设计答辩现场技巧
  11. 9.软件架构设计:大型网站技术架构与业务架构融合之道 --- 高可用与稳定性
  12. 财务人员必备的5个Excel技能,学会工资高出同事3倍!
  13. 大数据错题库(微信群Bug整理)
  14. php 模块不存在,模块不存在:index.php?
  15. cad图纸问号怎么转换文字_教你如何解决CAD图纸上字体显示问号的问题
  16. 工科数学分析 MA_12 Vectors and the Geometry of Space (下篇)
  17. 免费mysql数据库_免费mysql空间,免费数据库,免费MYSQL云数据库申请 | 帮助信息-动天数据...
  18. 使用扩展卡尔曼滤波(EKF)进行AHRS九轴姿态融合
  19. InfluxDB 2.0 原理与应用实践
  20. Android怎么查看手机中的本地数据库

热门文章

  1. 损失函数——均方误差(Mean Squared Error,MSE)
  2. Revit二次开发前期准备
  3. 【机器学习】Tensorflow.js:我在浏览器中实现了迁移学习
  4. 优秀的项目经理是如何进行项目管理的
  5. 认证模式之Digest模式
  6. C语言基础习题及答案7
  7. 计算机4F,光学4F系统介绍
  8. 基于Spring Boot的点餐微信小程序设计与实现
  9. 【驱动调试】SoftICE 使用说明
  10. Antd的Upload组件上传文件控制文件数量、格式等,以及提交时如何获取文件