A Curious Matt

Time Limit: 1 Sec

Memory Limit: 256 MB

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=5112

Description

There is a curious man called Matt.

One day, Matt's best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.

Input

The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records.

Each of the following N lines contains two integers ti and xi (0 ≤ ti, xi ≤ 106), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time. It’s guaranteed that all ti would be distinct.

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places.

Sample Input

2
3
2 2
1 1
3 4
3
0 3
1 5
2 0

Sample Output

Case #1: 2.00
Case #2: 5.00

HINT

题意

给你n个时间点和当前的位置,问你哪段的平均速度最大,是多少

题解:

暴力就好了

对着时间排序

代码:

//qscqesze
#include <cstdio>
#include <cmath>
#include <cstring>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <set>
#include <vector>
#include <sstream>
#include <queue>
#include <typeinfo>
#include <fstream>
#include <map>
#include <stack>
typedef long long ll;
using namespace std;
//freopen("D.in","r",stdin);
//freopen("D.out","w",stdout);
#define sspeed ios_base::sync_with_stdio(0);cin.tie(0)
#define maxn 2000000 + 500
#define mod 10007
#define eps 1e-9
int Num;
char CH[20];
//const int inf=0x7fffffff;   //нчоч╢С
const int inf=0x3f3f3f3f;
//**************************************************************************************struct node
{double t,x;
};
node a[100010];
bool cmp(node a,node b)
{return a.t<b.t;
}
int main()
{int t;scanf("%d",&t);int cas = 1;while(t--){int n;scanf("%d",&n);for(int i=1;i<=n;i++)scanf("%d%d",&a[i].t,&a[i].x);sort(a+1,a+1+n,cmp);double ans = 0;for(int i=1;i<n;i++)ans = max(ans,abs(a[i+1].x-a[i].x)/(a[i+1].t-a[i].t));printf("Case #%d: %.2f\n",cas++,ans);}
}

转载于:https://www.cnblogs.com/qscqesze/p/4817568.html

HDU 5112 A Curious Matt 水题相关推荐

  1. hdu 5112 A Curious Matt

    题目连接 http://acm.hdu.edu.cn/showproblem.php?pid=5112 A Curious Matt Description There is a curious ma ...

  2. HDU 6264 Super-palindrome(CCPC2017杭州) 水题

    http://acm.hdu.edu.cn/showproblem.php?pid=6264 题目大意:给定字符串TTT,使得该字符串的每个长度为奇数的子串都是回文串,求至少要修改的字符的数量. 思路 ...

  3. hdu 2041:超级楼梯(水题,递归)

    超级楼梯Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submissio ...

  4. 【HDU - 5585】Numbers (水题,数学,数论)

    题干: There is a number N.You should output "YES" if N is a multiple of 2, 3 or 5,otherwise ...

  5. HDU 2549 壮志难酬 (水题,但有个小坑!)

    壮志难酬 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submi ...

  6. HDOJ(HDU) 2139 Calculate the formula(水题,又一个用JavaAC不了的题目)

    Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) 看到这个时间,我懵逼了... 果然,J ...

  7. HDU 5680 zxa and set 水题

    zxa and set 题目连接: http://acm.hdu.edu.cn/showproblem.php?pid=4681 Description zxa has a set A={a1,a2, ...

  8. hdu 5062 Beautiful Palindrome Number(水题)

    题目链接:hdu 5062 Beautiful Palindrome Number 题目大意:略. 解题思路:暴力或者手算都可以,注意手算的话,分别算出1,2,3...位的情况后,答案是累加上去的. ...

  9. hdu 4541 Ten Googol 小水题

    Ten Googol Time Limit: 500/200 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others) Total S ...

最新文章

  1. 英特尔宣布推出“Nervana”神经网络处理器
  2. http 协议上传文件multipart form-data boundary 说明--转载
  3. html2image api,图像标签_图像识别 Image_API参考_API_华为云
  4. gradle 上传jar包_gradle 打包jar上传到nexus 同时上传源码jar
  5. 怎么撤销定时说说_已注册商标遇到撤三申请怎么办
  6. haut-1280 诡异的迷宫
  7. 巧用.mdb后缀数据库做后门
  8. STM32 - 定时器高级应用说明 - 多触波的实现 (N-pulse waveform generation using timer synchronization)- 01
  9. airpods pro连接安卓声音小_airpods pro 麦克风声音小
  10. 【oracle】oracle常用命令汇总
  11. Cesium:去除原生自带右上角弹窗
  12. PostgreSQL与mysql语法不同
  13. SPSS数据分析全套教程(2)—— 变量处理
  14. android手机版excel怎样填充序列号,规范日期数据的极简法。Excel填充功能快速填充序号操作详解。如何制作工作日序列号填充,快速填充功能无法使用...
  15. format函数python生成列表_python之自动生成器(持续更新)
  16. 《Dreamweaver CS6 完全自学教程》笔记 第二章:Dreamweaver CS6 入门
  17. java的体重_标准体重计算示例代码
  18. 程序员武器之键盘,适用于其他文字录入者
  19. 高性能分布式执行框架——Ray
  20. Mysql数据库数据拆分之分库分表总结

热门文章

  1. 三种组播×××承载方案对比
  2. NetBeans 时事通讯(刊号 # 4 - Apr 22, 2008)
  3. java代码二进制转为十六进制_Java 中二进制转换成十六进制的两种实现方法
  4. 3.7 PPP协议和HDLC协议
  5. C/C++产生随机数
  6. 网卡指示灯含义及故障分析
  7. 原来音色是波峰到波谷时间序列
  8. TCP/IP记一次关于IP地址和MAC物理地址的思考
  9. Recover Binary Search Tree
  10. 快速上手RaphaelJS-Instant RaphaelJS Starter翻译(一)