推桌子

时间限制:1000 ms  |  内存限制:65535 KB
难度:3

描述
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.
输入
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move. 
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 
line, the remaining test cases are listed in the same manner as above.
输出
The output should contain the minimum time in minutes to complete the moving, one per line.
样例输入
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
样例输出
10
20
30
上传者
苗栋栋

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
int s,e,t,n;
scanf("%d",&t);

while(t--)
{

int num[300]={0};//初始化数组。一共400个房间,简化后为200个,所以定义300大小,没问题;一定要写在循环里面,不然有重叠加不了;

scanf("%d",&n);
while(n--)
{
scanf("%d%d",&s,&e);
s = (s+1)/2;  //可以看为将对面两个房间的房间号变为一样,将房间数简化为200个,且在一条直线上,看做区间覆盖问题。
e = (e+1)/2;
if(s>e)//不论是从小房间号到大房间号,还是从大房间号到小房间号,都化为一条直线上从小到大的排序,便于标记计算。
swap(s,e);//交换大小
for(int j = s;j<=e;j++)//重点来了,之前初始化数组为0,现在对每一组输入进行标记,比如从15-16,其实s=8,e=8,标记在一条线段上为8处+1,以此类推,若第二组经过8,则8处再+1; 
num[j]++;
}
int ans = 0;//初始比较数,设为0,没有经过的房间数在数组中值都为0,经过以此即为1,以此类推;
for(int i = 0;i<200;i++)
{
if(num[i]>ans)
ans = num[i];//循环遍历整个200大小的数组,找出数组中的最大值,即为推桌子活动中重叠的次数;
}
printf("%d\n",ans*10);
}
return 0;
}

终于弄懂了,入门艰难,且行且珍惜,加油!!

转载于:https://www.cnblogs.com/yecindy/p/7269608.html

HDOJ-1050-Moving Tables(nyoj220)相关推荐

  1. hdu 1050 Moving Tables

    Moving Tables Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other) Font: ...

  2. hdu 1050 Moving Tables

    http://acm.hdu.edu.cn/showproblem.php?pid=1050 对与每个房间前面过道,操作一次标记一次,标记的最多的次数就是必须用的时间. 1 #include < ...

  3. Moving Tables(贪心)

    链接:http://acm.hdu.edu.cn/showproblem.php?pid=1050 原题: Moving Tables Time Limit: 2000/1000 MS (Java/O ...

  4. POJ1083 Moving Tables

    1083:Moving Tables 题目分析:初看似乎像贪心算法中的活动安排问题,不同的是这里的所有活动(相当于搬桌子的距离)都需要安排. 有四种贪心策略:最短优先,最长优先,最早开始时间优先,最早 ...

  5. HDU 1050 NYOJ 220 Moving Tables

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1050  http://acm.nyist.net/JudgeOnline/problem.php?pi ...

  6. uva live 2326 - Moving Tables

    把房间号映射在一条坐标上,然后排序,最后找从左到右找一次可行的计划,最后找从左到右找一次可行的计划,最后找从左到右找一次可行的计划,最后找从左到右找一次可行的计划, ............ 次数*1 ...

  7. poj 1083 Moving Tables

    题目 两种做法,开始用贪心做的,有种情况没考虑到,结果排序错了. 这个例子,感觉上有三个交点,以为是30,其实是20. 贪心代码: #include <iostream> #include ...

  8. 【POJ1083】 Moving Tables (并行的搬运)

    BUPT2017 wintertraining(15) #6E 题意 房间1和2,3和4,...,399和400共用一节走廊,有q次从房间li到ri的搬运桌子,一次搬运10分钟.两个搬运如果走廊有重叠 ...

  9. POJ-1083 Moving Tables(imos算法)

    这一题有两个陷阱: 给出的起始点可能小于终点 ,所以必须要加个判断,让第二个数大于第一个数 区间算的时候,一定是奇数到偶数,才能做到真正的区间全覆盖.所以如果第二个数是奇数,要加一变为偶数:第一个数为 ...

最新文章

  1. Yolov3Yolov4网络结构与源码分析
  2. 解决win 10 vscode 打开后白屏问题
  3. Java 7之集合类型 - 二叉排序树、平衡树、红黑树---转
  4. wordpress插件翻译不生效_新的恶意软件利用wordpress插件漏洞攻击数百万网站
  5. RocketMQ错误消息重试策略之Consumer的重试机制(Exception情况)
  6. 云服务器与传统服务器的优势差异
  7. android 之 百度地图
  8. windows10双系统安装ubuntu18.04
  9. 【python教程入门学习】什么是生成器?
  10. 【坐在马桶上看算法】啊哈算法13:零基础彻底弄懂“并查集“
  11. 《CCNA安全640-554认证考试指南》——第6章在Cisco IOS设备上保护管理层
  12. python网络爬虫学习笔记(十):数据存储
  13. webpack5配置dev-server在控制台打印信息
  14. iTextSharp 添加图片
  15. apktool 回编译说文件名或扩展名太长
  16. 华为突破封锁,对标谷歌Dropout专利,开源自研算法Disout,多项任务表现更佳
  17. Android曲线水波纹动画,Android水波纹显示进度效果,很炫
  18. 基于Google Earth Engine的Landsat单窗算法地表温度(LST)反演
  19. 谷歌学术403:某URL没有权限访问
  20. 学计算机的上升路线,学习计算机路线图.doc

热门文章

  1. python 中time, datetime的用法
  2. Unity3d 屏幕空间人体皮肤知觉渲染次表面散射Screen-Space Perceptual Rendering Subsurface Scattering of Human Skin...
  3. TypeScript内置对象
  4. 计算机网络学习笔记(23. HTTP连接类型)
  5. 删除桌面图标的小箭头
  6. 宇宙中的最大天体有多大
  7. 每一个企业的供应商都有供应商
  8. 如何将微商管理模式流程化
  9. 在职场,没有永远的朋友,也没有永远的敌人,因为只有利益
  10. 传统行业生意,现在想要发财