配置命令
R1===================================
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone EST -5
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip source-route
!
!
!         
!
ip cef
no ip domain lookup
ip multicast-routing 
no ipv6 traffic interface-statistics
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy

!
!
!
!         
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 ip pim sparse-mode
 ip igmp join-group 239.1.1.1
!
interface Ethernet0/0
 no ip address
!
interface Ethernet0/0.12
 encapsulation dot1Q 12
 ip address 12.1.1.1 255.255.255.0
 ip pim bsr-border
 ip pim sparse-mode
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Serial1/0
 no ip address
 shutdown
 no fair-queue
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!         
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.1 mask 255.255.255.255
 neighbor 12.1.1.2 remote-as 200
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip pim bsr-candidate Loopback0 0
ip pim rp-candidate Loopback0
ip msdp peer 2.2.2.2 connect-source Loopback0
ip msdp cache-sa-state
!
!         
!
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
exception data-corruption buffer truncate
end
R2===================================
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone EST -5
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip source-route
!
!
!         
!
ip cef
no ip domain lookup
ip multicast-routing 
no ipv6 traffic interface-statistics
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy

!
!
!
!         
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 ip pim sparse-mode
!
interface Ethernet0/0
 no ip address
!
interface Ethernet0/0.12
 encapsulation dot1Q 12
 ip address 12.1.1.2 255.255.255.0
 ip pim bsr-border
 ip pim sparse-mode
!
interface Ethernet0/0.23
 encapsulation dot1Q 23
 ip address 23.1.1.2 255.255.255.0
 ip pim bsr-border
 ip pim sparse-mode
!         
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Serial1/0
 no ip address
 shutdown
 no fair-queue
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!         
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 2.2.2.2 mask 255.255.255.255
 neighbor 12.1.1.1 remote-as 100
 neighbor 23.1.1.3 remote-as 300
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip pim bsr-candidate Loopback0 0
ip pim rp-candidate Loopback0
ip msdp peer 1.1.1.1 connect-source Loopback0
ip msdp peer 3.3.3.3 connect-source Loopback0
ip msdp cache-sa-state
!
!
!
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
exception data-corruption buffer truncate
end
R3===================================
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone EST -5
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip source-route
!
!
!         
!
ip cef
no ip domain lookup
ip multicast-routing 
no ipv6 traffic interface-statistics
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy

!
!
!
!         
!
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 ip pim sparse-mode
!
interface Ethernet0/0
 no ip address
!
interface Ethernet0/0.23
 encapsulation dot1Q 23
 ip address 23.1.1.3 255.255.255.0
 ip pim bsr-border
 ip pim sparse-mode
!
interface Ethernet0/0.34
 encapsulation dot1Q 34
 ip address 34.1.1.3 255.255.255.0
 ip pim sparse-mode
!
interface Ethernet0/0.35
 encapsulation dot1Q 35
 ip address 35.1.1.3 255.255.255.0
 ip pim sparse-mode
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 100
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 34.1.1.3 0.0.0.0 area 0
 network 35.1.1.3 0.0.0.0 area 0
!
router bgp 300
 no synchronization
 bgp log-neighbor-changes
 network 3.3.3.3 mask 255.255.255.255
 neighbor 4.4.4.4 remote-as 300
 neighbor 4.4.4.4 update-source Loopback0
 neighbor 4.4.4.4 next-hop-self
 neighbor 5.5.5.5 remote-as 300
 neighbor 5.5.5.5 update-source Loopback0
 neighbor 5.5.5.5 next-hop-self
 neighbor 23.1.1.2 remote-as 200
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip msdp peer 2.2.2.2 connect-source Loopback0
ip msdp peer 4.4.4.4 connect-source Loopback0
ip msdp cache-sa-state
!
!
!
!
!
!         
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
exception data-corruption buffer truncate
end
R4===================================
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone EST -5
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip source-route
!
!
!         
!
ip cef
no ip domain lookup
ip multicast-routing 
no ipv6 traffic interface-statistics
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy

!
!
!
!         
!
!
!
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 ip pim sparse-mode
!
interface Ethernet0/0
 no ip address
!
interface Ethernet0/0.34
 encapsulation dot1Q 34
 ip address 34.1.1.4 255.255.255.0
 ip pim sparse-mode
!
interface Ethernet0/0.45
 encapsulation dot1Q 45
 ip address 45.1.1.4 255.255.255.0
 ip pim sparse-mode
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Serial1/0
 no ip address
 shutdown
 no fair-queue
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 100
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 300
 no synchronization
 bgp log-neighbor-changes
 network 4.4.4.4 mask 255.255.255.255
 neighbor 3.3.3.3 remote-as 300
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 5.5.5.5 remote-as 300
 neighbor 5.5.5.5 update-source Loopback0
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip pim bsr-candidate Loopback0 0
ip pim rp-candidate Loopback0
ip msdp peer 3.3.3.3 connect-source Loopback0
ip msdp cache-sa-state
!
!
!
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
exception data-corruption buffer truncate
end
R5===================================

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone EST -5
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip source-route
!
!
!         
!
ip cef
no ip domain lookup
ip multicast-routing 
no ipv6 traffic interface-statistics
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy

!
!
!
!         
!
!
!
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
 ip pim sparse-mode
!
interface Ethernet0/0
 no ip address
!
interface Ethernet0/0.35
 encapsulation dot1Q 35
 ip address 35.1.1.5 255.255.255.0
 ip pim sparse-mode
!
interface Ethernet0/0.45
 encapsulation dot1Q 45
 ip address 45.1.1.5 255.255.255.0
 ip pim sparse-mode
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Serial1/0
 no ip address
 shutdown
 no fair-queue
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 100
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 300
 no synchronization
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 300
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 4.4.4.4 remote-as 300
 neighbor 4.4.4.4 update-source Loopback0
 no auto-summary
!
ip forward-protocol nd
!         
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
exception data-corruption buffer truncate
end

EBGP ==================================================

msdp rpf 规则1相关推荐

  1. 十五、组播(Multicast)

    组播(Multicast) 组播基础 前言 当网络中部署点到多点通信应用时,若采用单播方式,网络中传输的信息量与需要该信息的用户量成正比.多份内容相同的信息发送给不同用户,对信源及网络带宽都将造成巨大 ...

  2. 2022-10-31 网工进阶(三十三) IP组播-流量模型、组播概念、组播报文结构、组播地址与MAC、组播网络架构、组播服务模型、组播数据转发原理(RPF检查、组播分发树、组播协议介绍)

    IP组播概念 流量模型 网络中存在各种各样的业务,从流量模型看一般可以将业务分为两类: 点到点业务:比如FTP,WEB业务,此类业务主要特点是不同的用户有不同的需求,比如用户A需要下载资料A,用户B需 ...

  3. ip pim spare 源树 和 共享树_Pim通用规则+Dense模式规则+Sparse模式规则

    一.pim 通用规则 pim 通用规则1: 无论何时之创建一个(S,G)项而相应的父(*,G)项存在,就首先自动创建新的(*,G)项.(有(S,G)一定有(*,G),可以比喻为(*,G)是(S,G)的 ...

  4. 组播反向路径转发RPF

    什么是RPF? 路由器收到组播数据报文后,只有确认这个数据报文是从自身连接到组播源的接口上收到的,才进行转发,否则丢弃. RPF检查 在单播路由表中查找到组播报文源地址的路由 如果该路由的出接口就是组 ...

  5. 组播路由协议基础——组播表项和RPF机制

    IGMP组表 一旦设备在某个接口上激活了IGMP,该设备就会开始维护IGMP组表.初始情况下该数据表是空的,当设备在接口上收到直连网段中的主机发送出来的IGMP成员关系报告时,设备就会在IGMP组表中 ...

  6. 华为设备配置基于静态RPF对等体的AS间组播

    配置各接口IP地址 [LSW1]vlan batch 10 40 100 [LSW1-GigabitEthernet0/0/1]port link-type hybrid [LSW1-GigabitE ...

  7. RPF检查在组播数据转发中的应用

    组播路由协议通过已有的单播路由信息来确定上.下游邻居设备,创建组播路由表项.运用RPF检查机制,来确保组播数据流能够沿组播分发树(路径)正确的传输,同时可以避免转发路径上环路的产生.         ...

  8. 浅显易懂 Makefile 入门 (03)— 目标文件搜索(VPATH 和 vpath 的区别和使用)、隐含规则

    1. 目标文件搜索(VPATH和vpath) 如果需要的文件是存在于不同的路径下(即源文件与 Makefile 文件不在同一个路径下),在编译的时候就用到了 Makefile 中为我们提供的目录搜索文 ...

  9. 浅显易懂 Makefile 入门 (01)— 什么是Makefile、为什么要用Makefile、Makefile规则、Makefile流程如何实现增量编译

    1. 什么是 Makefile Makefile 文件描述了 Linux 系统下 C/C++ 工程的编译规则,它用来自动化编译 C/C++ 项目.一旦写编写好 Makefile 文件,只需要一个 ma ...

  10. Java中类、常量、变量、方法名等命名规则

    Java中类.常量.变量.方法名等命名规则 命名规则: 命名由字母.数字.下划线.美元符号($)构成. 命名不可以数字作为开头. 长度无限制,但不可存在空格. 大小写所表述内容含义不同. 命名不可与J ...

最新文章

  1. 网络流Dinic cur当前弧优化
  2. quick-cocos2dx-2.2.4环境搭建
  3. vue 监听表格里的数据变化_vue中监听数据变化 watch
  4. DHCP Client 无法启动 拒绝访问
  5. python中文词云生成_Python 词云生成
  6. 【剑指offer】二叉搜索树转双向链表,C++实现
  7. 【小梅哥SOPC学习笔记】系统时钟的使用
  8. 1.1.0-简介-P4-一致性、2PC和3PC
  9. 利用计算机传播非法信息,非法侵入计算机信息系统罪如何处罚
  10. NGINX防御CC攻击教程
  11. 写一个微信和支付宝订单的查询方法:
  12. javascript 下载方法
  13. arXiv | FedPer:带个性化层的联邦学习
  14. 基于华为java编程规范的checkstyle.xml以及格式化模版,注释模版
  15. 2021年大厂iOS 面试题 - 前篇
  16. 蓝牙耳机选哪种的比较好、高端蓝牙耳机推荐
  17. Database connections will be migrated
  18. 移植 u-boot-2020.07 到 iTOP-4412(二)地址相关码 boot
  19. mysql触发器不起作用_mysql – 授予模式触发器不起作用
  20. numeric_limits

热门文章

  1. (一)阿里云创建自己的产品和设备
  2. python随机产生100个整数二进制_python产生随机整数
  3. 《Revisiting Pre-trained Models for Chinese Natural Language Processing》(MacBERT)阅读记录
  4. centos 下 docker 的 安装与使用 (一)
  5. PM-项目管理(Project Management)
  6. 图像增强(对数,指数,曝光,马赛克)
  7. 恋与抽卡模拟器网页_恋与制作人抽卡模拟器-恋与制作人抽卡模拟器软件下载v1.14.1202-k73游戏之家...
  8. u检验中的查u界值表_u检验、t检验、F检验、X2检验
  9. week15作业(字符串)
  10. 电脑显示网络计算机和设备不可见,win10系统网络发现已关闭看不到网络计算机和设备的解决方法...