HSRP:
1.启用HSRP功能,并设置虚拟地址IP, 1为standby的组号。
2.相同组号的路由器属于同一个HSRP组,所有属于同一个HSRP组的路由器的虚拟地址必须一致。
3.HSRP的优先级默认为100,该值越大抢占为活动路由器的优先权越高
4.可以设置路由器是否抢占为活动路由器
5.由于局域网内大多使用三层交换机,此时HSRP是在交换机的SVI接口上配置的。

1.网关冗余热备份协议HSRP(CISCO私有)
2.VRRP
3.GLBP

enable
conf t
no ip do lo
enable pass cisco
line con 0
logg sync
exec-t 0 0
line vty 0 4
pass cisco
logg sync
exit
host

1.网关冗余热备份协议HSRP(CISCO私有)
-------------------------------------------------------------------------


R1:
int e0/0
ip add 10.1.1.1 255.255.255.0
no shut
exit
int e0/1
ip add 13.1.1.1 255.255.255.0
no shut
exit

router rip
version 2
no auto-summary
network 10.0.0.0
network 13.0.0.0
passive-int e0/0
exit

R2:
int e0/0
ip add 10.1.1.2 255.255.255.0
no shut
exit
int e0/1
ip add 23.1.1.2 255.255.255.0
no shut
exit

router rip
version 2
no auto-summary
network 10.0.0.0
network 23.0.0.0
passive-interface e0/0
exit

R3:
int l0
ip add 33.1.1.1 255.255.255.0
exit
int e0/1
ip add 13.1.1.3 255.255.255.0
no shut
exit
int e0/2
ip add 23.1.1.3 255.255.255.0
no shut
exit

router rip
version 2
no auto-summary
network 33.0.0.0
network 13.0.0.0
network 23.0.0.0
exit

R1:
int e0/0
standby 1 ip 10.1.1.254
standby 1 priority 120
standby 1 preempt
standby 1 authentication mode md5 key-string cisco

standby 2 ip 10.1.1.253
standby 2 preempt
standby 2 authentication mode md5 key-string cisco
exit

R2:
int e0/0
standby 1 ip 10.1.1.254
standby 1 preempt
standby 1 authentication mode md5 key-string cisco

standby 2 ip 10.1.1.253
standby 2 priority 120
standby 2 preempt
standby 2 authentication mode md5 key-string cisco
exit

R1/R2:
show standby brief

PC1:
no ip routing
int e0/0
ip add 10.1.1.100 255.255.255.0
no shut
exit
ip default-gateway 10.1.1.254

ping 33.1.1.1 repeat 10000

R3:
show standby brief

R1:
int e0/0
shutdown
exit

R3:
show standby brief

R1:
int e0/0
standby 1 track e0/1 30
exit

int e0/1
shutdown
exit

show standby brief
show standby

2.VRRP
--------------------------------------------------------------------------
R1:
default int e0/0

int e0/0
ip add 10.1.1.1 255.255.255.0
no shut
exit

router rip
network 10.0.0.0
passive-int e0/0
exit

R2:
default int e0/0

int e0/0
ip add 10.1.1.2 255.255.255.0
no shut
exit

router rip
network 10.0.0.0
passive-interface e0/0
exit

R1:
track 1 int e0/1 line-protocol
exit

int e0/0
vrrp 1 ip 10.1.1.254
vrrp 1 priority 120
vrrp 1 preempt
vrrp 1 authentication mode md5 key-string cisco
vrrp 2 ip 10.1.1.253
vrrp 2 preempt
vrrp 2 authentication mode md5 key-string cisco
vrrp 2 track 1 decrement 30
exit

R2:
track 1 int e0/1 line-protocol
exit

int e0/0
vrrp 1 ip 10.1.1.254
vrrp 1 priority 120
vrrp 1 preempt
vrrp 1 authentication mode md5 key-string cisco
vrrp 2 ip 10.1.1.253
vrrp 2 priority 120
vrrp 2 preempt
vrrp 2 authentication mode md5 key-string cisco
vrrp 2 track 1 decrement 30
exit

R1/R2:
show vrrp brief

3. GLBP
--------------------------------------------------------------------

R1:
int e0/0
ip add 10.1.1.1 255.255.255.0
no shut
exit
int e0/1
ip add 20.1.1.1 255.255.255.0
no shut
exit

router rip
version 2
no auto-summary
network 10.0.0.0
network 20.0.0.0
passive-interface e0/0
exit

R2:
int e0/0
ip add 10.1.1.2 255.255.255.0
no shut
exit
int e0/1
ip add 20.1.1.2 255.255.255.0
no shut
exit

router rip
version 2
no auto-summary
network 10.0.0.0
network 20.0.0.0
passive-interface e0/0
exit

R3:
int e0/0
ip add 10.1.1.3 255.255.255.0
no shut
exit
int e0/1
ip add 20.1.1.3 255.255.255.0
no shut
exit

router rip
version 2
no auto-summary
network 10.0.0.0
network 20.0.0.0
passive-interface e0/0
exit

R4:
int l0
ip add 44.1.1.1 255.255.255.0
exit
int e0/0
ip add 20.1.1.4 255.255.255.0
no shut
exit

router rip
version 2
no auto-summary
network 20.0.0.0
network 44.0.0.0
exit

-----------------------------------------------------
R1:
int e0/0
glbp 1 ip 10.1.1.254
glbp 1 priority 200
glbp 1 preempt
glbp 1 authentication text cisco
exit

R2:
int e0/0
glbp 1 ip 10.1.1.254
glbp 1 priority 180
glbp 1 preempt
glbp 1 authentication text cisco
exit

R3:
int e0/0
glbp 1 ip 10.1.1.254
glbp 1 priority 160
glbp 1 preempt
glbp 1 authentication text cisco
exit

R1:
show glbp

R7-PC1:
no ip routing

int e0/0
ip add 10.1.1.100 255.255.255.0
no shut
exit
ip default-gateway 10.1.1.254

ping 44.1.1.1
show arp
clear arp cache
ping 44.1.1.1
show arp

跟踪上行链路
------------------------------------------------------
R1:
track 2 int e0/1 line-protocol

int e0/0
glbp 1 wighting 110 lower 85 upper 105
glb1 1 weighting track 2 decrement 50

转载于:https://www.cnblogs.com/thlzhf/p/3258498.html

CCNP交换实验(5) -- 网关热备冗余相关推荐

  1. 【分享】搭建域环境实现主域和文件服务器的热备冗余

    好多年前玩过域了,当时都是单独一个主域,没有辅域的环境,也是好怕服务器出问题,还好,离开的时候都还没出问题 现在这家公司原来没域,客户机120左右,我想是时候该上域了,为了方便以后的管理,统一部署. ...

  2. CCNP交换实验(3) -- STP

    enable 转载于:https://www.cnblogs.com/thlzhf/p/3258495.html

  3. 华为防火墙双机热备配置实例

    拓扑解释 两台防火墙FW1与FW2做双机热备冗余,SW2方向做trust区域,SW3方向做UNtrust区域 适用场景 一般园区网中 配置开始 先搞定底层的交换机 SW2上:(SW3上相同) vlan ...

  4. [na]vrrp两用(网关冗余+服务器热备)

    VRRP的两种用途 早上想了想vrrp的使用,1,网关冗余 2,服务器热备 思想稍微有点不一样.主要在于监控口 服务器的话有心跳线,用户同步一些配置和迁移一些服务.达到热备的目的.:牵涉到四个优先级: ...

  5. 双机热备技术(讲解+实验)——静态路由实现

    目录 一.双机热备(冗余技术)简介: (1)HSRP 技术简介: (2)VRRP技术简介: 二.双机热备分析: (1)静态路由分析 (2)生成树分析 (3)热备切换分析 三.双机热备配置: (1)HS ...

  6. ensp 双机热备 配置_【解忧番外篇】基于eNSP USG6000v的双机热备实验

    前言 本实验使用华为模拟器eNSP中USG6000v完成实验. 实验拓扑 配置过程 一.导入设备包 由于USG6000v模拟器需要导入设备包才能使用,所以需要在华为企业专网下载USG6000v的设备包 ...

  7. RAID磁盘阵列详解and软阵列(raid0,raid1,raid5,raid1+0 热备盘)配置实验

    文章目录 前言 一:RAID磁盘阵列详解 1.1:RAID 0磁盘阵列介绍 1.2:RAID容错对比表 二:阵列卡介绍 2.1:阵列卡介绍 2.2:RAID卡的接口类型 2.3:阵列卡的缓存 三. 软 ...

  8. 双机热备实验——(VRRP技术+HSRP技术)讲解+配置

    目录 一.双机热备(冗余技术)简介: 二.HSRP 技术简介: 三.VRRP技术简介: 四.HSRP配置: 五.VRRP配置: 一.双机热备(冗余技术)简介: 两核心交换机,业务流量优先从主核心交换机 ...

  9. 防火墙双机热备,DHCP服务器,核心交换机负载分担及冗余设计

    文章目录 目录: 一.防火墙双机热备技术概念 二.配合使用的相关技术指导 三.设计要求及拓扑图 四:配置过程及相应命令 总结 一.防火墙热备概述:         一般而言,防火墙部署于公司网络的出口 ...

  10. Keepalived+Nginx双机热备实验

    文章目录 前言 一.Keepalived的工作过程 二.Keepalived+Nginx双机热备实验 1.基础环境 1.1.关闭防火墙和selinux 2.安装nginx 2.1.nginx的一些默认 ...

最新文章

  1. Mongodb集群 - 副本集内部选举机制
  2. env export set 作用
  3. java之IO整理(中)
  4. 给asterisk1.8.7添加menuselct选项
  5. 【安卓开发 】Android初级开发(六)Activity生命周期
  6. java openssl dgst_(7) openssl dgst(生成和验证数字签名)
  7. 蓝桥杯第六届国赛JAVA真题----切开字符串
  8. java上传头像插件_JSP+SpringMVC框架使用WebUploader插件实现注册时候头像图片的异步上传功能...
  9. 两台电脑共享怎么设置_两台电脑共用键鼠的简单设置
  10. python真的是吹过了-被吹的神乎其神的Python到底都能干什么
  11. 动态规划法求最大字段和时间复杂度_面试必备——手撕代码(1)“最大子序列和”...
  12. java集成agent作用_javaagent 基于 javaagent 开发的 APM 工具,收集方法的执行次数和执行时间,定时输出成 json 格式 @codeKK Android开源站...
  13. Matlab控制器设计app(controlSystemDesigner)的使用
  14. mid、mif文件转shapefile、geojson等格式的数据
  15. 什么是 PHP 过滤器?为什么使用过滤器?
  16. 颠覆者-读周鸿祎新书
  17. 简述DB ,DBMS与DBS
  18. Linux系统之LVM(逻辑卷管理)
  19. Java 之父:找Bug最浪费时间,现在不是开源的黄金时代!
  20. 诚挚地希望你加入2018年第三届中国新媒体千人峰会!

热门文章

  1. 灰狼优化算法与影响力最大化问题
  2. java path combine_Path.Combine (合并两个路径字符串)方法的一些使用细节
  3. mysql获取多张表中的数据_mysql – 从具有递归关系的两个表中获取数据
  4. 光纤光信号闪红灯_激光放大器在光纤领域的应用
  5. JAVA动态绑定浅析
  6. 自定义Toast的出现样式
  7. 无聊的时候去火箭队官网调戏客服
  8. ajax的param方法,jQuery ajax - param() 方法
  9. 程序员找工作?只凭感觉去面试?不要做白日梦了,程序员必备面试题,脱口而出的专业语言,让你的薪水翻一番,建议收藏
  10. 信息网络传播中的服务器标准,信息网络传播权的服务器标准与实质替代标准之争...