端口聚合工作原理
将连接多个物理链路的端口捆绑在一起形成一个逻辑端口,这个逻辑端口成为聚合端口(AP)。聚合端口AP的功能遵循IEEE802.3ad标准,目标是扩展链路带宽,提高链路可靠性。
端口聚合条件:
一般交换机最多支持8个物理端口组成一个聚合端口,同时要满足以下条件:
1、物理端口速度相同;
2、物理端口介质相同;
3、物理端口层次一致;
4、AP成员端口必须属于同一个VLAN。

端口聚合又称链路捆绑,分为二层端口聚合和三层端口聚合。二层端口聚合针对二层交换机,交换机接口只能是二层性质的,接口链路类型可以设置为trunk和access,形成的链路不带IP地址功能。三层聚合端口也称为路由聚合端口,针对三层交换机,形成的链路带IP地址功能,则不能设置链路类型为trunk和access。原文链接:https://blog.csdn.net/STARDEIT/article/details/119833428

二层聚合端口配置
配置二层聚合端口的过程:
1、创建聚合端口
2、将端口绑定到聚合端口
3、设置聚合端口类型

下面是以思科模拟器为例做二层聚合端口操作步骤:
1、创建聚合组进入聚合接口模式(全局模式)
Switch(config)#interface port-channel 1
2、将端口绑定到聚合端口(接口模式)
Switch(config)#int range f0/1-3
Switch(config-if-range)#channel-group 1 mode on
channel-group指定当前端口要加入到的聚合组(聚合端口ID)
3、聚合接口下端口配置(聚合接口模式)
Switch(config)#int port-channel 1
Switch(config-if)#switchport mode trunk

二层实例

交换机switch0的配置

Switch>en
Switch#conf
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#int port-channel 1
Switch(config-if)#exit
Switch(config)#int range f0/2-3
Switch(config-if-range)#channel-group 1 mode on
Switch(config-if-range)#
%LINK-5-CHANGED: Interface Port-channel 1, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel 1, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to upSwitch(config-if-range)#exit
Switch(config)#int port-channel 1
Switch(config-if)#switchport mode trunkSwitch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel 1, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel 1, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up

交换机switch1的配置

Switch>en
Switch#conf
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#int port-channel 1
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#int range f0/2-3
Switch(config-if-range)#channel-group 1 mode on
Switch(config-if-range)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down%EC-5-CANNOT_BUNDLE2: Fa0/2 is not compatible with Po1 and will be suspended (vlan mask is different)%LINK-5-CHANGED: Interface Port-channel 1, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel 1, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up

三层聚合端口配置
配置三层聚合端口的过程:
1、创建聚合端口,并将类型设置为三层端口(路由端口),并为其配置IP地址。
2、将需要加入的物理端口类型设置为三层端口。
3、将需要加入的物理端口加入到聚合端口。
4、如有不同网段的信息通信,需要开启路由,并做路由配置。

下面是以思科模拟器为例做二层聚合端口操作步骤:
1、创建聚合组进入聚合接口模式(全局模式)
Switch(config)#interface port-channel 1
2、将端口绑定到聚合端口(接口模式)
Switch(config)#int range f0/1-3
Switch(config-if-range)#channel-group 1 mode on
channel-group指定当前端口要加入到的聚合组(聚合端口ID)
3、聚合接口下端口配置(聚合接口模式)
Switch(config)#int port-channel 1
Switch(config-if)#switchport mode trunk
4、全局模式下开启路由功能
Switch(config)#ip routing
Switch(config)#ip route 192.168.1.0 255.255.255.0 192.168.12.1

三层实例

交换机switch0的配置代码

Switch>en
Switch#conf
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#int vlan 1
Switch(config-if)#ip add 192.168.1.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#int port-channel 1
Switch(config-if)#no switchport
Switch(config-if)#ip add 192.168.12.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#int range f0/1-3
Switch(config-if-range)#no switchport
Switch(config-if-range)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to upSwitch(config-if-range)#channel-group 1 mode on
Switch(config-if-range)#
%LINK-5-CHANGED: Interface Port-channel 1, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel 1, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to upSwitch(config-if-range)#exit
Switch(config)#ip routing
Switch(config)#ip route 192.168.2.0 255.255.255.0 192.168.12.2
Switch(config)#
%LINK-5-CHANGED: Interface FastEthernet0/5, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, changed state to up%LINK-5-CHANGED: Interface FastEthernet0/5, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, changed state to down

交换机switch1的配置代码:

Switch>en
Switch#conf
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 2
Switch(config-vlan)#int vlan 2
Switch(config-if)#ip add 192.168.2.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#int f0/4
Switch(config-if)#sw acc vlan 2
Switch(config-if)#exit
Switch(config)#int port-channel 1
Switch(config-if)#no switchport
Switch(config-if)#ip add 192.168.12.2 255.255.255.0
Switch(config-if)#int range f0/1-3
Switch(config-if-range)#no switchport
Switch(config-if-range)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to upSwitch(config-if-range)#channel-group 1 mode on
Switch(config-if-range)#
%LINK-5-CHANGED: Interface Port-channel 1, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel 1, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to upSwitch(config-if-range)#exit
Switch(config)#ip routing
Switch(config)#ip route 192.168.1.0 255.255.255.0 192.168.12.1
Switch(config)#end
Switch#sh ip rou
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter areaN1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGPi - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area* - candidate default, U - per-user static route, o - ODRP - periodic downloaded static routeGateway of last resort is not setS    192.168.1.0/24 [1/0] via 192.168.12.1
C    192.168.2.0/24 is directly connected, Vlan2
C    192.168.12.0/24 is directly connected, Port-channel 1

思科模拟器 交换机链路聚合(二层、三层)相关推荐

  1. H3C交换机配置链路聚合二层三层

    二层聚合: 一.静态聚合 [SW]int Bridge-Aggregation 1 [SW-Ethernet1/0/1]port link-aggregation group 1 [SW-Ethern ...

  2. 某虚拟化项目中思科与华为交换机链路聚合互连案例

    在今年初的时候,我在实施一个VMware虚拟化项目中,涉及到华为与思科交换机通过"链路聚合"的方式互连,经过咨询华为的技术工程师,问题得以成功解决. 不像某些厂家的售后:我们的产品 ...

  3. linux服务器双网卡链路聚合,服务器多网卡绑定与交换机链路聚合对接探讨

    <服务器多网卡绑定与交换机链路聚合对接探讨>由会员分享,可在线阅读,更多相关<服务器多网卡绑定与交换机链路聚合对接探讨(9页珍藏版)>请在人人文库网上搜索. 1.服务器多网卡绑 ...

  4. 交换机链路聚合技术的负载均衡算法原理(含C语言实现)

    [注:本文[原理]部分来自转载,转载来源为https://blog.csdn.net/wuheshi/article/details/79128044,此部分原创作者暂未找到,但感谢原作者的知识贡献] ...

  5. 华三企业交换机链路聚合实例

    本期为大家带来华三交换机的链路聚合的实例,请看拓补图 前言:华三的交换机链路聚合和华为的有异曲同工之妙,下面是关键字 华三Bridge-Aggregation1  =华为Eth-trunk 华三加入聚 ...

  6. Cisco交换机链路聚合

    Cisco交换机链路聚合 2009-08-04 20:40:44 标签:负载均衡 Cisco 端口聚合 局域网 [推送到技术圈] 版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出 ...

  7. 交换机链路聚合在网络中的作用

    交换机链路聚合在网络中的作用  分类: 系统运维 链路聚合有成端口聚合,断口捆绑,英文名port trunking.功能是将交换机的多个低带宽端口捆绑成一条高带宽链路,可以实现链路负载平衡.避免链路出 ...

  8. 华为交换机链路聚合命令总结(eNSP)

    华为交换机链路聚合: [LSW1]和[LSW2]配置相同, [LSW1]undo info-center enable 关闭信息提示 [LSW1]interface Eth-Trunk 1 [LSW1 ...

  9. 服务器网卡+链路+和协议,服务器双网卡捆绑与交换机链路聚合排障1例

    1故障现象 在实际组网环境中,将1台HP DL380服务器集成的双网卡进行双千兆网卡捆绑,并与盒式千兆3层交换机H3C S5500-28TP-SI的2个GE光口进行连接,该交换机的2个GE光口进行(l ...

  10. eNSP第二篇:Eth-trunk,链路聚合,常用命令,二层链路聚合和三层链路聚合

    链路聚合,Eth-trunk,ip-trunk 链路聚合:顾名思义,就是将多条链路聚合成一条链路,这条链路的带宽等于所有有效链路的总和:属于可靠性技术. 主要作用是:提高带宽,增加可靠性 在eNSP中 ...

最新文章

  1. Linux tcpdump命令详解与Wireshark
  2. React使用Styled-Componets来添加样式
  3. 第九篇:Spring Boot整合Spring Data JPA_入门试炼06
  4. Java LocalDateTime类| 带示例的getDayOfYear()方法
  5. CSS3 浮动与定位
  6. 基于嵌入式系统的gnash最小库依赖关系
  7. code vs 集成tfs_10大Python集成开发环境和代码编辑器
  8. linux获取系统启动时间
  9. 【干货】10个高质量的java自学网站推荐
  10. 00_51入门知识积累__学看电路原理图
  11. 电脑出现问题,你的PIN不可用。请单击以重新设置。
  12. Subsonic使用
  13. 3dsmax注册机不能用管理员身份运行的解决办法
  14. java spfa_SPFA算法简介
  15. 【实用】神级工具类Hutool,你值得拥有!
  16. 工具 - 文本比较/对比 - 收集
  17. 总决赛G5:冠军团队的样子,令人动容
  18. 苏宁云宣布下线公有云服务!
  19. vue导出word纯前端实现
  20. Generative Adversarial Registration for Improved Conditional Deformable Templates 论文

热门文章

  1. php怎么写书店系统,基于PHP技术的新华在线购书店系统
  2. Android 蓝牙 自动配对连接
  3. 【单片机】RGB和RGBW LED灯珠的区别
  4. kux格式如何无损转换为MP4格式
  5. cadence从原理图导出器件库_一种cadence中原理图替换元器件库的方法与流程
  6. matlab仿真动力学方程的几种方法,总结,以范德波振子为例
  7. 机器学习:学习的分类
  8. 装系统比较好用的PE工具推荐
  9. 苹果画画软件_想在iPad 上画画,推荐用这些软件
  10. cad打印本计算机未配置,CAD打印的基本设置详细教程