XHXJ's LIS

HDU - 4352

#define xhxj (Xin Hang senior sister(学姐)) 
If you do not know xhxj, then carefully reading the entire description is very important. 
As the strongest fighting force in UESTC, xhxj grew up in Jintang, a border town of Chengdu. 
Like many god cattles, xhxj has a legendary life: 
2010.04, had not yet begun to learn the algorithm, xhxj won the second prize in the university contest. And in this fall, xhxj got one gold medal and one silver medal of regional contest. In the next year's summer, xhxj was invited to Beijing to attend the astar onsite. A few months later, xhxj got two gold medals and was also qualified for world's final. However, xhxj was defeated by zhymaoiing in the competition that determined who would go to the world's final(there is only one team for every university to send to the world's final) .Now, xhxj is much more stronger than ever,and she will go to the dreaming country to compete in TCO final. 
As you see, xhxj always keeps a short hair(reasons unknown), so she looks like a boy( I will not tell you she is actually a lovely girl), wearing yellow T-shirt. When she is not talking, her round face feels very lovely, attracting others to touch her face gently。Unlike God Luo's, another UESTC god cattle who has cool and noble charm, xhxj is quite approachable, lively, clever. On the other hand,xhxj is very sensitive to the beautiful properties, "this problem has a very good properties",she always said that after ACing a very hard problem. She often helps in finding solutions, even though she is not good at the problems of that type. 
Xhxj loves many games such as,Dota, ocg, mahjong, Starcraft 2, Diablo 3.etc,if you can beat her in any game above, you will get her admire and become a god cattle. She is very concerned with her younger schoolfellows, if she saw someone on a DOTA platform, she would say: "Why do not you go to improve your programming skill". When she receives sincere compliments from others, she would say modestly: "Please don’t flatter at me.(Please don't black)."As she will graduate after no more than one year, xhxj also wants to fall in love. However, the man in her dreams has not yet appeared, so she now prefers girls. 
Another hobby of xhxj is yy(speculation) some magical problems to discover the special properties. For example, when she see a number, she would think whether the digits of a number are strictly increasing. If you consider the number as a string and can get a longest strictly increasing subsequence the length of which is equal to k, the power of this number is k.. It is very simple to determine a single number’s power, but is it also easy to solve this problem with the numbers within an interval? xhxj has a little tired,she want a god cattle to help her solve this problem,the problem is: Determine how many numbers have the power value k in L,RL,Rin O(1)time. 
For the first one to solve this problem,xhxj will upgrade 20 favorability rate。

Input

First a integer T(T<=10000),then T lines follow, every line has three positive integer L,R,K.( 
0<L<=R<2 63-1 and 1<=K<=10).

Output

For each query, print "Case #t: ans" in a line, in which t is the number of the test case starting from 1 and ans is the answer.

Sample Input

1
123 321 2

Sample Output

Case #1: 139 

题意:

给出L和R找出在[L,R]中满足最长递增子序列长度等于K的个数。

题解:

状压想不到,看了kuangbin的才明白,1<<10状压存数出现了没有。利用了nlogn递增字序列算法的思想。

数位DP+状态压缩,这题首先考虑如何来求数位的LIS,很明显不可能用n*n的方法,考虑nlogn的方法,维护的是一个数组,在这里要严格递增,所以最长的LIS小于10,所以我们可以将这个数组用2进制压缩成一个状态,然后这个2进制1的个数就是LIS的值,如果不懂LIS nlogn的原理:传送门,然后再考虑决策状态:由于这题t比较大,只能初始化一次,所以会影响到前面状态的都不能当作决策条件,比如说inf(表示是否达到上限),当前位置pos,压缩状态s肯定是要的,然后考虑到我们可以对每一个k进行DP,所以要多开一维来保存k,然后dp[i][j][k] 就是dp的状态保存,i表示考虑到当前第i位,j表示当前的压缩状态,k表示LIS恰好为k的答案

#include <bits/stdc++.h>
using namespace std;
long long dp[25][1<<10][11];///dp[i][j][k]:i为当前进行到的数位,j状态压缩,为10个数字出现过的,其中1的个数就是最长上升子序列,k要求的上升子序列的长度int K;
int getnews(int x,int s) ///更新新的状态
{for(int i=x;i<10;i++)if(s&(1<<i))return (s^(1<<i))|(1<<x);return s|(1<<x);
}int getnum(int s)       ///得到状态s中1的个数
{int ret=0;while(s){if(s&1)  ret++;s>>=1;}return ret;
}
int bit[25];
long long dfs(int pos,int s,bool e,bool z)//e是是不是上界标记,z是是不是前面的为0标记
{if(pos==-1)return getnum(s)==K;if(!e &&dp[pos][s][K]!=-1)return dp[pos][s][K];///核心long long ans=0;int end=e?bit[pos]:9;for(int i=0;i<=end;i++)ans+=dfs(pos-1,(z&&i==0)?0:getnews(i,s),e&&i==end,z&&(i==0));if(!e)dp[pos][s][K]=ans;return ans;
}
long long calc(long long n)
{int len=0;while(n)bit[len++]=n%10 ,  n/=10;return dfs(len-1,0,1,1);
}
int main()
{//freopen("in.txt","r",stdin);//freopen("out.txt","w",stdout);int T;long long l,r;memset(dp,-1,sizeof(dp));scanf("%d",&T);int iCase=0;while(T--){iCase++;scanf("%I64d%I64d%d",&l,&r,&K);printf("Case #%d: ",iCase);printf("%I64d\n",calc(r)-calc(l-1));}return 0;
}/** HDU 4352 XHXJ's LIS* 问L到R,各位数字组成的严格上升子序列的长度为K的个数。* 0<L<=R<263-1 and 1<=K<=10* 注意这里最长上升子序列的定义,和LIS是一样的,不要求是连续的* 所以用十位二进制表示0~9出现的情况,和O(nlogn)求LIS一样的方法进行更新**/

HDU 4352 XHXJ's LIS(*数位DP 记忆化搜索 待整理)相关推荐

  1. 数位dp 记忆化搜索java_hdu 5787 数位dp,记忆化搜索

    题意:求区间[l,r]内有多少个数符合,这个数的任意的相邻k位数(digits),这k个数都两两不相等 l,r范围是1~1e18,k是2~5 思路:数位DP,因为K<=5,我们最多需要保存下来当 ...

  2. bzoj1833: [ZJOI2010]count 数字计数(数位DP+记忆化搜索)

    1833: [ZJOI2010]count 数字计数 题目:传送门 题解: 今天是躲不开各种恶心DP了??? %爆靖大佬啊!!! 据说是数位DP裸题...emmm学吧学吧 感觉记忆化搜索特别强: 定义 ...

  3. UVA - 11361 Investigating Div-Sum Property(数位dp/记忆化搜索板子)

    题目:https://vjudge.net/problem/UVA-11361 思路:数位dp,用记忆化搜索写,dp[pos][i][j][limit] 代表剩余有pos位,每位上的数字和模k 等于i ...

  4. HDU 5001 概率DP || 记忆化搜索

    2014 ACM/ICPC Asia Regional Anshan Online 给N个点,M条边组成的图,每一步能够从一个点走到相邻任一点,概率同样,问D步后没走到过每一个点的概率 概率DP  測 ...

  5. Palindrome subsequence HDU - 4632 区间dp|记忆化搜索

    // 区间dp import java.util.Scanner;/**** @author CN*/ public class main {static int mod = 10007;static ...

  6. 思维dp ---- Codeforces Round #711 (Div. 2) - C. Planar Reflections[dp/记忆化搜索]

    题目链接 题目大意: 就是给你n个平面和一个寿命为k的衰变粒子.开始粒子从左向右飞行,粒子每经过一个平面就会产生一个副本粒子,这个副本粒子比原粒子的寿命少1,即为k-1,并且飞行方向是原粒子的反方向. ...

  7. BZOJ1415 [Noi2005]聪聪和可可 【SPFA + 期望dp记忆化搜索】

    题目 输入格式 数据的第1行为两个整数N和E,以空格分隔,分别表示森林中的景点数和连接相邻景点的路的条数. 第2行包含两个整数C和M,以空格分隔,分别表示初始时聪聪和可可所在的景点的编号. 接下来E行 ...

  8. pku 1191 棋盘分割 DP / 记忆化搜索

    http://poj.org/problem?id=1191 题意:中文省略. 思路:黑说p116有讲解, 主要的状态转移方程为 横着切: dp[k][x1][y1][x2][y2]  = min(d ...

  9. [蓝桥杯][算法提高VIP]Sharing Chocolate(状压dp记忆化搜索)

    题目描述 每天,巧克力在它的许多形式上被全世界数百万人分享.它是一个真正普遍的糖果,实际上在世界上每个国家都能得到. 你发现唯一比吃巧克力更好的事情是把它分享给朋友.不幸的是,你的朋友非常挑剔,有着不 ...

最新文章

  1. 高级 Angular 组件模式 (3a)
  2. Web开发的那点事--业务层常用功能
  3. VS2005 there is no source code available for the current location 解决方案
  4. CF Fox And Two Dots (DFS)
  5. python二进制文件读写文件_Python二进制文件读写
  6. Android 开源项目分类汇总(转)
  7. 上海宝付教你如何更好地保护手机隐私
  8. java 毫秒转分钟和秒_Java程序将毫秒转换为分钟和秒
  9. 如何搭建中国电信物联网云平台
  10. C盘清理瘦身就这三招
  11. 多渠道打包,生成不同包名的包
  12. 爬取豆瓣 TOP250 电影排行榜
  13. iOS开发(OC)——音频播放AVPlayer
  14. 【大疆DJI】安卓开发实习历程- 0.前期准备到面试(HR电话初面+技术一面+技术二面/终面+OC)
  15. 百度网盘下载提速方法(更新于2020年6月)
  16. 查查自己五行属什么命_ywyuan_新浪博客
  17. 作为校招loser,我如何在一年半后的社招中咸鱼翻身
  18. java 字体选择器_常见CSS3选择器和文本字体样式汇总
  19. 零基础做算法?清华计算机系学长带你斩获大厂算法校招SSP
  20. HTML5+CSS3小实例:炫彩的发光字特效

热门文章

  1. Python微信订餐小程序课程汇总
  2. 毕业设计学习锋迷商城笔记
  3. 预约美容APP开发,上门预约美容平台如何低成本运作
  4. 简述 GFS Chubby Bigtable Mapreduce
  5. java actor akka_Java akka框架入门学习
  6. 零基础thinkPHP验证码刷新及验证
  7. python二级证书含金量排名_计算机二级证书含金量有多高?墙妹带你熟悉今年考试系统!...
  8. Win10远程连接,出现身份验证错误。远程计算机要求的函数不受支持 这可能是由于CredSSP加密Oracle修正 。
  9. C语言学习 字母出现频率
  10. I/O口输入时的上拉、下拉、三态