Treasure Exploration
Time Limit: 6000MS   Memory Limit: 65536K
Total Submissions: 8301   Accepted: 3402

Description

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you. 
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure. 
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point. 
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars. 
As an ICPCer, who has excellent programming skill, can your help EUC?

Input

The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.

Output

For each test of the input, print a line containing the least robots needed.

Sample Input

1 0
2 1
1 2
2 0
0 0

Sample Output

1
1
2

Source

POJ Monthly--2005.08.28,Li Haoyuan

Problem : Treasure Exploration
Description : 机器人探索宝藏,有N个点,M条边。问你要几个机器人才能遍历所有的点。
Solution : 二分图的最小路径覆盖。这个题看来好像就是裸的最小路径覆盖,但是题中说了一个点可以遍历多次,这和最小路径覆盖中路径之间不能有交点是矛盾的。那么怎么办呢,我们跑一遍floyd算法,来求出它的传递闭包,这样就可以构造一个新的图了。为什么可以这样呢,因为这样可以新增加边,使得原来路径不能共用同一个点的问题解决了,画个图就明白了。


如果不跑Floyd,那么最小路径覆盖数就是3,{[1->2->3],[4],[5]};跑一下传递闭包,就新增了两条边,如图中虚线所示,这时候4和5这两个点就可以直接连接了,因为[1->2->3]变成了[1->3]给[4->5]让开了一条路。因此以后如果不要求一个点只能走一次,那么就要跑floyd算法。

                                            ——摘自网络

#include<cstdio>
#include<cstring>
using namespace std;
const int N=510;
int n,m,match[N],f[N][N];
bool vis[N];
void init(){for(int i=1;i<=n;i++){for(int j=1;j<=n;j++){f[i][j]=0;}}for(int i=1;i<=n;i++) match[i]=0;
}
bool hunguary(int x){for(int i=1;i<=n;i++){if(!vis[i]&&f[x][i]){vis[i]=1;if(!match[i]||hunguary(match[i])){match[i]=x;return 1;}}}return 0;
}
void floyed(){for(int k=1;k<=n;k++){for(int i=1;i<=n;i++){for(int j=1;j<=n;j++){if(f[i][k]&&f[k][j]){f[i][j]=1;}}}}
}
void solve(){int ans=0;for(int i=1;i<=n;i++){memset(vis,0,sizeof vis);if(hunguary(i)) ans++;}printf("%d\n",n-ans);
}
int main(){while(scanf("%d%d",&n,&m)==2,n+m){init();for(int i=1,x,y;i<=m;i++) scanf("%d%d",&x,&y),f[x][y]=1;floyed();solve();}return 0;
}

转载于:https://www.cnblogs.com/shenben/p/6380144.html

POJ2594 Treasure Exploration[DAG的最小可相交路径覆盖]相关推荐

  1. POJ2594 Treasure Exploration

    Treasure Exploration Time Limit: 6000MS   Memory Limit: 65536K Total Submissions: 8879   Accepted: 3 ...

  2. POJ--2594|Treasure Exploration

    Treasure Exploration Time Limit: 6000MS   Memory Limit: 65536K Total Submissions: 8223   Accepted: 3 ...

  3. poj2594(最小可相交覆盖路径问题)

    最小可相交覆盖: 先用floyd求出原图的传递闭包,即如果a->b有路径,b->c有路径,,则加边a->c.然后就转化成了最小路径覆盖问题(最小不相交路径覆盖问题). 最小路径覆盖数 ...

  4. POJ Treasure Exploration 【DAG交叉最小路径覆盖】

    传送门:http://poj.org/problem?id=2594 Treasure Exploration Time Limit: 6000MS   Memory Limit: 65536K To ...

  5. Treasure Exploration

    Description Have you ever read any book about treasure exploration? Have you ever see any film about ...

  6. 【POJ - 2594】Treasure Exploration(floyd传递闭包 + 最小路径覆盖,图论)

    题干: Have you ever read any book about treasure exploration? Have you ever see any film about treasur ...

  7. poj 2594 Treasure Exploration

    Treasure Exploration Time Limit: 6000MS   Memory Limit: 65536K Total Submissions: 6284   Accepted: 2 ...

  8. pku2594 Treasure Exploration

    题意:给一个有向无环图,求最小的路径数覆盖每个顶点至少一次 分析:很明显的一道最小路径覆盖,可是稍微有些不同的是:"You should notice that the roads of t ...

  9. poj2594(二分图,最小路径覆盖变形)

    Treasure Exploration Time Limit: 6000MS   Memory Limit: 65536K Total Submissions: 7611   Accepted: 3 ...

最新文章

  1. 一周的微信公众平台接口开发总结
  2. NCBI 下载fna文件 human viral bacteria
  3. linux ubuntu文件浏览器如何显示隐藏文件?(快捷键ctrl+h)
  4. 输入一个字母,转大小写
  5. 为什么人们认为区块链是大忽悠?
  6. Taotao Picks Apples
  7. 【Java】访问控制
  8. 21、List遍历时修改元素的问题
  9. mysql客户端重庆_MySQL:MySQL工具以及5.7mysqlbinlog|mysql速度极慢问题
  10. RESTful登录设计(基于Spring及Redis的Token鉴权)
  11. 思科为计算机配置ip命令,cisco路由器配置命令练习
  12. PHP读取PDF内容方法
  13. 从简单泛函到第二类拉格朗日方程
  14. win7字体_潇洒个性艺术!100款英文手写签名字体
  15. 中山大学3D游戏设计读书笔记 unity3D Note9
  16. java毕业设计_汽车租赁系统
  17. Canon背后的故事
  18. 【推荐】两大APP与云账户红包SDK集成详情及Demon分享
  19. 七.面向对象编程(中)
  20. 解决IE浏览器没有网络的情况

热门文章

  1. 介绍一款开源的类Excel电子表格软件
  2. varchar和nvarchar的区别
  3. 「APIO2018」选圆圈
  4. Mybatis中模糊查询的各种写法(转)
  5. Theano学习笔记(三)——图结构
  6. Android Support v4、v7、v13的区别和应用场景
  7. 谈谈JIT编译器和本机影像生成器(NGen.exe)
  8. 铁路网上购票需要完善但值得鼓励
  9. ASP.NET连接带密码Access的方法
  10. 如何在一个领域内成为顶尖人才?