我将我做的发出来供大家参考参考,可能还有的地方还没有做好,如果发现请大家说出来大家一起分享你的意见学习学习!
 
R1的配置:
R1#sh run
Building configuration...
Current configuration : 1044 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 172.16.0.1 255.255.255.0
!
interface Loopback1
 ip address 172.16.1.1 255.255.255.0
!
interface Loopback2
 ip address 172.16.2.1 255.255.255.0
!
interface Loopback3
 ip address 172.16.3.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 ip address 10.1.1.1 255.255.255.0
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 100
 router-id 1.1.1.1
 log-adjacency-changes
 area 1 stub                                           将区域1设置成末节区域。
 network 10.1.1.0 0.0.0.255 area 1
 network 172.16.0.0 0.0.255.255 area 1
!
ip classless
no ip http server
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
end
R2的配置:
R2#sh run
Building configuration...
Current configuration : 1043 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 10.1.1.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 ip address 172.17.1.1 255.255.255.0
 encapsulation frame-relay                                              封装成帧中继格式。
 ip ospf network broadcast                                              将ospf的网络类型改为广播型。
 ip ospf priority 255                                                            将R2设置成为DR
 serial restart-delay 0
 no arp frame-relay
 frame-relay map ip 172.17.1.2 203 broadcast                帧中继的映射
 frame-relay map ip 172.17.1.3 204 broadcast
 no frame-relay inverse-arp
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 100
 router-id 2.2.2.2
 log-adjacency-changes
 area 1 stub no-summary                        将区域1设置成末节区域                                          
 network 10.1.1.0 0.0.0.255 area 1
 network 172.17.1.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
end
R3的配置:
R3#sh run
Building configuration...
Current configuration : 1082 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 ip address 10.1.2.1 255.255.255.0
 serial restart-delay 0
!
interface Serial1/2
 ip address 172.17.1.2 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf priority 0                                      和R2的一样配置帧中继
 serial restart-delay 0
 no arp frame-relay
 frame-relay map ip 172.17.1.3 302 broadcast
 frame-relay map ip 172.17.1.1 302 broadcast
 no frame-relay inverse-arp
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 100
 router-id 3.3.3.3
 log-adjacency-changes
 area 4 nssa no-summary                       配置成NSSA               
 summary-address 192.168.0.0 255.255.0.0
 network 10.1.2.0 0.0.0.255 area 4
 network 172.17.1.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
end
R4的配置:
R4#sh run
Building configuration...
Current configuration : 1082 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R4
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 ip address 10.1.3.1 255.255.255.0
 serial restart-delay 0
!
interface Serial1/2
 ip address 172.17.1.3 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf priority 0                                     与上面的一样
 no arp frame-relay
 frame-relay map ip 172.17.1.2 402 broadcast
 frame-relay map ip 172.17.1.1 402 broadcast
 no frame-relay inverse-arp
!        
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 100
 router-id 4.4.4.4
 log-adjacency-changes
 area 2 virtual-link 7.7.7.7              配置虚链路,7.7.7.7是对方路由器的路由ID
 network 10.1.3.0 0.0.0.255 area 2
 network 172.17.1.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
end
R5的配置:
R5#sh run
Building configuration...
Current configuration : 1109 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R5
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 172.19.0.1 255.255.255.0
!
interface Loopback1
 ip address 172.19.1.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 10.1.2.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 ip address 192.168.255.1 255.255.255.0
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 100
 router-id 5.5.5.5
 log-adjacency-changes
 area 4 nssa no-summary                    配置NSSA网络
 redistribute rip subnets                      将RIP中的路由条目重分发到ospf中
 network 10.1.2.0 0.0.0.255 area 4
 network 172.19.0.0 0.0.0.255 area 4
 network 172.19.1.0 0.0.0.255 area 4
!
router rip
 version 2
 redistribute ospf 100 metric 2          将ospf中的路由条目重分发到RIP里
 network 192.168.255.0
 no auto-summary
!
ip classless
no ip http server
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
end
R6的配置:
R6#sh run
Building configuration...
Current configuration : 1687 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R6
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 192.168.0.1 255.255.255.0
!
interface Loopback1
 ip address 192.168.1.1 255.255.255.0
!
interface Loopback2
 ip address 192.168.2.1 255.255.255.0
!
interface Loopback3
 ip address 192.168.3.1 255.255.255.0
!
interface Loopback4
 ip address 192.168.4.1 255.255.255.0
!
interface Loopback5
 ip address 192.168.5.1 255.255.255.0
!
interface Loopback6
 ip address 192.168.6.1 255.255.255.0
!
interface Loopback7
 ip address 192.168.7.1 255.255.255.0
!
interface Loopback8
 ip address 192.168.8.1 255.255.255.0
!
interface Loopback9
 ip address 192.168.9.1 255.255.255.0
!
interface Loopback10
 ip address 192.168.10.1 255.255.255.0
!
interface Loopback11
 ip address 192.168.11.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 192.168.255.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!        
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router rip
 version 2
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.4.0
 network 192.168.5.0
 network 192.168.6.0
 network 192.168.7.0
 network 192.168.8.0
 network 192.168.9.0
 network 192.168.10.0
 network 192.168.11.0
 network 192.168.255.0
 no auto-summary
!
ip classless
no ip http server
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
end
R7的配置:
R7#sh run
Building configuration...
Current configuration : 1021 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R7
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 7.7.7.7 255.255.255.255
!
interface Loopback1
 ip address 172.18.1.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 10.1.3.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 ip address 10.1.4.1 255.255.255.0
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 100
 router-id 7.7.7.7
 log-adjacency-changes
 area 2 virtual-link 4.4.4.4                配置虚链路
 network 10.1.3.0 0.0.0.255 area 2
 network 10.1.4.0 0.0.0.255 area 3
 network 172.18.0.0 0.0.0.255 area 2
 network 172.18.1.0 0.0.0.255 area 2
!
ip classless
no ip http server
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
end
R8的配置:
R8#sh run
Building configuration...
Current configuration : 1217 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R8
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 172.20.0.1 255.255.255.0
!
interface Loopback1
 ip address 172.20.1.1 255.255.255.0
!
interface Loopback2
 ip address 172.20.2.1 255.255.255.0
!
interface Loopback3
 ip address 172.20.3.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 10.1.4.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 100
 router-id 8.8.8.8
 log-adjacency-changes
 network 10.1.4.0 0.0.0.255 area 3
 network 172.20.0.0 0.0.0.255 area 3
 network 172.20.1.0 0.0.0.255 area 3
 network 172.20.2.0 0.0.0.255 area 3
 network 172.20.3.0 0.0.0.255 area 3
!
ip classless
no ip http server
!        
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
end
FR(帧中继交换机)的配置:
FR#sh run
Building configuration...
Current configuration : 1441 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname FR
!
!
ip subnet-zero
no ip routing              关闭路由器的路由功能。
!
!
no ip domain-lookup
!
frame-relay switching             将路由器封装成帧中继交换机。
!
!
!
interface FastEthernet0/0
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 encapsulation frame-relay                       封装帧中继交换机
 no ip route-cache
 no ip mroute-cache
 serial restart-delay 0
 clock rate 64000                                         设置DCE的时钟频率。
 no arp frame-relay                                      
 no frame-relay inverse-arp
 frame-relay lmi-type cisco                        设定LMI类型为Cisco
 frame-relay intf-type dce                           定义帧中继的接口类型为DCE,即所连接的电缆类型为DCE;
 frame-relay route 203 interface Serial1/1 302               为203的DLCI形成1个虚电路。
 frame-relay route 204 interface Serial1/2 402
!
interface Serial1/1
 no ip address
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
 serial restart-delay 0
 clock rate 64000
 no arp frame-relay
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
 frame-relay intf-type dce
 frame-relay route 302 interface Serial1/0 203
!
interface Serial1/2
 no ip address
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
 serial restart-delay 0
 clock rate 64000
 no arp frame-relay
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
 frame-relay intf-type dce
 frame-relay route 402 interface Serial1/0 204
!
interface Serial1/3
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
ip classless
ip http server
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
end
以上就是配置。下面是show ip route 出来的结果:
R1#sh ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.1.1.2 to network 0.0.0.0
172.16.0.0/24 is subnetted, 4 subnets
C       172.16.0.0 is directly connected, Loopback0
C       172.16.1.0 is directly connected, Loopback1
C       172.16.2.0 is directly connected, Loopback2
C       172.16.3.0 is directly connected, Loopback3
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Serial1/1
O*IA 0.0.0.0/0 [110/65] via 10.1.1.2, 02:38:49, Serial1/1  配置了末节区域以后自动生成的一条默认路由
 
R2#sh ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Serial1/2
     172.16.0.0/32 is subnetted, 4 subnets
O       172.16.1.1 [110/65] via 10.1.1.1, 02:39:37, Serial1/0
O       172.16.0.1 [110/65] via 10.1.1.1, 02:39:37, Serial1/0
O       172.16.3.1 [110/65] via 10.1.1.1, 02:39:37, Serial1/0
O       172.16.2.1 [110/65] via 10.1.1.1, 02:39:37, Serial1/0
     172.19.0.0/32 is subnetted, 2 subnets
O IA    172.19.0.1 [110/129] via 172.17.1.2, 01:12:10, Serial1/2
O IA    172.19.1.1 [110/129] via 172.17.1.2, 01:12:10, Serial1/2
     172.18.0.0/32 is subnetted, 1 subnets
O IA    172.18.1.1 [110/129] via 172.17.1.3, 01:12:10, Serial1/2
     172.20.0.0/32 is subnetted, 4 subnets
O IA    172.20.1.1 [110/193] via 172.17.1.3, 00:56:10, Serial1/2
O IA    172.20.0.1 [110/193] via 172.17.1.3, 00:56:10, Serial1/2
O IA    172.20.3.1 [110/193] via 172.17.1.3, 00:56:10, Serial1/2
O IA    172.20.2.1 [110/193] via 172.17.1.3, 00:56:10, Serial1/2
     10.0.0.0/24 is subnetted, 4 subnets
O IA    10.1.3.0 [110/128] via 172.17.1.3, 01:12:11, Serial1/2
O IA    10.1.2.0 [110/128] via 172.17.1.2, 01:12:11, Serial1/2
C       10.1.1.0 is directly connected, Serial1/0
O IA    10.1.4.0 [110/192] via 172.17.1.3, 01:06:10, Serial1/2
O E2 192.168.0.0/16 [110/20] via 172.17.1.2, 01:12:11, Serial1/2
R3#sh ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
O N2 192.168.8.0/24 [110/20] via 10.1.2.2, 01:12:46, Serial1/1
O N2 192.168.9.0/24 [110/20] via 10.1.2.2, 01:12:46, Serial1/1
O N2 192.168.10.0/24 [110/20] via 10.1.2.2, 01:12:46, Serial1/1
     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Serial1/2
     172.16.0.0/32 is subnetted, 4 subnets
O IA    172.16.1.1 [110/129] via 172.17.1.1, 01:12:46, Serial1/2
O IA    172.16.0.1 [110/129] via 172.17.1.1, 01:12:46, Serial1/2
O IA    172.16.3.1 [110/129] via 172.17.1.1, 01:12:46, Serial1/2
O IA    172.16.2.1 [110/129] via 172.17.1.1, 01:12:46, Serial1/2
     172.19.0.0/32 is subnetted, 2 subnets
O       172.19.0.1 [110/65] via 10.1.2.2, 01:27:50, Serial1/1
O       172.19.1.1 [110/65] via 10.1.2.2, 01:27:50, Serial1/1
     172.18.0.0/32 is subnetted, 1 subnets
O IA    172.18.1.1 [110/129] via 172.17.1.3, 01:12:46, Serial1/2
     172.20.0.0/32 is subnetted, 4 subnets
O IA    172.20.1.1 [110/193] via 172.17.1.3, 00:56:46, Serial1/2
O IA    172.20.0.1 [110/193] via 172.17.1.3, 00:56:46, Serial1/2
O IA    172.20.3.1 [110/193] via 172.17.1.3, 00:56:46, Serial1/2
O IA    172.20.2.1 [110/193] via 172.17.1.3, 00:56:46, Serial1/2
O N2 192.168.11.0/24 [110/20] via 10.1.2.2, 01:12:46, Serial1/1
O N2 192.168.4.0/24 [110/20] via 10.1.2.2, 01:12:46, Serial1/1
O N2 192.168.5.0/24 [110/20] via 10.1.2.2, 01:12:46, Serial1/1
     10.0.0.0/24 is subnetted, 4 subnets
O IA    10.1.3.0 [110/128] via 172.17.1.3, 01:12:46, Serial1/2
C       10.1.2.0 is directly connected, Serial1/1
O IA    10.1.1.0 [110/128] via 172.17.1.1, 01:12:46, Serial1/2
O IA    10.1.4.0 [110/192] via 172.17.1.3, 01:06:46, Serial1/2
O N2 192.168.6.0/24 [110/20] via 10.1.2.2, 01:12:46, Serial1/1
O N2 192.168.7.0/24 [110/20] via 10.1.2.2, 01:12:46, Serial1/1
O N2 192.168.255.0/24 [110/20] via 10.1.2.2, 01:12:46, Serial1/1
O N2 192.168.1.0/24 [110/20] via 10.1.2.2, 01:12:46, Serial1/1
O N2 192.168.2.0/24 [110/20] via 10.1.2.2, 01:12:46, Serial1/1
O N2 192.168.3.0/24 [110/20] via 10.1.2.2, 01:12:46, Serial1/1
O    192.168.0.0/16 is a summary, 01:12:45, Null0
R4#sh ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
4.0.0.0/32 is subnetted, 1 subnets
C       4.4.4.4 is directly connected, Loopback100
     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Serial1/2
     172.16.0.0/32 is subnetted, 4 subnets
O IA    172.16.1.1 [110/129] via 172.17.1.1, 00:57:14, Serial1/2
O IA    172.16.0.1 [110/129] via 172.17.1.1, 00:57:14, Serial1/2
O IA    172.16.3.1 [110/129] via 172.17.1.1, 00:57:14, Serial1/2
O IA    172.16.2.1 [110/129] via 172.17.1.1, 00:57:14, Serial1/2
     172.19.0.0/32 is subnetted, 2 subnets
O IA    172.19.0.1 [110/129] via 172.17.1.2, 00:57:14, Serial1/2
O IA    172.19.1.1 [110/129] via 172.17.1.2, 00:57:14, Serial1/2
     172.18.0.0/32 is subnetted, 1 subnets
O       172.18.1.1 [110/65] via 10.1.3.2, 00:57:15, Serial1/1
     172.20.0.0/32 is subnetted, 4 subnets
O IA    172.20.1.1 [110/129] via 10.1.3.2, 00:57:09, Serial1/1
O IA    172.20.0.1 [110/129] via 10.1.3.2, 00:57:09, Serial1/1
O IA    172.20.3.1 [110/129] via 10.1.3.2, 00:57:09, Serial1/1
O IA    172.20.2.1 [110/129] via 10.1.3.2, 00:57:09, Serial1/1
     10.0.0.0/24 is subnetted, 4 subnets
C       10.1.3.0 is directly connected, Serial1/1
O IA    10.1.2.0 [110/128] via 172.17.1.2, 00:57:15, Serial1/2
O IA    10.1.1.0 [110/128] via 172.17.1.1, 00:57:15, Serial1/2
O IA    10.1.4.0 [110/128] via 10.1.3.2, 00:57:15, Serial1/1
O E2 192.168.0.0/16 [110/20] via 172.17.1.2, 00:57:15, Serial1/2
R5# sh ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.1.2.1 to network 0.0.0.0
R    192.168.8.0/24 [120/1] via 192.168.255.2, 00:00:20, Serial1/1
R    192.168.9.0/24 [120/1] via 192.168.255.2, 00:00:20, Serial1/1
R    192.168.10.0/24 [120/1] via 192.168.255.2, 00:00:20, Serial1/1
     172.19.0.0/24 is subnetted, 2 subnets
C       172.19.1.0 is directly connected, Loopback1
C       172.19.0.0 is directly connected, Loopback0
R    192.168.11.0/24 [120/1] via 192.168.255.2, 00:00:20, Serial1/1
R    192.168.4.0/24 [120/1] via 192.168.255.2, 00:00:20, Serial1/1
R    192.168.5.0/24 [120/1] via 192.168.255.2, 00:00:20, Serial1/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.2.0 is directly connected, Serial1/0
R    192.168.6.0/24 [120/1] via 192.168.255.2, 00:00:20, Serial1/1
R    192.168.7.0/24 [120/1] via 192.168.255.2, 00:00:20, Serial1/1
C    192.168.255.0/24 is directly connected, Serial1/1
R    192.168.1.0/24 [120/1] via 192.168.255.2, 00:00:21, Serial1/1
R    192.168.2.0/24 [120/1] via 192.168.255.2, 00:00:21, Serial1/1
R    192.168.3.0/24 [120/1] via 192.168.255.2, 00:00:21, Serial1/1
O*IA 0.0.0.0/0 [110/65] via 10.1.2.1, 01:28:29, Serial1/0
R6#sh ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.255.1 to network 0.0.0.0
C    192.168.8.0/24 is directly connected, Loopback8
C    192.168.9.0/24 is directly connected, Loopback9
C    192.168.10.0/24 is directly connected, Loopback10
     172.19.0.0/24 is subnetted, 2 subnets
R       172.19.1.0 [120/2] via 192.168.255.1, 00:00:21, Serial1/0
R       172.19.0.0 [120/2] via 192.168.255.1, 00:00:21, Serial1/0
C    192.168.11.0/24 is directly connected, Loopback11
C    192.168.4.0/24 is directly connected, Loopback4
C    192.168.5.0/24 is directly connected, Loopback5
     10.0.0.0/24 is subnetted, 1 subnets
R       10.1.2.0 [120/2] via 192.168.255.1, 00:00:21, Serial1/0
C    192.168.6.0/24 is directly connected, Loopback6
C    192.168.7.0/24 is directly connected, Loopback7
C    192.168.255.0/24 is directly connected, Serial1/0
C    192.168.0.0/24 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, Loopback1
C    192.168.2.0/24 is directly connected, Loopback2
C    192.168.3.0/24 is directly connected, Loopback3
R*   0.0.0.0/0 [120/2] via 192.168.255.1, 00:00:21, Serial1/0
R7#sh ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.17.0.0/24 is subnetted, 1 subnets
O       172.17.1.0 [110/128] via 10.1.3.1, 01:07:44, Serial1/0
     172.16.0.0/32 is subnetted, 4 subnets
O IA    172.16.1.1 [110/193] via 10.1.3.1, 00:57:44, Serial1/0
O IA    172.16.0.1 [110/193] via 10.1.3.1, 00:57:44, Serial1/0
O IA    172.16.3.1 [110/193] via 10.1.3.1, 00:57:44, Serial1/0
O IA    172.16.2.1 [110/193] via 10.1.3.1, 00:57:44, Serial1/0
     172.19.0.0/32 is subnetted, 2 subnets
O IA    172.19.0.1 [110/193] via 10.1.3.1, 00:57:44, Serial1/0
O IA    172.19.1.1 [110/193] via 10.1.3.1, 00:57:44, Serial1/0
     172.18.0.0/24 is subnetted, 1 subnets
C       172.18.1.0 is directly connected, Loopback1
     172.20.0.0/32 is subnetted, 4 subnets
O       172.20.1.1 [110/65] via 10.1.4.2, 00:57:45, Serial1/1
O       172.20.0.1 [110/65] via 10.1.4.2, 00:57:45, Serial1/1
O       172.20.3.1 [110/65] via 10.1.4.2, 00:57:45, Serial1/1
O       172.20.2.1 [110/65] via 10.1.4.2, 00:57:45, Serial1/1
     7.0.0.0/32 is subnetted, 1 subnets
C       7.7.7.7 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 4 subnets
C       10.1.3.0 is directly connected, Serial1/0
O IA    10.1.2.0 [110/192] via 10.1.3.1, 00:57:45, Serial1/0
O IA    10.1.1.0 [110/192] via 10.1.3.1, 00:57:45, Serial1/0
C       10.1.4.0 is directly connected, Serial1/1
O E2 192.168.0.0/16 [110/20] via 10.1.3.1, 00:57:45, Serial1/0
R8#sh ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.17.0.0/24 is subnetted, 1 subnets
O IA    172.17.1.0 [110/192] via 10.1.4.1, 00:58:07, Serial1/0
     172.16.0.0/32 is subnetted, 4 subnets
O IA    172.16.1.1 [110/257] via 10.1.4.1, 00:58:07, Serial1/0
O IA    172.16.0.1 [110/257] via 10.1.4.1, 00:58:07, Serial1/0
O IA    172.16.3.1 [110/257] via 10.1.4.1, 00:58:07, Serial1/0
O IA    172.16.2.1 [110/257] via 10.1.4.1, 00:58:07, Serial1/0
     172.19.0.0/32 is subnetted, 2 subnets
O IA    172.19.0.1 [110/257] via 10.1.4.1, 00:58:07, Serial1/0
O IA    172.19.1.1 [110/257] via 10.1.4.1, 00:58:07, Serial1/0
     172.18.0.0/32 is subnetted, 1 subnets
O IA    172.18.1.1 [110/65] via 10.1.4.1, 00:58:07, Serial1/0
     172.20.0.0/24 is subnetted, 4 subnets
C       172.20.0.0 is directly connected, Loopback0
C       172.20.1.0 is directly connected, Loopback1
C       172.20.2.0 is directly connected, Loopback2
C       172.20.3.0 is directly connected, Loopback3
     10.0.0.0/24 is subnetted, 4 subnets
O IA    10.1.3.0 [110/128] via 10.1.4.1, 00:58:08, Serial1/0
O IA    10.1.2.0 [110/256] via 10.1.4.1, 00:58:08, Serial1/0
O IA    10.1.1.0 [110/256] via 10.1.4.1, 00:58:08, Serial1/0
C       10.1.4.0 is directly connected, Serial1/0
O E2 192.168.0.0/16 [110/20] via 10.1.4.1, 00:58:08, Serial1/0
以上就是这个实验的全部配置,我觉得路由条目还没有很好的精减!有时间再慢慢的来做一下!

转载于:https://blog.51cto.com/ltyluck/185570

工大瑞普 NP-OSPF综合实验相关推荐

  1. 关于工大瑞普Dynamips模拟器

    关于工大瑞普Dynamips模拟器 关于工大瑞普Dynamips模拟器   关键是这个模拟器是真强大!!! 很多朋友不知道在哪里下载,现在偶告诉大家   Dynamips-0.2.6-RC5 for ...

  2. 个人自学ccna的资料+工大瑞普模拟器

    资料都是网上的,,文档的实验都基本上做完了,,帧中继实际企业中很少用到就抛弃之,,EIGRP实验没做..实验做得断断续续,发到博客自勉,,也希望能帮到其他学友..... 实验文档:在附件(命令有整理修 ...

  3. 华为ensp ospf综合实验

    实验拓扑 ​拓扑下载 华为OSPF综合实验 图 1-1 注:如无特别说明,描述中的 R1 或 SW1 对应拓扑中设备名称末尾数字为 1 的设备,R2 或 SW2 对应拓扑中设备名称末尾数字为 2 的设 ...

  4. HCIP(华为高级网络安全工程师)(实验五)(OSPF综合实验)

    目录 实验要求 实验思路 实验内容及步骤 1.各区域IP地址的划分 2.对AERA0区域的设备进行IP地址及环回地址和缺省路由的配置 4.配置AREA1.AREA2.AREA3.AREA4的IP地址及 ...

  5. IP(OSPF综合实验)

    一.实验 1.R4为ISP,其上只能配置IP地址:R4与其他所有直连设备间使用公有IP 2.R3-R5/6/7为MGRE环境,R3为中心站点 3.整个OSPF环境IP地址自定义 4.所有设备均可访问R ...

  6. 华为路由器OSPF综合实验

    目录 [实验题目] [实验思路] [实验记录] 一.配置IP地址 二.配置缺省路由使公网通畅 三.搭建MGRE环境 四.配置OSPF和RIP 五.OSPF路由汇总 六.为area1.area2.are ...

  7. ospf综合实验配置

    文章目录 一.题目要求 二.IP地址分配 三.IP地址及其相关配置 四.搭建MGRE环境 五.启动OSPF协议和RIP协议 六.减少LSA的更新量(进行汇总和做特殊区域) 七.加快收敛(可以修改hel ...

  8. 全网最详细的OSPF综合实验

    实验需求 area 0所有的路由器与帧中继交换机相连,实现全互联 如图所示运行OSPF ARBA 3学不到其它区域的路由通过虚链路解诀 AREA 0的网络需求 单播建立邻居,不用选DR和BDR,请选择 ...

  9. OSPF综合实验报告

    一.实验要求 1.R4为ISP,其上只能配置IP地址:R4与其他所有直连设备间使用公有IP 2.R3-R5/6/7为MGRE环境,R3为中心站点 3.整个OSPF环境IP地址为172.16.0.0/1 ...

  10. MGRE与OSPF综合实验

    要求: 1,R6为ISP只能配置IP地址,R1-R5的环回为私有网段 2,R1/4/5为全连的GRE结构; R1/2/3为星型的拓扑结构,R1为中心站点 3,所有私有网段可以互相通讯,私有网段使用OS ...

最新文章

  1. Create a restful app with AngularJS/Grails(4)
  2. “外星人”字符串生成算法研究
  3. FastReport分页和空行填充
  4. 意向保护:你的 A/B 测试数据期骗你了吗?
  5. MVC、MVP、MVVM分别是什么?有什么区别?
  6. T-sql检测文件夹是否存在
  7. jzoj4671-World Tour【图论,bfs】
  8. mysql性能调优之配置优化_MySQL优化必须调整的10项配置
  9. python如何抓取微博定时热搜
  10. 快用苹果助手安装失败_穿越火线辅助腾讯手游助手常见问题汇总
  11. 谈谈网络通信中的 ACK、NACK 和 REX
  12. Null和Underfined
  13. 梧桐树金玉满堂增额终身寿险将下架,百度开屏也懂我的资产荒焦虑
  14. 判断windows系统类型和IE浏览器版本
  15. Chrome浏览器首次打开后未响应较长时间
  16. 【SSL 1458】zzzyyds(DP)
  17. 别让所谓的“富人思维”毁了你
  18. Linux云计算架构师:SSHD服务搭建管理和防止暴力破解
  19. 参考文献起止页码怎么写_怎么看论文的起止页码
  20. 小飞侠的游园方案答案

热门文章

  1. php vue插件 hplus-ui初学
  2. 谷歌归期未定,但敏感词库已经建起来了
  3. Python:利用python代码编程实现将视频的avi格式转换为MP4格式
  4. 蓝桥杯C++AB算法辅导
  5. 软件工程经济学知识点总结
  6. stm32f4串口烧录[flymcu]
  7. java多分支流程图_Java 流程控制 之 分支结构(条件判断)
  8. 网抑云音乐.ncm加密格式转换mp3
  9. 用友u8cloud使用教程_用友财务软件还不会操作?看完这些操作,工作得心应手...
  10. 【人脸识别】基于模板匹配算法实现人脸识别matlab源码