期末的专业实训,在cisco6.0下配置一个简单的局域网。主要用到了下面几个技术:dhcp中继、vlan的划分、链路聚合、静态nat、ospf协议、访问控制列表。先看一下总的拓扑图,在分步实现功能。

  • 2、全网配置OSPF协议。
  • 3、总部和分部分别配置NAT。
  • 4、公司总部LSW1、LSW2之间配置链路聚合。
  • 5、公司分部的Ser服务器负责vlan10、vlan20的ip地址分配。在安全上要求vlan20不允许访问Ser上的www服务

0x01:公司分部(共四个网段10.28.4.0 10.28.5.0 10.28.6.0 10.28.7.0)

配置ser的ip,如下:

配置dhcp:

在三层交换机上配置dhcp中继:

Switch#vlan database
% Warning: It is recommended to configure VLAN from config mode,as VLAN database mode is being deprecated. Please consult userdocumentation for configuring VTP/VLAN in config mode.Switch(vlan)#vlan 100        //创建vlan
VLAN 100 added:Name: VLAN0100
Switch(vlan)#vlan 10
VLAN 10 added:Name: VLAN0010
Switch(vlan)#vlan 20
VLAN 20 added:Name: VLAN0020
Switch(vlan)#exit
APPLY completed.
Exiting....
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#int vlan 10
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan10, changed state to up      //分别为vlan绑定网段的掩码
ip address 10.28.6.254 255.255.255.0
Switch(config-if)#ip help
Switch(config-if)#ip helper-address 10.28.5.1            //为vlan配置中继代理
Switch(config-if)#int vlan 20
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan20, changed state to up
ip address 10.28.7.254 255.255.255.0
Switch(config-if)#ip help
Switch(config-if)#ip helper-address 10.28.5.1
Switch(config-if)#int vlan 100
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan100, changed state to up
ip address 10.28.5.254 255.255.255.0
Switch(config-if)#int f0/1
Switch(config-if)#swiyc
Switch(config-if)#switc
Switch(config-if)#switchport access vlan 10
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to upSwitch(config-if)#int f0/2
Switch(config-if)#switchport access vlan 20
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to upSwitch(config-if)#int f0/24
Switch(config-if)#switchport access vlan 100
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to upSwitch(config-if)#exit

把vlan10和vlan20的IP获取设置为dhcp模式,查看分配IP。

在三层交换机上配置ospf,为了能够让vlan10、vlan20与ser互通

Switch(config)#ip routing
Switch(config)#router ospf 1
Switch(config-router)#network 10.28.4.0 0.0.0.255 area 0
Switch(config-router)#network 10.28.5.0 0.0.0.255 area 0
Switch(config-router)#network 10.28.6.0 0.0.0.255 area 0
Switch(config-router)#network 10.28.7.0 0.0.0.255 area 0
Switch(config-router)#exit
Switch(config)#exit

查看连通性

访问ser的www服务

在三成交换机上配置扩展ACL,阻止vlan20访问ser的www服务。

Switch(config)#access
Switch(config)#access-list 101 deny tcp 10.28.7.0 0.0.0.255 10.28.5.0 0.0.0.255  eq www  //tcp后面依次是要被阻止的网段、阻止网段的反向掩码、ser的网段。ser的反向掩码
Switch(config)#ac
Switch(config)#access-list 101 permit ip any any
Switch(config)#int vlan 100
Switch(config-if)#ip accrss
Switch(config-if)#ip acce
Switch(config-if)#ip access-group 101 out
Switch(config-if)#

用vlan20再次访问ser的www服务,访问失败

0x02:公司总部 (共四个网段 10.28.10.0 10.28.20.0 10.28.30.0 10.28.40.0)

首先为pc2、pc3手动设置IP

然后依次在左边交换机和右边交换机生配置链路聚合

左边交换机配置:

Switch(config)#host S1
S1(config)#vlan 10
S1(config-vlan)#exit
S1(config)#vlan 20
S1(config-vlan)#exit
S1(config)#int range f0/10 - 11
S1(config-if-range)#switchport trunk encapsulation dot1q
S1(config-if-range)#switchport mode trunk
S1(config-if-range)#duplex full
S1(config-if-range)#speed 100
S1(config-if-range)#channel-group 1 mode active
S1(config-if-range)#exit
S1(config)#int vlan 10
S1(config-if)#ip address 10.28.10.254 255.255.255.0
S1(config-if)#int vlan 20
S1(config-if)#ip address 10.28.20.254 255.255.255.0
S1(config-if)#exit
S1(config)#ip routing
S1(config)#int f0/2
S1(config-if)#switch
S1(config-if)#switchport access vlan 10
S1(config-if)#

右边交换机配置:

Switch(config)#host S2
S2(config)#vlan 10
S2(config-vlan)#exit
S2(config)#vlan 20
S2(config-vlan)#exit
S2(config)#int range f0/10 - 11
S2(config-if-range)#switchport trunk encapsulation dot1q
S2(config-if-range)#switchport mode trunk
S2(config-if-range)#duplex full
S2(config-if-range)#speed 100
S2(config-if-range)#channel-group 1 mode passive
S2(config-if-range)#exit
S2(config)#int vlan 10
S2(config-if)#ip address 10.28.10.254 255.255.255.0
S2(config-if)#exit
S2(config)#int vlan 20
S2(config-if)#ip address 10.28.20.254 255.255.255.0
S2(config-if)#exit
S2(config)#ip routing
S2(config)#int f0/2
S2(config-if)#switc
S2(config-if)#switchport access vlan 20
S2(config-if)#

检测连通性,pc2 ping pc3:

给上面路由器的f0/1、f1/0接口和两个交换机的f0/1接口配置IP。

Router(config)#int f0/1
Router(config-if)#ip address 10.28.30.1 255.255.255.0
Router(config-if)#no shuRouter(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to upRouter(config-if)#int f1/0
Router(config-if)#ip address 10.28.40.1 255.255.255.0
Router(config-if)#no shuRouter(config-if)#
%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to upRouter(config-if)#

S1(config)#int f0/1
S1(config-if)#no switch
S1(config-if)#no switchport
S1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to upS1(config-if)#ip address 10.28.30.2 255.255.255.0
S1(config-if)#

S2(config)#int f0/1
S2(config-if)#no switch
S2(config-if)#no switchport
S2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to upS2(config-if)#ip address 10.28.40.2 255.255.255.0

在两个交换机上配置ospf

S1(config)#router ospf 1
S1(config-router)#network 10.28.10.0 0.0.0.255 area 0
S1(config-router)#network 10.28.20.0 0.0.0.255 area 0
S1(config-router)#network 10.28.30.0 0.0.0.255 area 0
S1(config-router)#network 10.28.40.0 0.0.0.255 area 0
S1(config-router)#exit
S1(config)#exit

 0x03:连接总部分部(两个接口使用100.100.100.1 和 100.100.100.2)

给两个路由器的接口配置IP和ospf

Router(config)#int f0/0
Router(config-if)#ip address 100.100.100.1 255.255.255.0
Router(config-if)#no shu

Router(config)#int f0/0
Router(config-if)#ip address 100.100.100.2 255.255.255.0
Router(config-if)#no shu

Router(config-router)#router ospf 1
Router(config-router)#network 10.28.30.0 0.0.0.255 area 0
Router(config-router)#network 10.28.40.0 0.0.0.255 area 0
Router(config-router)#network 100.100.100.0 0.0.0.255 area 0
Router(config-router)#exit
Router(config)#exit

Router(config)#router ospf 1
Router(config-router)#network 10.28.4.0 0.0.0.255 area 0
Router(config-router)#network 100.100.100.0 0.0.0.255 area 0
Router(config-router)#exit

然后用左边的pc去ping一下右边的服务器,检查连通性。

0x04:在两个路由器上配置nat。

左边路由器配置如下:

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#
Router(config)#int f0/1
Router(config-if)#ip nat inside
Router(config-if)#int f1/0
Router(config-if)#ip nat inside
Router(config-if)#int f0/0
Router(config-if)#ip nat outside
Router(config-if)#exit
Router(config)#ip nat inside source static 10.28.10.1 100.100.100.3
Router(config)#ip nat inside source static 10.28.20.1 100.100.100.4
Router(config)#end
Router#show ip nat trans
Pro  Inside global     Inside local       Outside local      Outside global
---  100.100.100.3     10.28.10.1         ---                ---
---  100.100.100.4     10.28.20.1         ---                ---

右边路由器配置如下:

Router(config)#int f0/1
Router(config-if)#ip nat inside
Router(config-if)#int f0/0
Router(config-if)#ip nat outside
Router(config-if)#exit
Router(config)#ip nat inside source static 10.28.6.1 100.100.100.5          //static后面跟数据报来源(右边两台pc)的IP和公网的IP(100.100.100.x)
Router(config)#ip nat inside source static 10.28.7.1 100.100.100.6
Router(config)#end
Router#show ip nat trans
Pro  Inside global     Inside local       Outside local      Outside global
---  100.100.100.5     10.28.6.1          ---                ---
---  100.100.100.6     10.28.7.1          ---                ---Router#

再次ping右边的服务器

最后在路由器上看一下nat表,检车地址是否转换成功。

(ps:本人太菜,若有错误的地方欢迎大佬随时责骂。。。。xixixii)

转载于:https://www.cnblogs.com/liangxiyang/p/10999676.html

Cisco packet tracer6.0下的网络工程实训相关推荐

  1. 网络工程实训综合测验(eNSP)

    一.主题 :在eNSP中 设计一个局域网. 二.物理环境要求: 1.按不同网络功能区划分,包括以下内容: a.教学楼区(共5栋,每栋有100个信息点): b.图书馆(独栋共5层,每层楼有200个信息点 ...

  2. 网络工程实训eNSP学习记录

    参考视频b站众元助教元元-电源老师 目录 1.同网段主机与网关通信 2.基本VLAN划分 3.跨交换机VLAN划分 4.交换机间的链路聚合 5.单臂路由 8.动态路由协议 9.DHCP动态主机配置协 ...

  3. Packet Tracer6.0静态路由,RIP,OSPF路由方案配置(1)

    BackGround: 建立如下网络拓扑,并进行IP编址. 1 以静态路由方案,配置连通网络   (1) 配置各设备IP地址,掩码,A,B网关 (2)配置R1,R2,R3静态路由 2 以动态RIP路由 ...

  4. Cisco Packet Tracer 网络系统工程实训大作业【附网络拓扑图】

    文章目录 前言 网络拓扑图资源 项目基本要求 项目一 项目二 项目三 实验原理 静态路由基本原理 VLAN基本原理 OSPF的基本原理 项目的实现 项目一的设计与实现 网络拓扑图 接口信息 配置流程 ...

  5. 网络营销实训一:什么是网络营销?

      根据以上实训内容,写一份实验报告(需要是自己的体会,各人独立完成,不能照搬网上内容,也不能照搬他人,若有,实验分数记为0分),报告内容如下:   做完实训内容一后,你对以下内容有何体会? 什么是网 ...

  6. 数字化工业4.0柔性智能制造生产线实训系统

    数字化工业4.0柔性智能制造生产线实训系统 一.项目建设介绍 (一)项目建设目标 2.项目总体规划尺寸图 3.系统平面图 (三)项目建设特色 以工程教学为背景.以建设大系统为终极目标,提供具有高集成度 ...

  7. 南大科院大数据Hadoop工程实训

    科学技术学院 SCIENCE & TECHNOLOGY COLLEGE OF NANCHANG UNIVERSITY  <工 程 训 练>报 告    REPORT ON ENGI ...

  8. 【光电工程实训】红外测温枪 红外辐射原理 测量影响因素探究标定

    实验报告 实验名称:红外测温枪实验 课程名称:光电工程实训 实验一 红外测温枪装调实践训练 一. 实验目的 1.学习红外测温的原理,了解红外光谱 2. 熟悉了解红外测温枪的组成以及工作原理,能对其进行 ...

  9. 【光电工程实训】物理光学 干涉及衍射实验 偏振现象 波的衍射理论 光的偏振 方晶石

    实验报告二 实验名称:物理光学实验 课程名称:光电工程实训 一.实验题目和实验目的总览 实验题目: 1)干涉及衍射实验现象观察实验 2偏振现象观察实验(偏振与双折射) 实验目的: 1观察单缝衍射现象, ...

最新文章

  1. centos 6.5下KVM环境搭建
  2. 计网 - 流和缓冲区:缓冲区的 flip 是怎么回事?
  3. 抛物线交点式公式_2020“九校联考”中点公式解决平四存在性问题
  4. com.alibaba.fastjson.JSONObject之对象与JSON转换方法
  5. 使用cmake安装mysql5.5.13
  6. Oracle数据库中表格的级联删除问题
  7. STM32工作笔记0010---认识GPIO IO端口
  8. 使用电脑时,眼睛离电脑多远才合适
  9. 从ext2文件系统上读出超级块
  10. 行军导航过程中导向箭头
  11. Qt高级编程完整源码
  12. 《计算机网络 第七版》读后感
  13. 我的世界高亮显示服务器,waila(我的世界高亮显示没了)
  14. 《Linux程序设计》第4版 核心笔记
  15. excel退出打印预览快捷键?
  16. Excel 批量合并相同内容单元格方法
  17. 国民岳父的“屁民理论”
  18. 18.8.17 考试总结
  19. 初级算法题->有效的数独--弄清哈希表的本质
  20. 当别人加快脚步的时候,你更应该慢下来

热门文章

  1. 找某個ColumnName在那些Tables
  2. 3Delight NSI: A Streamable Render API
  3. 服务器系统的王者——Linux 系统
  4. 实现数据库的增删改查
  5. struts.xml文件的配置说明
  6. 【一天一个shell命令】好管家-磁盘-du
  7. 浅谈构建 apache 2 虚拟主机[zt]
  8. md3600i存储服务器连接 iscsi+multipath配置
  9. Xposed是如何为所欲为的?
  10. android fitsSystemWindows的使用