A registration card number of PAT consists of 4 parts:

the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
the 2nd – 4th digits are the test site number, ranged from 101 to 999;
the 5th – 10th digits give the test date, in the form of yymmdd;
finally the 11th – 13th digits are the testee’s number, ranged from 000 to 999.
Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10
​4) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner’s score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt’s, or in increasing order of site numbers if there is a tie of Nt.
If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

题目大意:给出一组学生的准考证号和成绩,准考证号包含了等级(乙甲顶),考场号,日期,和个人编号信息,并有三种查询方式
查询一:给出考试等级,找出该等级的考生,按照成绩降序,准考证升序排序
查询二:给出考场号,统计该考场的考生数量和总得分
查询三:给出考试日期,查询改日期下所有考场的考试人数,按照人数降序,考场号升序排序

分析:先把所有考生的准考证和分数记录下来~
1.按照等级查询,枚举选取匹配的学生,然后排序即可
2.按照考场查询,枚举选取匹配的学生,然后计数、求和
3.按日期查询每个考场人数,用unordered_map存储,最后排序汇总~
注意:1.第三个用map存储会超时,用unordered_map就不会超时啦~
2.排序传参建议用引用传参,这样更快,虽然有时候不用引用传参也能通过,但还是尽量用,养成好习惯~

#include <iostream>
#include <vector>
#include <unordered_map>
#include <algorithm>
using namespace std;
struct node {string t;int value;
};
bool cmp(const node &a, const node &b) {return a.value != b.value ? a.value > b.value : a.t < b.t;
}
int main() {int n, k, num;string s;cin >> n >> k;vector<node> v(n);for (int i = 0; i < n; i++)cin >> v[i].t >> v[i].value;for (int i = 1; i <= k; i++) {cin >> num >> s;printf("Case %d: %d %s\n", i, num, s.c_str());vector<node> ans;int cnt = 0, sum = 0;if (num == 1) {for (int j = 0; j < n; j++)if (v[j].t[0] == s[0]) ans.push_back(v[j]);} else if (num == 2) {for (int j = 0; j < n; j++) {if (v[j].t.substr(1, 3) == s) {cnt++;sum += v[j].value;}}if (cnt != 0) printf("%d %d\n", cnt, sum);} else if (num == 3) {unordered_map<string, int> m;for (int j = 0; j < n; j++)if (v[j].t.substr(4, 6) == s) m[v[j].t.substr(1, 3)]++;for (auto it : m) ans.push_back({it.first, it.second});}sort(ans.begin(), ans.end(),cmp);for (int j = 0; j < ans.size(); j++)printf("%s %d\n", ans[j].t.c_str(), ans[j].value);if (((num == 1 || num == 3) && ans.size() == 0) || (num == 2 && cnt == 0)) printf("NA\n");}return 0;
}

PAT 1153 Decode Registration Card of PAT (25 分)- 甲级相关推荐

  1. 1153 Decode Registration Card of PAT (25分)

    1153 Decode Registration Card of PAT (25分) 题意: 给出一组学生的准考证号和成绩 准考证号组成为:考试等级(TAB),考场号(从101到999),考试日期(y ...

  2. PAT甲级1153 Decode Registration Card of PAT :[C++题解]结构体、哈希表、排序、类似数据库查询题、好题

    文章目录 题目分析 题目来源 题目分析 来源:acwing 分析: 本题是三种不同的询问,难道要写三个结构体?想了想,就写了一个结构体,参赛人结构体,内容包括考号id和成绩grade,然后开结构体数组 ...

  3. PAT A1153 Decode Registration Card of PAT ——凭谁问,廉颇老矣,尚能饭否

    PAT A1153 Decode Registration Card of PAT 今天选的题目真是*&^%$#*,不但不值钱,搞起来还相当麻烦 思路就是输入的过程中根据查询条件映射和排序好所 ...

  4. PAT(甲级)2018年冬季考试 7-2 Decode Registration Card of PAT

    目录 体会 代码(非满分) 改进 AC代码 体会 这题主要是考察对STL中string,map,vector的应用以及自定义sort()应用. 类型1和2的处理很容易. 类型3要求对于指定date,按 ...

  5. PAT乙级 1005 继续(3n+1)猜想 (25分)

    1005 继续(3n+1)猜想 (25分) 卡拉兹(Callatz)猜想已经在1001中给出了描述.在这个题目里,情况稍微有些复杂. 当我们验证卡拉兹猜想的时候,为了避免重复计算,可以记录下递推过程中 ...

  6. 【PAT甲】1007 Maximum Subsequence Sum (25分),求最大字段和及区间

    problem 1007 Maximum Subsequence Sum (25分) Given a sequence of K integers { N ​1 ​​ , N ​2 ​​ , -, N ...

  7. 【2020模拟考试T5】【PAT乙】1035 插入与归并 (25分) 两种排序的sort写法

    problem 1035 插入与归并 (25分) 根据维基百科的定义: 插入排序是迭代算法,逐一获得输入数据,逐步产生有序的输出序列.每步迭代中,算法从输入序列中取出一元素,将之插入有序序列中正确的位 ...

  8. 【PAT乙】1080 MOOC期终成绩 (25分)

    problem 1080 MOOC期终成绩 (25分) 对于在中国大学MOOC(http://www.icourse163.org/ )学习"数据结构"课程的学生,想要获得一张合格 ...

  9. 【PAT (Basic Level) 】1030 完美数列 (25 分)

    给定一个正整数数列,和正整数 p,设这个数列中的最大值是 M,最小值是 m,如果 M≤mp,则称这个数列是完美数列. 现在给定参数 p 和一些正整数,请你从中选择尽可能多的数构成一个完美数列. [输入 ...

最新文章

  1. import export php,import与export在node.js中的使用方法
  2. python统计httpd 进程的内存占用百分比
  3. ACL 2019 | 面向远程监督关系抽取的模式诊断技术
  4. 动态密码卡TOTP算法
  5. 376 Wiggle Subsequence 贪心解法以及证明
  6. java蓝桥杯算法训练 求1000以内的完数(题解)
  7. matplotlib xticks yticks
  8. 洛谷P2709 小B的询问
  9. linux rm -rf 根目录,在linux 根目录rm * -rf以后怎么办?
  10. 题目1555:重复子串
  11. Qt的http下载的Demo
  12. 普通话测试-短文60篇文章,附带拼音(41-50篇)
  13. 全国各省会城市经纬度(包含港澳台)
  14. 论文中常见的argmin,argmax是什么意思?
  15. 威廉玛丽大学计算机本科专业,威廉玛丽学院本科专业有哪些?
  16. 谷歌浏览器点击网页任何一段文字都会出现光标问题解决
  17. 【javaScript案例】之搜索的数据显示
  18. Wifi-direct 相关记录
  19. 【i.MX6ULL】驱动开发3——GPIO寄存器配置原理
  20. elevation格式_Google Elevation的工作方式以及如何创建简单的C#应用​​程序?

热门文章

  1. linux wait函数头文件_第五十八章、linux中的3种正常结束进程的方式你都了解么...
  2. 面向 Android 软件开发套件(SDK)的 x86 Android* 系统映像许可协议
  3. oracle中distinct的正确应用
  4. android4.0自定义锁屏总结【android锁屏研究一】
  5. 如何获取InnoDB树的高度
  6. 【No.1】基于Cookie的单点登录(SSO)
  7. postgresql 用户安全配置
  8. ZOJ 3817Chinese Knot(The 2014 ACM-ICPC Asia Mudanjiang Regional First Round)
  9. EF Code First 学习笔记:约定配置
  10. SonicWall:速度修复这些严重的 SMA 100 漏洞