实验指南
 
BGP 路由汇聚
1,summary-only

Night
conf t
int s2/0
ip ad 10.1.1.1 255.255.255.0
encap f
no arp f
no frame inver
frame map ip 10.1.1.2 102 b
no shut
router bgp 1
no au
no sy
nei 10.1.1.2 remote 1
end
 
 
Day
conf t
host Day
int l 0
ip ad 156.202.148.1 255.255.255.192
int l 1
ip ad 156.202 148.65 255.255.255.192
int l 2
ip ad 156.202.148.129 255.255.255.192
int l 3
ip ad 156.202.148.193 255.255.255.192
int s2/0
ip ad 10.1.1.2 255.255.255.0
encap f
no arp f
no frame inver
frame map ip 10.1.1.1 201 b
no shut
router bgp 1
no au
no sy
nei 10.1.1.1 remote 1
net 156.202.148.0 mask 255.255.255.192
net 156.202.148.64 mask 255.255.255.192
net 156.202.148.128 mask 255.255.255.192
net 156.202.148.192 mask 255.255.255.192
end

这时Night上的BGP表
R1#sh ip bgp
BGP table version is 5, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*>i156.202.148.0/26 10.1.1.2                 0    100      0 i
*>i156.202.148.64/26
                    10.1.1.2                 0    100      0 i
*>i156.202.148.128/26
                    10.1.1.2                 0    100      0 i
*>i156.202.148.192/26
                    10.1.1.2                 0    100      0 i
 
在Day上做路由汇聚
Day(config-router)#aggregate-address 156.202.148.0 255.255.255.0
 
这时Night上BGP表状态
R1#sh ip bgp
BGP table version is 6, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*>i156.202.148.0/26 10.1.1.2                 0    100      0 i
*>i156.202.148.0/24 10.1.1.2                 0    100      0 i
*>i156.202.148.64/26
                    10.1.1.2                 0    100      0 i
*>i156.202.148.128/26
                    10.1.1.2                 0    100      0 i
*>i156.202.148.192/26
                    10.1.1.2                 0    100      0 i
 
会发现多出一条汇聚的路由条目,当我们想路由器Day只发布这条汇聚条目的时候
Day(config-router)#aggregate-address 156.202.148.0 255.255.255.0 summary-only
 
Night上BGP表变为
R1#sh ip bgp
BGP table version is 11, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*>i156.202.148.0/24 10.1.1.2                 0    100      0 i
 
Day的BGP表状态
R2(config-router)#do sh ip bgp
BGP table version is 11, local router ID is 156.202.148.193
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
s> 156.202.148.0/26 0.0.0.0                  0         32768 i
*> 156.202.148.0/24 0.0.0.0                       100  32768 i
s> 156.202.148.64/26
                    0.0.0.0                  0         32768 i
s> 156.202.148.128/26
                    0.0.0.0                  0         32768 i
s> 156.202.148.192/26
                    0.0.0.0                  0         32768 i
会发现除了156.202.148.0/24以外,其余的路由条目被抑制
 
 
2,AS-SET
Night
conf t
host Night
int s2/0
ip ad 10.1.1.2 255.255.255.0
encap f
no arp f
no frame inver
frame map ip 10.1.1.1 102 b
no shut
router bgp 9
no au
no sy
nei 10.1.1.1 remote 8
end

Day
conf t
host Day
int s2/0
ip ad 10.1.1.1 255.255.255.0
encap f
no arp f
no frame inver
 frame map ip 10.1.1.2 201 b
no shut
int f 0/0
ip ad 192.168.1.1 255.255.255.0
no shut
router bgp 8
no au
no sy
nei 10.1.1.2 remote 9
nei 192.168.1.2 remote 141
nei 192.168.1.3 remote 142
nei 192.168.1.4 remote 143
end

RouterA
conf t
host RouterA
int l 0
ip ad 156.202.148.1 255.255.255.192
int f 0/0
ip ad 192.168.1.2 255.255.255.0
no shut
router bgp 141
no au
no sy
nei 192.168.1.1 remote 8
net 156.202.148.0 mask 255.255.255.192
end

RouterB
conf t
host RouterB
int l 0
ip ad 156.202.148.65 255.255.255.192
int f 0/0
ip ad 192.168.1.3 255.255.255.0
no shut
router bgp 142
no au
no sy
nei 192.168.1.1 remote 8
net 156.202.148.64 mask 255.255.255.192
end

RouterC
conf t
host RouterC
int l 0
ip ad 156.202.148.129 255.255.255.192
int l 1
ip ad 156.202.148.193 255.255.255.192
int f 0/0
ip ad 192.168.1.4 255.255.255.0
no shut
router bgp 143
no au
no sy
nei 192.168.1.1 remote 8
net 156.202.148.128 mask 255.255.255.192
net 156.202.148.192 mask 255.255.255.192
end
 
在Day上做路由汇聚
Day(config-router)#aggregate-address 156.202.148.0 255.255.255.0 summary-only
这时Night上BGP表状态
Night#sh ip bgp
BGP table version is 10, local router ID is 10.1.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 156.202.148.0/24 10.1.1.1                 0             0 8 i
会发现156.202.148.0/24的Path为8,路由器只认为这个汇聚条目是从AS8发送过来的,把AS141 142 143的路径忽略了,这样对路径检查和排错不利,若想是BGP表中显示具体的路径
Day(config-router)#aggregate-address 156.202.148.0 255.255.255.0 summary-only as-set
这时Night上BGP表的状态
Night#sh ip bgp
BGP table version is 11, local router ID is 10.1.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 156.202.148.0/24 10.1.1.1                 0             0 8 {141,142,143} i
这样就可以体现出路由条目的具体路径了。
 
 
 
3,suppress-map
Rainier
conf t
host Rainier
int l 0
ip ad 194.69.12.1 255.255.255.0
int l 1
ip ad 194.69.13.1 255.255.255.0
int l 2
ip ad 194.69.14.1 255.255.255.0
int l 3
ip ad 194.69.15.1 255.255.255.0
int s2/0
ip ad 85.122.8.6 255.255.255.248
encap f
no arp f
no frame inver
frame map ip 85.122.8.5 102 b
no shut
int s2/1
ip ad 85.122.8.10 255.255.255.248
encap f
no arp f
no frame inver
frame map ip 85.122.8.9 113 b
no shut
router bgp 852
no au
no sy
nei 85.122.8.5 remote 7518
nei 85.122.8.9 remote 7518
net 194.69.12.0 mask 255.255.255.0
net 194.69.13.0 mask 255.255.255.0
net 194.69.14.0 mask 255.255.255.0
net 194.69.15.0 mask 255.255.255.0
end

Vemon
conf t
host Vemon
int s 2/1
ip ad 85.122.8.9 255.255.255.248
encap f
no arp f
no frame inver
frame map ip 85.122.8.10 311 b
no shut
router bgp 7518
no au
no sy
nei 85.122.8.10 remote 852
end


在Rainier上做路由汇聚的同时,也要把194.69.14.0/24网段发布对端
access-list 100 permit ip host 194.69.14.0 host 255.255.255.0
route-map ADV deny 10
match ip ad 100
route-map ADV permit 20
router bgp 852
aggregate-address 194.69.12.0 255.255.252.0 summary-only suppress-map ADV
Rainier上BGP表的状态
Rainier(config-router)#do sh ip bgp
BGP table version is 29, local router ID is 194.69.15.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network          Next Hop            Metric LocPrf Weight Path
s> 194.69.12.0      0.0.0.0                  0         32768 i
*> 194.69.12.0/22   0.0.0.0                            32768 i
s> 194.69.13.0      0.0.0.0                  0         32768 i
*> 194.69.14.0      0.0.0.0                  0         32768 i
s> 194.69.15.0      0.0.0.0                  0         32768 i
Vemon上BGP表的状态
Vemon#sh ip bgp
BGP table version is 51, local router ID is 85.122.8.9
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network          Next Hop            Metric LocPrf Weight Path
*> 194.69.12.0/22   85.122.8.10              0             0 852 i
*> 194.69.14.0      85.122.8.10              0             0 852 i

转载于:https://blog.51cto.com/matthewyin/25368

实验指南:BGP路由汇聚(上)相关推荐

  1. 实验指南:BGP路由汇聚(下)

    实验指南 4,attribute-map/route-map 初始配置见实验指南:BGP路由汇聚(上)3 在Rainier上做BGP路由汇聚 aggregate-address 194.69.12.0 ...

  2. HCL实验:OSPF路由汇聚

    OSPF协议提供了路由汇聚功能,能够减少路由表中的路由条目. 路由汇聚在区域边界路由器(ABR)和 自治系统边界路由器(ASBR) 上进行配置,其命令分别为: [OSPF视图]abr-summary ...

  3. CCIE路由实验(4) -- BGP路由控制

    1.过滤BGP路由的方法 2.用AS-path filter控制路由 3.用Community Filter控制路由 enable conf t no ip do lo enable pass cis ...

  4. 华为eNSP实验记录BGP路由反射配置

    使用eNSP搭建实验环境: 1)确保设备之间的连通性 2)配置BGP 3)配置RR 实现此案例需要按照如下步骤进行. //R1的基本配置interface gi0/0/0 ip address 192 ...

  5. h3c BGP路由控制实验

    实验拓扑 BGP路由控制实验 图 1-1 注:如无特别说明,描述中的 R1 或 SW1 对应拓扑中设备名称末尾数字为 1 的设备,R2 或 SW2 对应拓扑中设备名称末尾数字为 2 的设备,以此类推: ...

  6. 【H3C V7路由器实战视频课程系列-9】BGP路由配置与管理-王达-专题视频课程

    [H3C V7路由器实战视频课程系列-9]BGP路由配置与管理-42人已学习 课程介绍         全面介绍H3C路由器中BGP协议的基础知识和工作原理,并以实战方式介绍H3C路由器BGP路由配置 ...

  7. 【直通华为HCNA/HCNP系列R篇-12】BGP路由配置与管理-王达-专题视频课程

    [直通华为HCNA/HCNP系列R篇-12]BGP路由配置与管理-20623人已学习 课程介绍         本课程以笔者编写.由华为公司指定作为ICT认证培训教材的<华为路由器学习指南> ...

  8. 新华三杯复赛实验赛题解析IPv4 BGP路由部署+路由优化部署

    拓扑图与题目在本专栏的2016新华三杯复赛实验试题博客中,基础配置不包含(IP地址与vlan划分) IPv4 BGP路由部署 总部与分布间使用BGP协议,具体要求如下: 分部为AS200,总部为AS1 ...

  9. 华为数通笔记-BGP路由选路实验

    实验拓扑 查看R4的bgp路由表,发现到达10.10.10.10网段有两条路径,优选了下一跳为R2的路径.(R3上配置了next-hop-local,使其向R4通告路由的下一跳为自身ip地址.) 1. ...

最新文章

  1. cv2.VideoCapture().set(propId, value)设置摄像头图片大小的用法
  2. 《黑客与画家》读后感
  3. NSTimer用法,暂停,继续,初始化
  4. C++的IO流的函数
  5. 苹果CarPlay新功能上线,老司机们更方便了
  6. c++基于asio的组播:windows linux通信
  7. 靠模仿就能建立第二个“Google”?
  8. 【转】webservice 测试地址
  9. No.1大数据入门 | 环境搭建:VM、CentOS7安装及网络配置
  10. mysql安装出现change_mysql-5.msi安装出现change,repaire,or remove installation
  11. 这份来自阿里的微服务前后端开发手册,火了
  12. 004-如何用PS把彩色图片设置成黑白图片?
  13. DoNet开源项目-基于jQuery EasyUI的后台管理系统
  14. python中的subprocess.Popen()使用详解---以及注意的问题(死锁)
  15. 一些信息,我也 不知道写的什么,不过以后会有用
  16. Java匿名内部类中this的小知识(待补充完整)
  17. Q3财报利好股价却下跌,出海老将兰亭集势如何重拾涨势?
  18. AD软件解决unknown pin问题
  19. 【VS开发】MP4与H.264
  20. 计算机学院创新基金项目题目,大学生科技创新基金项目立项

热门文章

  1. 浅谈电子学--台湾新竹交通大学 陈英龙
  2. 用计算机刻录光盘,刻录光盘,教您如何使用计算机将文件刻录到光盘上.
  3. 物理学的困惑: 弦理论崛起了, 科学却衰落了
  4. 《SLAM十四讲》7.6 三角测量 triangulation.cpp
  5. python图像倾斜校正_python 图像倾斜校正
  6. PostgreSQL 磁盘空间的保护伞 PG_repack VS 表膨胀
  7. 色彩设计的原理txt_设计原理:颜色
  8. 游戏开发程序员可能会遇到的英文单词
  9. uni真机showToast不显示
  10. iOS开发-简单图片背景替换(实现抠图效果)