This time, you are supposed to help us collect the data for family-owned property. Given each person’s family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child1 … Childk M_estate Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID’s of this person’s parents (if a parent has passed away, -1 will be given instead); k (0<=k<=5) is the number of children of this person; Childi’s are the ID’s of his/her children; M_estate is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG_sets AVG_area

where ID is the smallest ID in the family; M is the total number of family members; AVG_sets is the average number of sets of their real estate; and AVG_area is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID’s if there is a tie.

Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

题意就是按照题目要求把一个人的信息给我们 让我们根据给出的信息网络
找出一个家庭中符合条件的信息输出 这个家庭的最小编号 家庭人数 每个人的人均数量和人均房产面积

并查集和搜索 都可以做 这里我用了并查集
每个结构体里多记录点信息 然后合并的时候好合并 因为这些信息都是可以加减替代更新到根节点上的 这里我们可以把输入的所有有关联的id全部连接起来
然后连接的时候如果不是在一个联通块中就要把不同联通块更新到一个联通块中
最后输出的时候 就是把每个家庭的根节点排序输出出来即可

#include<bits/stdc++.h>
using namespace std;
struct node{int f,s_area,s_set,min_id,pep;
}n[10003];
void unin(int a,int b){n[b].f = a;n[a].min_id = min(n[a].min_id,n[b].min_id);n[a].pep +=n[b].pep;n[a].s_area+=n[b].s_area;n[a].s_set+=n[b].s_set;
}
bool cmp(node a,node b){return ((double)a.s_area/a.pep)>((double)b.s_area/b.pep)||(((double)a.s_area/a.pep)==((double)b.s_area/b.pep)&&a.min_id<b.min_id);
}//
int find(int x){int k,p,j=x;while(n[x].f!=x)x = n[x].f;k = x;while(n[j].f!=j){p = n[j].f;n[j].f = k;j = p;      }return k;
}
int main()
{int N;scanf("%d",&N);for(int i=0;i<=9999;i++){n[i].f=i;n[i].min_id = i;n[i].pep = 1;}set<int>pep;while(N--){int id,fa,ma,k;scanf("%d%d%d%d",&id,&fa,&ma,&k);pep.insert(id);int fid = find(id);if(fa!=-1){int ffa = find(fa);if(ffa!=fid)unin(fid,ffa);  //      pep.insert(fa);}if(ma!=-1){int fma = find(ma);if(fma!=fid)unin(fid,fma);      //pep.insert(ma);}while(k--){int child;scanf("%d",&child);int fchild = find(child);//if(fchild!=fid)unin(fid,fchild);//pep.insert(child);}int m_es,area;scanf("%d%d",&m_es,&area);n[fid].s_area+=area;n[fid].s_set+=m_es;} set<int>s;// 去重复根节点 vector<node>ans; for(set<int>::iterator i = pep.begin();i!=pep.end();i++){int c = find(*i);if(s.find(c)==s.end()){s.insert(c);ans.push_back(n[c]);}}sort(ans.begin(),ans.end(),cmp);printf("%d\n",ans.size());for(int i = 0;i<ans.size();i++){printf("%04d %d %.3f %.3f\n",ans[i].min_id,ans[i].pep,(double)ans[i].s_set/ans[i].pep,(double)ans[i].s_area/ans[i].pep);}//return 0;
}

PAT 1114 Family Property 并查集相关推荐

  1. PAT甲级1114 Family Property:[C++题解]结构体、并查集、测试点3、4、5有问题的进来!!

    文章目录 题目分析 题目链接 题目分析 来源:acwing 分析: 先建边.读入每家的信息,在本人和父母(如果有的话),本人与子女(如果有的话)之间分别建边.边用结构体来存,边记录两个端点. 遍历每条 ...

  2. 1114. Family Property (25)-PAT甲级真题(并查集)

    This time, you are supposed to help us collect the data for family-owned property. Given each person ...

  3. C++学习之路 | PTA(甲级)—— 1114 Family Property (25分)(带注释)(并查集)(精简)

    1114 Family Property (25分) This time, you are supposed to help us collect the data for family-owned ...

  4. 1114 Family Property (25 分)【难度: 中/ 知识点: 并查集】

    https://pintia.cn/problem-sets/994805342720868352/problems/994805356599820288 挺好的一个并查集,先读入然后再处理.注意:在 ...

  5. PAT甲级题目翻译+答案 AcWing(并查集)

    1013 Battle Over Cities (25 分) 题意 :给图,问去掉所询问的一个点后,需要添加多少条边可以使图连通,N<1000N<1000N<1000 思路 :并查集 ...

  6. PAT甲级1118 Birds in Forest :[C++题解]并查集

    文章目录 题目分析 题目链接 题目分析 来源:acwing 分析:并查集的合并和查询. 问:一张照片上的鸟如何合并?相邻的合并(笔者采用的方式)或者全合并到第一只鸟就行,遍历一遍.所有照片中的鸟,合并 ...

  7. PAT甲级1013 Battle Over Cities:[C++题解]并查集、结构体存边

    文章目录 题目分析 题目链接 题目分析 来源:acwing 分析:并查集题目. 不清楚并查集的小伙伴,请移步并查集原理并查集板子:acwing836. 合并集合. 题意:给定一个连通图,当删掉任意1个 ...

  8. PAT甲级1126 Eulerian Path:[C++题解] 欧拉路径、并查集,测试点4有问题请进来

    文章目录 题目分析 题目链接 题目分析 来源:acwing 分析: 欧拉图: 1)连通 2)度都为偶数 半欧拉图:欧拉路径:2)连通2) 度为奇数的结点有两个,其他度都是偶数 非欧拉图:不是欧拉图和半 ...

  9. PAT甲级1021 Deepest Root :[C++题解]树的最大深度、并查集、dfs求树的深度

    文章目录 题目分析 题目链接 题目分析 分析: 考察知识点:并查集.dfs.树的深度 给定n个结点,n-1条边,只要能保证只有1个连通分量,就是一棵树.否则的话就不是树,它是不连通的. 用并查集来看是 ...

最新文章

  1. 正规Java培训机构是什么样的
  2. linux hadoop etc目录,题目Linux平台下Hadoop的安装配置
  3. ios rsa java_一篇搞定RSA加密与SHA签名|与Java完全同步
  4. CSS基础(part11)--盒子模型之内边距
  5. 小白的算法初识课堂(part2)--选择排序
  6. 基于JAVA+JSP+MYSQL的小说网站阅读管理系统
  7. 网站服务器 凭证,登录云服务器的凭证是什么
  8. httpd-2.2部署Discuz!论坛系统、wordpress博客系统和phpMyAdmin程序
  9. 微软商店下载的python_微软商店可下载安装Python 3.7啦
  10. wps下一步快捷键_WPS的快捷键有哪些
  11. 初学C语言 输出图形
  12. vue组件库(Element UI)
  13. echarts字符云(词云)
  14. SpringBoot+Vue打造资产出入库管理系统
  15. OSChina 周五乱弹 —— 那地图上的点到底去哪儿
  16. Python 爬虫下载喜马拉雅音频文件
  17. Android 10 拨打电话流程
  18. [知乎]如何做到像使用 LaTeX 那样“优雅”地使用 Word?
  19. JDBC如何有效防止SQL注入
  20. 学习笔记-Speed-Linux

热门文章

  1. 第一次冲刺阶段(三)
  2. Java单例模式简单实现
  3. kendo-ui学习笔记——题记
  4. openSUSE 13.1 Milestone 2 发布
  5. 在虚拟机中安装和配配置 MOSS2007 全过程
  6. 服务器控件HtmlTable下控件赋值问题
  7. 使用 bat 文件管理计算机服务
  8. Java 深copy 浅copy 引用copy
  9. Android 6.0及以上版本动态申请权限,11权限
  10. 小程序 canvas 设置 字体 字号加粗