Problem Description

Social Network is popular these days.The Network helps us know about those guys who we are following intensely and makes us keep up our pace with the trend of modern times.
But how?
By what method can we know the infomation we wanna?In some websites,maybe Renren,based on social network,we mostly get the infomation by some relations with those "popular leaders".It seems that they know every lately news and are always online.They are alway publishing breaking news and by our relations with them we are informed of "almost everything".
(Aha,"almost everything",what an impulsive society!)
Now,it's time to know what our problem is.We want to know which are the key relations make us related with other ones in the social network.
Well,what is the so-called key relation?
It means if the relation is cancelled or does not exist anymore,we will permanently lose the relations with some guys in the social network.Apparently,we don't wanna lose relations with those guys.We must know which are these key relations so that we can maintain these relations better.
We will give you a relation description map and you should find the key relations in it.
We all know that the relation bewteen two guys is mutual,because this relation description map doesn't describe the relations in twitter or google+.For example,in the situation of this problem,if I know you,you know me,too.

Input

The input is a relation description map.
In the first line,an integer t,represents the number of cases(t <= 5).
In the second line,an integer n,represents the number of guys(1 <= n <= 10000) and an integer m,represents the number of relations between those guys(0 <= m <= 100000).
From the second to the (m + 1)the line,in each line,there are two strings A and B(1 <= length[a],length[b] <= 15,assuming that only lowercase letters exist).
We guanrantee that in the relation description map,no one has relations with himself(herself),and there won't be identical relations(namely,if "aaa bbb" has already exists in one line,in the following lines,there won't be any more "aaa bbb" or "bbb aaa").
We won't guarantee that all these guys have relations with each other(no matter directly or indirectly),so of course,maybe there are no key relations in the relation description map.

Output

In the first line,output an integer n,represents the number of key relations in the relation description map.
From the second line to the (n + 1)th line,output these key relations according to the order and format of the input.

Sample Input

1
4 4
saerdna aswmtjdsj
aswmtjdsj mabodx
mabodx biribiri
aswmtjdsj biribiri

Sample Output

1
saerdna aswmtjdsj

题意:给出一个 n 个点 m 条边的无向图,求这个图中桥的个数,并按顺序输出桥

思路:由于图可能不连通,因此首先需要判断是否存在 dfn[i]=0,如果存在则说明图不连通,直接输出 0 即可

求桥可以直接套 Tarjan 算法模版,难点在于按输入顺序求桥,因此不能在求桥的过程中输出,必须在求完所有桥后按顺序判断每条边是否是桥,因此可用 map 来实现一个字符串到点编号的映射,则一个输入边即为两个字符串结点 Node 组成

对于边 x-y 来说,只要满足 low[x]>dfn[y] 或 low[y]>dnf[x] 则该边一定是桥,因而先求完所有节点的 low 值,然后在退出 Tarjan 算法后,重新扫描每一条边的两个节点 x、y 的 low值、dfn 值,再判断该边是否为桥

Source Program

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstdlib>
#include<queue>
#include<set>
#include<map>
#include<stack>
#include<ctime>
#include<vector>
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define N 20001
#define MOD 16007
#define E 1e-6
#define LL long long
using namespace std;
struct Node{char str[20];bool operator <(const Node s)const{return strcmp(str,s.str)<0;}
};
struct Edge{Node x;Node y;bool flag;//判断该边是否为割边
}edge[N];
map<Node,int> mp;//将 字符串Node映射成结点编号
vector<int> G[N];
int n,m;
int dfn[N],low[N];
int block_cnt;
void Tarjan(int x,int father){low[x]=dfn[x]=++block_cnt;for(int i=0;i<G[x].size();i++){int y=G[x][i];if(y==father)continue;if(dfn[y]==0){Tarjan(y,x);low[x]=min(low[x],low[y]);}elselow[x]=min(low[x],dfn[y]);}
}
int main()
{int t;scanf("%d",&t);while(t--){scanf("%d%d",&n,&m);mp.clear();for(int i=0;i<n;i++)G[i].clear();block_cnt=0;memset(dfn,0,sizeof(dfn));int num=0;//记录编号for(int i=0;i<m;i++){edge[i].flag=false;;scanf("%s%s",edge[i].x.str,edge[i].y.str);if(mp.find(edge[i].x)==mp.end())mp[edge[i].x]=++num;if(mp.find(edge[i].y)==mp.end())mp[edge[i].y]=++num;int x=mp[edge[i].x];int y=mp[edge[i].y];G[x].push_back(y);G[y].push_back(x);}Tarjan(1,-1);bool connection=true;//判断是否连通for(int i=1;i<=n;i++){if(dfn[i]==0){connection=false;break;}}if(connection==false)printf("0\n");else{int res=0;for(int i=0;i<m;i++){int x=mp[edge[i].x];int y=mp[edge[i].y];if(low[x]>dfn[y] || low[y]>dfn[x]){edge[i].flag=true;res++;}}printf("%d\n",res);for(int i=0;i<m;i++)if(edge[i].flag)printf("%s %s\n",edge[i].x.str,edge[i].y.str);}}return 0;
}

By Recognizing These Guys, We Find Social Networks Useful(HDU-3849)相关推荐

  1. Paper笔记: 《Towards Evaluating the Robustness of Neural Networks》(CW攻击)

    论文: https://arxiv.org/pdf/1608.04644.pdf?source=post_page 代码:https://github.com/Harry24k/CW-pytorch ...

  2. Information and Influence Propagation in Social Networks学习笔记

    Information and Influence Propagation in Social Networks学习笔记 Wei Chen dalao写的书,在传播问题上感觉写的写的很详细,因为之前看 ...

  3. 谣言检测文献阅读二—Earlier detection of rumors in online social networks using certainty‑factor‑based convolu

    系列文章目录 谣言检测文献阅读一-A Review on Rumour Prediction and Veracity Assessment in Online Social Network 谣言检测 ...

  4. UIL 算法学习 Structure Based User Identification across Social Networks

    Structure Based User Identification across Social Networks 这是篇无监督的论文. TKDE 2018 因此,在本研究中,我们研究了无监督策略, ...

  5. 【论文】解读Evolutionary dynamics of traveling behavior in social networks

    Evolutionary dynamics of traveling behavior in social networks 摘要 本文利用复杂网络的拓扑结构来描述出行者之间的相互作用.基于旅游者有限 ...

  6. Online social networks security and privacy: comprehensive review and analysis 笔记

    Introduction 社交网络可以被分为四种板块:社交关系(social connections).多媒体分享(multimedia sharing).专业(professional)和论坛(di ...

  7. 论文阅读:A Survey of Textual Event Extraction from Social Networks 综述:从社交媒体中抽取文本事件

    A Survey of Textual Event Extraction from Social Networks 综述:从社交媒体中抽取文本事件 目录 A Survey of Textual Eve ...

  8. 图隐私论文速递:A graph modification approach for k‑anonymity in social networks using the genetic algorith

    作者:gufe_hfding 文章目录 论文概况 论文主要创新点 论文启示 论文概况 今天要分享的是来自伊朗的论文,标题为:A graph modification approach for k‑an ...

  9. Influence maximization in social networks using transfer learning via graph-based LSTM

    基于图LSTM的社交网络影响力最大化问题迁移学习 前言 文章内容 摘要 特征提取 标签生成 用基于图的LSTM训练模型 选LSTM的原因: 基于图的LSTM: 迁移学习 提出的模型架构 提出的算法 训 ...

最新文章

  1. java内存区域之程序计数器
  2. vb退出窗体代码_VB中基本概念(3)
  3. error while loading shared libraries的解決方法
  4. socket阻塞导致拿不到信息
  5. 34_pytorch,动量与lr衰减(momentum,learning rate)--学习笔记
  6. jenkins使用docker部署web应用
  7. 模块-基本概念和import导入复习
  8. centos7下安装python3 解决openssl等一系列问题
  9. (5)STM32使用HAL库实现串口通讯——实战操作
  10. VPP电源控制(VPP Power)-- 由DC-DC变换集成电路MC34063组成
  11. rk3399pro添加ALC5640音频配置
  12. 批处理html转excel,批量Excel转TXT工具(Batch Excel to Text Converter)v2020.12.1118官方免费版...
  13. 环境可靠性测试,气候环境类可靠性试验,可靠性测试标准
  14. 小学计算机教育计划,2021年小学信息技术教学计划
  15. web前端二维码打印模板编辑
  16. 阿里、华为和微软等多家国内外厂商组团搞OpenJDK,Oracle为啥不参加?
  17. 苹果,U盘越狱iPhone绕ID最新教程及各种坑解决,吐血之作(超详细超简单教程)-balenaEtcher-Checkm8-bootra1n
  18. git 冲突解决一把梭
  19. Android P 9.0 MTK平台 增加以太网静态IP功能
  20. iOS 解决scoryboard上tableview、collection view顶部有空白问题

热门文章

  1. FreeRTOS移植到STM32F103
  2. STM32之中断嵌套控制器
  3. mysql忘记密码怎末版_mysql忘记密码怎么办
  4. 【阿里内推001期】听说你要做中台,阿里中台部门招Java开发
  5. Spring Cloud 入门 之 Ribbon 篇(二)
  6. JEECG 3.6.3版本发布 企业级JAVA快速开发平台
  7. SpringBoot2 集成测试组件,七种测试手段对比
  8. 编程体系结构(04):JavaIO流文件管理
  9. Linux系统:Centos7搭建Redis单台和集群环境
  10. Handler原理分析