Frame-relay帧中继配置,实现网络连接

实验要求:帧中继接入网络,实现网路连接。
实验拓扑图:

FR-SW1配置:

Router>enable
Router#configure
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname FR-SW1
FR-SW1(config)#frame-relay switching
FR-SW1(config)#interface s2/0
FR-SW1(config-if)#encapsulation frame-relay ietf
FR-SW1(config-if)#no shutdown
FR-SW1(config-if)#
*Jun 11 02:57:29.322: %LINK-3-UPDOWN: Interface Serial2/0, changed state to up
FR-SW1(config-if)#
*Jun 11 02:57:40.325: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
*Jun 11 02:58:10.330: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to down
FR-SW1(config-if)#frame-relay route 102 interface s2/1 201
FR-SW1(config-if)#do sh frame route
Input Intf Input Dlci Output Intf Output Dlci Status
Serial2/0 102 Serial2/1 201 inactive
FR-SW1(config-if)#frame-relay route 103 interface s2/2 301
FR-SW1(config-if)#int e0/0
FR-SW1(config-if)#ip address 172.16.1.1 255.255.255.0
FR-SW1(config-if)#no shutdown
*Jun 11 03:05:22.669: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Jun 11 03:05:23.674: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up
FR-SW1(config-if)#exit
FR-SW1(config)#interface tunnel 0
*Jun 11 03:09:42.938: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down
FR-SW1(config-if)#tunnel source e0/0
FR-SW1(config-if)#no tunnel source e0/0
FR-SW1(config-if)#tunnel source 172.16.1.1
FR-SW1(config-if)#tunnel destination 172.16.1.2
*Jun 11 03:10:55.675: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
FR-SW1(config-if)#exit
FR-SW1(config)#interface s2/0
FR-SW1(config-if)#frame-relay route 104 interface tunnel 0 122
FR-SW1(config-if)#frame-relay intf-type dce

FR-SW1(config-if)#exit
FR-SW1(config)#interface s2/1
FR-SW1(config-if)#encapsulation fra
FR-SW1(config-if)#encapsulation frame-relay ietf
FR-SW1(config-if)#frame-relay intf-type dce
FR-SW1(config-if)#frame-relay route 201 interface s2/0 102
FR-SW2配置:
Router>enable
Router#configure
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname FR-SW2
FR-SW2(config)#interface e0/0
FR-SW2(config-if)#ip address 172.16.1.2 255.255.255.0
FR-SW2(config-if)#no shutdown
FR-SW2(config-if)#exit
FR-SW2(config)#
*Jun 11 03:07:17.466: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Jun 11 03:07:18.470: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up
FR-SW2(config)#do ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
.!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms
FR-SW2(config)#interface tunnel 0
*Jun 11 03:12:47.815: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down
FR-SW2(config-if)#tunnel source 172.16.1.2
FR-SW2(config-if)#tunnel destination 172.16.1.1
FR-SW2(config-if)#exit
*Jun 11 03:13:08.619: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
FR-SW2(config)#frame-relay switching
FR-SW2(config)#interface s2/0
FR-SW2(config-if)#encapsulation frame-relay ietf
FR-SW2(config-if)#frame-relay route 401 interface tunnel 0 122
FR-SW2(config-if)#frame-relay intf-type dce
R1配置:
Router>enable
Router#configure
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface s2/0
R1(config-if)#encapsulation frame-relay ietf
R1(config-if)#frame-relay intf-type dte
R1(config-if)#no shutdown
*Jun 11 03:50:39.010: %LINK-3-UPDOWN: Interface Serial2/0, changed state to up
*Jun 11 03:50:50.020: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
R1(config)#interface s2/0.10 point-to-point
R1(config-subif)#ip address 10.1.1.1 255.255.255.0
R1(config-subif)#frame-relay interface-dlci 102
R1(config-fr-dlci)#exit
R1(config-subif)#exit
R1(config)#interface s2/0.20 multipoint
R1(config-subif)#ip address 20.1.1.1 255.255.255.0
R1(config-subif)#frame-relay map ip 20.1.1.3 103
R1(config-subif)#frame-relay map ip 20.1.1.4 104
R1(config-subif)#exit
R1(config-if)#exit
R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#network 10.1.1.0 0.0.0.255 area 0
R1(config-router)#network 20.1.1.0 0.0.0.255 area 0
R1(config-router)#exit
R1(config)#interface s2/0.10 point-to-point
R1(config-subif)#ip ospf network point-to-point
R1(config-subif)#exit
R1(config)#interface s2/0.20 multipoint
R1(config-subif)#ip ospf network point-to-multipoint
R2配置:
Router>enable
Router#configure
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface s2/1
R2(config-if)#encapsulation frame-relay ietf
R2(config-if)#frame-relay intf-type dte
R2(config-if)#ip address 10.1.1.2 255.255.255.0
*Jun 11 03:59:32.579: %LINK-3-UPDOWN: Interface Serial2/1, changed state to up
R2(config-if)#
*Jun 11 03:59:43.586: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/1, changed state to up
*Jun 11 04:00:13.591: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/1, changed state to down
R2(config-if)#frame-relay map ip 10.1.1.1 201 broadcast
R2(config-if)exit
R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 192.168.2.0 0.0.0.255 area 0
R2(config-router)#network 10.1.1.0 0.0.0.255 area 0
R2(config-router)#exit
R2(config)#interface s2/1
R2(config-if)#ip os
R2(config-if)#ip ospf net
R2(config-if)#ip ospf network po
R2(config-if)#ip ospf network point-to-p
R2(config-if)#ip ospf network point-to-point
R3配置
R3>enable
R3#configure
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#hostname R3
R3(config)#interface s2/2
R3(config-if)#encapsulation frame-relay ietf
R3(config-if)#frame-relay intf-type dte
R3(config-if)#ip address 20.1.1.3 255.255.255.0
R3(config-if)#no shutdown
*Jun 11 04:17:29.215: %LINK-3-UPDOWN: Interface Serial2/2, changed state to up
*Jun 11 04:17:40.219: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/2, changed state to up
*Jun 11 04:18:10.223: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/2, changed state to down
R3(config-if)#frame-relay map ip 20.1.1.1 301 broadcast
R3(config-if)#exit
R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 192.168.3.0 0.0.0.255 area 0
R3(config-router)#network 20.1.1.0 0.0.0.255 area 0
R3(config-router)#exit
R3(config)#int s2/2
R3(config-if)#ip ospf network point-to-multipoint
R4配置
Router>enable
Router#configure
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R4
R4(config)#interface s2/0
R4(config-if)#encapsulation frame-relay ietf
R4(config-if)#frame-relay intf-type dte
R4(config-if)#ip address 20.1.1.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#
*Jun 11 04:22:02.944: %LINK-3-UPDOWN: Interface Serial2/0, changed state to up
*Jun 11 04:22:13.953: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
R4(config-if)#frame-relay map ip 20.1.1.1 401
*Jun 11 04:22:43.959: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to down
R4(config-if)#exit
R4(config)#router ospf 1
R4(config-router)#router-id 4.4.4.4
R4(config-router)#network 20.1.1.0 0.0.0.255 area 0
R4(config-router)#network 192.168.4.0 0.0.0.255 area 0
R4(config-router)#exit
R4(config)#int s2/0
R4(config-if)#ip ospf network point-to-multipoint

Frame-relay帧中继配置,实现网络连接相关推荐

  1. 树莓派 4b 配置 USB 网络连接

    树莓派 4b 配置 USB 网络连接 树莓派镜像: 2022-09-22-raspios-bullseye-arm64.img 电脑: windows 10 1 打开树莓派的 USB 网络 在 /bo ...

  2. OEL / RedHat linux 配置无线网络连接(含驱动安装)

    本机环境:Thinkpad E440,Oracle Linux Server release 6.7(kernel 3.8.13-68.3.4.el6uek.x86_64) 本机无线网卡为RTL872 ...

  3. 简单配置Centos网络连接

    开启自动启用网络连接 1.配置带桌面的Centos 2.配置纯命令界面的Centos (总结) 1.配置带桌面的Centos 将用户切换为管理员 右击桌面打开终端 输入命令vim /etc/sysco ...

  4. 树莓派Raspberry命令行配置无线网络连接

    前言: 树莓派有多种联网的方式,通过有线网或者通过无线网.通过有线网连接是比较简单的,在开启dhcp的路由器下,直接插上网线就可以联网,本文介绍树莓派无线联网的方式.再没联网的情况下,如果没有屏幕等外 ...

  5. 配置oracle网络连接命令,配置oracle网络环境

    向数据库注册实例的方法有静态注册和动态注册两种.对于静态注册来说,我们可以将一列硬编码在listener.ora文件中.动态注册意味着实例在启动时要定位侦听器并注册到侦听器中. 动态注册是向侦听器注册 ...

  6. 网狐登录提示,服务器连接失败,请检查网络配置以及网络连接状况

    出现这个有两个原因: 1.ServerInfo.INI 配置文件里没有配置对. 2.缺少 WHSocket.dll 文件. 其实很多问题都经常发现,但是处理了都没有做记录,现在呢都是搞下业余的,同时也 ...

  7. 『mcse 2008基础架构』Chapter 01 IP协议及配置方法 第1课网络连接及配置方法

    学习目标: 理解TCP/IP协议组中的4个层次 查看和配置本地网络连接的IP设置 理解网络广播的概念 使用TCP/IP工具排除网络连通性故障 转载于:https://blog.51cto.com/ld ...

  8. VMware网络连接方式(Host-only、NAT、Bridged)介绍及NAT环境下静态IP配置

    常识 三大网络连接方式简介 一个实例 操作 设置vmware 虚拟网络编辑器 静态ip配置 VMware网络连接方式的选择及静态IP的配置是hadoop集群搭建的一个必不可少的环节. 常识 VMwar ...

  9. Virtualbox如何配置Linux的网络连接

    来源地址:http://jingyan.baidu.com/article/456c463b64a23c0a59314472.html 如果是安装系统参考:如何在Virtualbox虚拟机中安装Lin ...

  10. 虚拟机三种网络连接方式(桥接、NAT、仅主机、vlan)、Fusioncompute中的网络配置(OVS、DVS)

    我们通过VMware workstation 安装虚拟机的时候,需要配置我们的虚拟网卡. 需要在网络适配器那里进行配置,网络连接这里一般有三种模式,桥接模式,NAT模式和仅主机模式,如下图所示,那么这 ...

最新文章

  1. C# 两时间,时间间隔
  2. 2.6 矩阵乘法重要特例
  3. 2016 ICPC 北京网络赛 A 恶心模拟 F 循环矩阵,FFT(待补) I 模拟
  4. 转整型_156.Ruby烘焙大理石豆沙吐司解锁大理石花纹整型
  5. Linux中的date、cal、bc三个简单命令
  6. jquery字符串序列化方法总结
  7. nginx源码分析之IO多路复用流程
  8. 局域网ssr转pptp_[网络技术][转]PPTP连接过程
  9. python编程软件哪个好-有哪些值得推荐的 Python 开发工具?
  10. LeetCode之翻转字符串里的单词
  11. Android源码编译问题
  12. 喜欢“唱跳rap和篮球”的不止有蔡徐坤,还有周杰伦,他可是唱跳rap的鼻祖
  13. 会写代码的CTO曹艳白曹总,智核创投创始人,给搜房贡献的第一个大数据方面的专利...
  14. 《大道至简——软件工程实践者的思想》读书笔记
  15. SpringBoot 报错锦集
  16. 织梦标签全攻略[转]
  17. Java 核心技术 - JVM
  18. C字符串操作strlen/strnlen_s详解
  19. seo-移动站优化问题修改针对落地页规范
  20. 密码学_SM4国密算法

热门文章

  1. 抖音上热门的小技巧,不看后悔
  2. XtraBackUp 全量备份
  3. 【Cesium】点击billboard弹出自定义气泡框
  4. win11取消右键菜单折叠恢复经典传统菜单模式方法解决
  5. 功能测试主要做什么?
  6. 数据分析案例--淘宝用户行为分析
  7. 无刷电机工作及控制原理
  8. 三角形个数(找规律)
  9. Word撤销键(Ctrl+z)无效的解决方法
  10. Mac 移动硬盘没有推出,再插上不显示移动硬盘解决办法