题干:

There is a very simple and interesting one-person game. You have 3 dice, namely Die1Die2 and Die3Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1K2K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers nK1K2K3abc (0 <= n <= 500, 1 < K1K2K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output

1.142857142857143
1.004651162790698

题目大意:有三个均匀的骰子,分别有k1,k2,k3个面分别代表点数1~k1,1~k2,1~k3。初始分数是0。每一回合掷一波骰子,当掷三个骰子的点数分别为a,b,c的时候,分数清零,否则分数加上三个骰子的点数和,当分数>n的时候结束。求需要掷骰子的次数的期望。

解题报告:

自己讲的也不好,也是参考一个题解吧:(链接)

写出的公式是有后续性的。我们需要弄一个递推公式,消去后续性。

本题通过代换系数,化简后求系数。一般形成环的用高斯消元法求解。但是此题都是和dp[0]相关。所有可以分离出系数。
设dp[i]表示达到i分时到达目标状态的期望,pk为投掷k分的概率,p0为回到0的概率
则dp[i]=∑(pk*dp[i+k])+dp[0]*p0+1;
都和dp[0]有关系,而且dp[0]就是我们所求,为常数
设dp[i]=A[i]*dp[0]+B[i];
代入上述方程右边得到:
dp[i]=∑(pk*A[i+k]*dp[0]+pk*B[i+k])+dp[0]*p0+1=(∑(pk*A[i+k])+p0)dp[0]+∑(pk*B[i+k])+1;明显A[i]=(∑(pk*A[i+k])+p0)B[i]=∑(pk*B[i+k])+1先递推求得A[0]和B[0].那么  dp[0]=B[0]/(1-A[0]);

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define F first
#define S second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 1000 + 5;
ll ans;
int k1,k2,k3,a,b,c,n;
int ci[666];
double A[MAX],B[MAX],dp[MAX];//dp[i]代表当前分数为i时,结束游戏所要掷骰子的次数的期望值
int main()
{int t;cin>>t;while(t--) {scanf("%d%d%d%d%d%d%d",&n,&k1,&k2,&k3,&a,&b,&c);memset(ci,0,sizeof ci);for(int i = 0; i<MAX; i++) A[i]=B[i]=0;for(int i = 1; i<=k1; i++) {for(int j = 1; j<=k2; j++) {for(int k = 1; k<=k3; k++) {if(i == a && j == b && k == c) continue;ci[i+j+k]++;}}}double p0=1.0/(k1*k2*k3);for(int i = n; i>=0; i--) {for(int j = 3; j<=k1+k2+k3; j++) {A[i] += ci[j]*1.0/(k1*k2*k3) * A[i+j];B[i] += ci[j]*1.0/(k1*k2*k3) * B[i+j];}A[i] += p0;B[i] += 1;}printf("%.12f\n",B[0]/(1-A[0]));}return 0 ;
}

总结:

刚开始WA了半天,发现是初始化的时候直接把ci和A数组放到一起用for初始化了,但是其实这样是不行的,因为你MAX=1000,但是ci只开到了666,所以就越界了呀。

【ZOJ - 3329】One Person Game(带循环的概率dp,数学期望,高斯消元,数学)相关推荐

  1. ZOJ 3329 One Person Game 带环的概率DP

    每次都和e[0]有关系 通过方程消去环 dp[i] = sigma(dp[i+k]*p)+dp[0]*p+1 dp[i] = a[i]*dp[0]+b[i] dp[i] = sigma(p*(a[i+ ...

  2. 高斯消元 zoj 3645 poj 1222/XOR消元

    double a[maxn][maxn] , x[maxn] ; //a[i][j] 系数矩阵 , a[i][n+1] = y[i] , x解 int n ; //n个方程 void guass(){ ...

  3. 【ZOJ - 2949】Coins of Luck (概率dp,期望)

    题干: 给你两种泡面 各N包,然后你扔硬币,正面朝上吃第一种,反面呢 吃第二种,有任意一种吃完时 就不需要抛硬币了,求停止抛硬币的期望. Sample Input 2 1 2 Sample Outpu ...

  4. zoj 3353 Chess Board 高斯消元

    高斯消元其本应用: 这题是要枚举自由元的: #include<iostream> #include<cstring> #include<cstdio> #defin ...

  5. poj 2096 , zoj 3329 , hdu 4035 —— 期望DP

    题目:http://poj.org/problem?id=2096 题目好长...意思就是每次出现 x 和 y,问期望几次 x 集齐 n 种,y 集齐 s 种: 所以设 f[i][j] 表示已经有几种 ...

  6. 激发数学思维!一个烧脑的顶级数学纪录片《维度:数学漫步》完整版,带你漫步数学之美!时长125分,建议先马再看!看完从此爱上数学!

    激发数学思维!一个烧脑的顶级数学纪录片<维度:数学漫步>完整版,带你漫步数学之美!时长125分,建议先马再看!看完从此爱上数学! https://www.bilibili.com/vide ...

  7. 解决JS在controll层定义带循环的公共方法,组件中调用时取不到返回值的问题

    问题描述:下拉列表中,点击一个子节点,获取父节点的Id. 如果将方法直接写在组件内调用,完全ok的. 如果将方法提取到外层,想公用的话,组件内调用会出现方法中已经拿到值,但是页面调用时取不到返回值: ...

  8. python如何检验数字范围是否连续_检查python中的数字是否在某个范围内(带循环)?...

    本问题已经有最佳答案,请猛点这里访问. 以下是我的代码: total = int(input("How many students are there")) print(" ...

  9. FlexTime 1.4 特别版 macOS 带循环任务的多功能计时器软件

    最近天气骤然转冷,整个人也突变慵懒,注意力不集中,工作效率超级拖拉,用过番茄工作法,现在又发现了更好的效率助推软件:FlexTime,你可以把它当做一个普通的计时器,也可以用来创建Mac系统内的自动循 ...

最新文章

  1. Castle ActiveRecord(一)概述
  2. mysql error 1231_解决ERROR 1231 (42000): Variable 'time_zone' can't
  3. Iterator接口介绍
  4. c语言 %15s,c语言求助
  5. android 用webView作为编辑器 各种问题
  6. 启动项目无法打印日志处理及logback简单使用
  7. Php开发银行接口之浦发银行
  8. 微程序控制器的组成及原理总结
  9. 一份值得收藏的ACL 2020参会笔记:重要论文与NLP领域的发展趋势解读
  10. UItextView使用详解
  11. Unity3D加载资源的四种方式
  12. java之继承 封装 多态
  13. 那些买了来客推商城V3多用户uni-app商城源码的客户体验怎么样?
  14. Hulk容器服务的镜像CI解决方案
  15. 边境的悍匪—机器学习实战:第十九 大规模训练和部署TensorFlow模型
  16. 关闭NV显卡的优化功能
  17. python音频合成_音频拼接的简单实现方法(python一种,java两种)
  18. 6410同时支持colorkey和aphablend
  19. 快数据如何在物联网高速公路上驱动分析
  20. 软件测试流程及流程管理

热门文章

  1. 在CentOS下源码安装 Xen并搭建Windows虚拟机
  2. 图片加到json中,提交到服务器端处理异常问题。
  3. [Leedcode][JAVA][第466题][统计重复个数][数组]
  4. mysql 命令行 主从复制_MySQL 的主从复制(高级篇)
  5. Please remove usages of `jcenter()` Maven repository from your build scripts and migrate your build
  6. android如何删除项目,AndroidStudio中怎样删除项目
  7. C#中string.Concat方法的使用
  8. python取前三位_Python 实现取多维数组第n维的前几位
  9. arduino 水位传感器_云南可信赖的威卡压力传感器哪里有
  10. 防灾科技学院计算机组成原理,防灾科技学院计算机组成原理复习材料1