1.单臂路由(图)

环境:一台路由器,一台二层交换机,两台pc机

二层交换机的配置

一般模式: Switch>

输入enable进入特权模式: Switch>enable

输入configure terminal进入全局配置模式:

Switch#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

创建vlan 10 和 vlan 20:

Switch(config)#vlan 10

Switch(config-vlan)#vlan 20

Switch(config-vlan)# exit

进入接口配置模式:

Switch(config)#interface fastEthernet 0/1

把0/1变成trunk口(默认是access口)

Switch(config-if)#switchport mode trunk

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Switch(config-if)#exit

进入接口配置模式分别把对应的接口,加入对应的vlan:

Switch(config)#interface fastEthernet 1/1

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 10

Switch(config-if)#interface fastEthernet 2/1

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 20

到此而层交换机配置完毕!

路由器的配置:

Router>

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#inter fas 0/0

Router(config-if)#no ip address

Router(config-if)#no shutdown

注意:单臂路由的配置父接口一定要no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#int fas 0/0.10

%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up

Router(config-subif)#encapsulation dot1Q 10

注意:在配置ip时一定要先封装802.1q协议

Router(config-subif)#ip address 192.168.10.1 255.255.255.0

Router(config-subif)#no shutdown

Router(config-subif)#int fas 0/0.20

%LINK-5-CHANGED: Interface FastEthernet0/0.20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.20, changed state to up

Router(config-subif)#ip address 192.168.20.1 255.255.255.0

% Configuring IP routing on a LAN subinterface is only allowed if that

subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,

or ISL vLAN.

Router(config-subif)#encapsulation dot1Q 20

Router(config-subif)#ip address 192.168.20.1 255.255.255.0

Router(config-subif)#no shutdown

Router(config-subif)#

查看路由表: Router#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.10.0/24 is directly connected, FastEthernet0/0.10

C 192.168.20.0/24 is directly connected, FastEthernet0/0.20

Router#

PC0的配置: ip 192.168.10.10

netmask 255.255.255.0

gateway 192.168.10.1

PC1的配置:

ip 192.168.20.20

netmask 255.255.255.0

gateway 192.168.20.1

2.使用SVI实现VLAN间的通信(图)

环境:一台三层交换机,两台pc机

三层交换机的配置:Switch>enable

Switch#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

创建vlan 10 20

Switch(config)#vlan 10

Switch(config-vlan)#vlan 20

Switch(config-vlan)#exit

配置SVI接口ip

Switch(config)#interface vlan 10

%LINK-5-CHANGED: Interface Vlan10, changed state to up

Switch(config-if)#ip address 192.168.10.1 255.255.255.0

Switch(config-if)#no shutdown

Switch(config-if)#interface vlan 20

%LINK-5-CHANGED: Interface Vlan20, changed state to up

Switch(config-if)#ip address 192.168.20.1 255.255.255.0

Switch(config-if)#no shutdown

Switch(config-if)#exit

改变接口模式并加入vlan

Switch(config)#interface fastEthernet 0/1

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 10

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up

Switch(config-if)#interface fastEthernet 0/2

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 20

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up

Switch(config-if)#

看三层交换机的路由表:

Switch#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.10.0/24 is directly connected, Vlan10

C 192.168.20.0/24 is directly connected, Vlan20

Switch#

两主机的配置与单臂路由中两主机的配置一样

3.跨交换机实现VLAN间的通信(图)

环境:一台三层交换机,两台二层交换机,两台pc机

三层交换机的配置(SW3)

Switch>enable

Switch#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

创建vlan 10 、 20 并设置ip Switch(config)#vlan 10

Switch(config-vlan)#vlan 20

Switch(config-vlan)#exit

Switch(config)#interface vlan 10

%LINK-5-CHANGED: Interface Vlan10, changed state to up

Switch(config-if)#ip address 192.168.10.1 255.255.255.0

Switch(config-if)#no shutdown

Switch(config-if)#interface vlan 20

%LINK-5-CHANGED: Interface Vlan20, changed state to up

Switch(config-if)#ip address 192.168.20.1 255.255.255.0

Switch(config-if)#no shutdown

Switch(config-if)#exit

设置接口模式并加入相应的vlan(注意trunk口的设置) Switch(config)#interface fastEthernet 0/1

Switch(config-if)#switchport mode trunk

Switch(config-if)#interface fastEthernet 0/1

Switch(config-if)#switchport access vlan 10

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up

Switch(config)#interface fastEthernet 0/2

Switch(config-if)#switchport mode trunk

Switch(config-if)#interface fastEthernet 0/2

Switch(config-if)#switchport access vlan 20

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up

Switch#

看路由表

Switch#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.10.0/24 is directly connected, Vlan10

C 192.168.20.0/24 is directly connected, Vlan20

SW21的配置

Switch>enable

Switch#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#vlan 10

Switch(config-vlan)#exit

Switch(config)#interface fastEthernet 0/1

Switch(config-if)#switchport mode trunk

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Switch(config-if)#interface fastEthernet 1/1

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 10

Switch(config-if)#exit

Switch(config)#

SW22的配置

Switch>

Switch>en

Switch#

Switch#configure ter

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#inter fas 1/1

Switch(config-if)#switchport mode trunk

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/1, changed state to up

Switch(config-if)#switchport mode access

Switch(config-if)#inter fas 2/1

Switch(config-if)#switchport mode trunk

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/1, changed state to up

Switch(config-if)#exit

Switch(config)#vlan 20

Switch(config-vlan)#inter fas 1/1

Switch(config-if)#switchport access vlan 20

Switch(config-if)#

注意:两交换机之间的链接是trunk链路

4.以上配置在模拟器上都可实现

在模拟器上配置其中pc图片

上述三种方式pc机的配置都一样

验证:

本文出自 “linuxme” 博客,请务必保留此出处http://linuxme.blog.51cto.com/1850814/389229

access下如何配置两个vlan_不同vlan间的通信如何简单配置(三种方式) ?相关推荐

  1. 105、三层交换机如何配置?如何实现不同vlan间的通信?

    前面我们曾提到关于vlan组网,有很多朋友反映有没有更详细.更简单的内容,这次我们用一个实例来讲解vlan的创建及组网过程,且所有的命令都有流释,我们一起来看下.在了解vlan之间,我们先来简单的了解 ...

  2. 三层交换机如何配置?如何实现不同vlan间的通信?

    一.什么是三层交换机? 在了解vlan之间,我们先来简单的了解下三层交换机. 要实现vlan间通信,就需要路由:解决的方法要么是二层交换机加路由器,要么就是直接使用三层交换机,为什么要使用三层交换机呢 ...

  3. win下配置的ES中的数据在哪里可以看到?三种方式你看那种更加高大上!!!(win_Elasticsearch)

    在上一篇博客<使用logstash将Mysql中的数据导入到ElasticSearch中(详细步骤,win_Elasticsearch)>中我们提到将数据插入到es中,那我怎么知道数据是否 ...

  4. linux的python2.7安装pip的三种方式,Linux(Centos)在装有Python2的情况下安装Python3 两版本并存,安装完python3后pip、pip2都指向了python3

    安装pip的三种方式 pip是python的一个工具,用来安装python包特别方便. Linux系统是是内置python程序,因为许多Linux内置文件都是使用python来编写的,比如说yum. ...

  5. spring配置datasource三种方式

    转自:http://blog.csdn.net/yangyz_love/article/details/8199207 1.使用org.springframework.jdbc.datasource. ...

  6. spring配置datasource三种方式 数据库连接

    1.使用org.springframework.jdbc.datasource.DriverManagerDataSource  说明:DriverManagerDataSource建立连接是只要有连 ...

  7. 在Tomcat配置JNDI数据源的三种方式

    转载自   在Tomcat配置JNDI数据源的三种方式 在我过去工作的过程中,开发用服务器一般都是Tomcat,数据源的配置往往都是在applicationContext.xml中配置一个dataSo ...

  8. mysql datasource property_spring配置datasource三种方式

    3.使用org.springframework.jndi.JndiObjectFactoryBean 说明:JndiObjectFactoryBean 能够通过JNDI获取DataSource jav ...

  9. java连接access数据库的三种方式以及远程连接

    连接access数据库,网上的内容很多,尝试的过程中也会遇到各种问题,没有特别好的介绍,所以自己想总结一下,日后备用. 这里需要提前说明下,win7系统32bit和64bit默认安装的access都是 ...

最新文章

  1. [QA]Python字节码优化问题
  2. python调用api应用接口_第三方免费快递物流查询接口平台(快递鸟)api接口调用...
  3. 夺命雷公狗---ECSHOP---08---商品页的拇改成星星
  4. vue实现查询多条记录_vue.js 实现天气查询
  5. Android ContextCompat 使用详解
  6. [渝粤教育] 西南科技大学 刑法学 在线考试复习资料(1)
  7. android与web服务器,Android之与WEB服务器交换数据(转)
  8. 北大青鸟 ASP.NET视频教程批量下载
  9. 微信小微商户申请入驻接口PHP示例
  10. 使用Git上传项目到Gitgub
  11. linux mysql.sock文件_关于linux上mysql.sock文件的个人理解
  12. 关于程序组团队建设的几点想法
  13. 四芯水晶头电话线的接法
  14. 存储单元、存储字、字、字节
  15. 3 A VTT端接 稳压器 NCP51200MNTXG资料
  16. 华为云区块链的跨云联通能力构建
  17. 华为云弹性文件服务 SFS
  18. 新买的笔记本电脑怎么分盘_笔记本电脑验机指南
  19. VMware vSphere 虚拟化实施手册及故障案例 | 多图
  20. 视频文件太大如何压缩变小?

热门文章

  1. django-带签名的cookie
  2. python Web抓取(一)[没写完]
  3. Python的简史:一切从讨厌花括号开始
  4. layui基础上的tree菜单动态渲染;
  5. spawn-fcgi 启动python 程序失败
  6. python 安装中的错误解决
  7. simlescalar CPU模拟器源代码分析
  8. CodeBlocks问题解决
  9. Mono for Android—初体验之“电话拨号器”
  10. shell例题3-百度面试题