相关学习推荐:

华为实验讲解:实验6-2 配置PPPOE客户端https://www.bilibili.com/video/BV18S4y1a7S7?spm_id_from=333.999.0.0

实验目的

1.理解PPPoE的原理

2.掌握PPPoE的配置

实验拓扑

实验需求

1.根据实验拓扑图,完成设备的基本配置;

2.R1是PPPoE服务器,R2是PPPoE客户端,R2去R1认证并获得IP地址。

实验步骤

步骤1:设备的基本配置

配置PC1:
VPCS> set pcname PC1   //设置主机名
PC1> ip 192.168.1.1/24 192.168.1.254   //设置IP地址与默认网关配置PC2:
VPCS> set pcname PC2   //设置主机名
PC2> ip 192.168.2.1/24 192.168.2.254   //设置IP地址与默认网关

配置R1:

Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#no ip domain-lookup
R1(config)#line console 0
R1(config-line)#exec-timeout 0 0
R1(config-line)#logging synchronous
R1(config-line)#end
R1#

配置R2:

Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#no ip domain-lookup
R2(config)#line console 0
R2(config-line)#exec-timeout 0 0
R2(config-line)#logging synchronous
R2(config-line)#exit
R2(config)#interface Eth0/1
R2(config-if)#ip address 192.168.1.254 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface Eth0/2
R2(config-if)#ip address 192.168.2.254 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#end
R2#

步骤2:配置PPPoE

配置R1:

R1(config)#username xmws password wisdom
R1(config)#bba-group pppoe ToR2
R1(config-bba-group)#virtual-template 1
R1(config-bba-group)#exit
R1(config)#interface ethernet0/0
R1(config-if)#pppoe enable group ToR2
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface virtual-template 1
R1(config-if)#ip address 12.1.1.1 255.255.255.252
R1(config-if)#ip mtu 1492
R1(config-if)#peer default ip address pool PoR2
R1(config-if)#ppp authentication chap
R1(config-if)#exit
R1(config)#ip local pool PoR2 12.1.1.2
R1(config)#end
R1#

配置R2:

R2(config)#interface ethernet0/0
R2(config-if)#pppoe enable
R2(config-if)#pppoe-client dial-pool-number 1
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface dialer 1
R2(config-if)#ip mtu 1492
R2(config-if)#dialer pool 1
R2(config-if)#ip address negotiated
R2(config-if)#encapsulation ppp
R2(config-if)#ppp ipcp route default
R2(config-if)#ppp chap hostname xmws
R2(config-if)#ppp chap password wisdom
R2(config-if)#end
R2#

步骤3:检查PPPoE

检查R2:

R2#show ip interface brief
Interface                  IP-Address     OK? Method Status                Protocol
Ethernet0/0                unassigned      YES unset  up                    up
Ethernet0/1                192.168.1.254   YES manual up                    up
Ethernet0/2                192.168.2.254 YES manual up                    up
Ethernet0/3                unassigned      YES unset  administratively down down
Serial1/0                  unassigned      YES unset  administratively down down
Serial1/1                  unassigned     YES unset  administratively down down
Serial1/2                  unassigned      YES unset  administratively down down
Serial1/3                  unassigned      YES unset  administratively down down
Dialer1                    12.1.1.2        YES IPCP   up                    up
Virtual-Access1            unassigned      YES unset  up                    up
Virtual-Access2            unassigned      YES unset  up                    up R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter areaN1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static route, H - NHRP, l - LISPa - application route+ - replicated route, % - next hop override, p - overrides from PfRGateway of last resort is 12.1.1.1 to network 0.0.0.0S*    0.0.0.0/0 [1/0] via 12.1.1.112.0.0.0/32 is subnetted, 2 subnets
C        12.1.1.1 is directly connected, Dialer1
C       12.1.1.2 is directly connected, Dialer1192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Ethernet0/1
L        192.168.1.254/32 is directly connected, Ethernet0/1192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, Ethernet0/2
L        192.168.2.254/32 is directly connected, Ethernet0/2R2#show interfaces dialer 1
Dialer1 is up, line protocol is up (spoofing)Hardware is UnknownInternet address is 12.1.1.2/32MTU 1492 bytes, BW 56 Kbit/sec, DLY 20000 usec,reliability 255/255, txload 1/255, rxload 1/255Encapsulation PPP, LCP Closed, loopback not setKeepalive set (10 sec)DTR is pulsed for 1 seconds on resetInterface is bound to Vi2Last input never, output never, output hang neverLast clearing of "show interface" counters 00:20:57Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0Queueing strategy: fifoOutput queue: 0/40 (size/max)5 minute input rate 0 bits/sec, 0 packets/sec5 minute output rate 0 bits/sec, 0 packets/sec6 packets input, 84 bytes250 packets output, 3500 bytes
Bound to:
Virtual-Access2 is up, line protocol is upHardware is Virtual Access interfaceMTU 1492 bytes, BW 56 Kbit/sec, DLY 20000 usec,reliability 255/255, txload 1/255, rxload 1/255--More--

步骤4:配置NAT上网

配置R2:

R2(config)#interface E0/1
R2(config-if)#ip nat inside
R2(config)#interface E0/2
R2(config-if)#ip nat inside
R2(config)#interface dialer 1
R2(config-if)#ip nat outside
R2(config)#ip nat inside source list 1 interface dialer 1 overloa

【技术分享】如何通过PPPOE拨号上网相关推荐

  1. linux中的pppoe拨号上网

    实例:(linux中的pppoe拨号上网) ① 安装软件:把下载的pppoe传到linux下的/root目录下,在终端对软件进行拆包: ll:查看目录,能看见软件包的名字 tar -zxvf rp-p ...

  2. 关于Ubuntu 使用PPPoe拨号上网,导致wifi没有错误。

    因为宿舍网是拨号上网, 刚从 温都死 转向Ubuntu(LINUX桌面版)基本上陌生的操作环境,所以百度一下 Ubuntu怎么拨号上网. gedit pppoeconfig  终端输入,就可以操作配置 ...

  3. Ubuntu PPPoE拨号上网

    安装PPPoE 有网络连接的情况下 sudo apt install pppoeconf 无网络连接的情况下 在其它电脑上依次下载以下软件包(注意选择适合自己硬件类型的版本) libc6 ifupdo ...

  4. 【windows10】使用宽带拨号即PPPoE拨号上网

    [windows10]使用宽带拨号即PPPoE拨号上网 1.背景 2.宽带拨号 1.背景 在接入互联网实现上网时,我目前使用的是PPPoE拨号上网. PPPoE(Point-to-Point Prot ...

  5. Kali PPPoE 拨号上网

    Kali PPPoE 拨号上网 1.下载PPPoE 2.Terminal > nm-connection-editor 3.Settings---->Network---->点击PP ...

  6. RouterOS(ROS)软路由PPPOE拨号上网配置指南(附授权镜像下载)

    本文将从零开始讲解Mikrotik RouterOS(ROS) PPPOE拨号上网配置,通过WinBox图形化操作,助力小白用户成功使用ROS进行上网,使用ROS内置的DNS缓存达到网页秒开的效果. ...

  7. linux桌面版拨号连接,linux中的pppoe拨号上网

    实例:(linux中的pppoe拨号上网) ①安装软件:把下载的pppoe传到linux下的/root目录下,在终端对软件进行拆包: ll:查看目录,能看见软件包的名字 tar -zxvf rp-pp ...

  8. linux pppoe拨号上网

    linux pppoe拨号上网 安装软件和修改配置文件: [root@cv ~]# yum -y install rp-pppoe [root@cv ~]# cp /usr/share/doc/rp- ...

  9. 路由器如何设置pppoe拨号上网

    新购买的路由器如何设置,怎么自动拨号.怎么设置wifi.怎么修改默认登录名称与密码?成为很多人的困扰,甚至被蹭网,无奈原本就不通畅的宽带变得回归到n年前的龟速!怎么办? 路由器设置pppoe拨号上网的 ...

  10. linux拨号上网指令,linux中的pppoe拨号上网

    实例:(linux中的pppoe拨号上网) ①安装软件:把下载的pppoe传到linux下的/root目录下,在终端对软件进行拆包: ll:查看目录,能看见软件包的名字 tar -zxvf rp-pp ...

最新文章

  1. linux查看msf安装目录,linux系统安装msf的过程详解
  2. 最新批量***dedecms|dedecms最新0day
  3. Linux 安装 Elasticsearch-rtf
  4. Window密码恢复的方法(转)
  5. 服务器搬迁方案_数据中心机房改造搬迁IDC机房工程建设
  6. 2015已经过去三分之一了
  7. 【linux】 rm 防止误删
  8. vs2017调用linux脚本,[代码] ShellExecute调用外部程序_VS2017
  9. 一步一步写算法(之链表逆转)
  10. C语言霍夫曼编码压缩,数据结构大作业——哈夫曼编码压缩BMP格式文件
  11. java8-谓词(predicate)
  12. ssm怎么自动排列序号6位数_小学数学1~6年级知识薄弱点应对方法汇总,建议收藏!...
  13. 基于Nonebot框架的QQ机器人词库生成器
  14. DNS和VIP的区别
  15. 因为毕业半年挣了100万,帅地在CSDN被喷上热榜
  16. SQL高级教程(三十)- - SQL NULL 函数
  17. html5 多点触控 缩放,WebBrowser禁用触摸缩放
  18. python数学库函数包括求最大公约数函数吗_pythonmathcot函数_math库是python语言的数学模块吗_Python中的数学模块:...
  19. 优秀产品经理的18种能力
  20. 专访富数科技吴海斌:隐私计算头部效应明显,2022年落地才是硬道理

热门文章

  1. 汇编语言程序设计-贺利坚-专题视频课程
  2. 112123---123456
  3. 【Windows】之搭建 Go 语言环境
  4. 虚拟机架设传奇3服务器,WIN8安装虚拟机玩传奇3教程-转
  5. 记录自己的成长--个人日记1
  6. R下运行UMAP方案
  7. JDK8新特性01-Lambda表达式
  8. php循环图案正方形,javascript输出指定行数正方形图案效果的实现方法
  9. AndroidStudio界面跳转
  10. Github:this exceeds GitHub‘s file size limit of 100.00 MB