实验目的:
验证RIP负载均衡,而RIP的负载均衡是由跳数决定,如果跳数相同则起到负载均衡.
实验拓扑图:
实验内容:
路由器的基本配置
R上的
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
照样粘贴上基本的命令
Router(config)#enable password cisco
Router(config)#no ip domain-lookup
Router(config)#line con 0
Router(config-line)# exec-timeout 0 0
Router(config-line)# logging synchronous
Router(config-line)#
Router(config-line)#line aux 0
Router(config-line)# exec-timeout 0 0
Router(config-line)# logging synchronous
Router(config-line)#line vty 0 4
Router(config-line)#
Router(config-line)#
Router(config-line)# exec-timeout 0 0
Router(config-line)# password cisco
Router(config-line)#
Router(config-line)# login
Router(config-line)#
Router(config-line)#
Router(config-line)#alias exec a sh ip int bri
Router(config)#alias exec b sh ip route
Router(config)#alias exec c sh ip route rip
Router(config)#alias exec d sh run
配置好名称,接口地址
Router(config)#hostname R1
R1(config)#interface loopback 1
R1(config-if)#ip address <?xml:namespace prefix = st1 ns = "urn:schemas-microsoft-com:office:smarttags" />1.1.1.1 255.255.255.0
R1(config-if)#exit
R1(config)#interface e0/0
R1(config-if)#ip address 172.16.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface s1/0
R1(config-if)#ip address
*Mar  1 00:14:04.503: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Mar  1 00:14:05.503: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up
R1(config-if)#ip address 172.16.2.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R2上的
Router(config)#hostname R2
R2(config)#interface s1/0
R2(config-if)#ip address 172.16.2.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface s1/1
R2(config-if)#ip address 172.16.
*Mar  1 00:14:57.579: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
R2(config-if)#ip address 172.16.3.1
*Mar  1 00:14:58.583: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up
R2(config-if)#ip address 172.16.3.1 255.255.255.0
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#exit
R3上的
Router(config)#hostname R3
R3(config)#interface loopback 0
R3(config-if)#ip address 3.3.3.3 255.255.255.0
R3(config-if)#exit
R3(config)#interface e0/0
R3(config-if)#ip address 172.16.1.2 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface s1/1
R3(config-if)#ip address 172.16.3.2 255.255.255.0
R3(config-if)#no shutdown
好了,现在开始配置RIP
先在R1上,宣告接口网络
R1(config)#router rip
R1(config-router)#network 1.0.0.0
R1(config-router)#network 172.16.2.0
R1(config-router)#network 172.16.1.0
R2上的,两样的格式
R2(config)#router rip
R2(config-router)#network 172.16.2.0
R2(config-router)#network 172.16.3.0
R3上的
R3(config)#router rip
R3(config-router)#network 3.0.0.0
R3(config-router)#network 172.16.1.0
R3(config-router)#network 172.16.3.0
配置好后,查看一下路由表
R1的路由表
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />
Gateway of last resort is not set
     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback1
R    3.0.0.0/8 [120/1] via 172.16.1.2, 00:00:03, Ethernet0/0
     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.1.0 is directly connected, Ethernet0/0
C       172.16.2.0 is directly connected, Serial1/0
R       172.16.3.0 [120/1] via 172.16.2.2, 00:00:10, Serial1/0
                   [120/1] via 172.16.1.2, 00:00:03, Ethernet0/0
注意最后的一条RIP路由,可以看到去172.16.3.0的路由已经产生了负载均衡的现象,因为它们的跳数是相同的.
R2上的路由表
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R    1.0.0.0/8 [120/1] via 172.16.2.1, 00:00:24, Serial1/0
R    3.0.0.0/8 [120/1] via 172.16.3.2, 00:00:03, Serial1/1
     172.16.0.0/24 is subnetted, 3 subnets
R       172.16.1.0 [120/1] via 172.16.2.1, 00:00:24, Serial1/0
                   [120/1] via 172.16.3.2, 00:00:03, Serial1/1
C       172.16.2.0 is directly connected, Serial1/0
C       172.16.3.0 is directly connected, Serial1/1
很清楚也显示了所有的链路.
R3的路由表
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R    1.0.0.0/8 [120/1] via 172.16.1.1, 00:00:03, Ethernet0/0
     3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.1.0 is directly connected, Ethernet0/0
R       172.16.2.0 [120/1] via 172.16.3.1, 00:00:17, Serial1/1
                   [120/1] via 172.16.1.1, 00:00:03, Ethernet0/0
C       172.16.3.0 is directly connected, Serial1/1
最后,用扩展的ping命令来测试负载均衡
先从R1的loopback 0 接口上pingR3的S1/1口
R1#ping
Protocol [ip]:
Target IP address: 172.16.3.2
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 1.1.1.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]: r
Number of hops [ 9 ]:
Loose, Strict, Record, Timestamp, Verbose[RV]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.2, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
Packet has IP options:  Total option bytes= 39, padded length=40
 Record route: <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
Reply to request 0 (136 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (172.16.2.1)
   (172.16.3.1)
   (172.16.3.2)
   (172.16.1.2)
   (1.1.1.1) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list
Reply to request 1 (112 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (172.16.1.1)
   (172.16.3.2)
   (172.16.1.2)
   (1.1.1.1) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list
Reply to request 2 (160 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (172.16.2.1)
   (172.16.3.1)
   (172.16.3.2)
   (172.16.1.2)
   (1.1.1.1) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list
Reply to request 3 (112 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (172.16.1.1)
   (172.16.3.2)
   (172.16.1.2)
   (1.1.1.1) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list
Reply to request 4 (160 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (172.16.2.1)
   (172.16.3.1)
   (172.16.3.2)
   (172.16.1.2)
   (1.1.1.1) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list
可以注意到数据包的路径可以发现,来回的路径不同,也就是说数据包是走了负载均衡的.

转载于:https://blog.51cto.com/bennie/101394

CCNA培训课总结笔记--RIPv1负载均衡(六)相关推荐

  1. CCNA培训课总结笔记(一)

    前记:虽然只有短短的五天CCNA培训,但学习的东西还挺多的,压力也很大.老师课堂上又讲得太快,笔记都记得一塌糊涂.只能回来后慢慢整理一下,在这里写出来和大家分享一下,匆促落笔,难免有错误,不足之处,望 ...

  2. CCNA培训课总结笔记--RIP的基本配置(五)

    实验目的: 熟悉RIPV1的基本配置,理解RIPV1的工作原理过程,以及RIPV1的路由表的学习的过程,理解RIPV1的几大特性. 实验拓扑图: 实验内容: 路由器的基本配置 R1 的配置 Route ...

  3. CCNA培训课总结笔记--交换机的基本配置(十三)

    实验目的: 熟悉交换机的基本配置,学会在交换机上划分VLAN及如何将接口划分到指定的VLAN.本实验主要是用模拟器DynamipsGUI及3640的IOS文件做的实验,所以配置的命令有些会有出入. 实 ...

  4. CCNA培训课总结笔记--配置OSPF实验(十一)

    实验目的: 理解OSPF协议,掌握配置OSPF协议的配置及验证命令. 实验拓扑图: 实验内容: 路由器的配置 R1上的配置 进入全局配置模式,同样地粘贴上基本路由命令 Router(config)#e ...

  5. 架构师课程之-haproxy专业级负载均衡软件权威讲解

    老男孩培训顶级架构师课程[企业场景haproxy专业负载均衡架构方案]教学大纲 2014/4/12日激情开讲! 伙伴们,既然选择了远方,就只顾风雨兼程! 老男孩老师已经做好了自断筋脉,把全部功力都传给 ...

  6. linux cdn服务器,wdcdn系统,CDN缓存系统,CDN加速系统,多节点CDN自架系统,CDN安装配置部署--Linux解决方案,技术支持与培训,服务器架构,性能优化,负载均衡,集群分流...

    WDCDN缓存加速管理系统,CDN软件,CDN管理平台,CDN解决方案 wdCDN是一套基于squid架构开发的CDN缓存加速系统及管理系统,高效,稳定,安全. 可帮助大中小站长或大中小企业低成本,快 ...

  7. 渡一教育公开课web前端开发JavaScript精英课学习笔记(二十六)JavaScript 打砖块

    打砖块 <!DOCTYPE html> <html><head><meta charset="UTF-8"><meta nam ...

  8. Nginx 反向代理、负载均衡、页面缓存、URL重写及读写分离详解(1)

    大纲 一.前言 二.环境准备 三.安装与配置Nginx 四.Nginx之反向代理 五.Nginx之负载均衡 六.Nginx之页面缓存 七.Nginx之URL重写 八.Nginx之读写分离 注,操作系统 ...

  9. 最新版Spring Cloud Alibaba微服务架构-Ribbon负载均衡篇

    文章目录 前言 一.Ribbon核心概念 二.服务器端负载均衡和Riboon客户端负载均衡 1.服务器端负载均衡: 2.Riboon客户端负载均衡: 三.Ribbon策略 四.Ribbon配置使用 五 ...

最新文章

  1. 2015年国际智慧教育展览会盛大开幕
  2. 消息队列服务器安装失败,开发环境下的RocketMQ完整安装步骤、错误分析以及示例...
  3. [crypto]-90-crypto的一些术语和思考[inProgress]
  4. linux openfire mysql_Openfire 服务器在Linux上的安装
  5. redhat简单安装Samba,JDK环境,Tomcat,Oracle11G
  6. SPSS Sobel检验(图文+数据集)【SPSS 044期】
  7. 机器学习数据预处理之字符串转数字
  8. 跟父母还是要保持一定的距离感
  9. iOSAPP创建桌面快捷方式
  10. 用C语言输入半径求球体的体积
  11. 使用JSONP解决跨域
  12. [2022-04-27] refresh PDB
  13. nginx反向代理实现指定接口访问指定机器
  14. 非线性方程的数值解法:正割法 python
  15. 远程调用中间件(RPC)
  16. 常见的关系型数据库有哪些
  17. 致创业新人,我网络创业的一些心得。
  18. Note For Linux By Jes(19)-Linux 备份策略
  19. 顶级专家寄语OpenStack Days China,开源之火已成燎原之势
  20. Tensorflow问题记录

热门文章

  1. qt之CheckBox选中与未选中的使用
  2. Android Studio自带模拟器读SDcard失败的解决方法
  3. 配置Nginx端口转发时的问题
  4. 【Android App】给三维的地球仪贴上动物贴纸实战(附源码和演示 超详细必看)
  5. 【产品宣传广告片制作软件】Focusky教程 | 前景设置功能
  6. e自然数到底是什么鬼
  7. mysql5.7 数据库文件_mysql57 数据库文件
  8. 基于AT89C52做秒表0~99秒
  9. MATLAB极坐标与xy坐标互相转换_不改变数据形状_极坐标变量v_p(theta,r)的平面图
  10. CSDN学霸课表——信息安全工程师(软考中级)