最近看了些Segment Routing的一些资料,官网找到的实验都是基于IOS-XR系统的,于是自己查看配置手册试着做了个简单实验测试下效果。

拓扑如下:


R1、R2、R3、R5、R6、R7之间运行OSPF和SR。
需要实现R1到R7的路径可以通过SRTE调控。

相关配置:

R1:

version 16.6
service timestamps debug datetime localtime
service timestamps log datetime localtime
!
hostname R1
!
enable secret 5 $1$iHyN$7.g231aGWy4GvTqV5r8yL1
!
aaa new-model
!
clock timezone Beijing 8 0
!
!
no ip domain lookup
!
mpls traffic-eng tunnels
!#开启MPLS流量工程
!
segment-routing mpls!connected-prefix-sid-mapaddress-family ipv41.1.1.1/32 index 1 range 1 exit-address-family!#开启SR并映射1.1.1.1的SID为16001
!
username cisco privilege 15 secret 5 $1$4pA7$0P6EYBG0CR0gNFIRuNQ.5/
!
!
interface Loopback0ip address 1.1.1.1 255.255.255.255ip ospf network point-to-pointip ospf 1 area 0
!
interface Tunnel17ip unnumbered Loopback0tunnel mode mpls traffic-engtunnel destination 7.7.7.7tunnel mpls traffic-eng autoroute announcetunnel mpls traffic-eng path-option 1 explicit name 1-2-3-7 segment-routingtunnel mpls traffic-eng path-option 2 explicit name 1-5-6-7 segment-routingtunnel mpls traffic-eng path-option 3 explicit name 1-2-3-5-6-7 segment-routingtunnel mpls traffic-eng path-option 4 explicit name 1-2-3-5-2-6-7 segment-routingtunnel mpls traffic-eng path-selection metric igptunnel mpls traffic-eng load-share 10
!
interface GigabitEthernet1ip address 192.168.12.1 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!#接口下需要开启MPLS的流量工程不然tunnel接口无法激活,并提示去往下一跳的接口不可达
interface GigabitEthernet2ip address 192.168.15.1 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
!
router ospf 1router-id 1.1.1.1segment-routing area 0 mplssegment-routing mplsmpls traffic-eng router-id Loopback0mpls traffic-eng area 0
!
ip explicit-path name 1-2-3-7 enableindex 1 next-label 16002index 2 next-label 16003index 3 next-label 16007
!
ip explicit-path name 1-5-6-7 enableindex 1 next-label 16005index 2 next-label 16006index 3 next-label 16007
!
ip explicit-path name 1-2-3-5-6-7 enableindex 1 next-label 16002index 2 next-label 16003index 3 next-label 16005index 4 next-label 16006index 5 next-label 16007
!
ip explicit-path name 1-2-3-5-2-6-7 enableindex 1 next-label 16002index 2 next-label 16003index 3 next-label 16005index 4 next-label 16002index 5 next-label 16006index 6 next-label 16007
!#下一跳经过的标签设备,实际上控制流量的路径

R2:

version 16.6
service timestamps debug datetime localtime
service timestamps log datetime localtime
!
hostname R2
!
!
enable secret 5 $1$u41o$kce3mcpuxRE8ReCghFulx0
!
aaa new-model
!
no ip domain lookup
!
mpls traffic-eng tunnels
!
segment-routing mpls!connected-prefix-sid-mapaddress-family ipv42.2.2.2/32 index 2 range 1 exit-address-family!
!
username cisco privilege 15 secret 5 $1$hIlL$F6cSHbfm4Ww.n1tIFHarL1
!
interface Loopback0ip address 2.2.2.2 255.255.255.255ip ospf network point-to-pointip ospf 1 area 0
!
interface GigabitEthernet1ip address 192.168.12.2 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
interface GigabitEthernet2ip address 192.168.23.2 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
interface GigabitEthernet3ip address 192.168.25.2 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
interface GigabitEthernet4ip address 192.168.26.2 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
router ospf 1router-id 2.2.2.2segment-routing area 0 mplssegment-routing mplsmpls traffic-eng router-id Loopback0mpls traffic-eng area 0
!

R3:

version 16.6
service timestamps debug datetime localtime
service timestamps log datetime localtime
!
hostname R3
!
enable secret 5 $1$b1os$BJXuUtqgSB618QuaXRRMi/
!
aaa new-model
!
no ip domain lookup
!
mpls traffic-eng tunnels
!
!
segment-routing mpls!connected-prefix-sid-mapaddress-family ipv43.3.3.3/32 index 3 range 1 exit-address-family!
username cisco privilege 15 secret 5 $1$MD6m$0XtlNNa5lqaMED7e.w6tL.
!
!
interface Loopback0ip address 3.3.3.3 255.255.255.255ip ospf network point-to-pointip ospf 1 area 0
!
interface GigabitEthernet1ip address 192.168.37.3 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
interface GigabitEthernet2ip address 192.168.23.3 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
interface GigabitEthernet3ip address 192.168.36.3 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
interface GigabitEthernet4ip address 192.168.35.3 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
router ospf 1segment-routing area 0 mplssegment-routing mplsmpls traffic-eng router-id Loopback0mpls traffic-eng area 0
!

R5:

version 16.6
service timestamps debug datetime localtime
service timestamps log datetime localtime
!
hostname R5
!
enable secret 5 $1$oFyQ$Ut2gzGdZLHGqKLvECqeTP0
!
aaa new-model
!
!
no ip domain lookup
!
mpls traffic-eng tunnels
!
segment-routing mpls!connected-prefix-sid-mapaddress-family ipv45.5.5.5/32 index 5 range 1 exit-address-family!
username cisco privilege 15 secret 5 $1$niXI$PCbPObKVCf/PdsOcYosq..
!
interface Loopback0ip address 5.5.5.5 255.255.255.255ip ospf network point-to-pointip ospf 1 area 0
!
interface GigabitEthernet1ip address 192.168.15.5 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
interface GigabitEthernet2ip address 192.168.56.5 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
interface GigabitEthernet3ip address 192.168.25.5 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
interface GigabitEthernet4ip address 192.168.35.5 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
router ospf 1router-id 5.5.5.5segment-routing area 0 mplssegment-routing mplsmpls traffic-eng router-id Loopback0mpls traffic-eng area 0
!

R6:

version 16.6
service timestamps debug datetime localtime
service timestamps log datetime localtime
!
hostname R6
!
enable secret 5 $1$Po5z$6s71Kv37hrd15UHpSDS3v0
!
aaa new-model
!
no ip domain lookup
!
!
mpls traffic-eng tunnels
!
!
segment-routing mpls!connected-prefix-sid-mapaddress-family ipv46.6.6.6/32 index 6 range 1 exit-address-family!
username cisco privilege 15 secret 5 $1$xdXH$tg7sf/WsTLO9Q8l.26weM.
!
interface Loopback0ip address 6.6.6.6 255.255.255.255ip ospf network point-to-pointip ospf 1 area 0
!
interface GigabitEthernet1ip address 192.168.67.6 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
interface GigabitEthernet2ip address 192.168.56.6 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
interface GigabitEthernet3ip address 192.168.36.6 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
interface GigabitEthernet4ip address 192.168.26.6 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
router ospf 1router-id 6.6.6.6segment-routing area 0 mplssegment-routing mplsmpls traffic-eng router-id Loopback0mpls traffic-eng area 0
!

R7:

version 16.6
service timestamps debug datetime localtime
service timestamps log datetime localtime
!
hostname R7
!
enable secret 5 $1$wF9L$is9ZSr7ekX/OMFQ2ZElaj1
!
aaa new-model
!
!
no ip domain lookup
!
mpls traffic-eng tunnels
!
segment-routing mpls!connected-prefix-sid-mapaddress-family ipv47.7.7.7/32 index 7 range 1 exit-address-family!
!
username cisco privilege 15 secret 5 $1$SHrU$gaLUTcd5xo6T2GS0jCZRs/
!
interface Loopback0ip address 7.7.7.7 255.255.255.255ip ospf network point-to-pointip ospf 1 area 0
!
interface GigabitEthernet1ip address 192.168.37.7 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
interface GigabitEthernet2ip address 192.168.67.7 255.255.255.0ip ospf network point-to-pointip ospf 1 area 0mpls traffic-eng tunnels
!
router ospf 1router-id 7.7.7.7segment-routing area 0 mplssegment-routing mplsmpls traffic-eng router-id Loopback0mpls traffic-eng area 0
!

查看状态

R1:

R1#show version
Cisco IOS XE Software, Version 16.06.05
Cisco IOS Software [Everest], Virtual XE Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 16.6.5, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2018 by Cisco Systems, Inc.
Compiled Mon 10-Dec-18 13:07 by mcpreCisco IOS-XE software, Copyright (c) 2005-2018 by cisco Systems, Inc.
All rights reserved.  Certain components of Cisco IOS-XE software are
licensed under the GNU General Public License ("GPL") Version 2.0.  The
software code licensed under GPL Version 2.0 is free software that comes
with ABSOLUTELY NO WARRANTY.  You can redistribute and/or modify such
GPL code under the terms of GPL Version 2.0.  For more details, see the
documentation or "License Notice" file accompanying the IOS-XE software,
or the applicable URL provided on the flyer accompanying the IOS-XE
software.ROM: IOS-XE ROMMONR1 uptime is 2 hours, 39 minutes
Uptime for this control processor is 2 hours, 42 minutes
System returned to ROM by reload
System image file is "bootflash:packages.conf"
Last reload reason: reloadThis product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.htmlIf you require further assistance please contact us by sending email to
export@cisco.com.License Level: ax
License Type: Default. No valid license found.
Next reload license Level: axcisco CSR1000V (VXE) processor (revision VXE) with 2190079K/3075K bytes of memory.
Processor board ID 9O8KIKS1UXW
4 Gigabit Ethernet interfaces
32768K bytes of non-volatile configuration memory.
3984864K bytes of physical memory.
7774207K bytes of virtual hard disk at bootflash:.
0K bytes of WebUI ODM Files at webui:.Configuration register is 0x2102R1#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static route, H - NHRP, l - LISPa - application route+ - replicated route, % - next hop override, p - overrides from PfRGateway of last resort is not set2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/2] via 192.168.12.2, 02:25:05, GigabitEthernet13.0.0.0/32 is subnetted, 1 subnets
O        3.3.3.3 [110/3] via 192.168.15.5, 02:25:00, GigabitEthernet2[110/3] via 192.168.12.2, 02:25:05, GigabitEthernet15.0.0.0/32 is subnetted, 1 subnets
O        5.5.5.5 [110/2] via 192.168.15.5, 02:25:05, GigabitEthernet26.0.0.0/32 is subnetted, 1 subnets
O        6.6.6.6 [110/3] via 192.168.15.5, 02:25:05, GigabitEthernet2[110/3] via 192.168.12.2, 02:25:05, GigabitEthernet17.0.0.0/32 is subnetted, 1 subnets
O        7.7.7.7 [110/4] via 7.7.7.7, 02:25:05, Tunnel17
O     192.168.23.0/24 [110/2] via 192.168.12.2, 02:25:05, GigabitEthernet1
O     192.168.25.0/24 [110/2] via 192.168.15.5, 02:25:05, GigabitEthernet2[110/2] via 192.168.12.2, 02:25:05, GigabitEthernet1
O     192.168.26.0/24 [110/2] via 192.168.12.2, 02:25:05, GigabitEthernet1
O     192.168.35.0/24 [110/2] via 192.168.15.5, 02:25:05, GigabitEthernet2
O     192.168.36.0/24 [110/3] via 192.168.15.5, 02:25:00, GigabitEthernet2[110/3] via 192.168.12.2, 02:25:05, GigabitEthernet1
O     192.168.37.0/24 [110/3] via 192.168.15.5, 02:25:00, GigabitEthernet2[110/3] via 192.168.12.2, 02:25:05, GigabitEthernet1
O     192.168.56.0/24 [110/2] via 192.168.15.5, 02:25:05, GigabitEthernet2
O     192.168.67.0/24 [110/3] via 192.168.15.5, 02:25:05, GigabitEthernet2[110/3] via 192.168.12.2, 02:25:05, GigabitEthernet1R1#
R1#show ip ospf segment-routing sid-database OSPF Router with ID (1.1.1.1) (Process ID 1)OSPF Segment Routing SIDsCodes: L - local, N - label not programmed,M - mapping-serverSID             Prefix              Adv-Rtr-Id       Area-Id          Type
--------------  ------------------  ---------------  ---------------  ----------
1       (L)     1.1.1.1/32          1.1.1.1          0                Intra
2               2.2.2.2/32          2.2.2.2          0                Intra
3               3.3.3.3/32          3.3.3.3          0                Intra
5               5.5.5.5/32          5.5.5.5          0                Intra
6               6.6.6.6/32          6.6.6.6          0                Intra
7               7.7.7.7/32          7.7.7.7          0                IntraR1#
R1#show mpls forwarding-table table 0
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
16    [T]  Pop Label  17/1[TE-Bind]    0             Tu17       point2point
17         Pop Label  192.168.15.5-A   0             Gi2        192.168.15.5
18         Pop Label  192.168.12.2-A   0             Gi1        192.168.12.2
16002      Pop Label  2.2.2.2/32       0             Gi1        192.168.12.2
16003      16003      3.3.3.3/32       0             Gi1        192.168.12.216003      3.3.3.3/32       0             Gi2        192.168.15.5
16005      Pop Label  5.5.5.5/32       0             Gi2        192.168.15.5
16006      16006      6.6.6.6/32       0             Gi1        192.168.12.216006      6.6.6.6/32       0             Gi2        192.168.15.5
16007      16007      0-7.7.7.7/32-0   0             Gi1        192.168.12.216007      0-7.7.7.7/32-0   0             Gi2        192.168.15.5[T]     Forwarding through a LSP tunnel.View additional labelling info with the 'detail' optionA  - Adjacency SIDR1#show ip inte brief
Interface              IP-Address      OK? Method Status                Protocol
GigabitEthernet1       192.168.12.1    YES NVRAM  up                    up
GigabitEthernet2       192.168.15.1    YES NVRAM  up                    up
GigabitEthernet3       unassigned      YES NVRAM  administratively down down
GigabitEthernet4       unassigned      YES NVRAM  administratively down down
Loopback0              1.1.1.1         YES NVRAM  up                    up
Tunnel17               1.1.1.1         YES TFTP   up                    up      R1#show mpls traffic-eng tunnels segment-routing P2P TUNNELS/LSPs:Name: R1_t17                              (Tunnel17) Destination: 7.7.7.7Status:Admin: up         Oper: up     Path: valid       Signalling: connectedpath option 1, (SEGMENT-ROUTING) type explicit 1-2-3-7 (Basis for Setup)path option 2, (SEGMENT-ROUTING) type explicit 1-5-6-7path option 3, (SEGMENT-ROUTING) type explicit 1-2-3-5-6-7path option 4, (SEGMENT-ROUTING) type explicit 1-2-3-5-2-6-7Config Parameters:Bandwidth: 0        kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFFMetric Type: IGP (interface)Path Selection:Protection: any (default)Path-selection Tiebreaker:Global: not set   Tunnel Specific: not set   Effective: min-fill (default)Hop Limit: disabled [ignore: Explicit Path Option with all Strict Hops]Cost Limit: disabledPath-invalidation timeout: 10000 msec (default), Action: TearAutoRoute: enabled  LockDown: disabled Loadshare: 10 [200000000]auto-bw: disabledFault-OAM: disabled, Wrap-Protection: disabled, Wrap-Capable: NoActive Path Option Parameters:State: explicit path option 1 is activeBandwidthOverride: disabled  LockDown: disabled  Verbatim: disabledHistory:Tunnel:Time since created: 2 hours, 28 minutesTime since path change: 2 hours, 26 minutesNumber of LSP IDs (Tun_Instances) used: 81Current LSP: [ID: 81]Uptime: 2 hours, 26 minutesTun_Instance: 81Segment-Routing Path Info (ospf 1  area 0)Segment0[Node]: 2.2.2.2, Label: 16002Segment1[ - ]: Label: 16003Segment2[ - ]: Label: 16007
P2MP TUNNELS:P2MP SUB-LSPS:

路径测试

R1#traceroute 7.7.7.7 source lo0
Type escape sequence to abort.
Tracing the route to 7.7.7.7
VRF info: (vrf in name/id, vrf out name/id)1 192.168.12.2 [MPLS: Labels 16003/16007 Exp 0] 641 msec 606 msec 434 msec2 192.168.23.3 [MPLS: Label 16007 Exp 0] 543 msec 206 msec 2 msec3 192.168.37.7 1040 msec 670 msec 1038 msec

测试结果如上所示流量是R1-R2-R3-R7。

更换流量路径:

R1#mpls traffic-eng reoptimize tunnel 17 path-option 3
The targeted path-option is not in lock down mode. Continue? [no]: yes
R1#
R1#traceroute 7.7.7.7 source lo0
Type escape sequence to abort.
Tracing the route to 7.7.7.7
VRF info: (vrf in name/id, vrf out name/id)1 192.168.12.2 [MPLS: Labels 16003/16005/16006/16007 Exp 0] 1654 msec 1009 msec 1078 msec2 192.168.23.3 [MPLS: Labels 16005/16006/16007 Exp 0] 63 msec 1021 msec 1296 msec3 192.168.35.5 [MPLS: Labels 16006/16007 Exp 0] 613 msec 1016 msec 1013 msec4 192.168.56.6 [MPLS: Label 16007 Exp 0] 120 msec 2 msec 3 msec5 192.168.67.7 9 msec *  297 msec

现在的流量路径为R1-R2-R3-R5-R6-R7

R1#show mpls traffic-eng tunnels segment-routing P2P TUNNELS/LSPs:Name: R1_t17                              (Tunnel17) Destination: 7.7.7.7Status:Admin: up         Oper: up     Path: valid       Signalling: connectedpath option 3, (SEGMENT-ROUTING) type explicit 1-2-3-5-6-7 (Basis for Setup)path option 1, (SEGMENT-ROUTING) type explicit 1-2-3-7path option 2, (SEGMENT-ROUTING) type explicit 1-5-6-7path option 4, (SEGMENT-ROUTING) type explicit 1-2-3-5-2-6-7Config Parameters:Bandwidth: 0        kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFFMetric Type: IGP (interface)Path Selection:Protection: any (default)Path-selection Tiebreaker:Global: not set   Tunnel Specific: not set   Effective: min-fill (default)Hop Limit: disabled [ignore: Explicit Path Option with all Strict Hops]Cost Limit: disabledPath-invalidation timeout: 10000 msec (default), Action: TearAutoRoute: enabled  LockDown: disabled Loadshare: 10 [200000000]auto-bw: disabledFault-OAM: disabled, Wrap-Protection: disabled, Wrap-Capable: NoActive Path Option Parameters:State: explicit path option 3 is activeBandwidthOverride: disabled  LockDown: disabled  Verbatim: disabledHistory:Tunnel:Time since created: 2 hours, 32 minutesTime since path change: 29 secondsNumber of LSP IDs (Tun_Instances) used: 82Current LSP: [ID: 82]Uptime: 32 secondsSelection: reoptimizationPrior LSP: [ID: 81]ID: path option unknownRemoval Trigger: reoptimization completedTun_Instance: 82Segment-Routing Path Info (ospf 1  area 0)Segment0[Node]: 2.2.2.2, Label: 16002Segment1[Node]: 3.3.3.3, Label: 16003Segment2[Node]: 5.5.5.5, Label: 16005Segment3[Node]: 6.6.6.6, Label: 16006Segment4[Node]: 7.7.7.7, Label: 16007P2MP TUNNELS:P2MP SUB-LSPS:
R1#

再次切换路径测试:

R1#mpls traffic-eng reoptimize tunnel 17 path-option 4
The targeted path-option is not in lock down mode. Continue? [no]: yes
R1#
R1#
R1#traceroute 7.7.7.7 source lo0
Type escape sequence to abort.
Tracing the route to 7.7.7.7
VRF info: (vrf in name/id, vrf out name/id)1 192.168.12.2 [MPLS: Labels 16003/16005/16002/16006/16007 Exp 0] 700 msec 111 msec 984 msec2 192.168.23.3 [MPLS: Labels 16005/16002/16006/16007 Exp 0] 97 msec 1000 msec 1098 msec3 192.168.35.5 [MPLS: Labels 16002/16006/16007 Exp 0] 652 msec 439 msec 652 msec4 192.168.25.2 [MPLS: Labels 16006/16007 Exp 0] 445 msec 91 msec 2 msec5 192.168.26.6 [MPLS: Label 16007 Exp 0] 2 msec 2 msec 2 msec6 192.168.67.7 4 msec *  4 msec

现在的流量路径为R1-R2-R3-R5-R2-R6-R7
查看状态也确实如此:

R1#show mpls traffic-eng tunnels segment-routing      P2P TUNNELS/LSPs:Name: R1_t17                              (Tunnel17) Destination: 7.7.7.7Status:Admin: up         Oper: up     Path: valid       Signalling: connectedpath option 4, (SEGMENT-ROUTING) type explicit 1-2-3-5-2-6-7 (Basis for Setup)path option 1, (SEGMENT-ROUTING) type explicit 1-2-3-7path option 2, (SEGMENT-ROUTING) type explicit 1-5-6-7path option 3, (SEGMENT-ROUTING) type explicit 1-2-3-5-6-7Config Parameters:Bandwidth: 0        kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFFMetric Type: IGP (interface)Path Selection:Protection: any (default)Path-selection Tiebreaker:Global: not set   Tunnel Specific: not set   Effective: min-fill (default)Hop Limit: disabled [ignore: Explicit Path Option with all Strict Hops]Cost Limit: disabledPath-invalidation timeout: 10000 msec (default), Action: TearAutoRoute: enabled  LockDown: disabled Loadshare: 10 [200000000]auto-bw: disabledFault-OAM: disabled, Wrap-Protection: disabled, Wrap-Capable: NoActive Path Option Parameters:State: explicit path option 4 is activeBandwidthOverride: disabled  LockDown: disabled  Verbatim: disabledHistory:Tunnel:Time since created: 2 hours, 34 minutesTime since path change: 17 secondsNumber of LSP IDs (Tun_Instances) used: 83Current LSP: [ID: 83]Uptime: 20 secondsSelection: reoptimizationPrior LSP: [ID: 82]ID: path option unknownRemoval Trigger: reoptimization completedTun_Instance: 83Segment-Routing Path Info (ospf 1  area 0)Segment0[Node]: 2.2.2.2, Label: 16002Segment1[Node]: 3.3.3.3, Label: 16003Segment2[Node]: 5.5.5.5, Label: 16005Segment3[Node]: 2.2.2.2, Label: 16002Segment4[Node]: 6.6.6.6, Label: 16006Segment5[Node]: 7.7.7.7, Label: 16007P2MP TUNNELS:P2MP SUB-LSPS:
R1#

Cisco IOS上Segment Routing TE的简单实验相关推荐

  1. 《MPLS在Cisco IOS上的配置》一第 1 章 MPLS概述1.1 IP转发过程概述

    本节书摘来自异步社区<MPLS在Cisco IOS上的配置>一书中的第1章,第1.1节,作者 [美]Lancy Lobo, CCIE #4690 , Umesh Lakshman,更多章节 ...

  2. 段路由SR(Segment Routing)是基于源路由理念而设计的在网络上转发数据包的一种技术架构

    一.SR背景 段路由SR(Segment Routing)是基于源路由理念而设计的在网络上转发数据包的一种技术架构. SR-MPLS可以通过多个MPLS形成路径(基于标签转发)     SRv6可以通 ...

  3. Cisco ftp linux 权限,在Cisco设备上利用FTP传IOS文件

    用FTP在路由器和服务器之间传输文件,是在Cisco IOS Release 12.0中引进的.因为FTP是一个使用TCP/IP的面向连接的应用,所以它比TFTP提供更好的吞吐量和成功率,TFTP是用 ...

  4. 《CCNA安全640-554认证考试指南》——第6章在Cisco IOS设备上保护管理层

    本节书摘来自异步社区<CCNA安全640-554认证考试指南>一书中的第6章在Cisco IOS设备上保护管理层,作者 [美]Keith Barker , Scott Morris,更多章 ...

  5. iOS上简单推送通知(Push Notification)的实现

    iOS上简单推送通知(Push Notification)的实现 根据这篇很好的教程(http://www.raywenderlich.com/3443/apple-push-notification ...

  6. TFTP服务器在Cisco设备上的应用(上传、下载IOS)

    网络拓扑图 基于对安全的考虑,Cisco总是默认关闭TELNET服务,并且只有配置了远程登陆密码才能使用.同时还要配置使能密码,负责不能进入特权模式. 实验一:通过TFTP服务器从Cisco路由器上下 ...

  7. RFC8402 Segment Routing Architecture 翻译

     黑色为原文 紫色为翻译 红色为校注 Internet Engineering Task Force (IETF)                                            ...

  8. Segment Routing IGP Control Plane

    本文是在读C. Filsfils et al.所著的Segment Routing第一卷第5章后所做的总结. 因为知识和能力有限,本章很多内容还没有理解,因此这里呈现的是极简版的. 通过扩展IGP协议 ...

  9. Cisco IOS Unicast NAT 工作原理 [一]

    NAT技术的出现源于对私有网络安全性的要求以及IPv4地址不够用的现状.Cisco IOS所支持的常用NAT技术有以下几种.今天发现公司同事对Cisco NAT的实现理解的不好,导致配置出问题.这里就 ...

最新文章

  1. 动态内存检测工具Valgrind
  2. 谈谈你对摩尔定律的理解,摩尔定律当前还是继续有效的吗?
  3. 如何提高工作效率,拥有自由支配时间?
  4. 菜鸟入门Java语言学习六大要点
  5. Navicat使用教程:使用Navicat Premium 12自动执行数据库复制(四)
  6. C#语言之“string格式的日期时间字符串转为DateTime类型”的方法
  7. 关于配置中心的几个问题
  8. 计算机二级等级考试模拟试题,2016年计算机二级考试office模拟试题
  9. WIN server 2003 安装(AD)域控制器
  10. hx711压力传感器工作原理_压电式压力传感器原理,你了解吗?
  11. php网站怎么优化,如何优化你的Z-BlogPHP网站
  12. Linux内核的裁剪移植,Linux内核裁剪移植学习分享
  13. flink 时间语义、水位线(Watermark)、生成水位线、水位线的传递
  14. To invoke and to begin invoke, that is a question.
  15. 惠州 菜鸟机器人_京东PK阿里谁怕谁?菜鸟称:智能机器人仓库已在广东惠阳投入使用...
  16. python写stm32_python开发stm32例程
  17. 小程序常用单位解释大全
  18. 系统集成项目管理工程师有什么用?你真的了解吗
  19. 蓝桥杯:约数个数(C++)
  20. 试题 算法训练 逗志芃的危机

热门文章

  1. android原生浏览器6,Android手机实用选择 欧朋浏览器6.7版评测
  2. 桌宠java_java桌宠(透明)
  3. 有什么视频转文字软件?快把这些方法收好
  4. php如何把图片上传到mysql并显示图片到前段页面?
  5. 论文查重率要达到多少才能通过查重?
  6. 【小程序入门】App函数注册小程序实例
  7. 地下城与勇士(DNF)海上列车副本(列车上的海贼、夺回西部线、幽灵列车、 雾都赫伊斯、阿登高地、特快列车追击战、卡勒特指挥部)(童年的回忆)
  8. 电脑如何打印文件资料?电脑打印文件资料的教程
  9. html自适应电脑屏幕大小,html页面怎样能够自适应电脑屏幕宽度?
  10. Android Studio打包apk后手机无法安装 提示 “解析软件包时出现问题”