我写的不是很完整。如果有点CCNA的知识的朋友,我想可以看的懂的。

路由接口

AUX接猫,它能远程通过猫来控制路由。不能代动局域网上网

SO1 和SO2 是连接广域网的,DDN专线它连的是机代猫用的是V.35线

AUI粗览接口。接交换机的,它用的是RJ45转AUI的,是交叉线。

线序:一头是(白橙,橙,白绿,蓝,白蓝,绿,白棕,棕)

另一头是(白绿,绿,白橙,蓝,白蓝,橙,白棕,棕)

同种设备用交叉线。
交换机和集线器是同种设备
路由器和主机是同种设备
不同种设备用直连线
集线器和路由器
交换机和路由器
主机和交换机
主机和集线器

ASY(异步接口)。接猫池的。能接16个猫

BRI(基本速率接口) 它是接ISDN的。这个接口不能乱接线。容易把接口烧毁

CONSOLE(控制台)。是用来调试和配置路由器的。

如果SO是接猫的 ip address dhcp

清除 clear ip dhcp binding

-----------------------------------------------------------------------
route>enable
routeA#show version
routeA#show ip protocols
route#config terminal
route(config)#hostname routeA
routeA(config)#enable password 123
routeA(config)#enable secret 456789
routeA(config)#interface ethernet 0
routeA(config-if)#ip address 192.168.0.12 255.255.255.0
routeA(config-if)#ip address 192.168.0.12 255.255.255.0 secondary
routeA(config-if)# description this is lan port!~!
routeA(config-if)#media-type 10BaseT
routeA(config-if)#no shutdown
routeA(config-if)#exit
routeA(config)#interface serial 0
routeA(config-if)#ip address 202.106.0.23 255.255.255.0
routeA(config-if)#no ip address 202.106.0.23 255.255.255.0
routeA(config-if)#ip address 202.106.0.25 255.255.255.0 secondary
routeA(config-if)#bandwidch 512000
routeA(config-if)#clock rate 64000
routeA(config-if)#no clock rate 64000
routeA(config-if)#description this is wan port!~!
routeA(config-if)#no shutdown
routeA(config-if)#shutdown
routeA(config-if)#exit
route(config)#line console 0
route(config-line)#login
route(config-line)#password 123456
route(config-line)#exec-timeout 0 0
route(config-line)#logging synchronous
route(config-line)#exit
route(config)#line aux 0
route(config-line)#login
route(config-line)#password 123456
route(config-line)#exit
route(config)#line vty 0 4
route(config-line)#login
route(config-line)#password 123456
route(config-line)#exit
route(config)#exit
routeA#copy running-config startup-config
routeA#show users
routeA#clear line 11
routeA#traceroute [url]www.baidu.com[/url]
routeA#show ip interface ethernet 0
routeA#show startup-config
routeA#show ip interface serial 0
routeA#erase nvram
routeA#ping [url]www.sina.com.cn[/url]

-----------------------------------------------------------------------

tftp

routeA#copy running-config tftp
routeA#copy tftp running-config
routeA#copy startup-config tftp
routeA#copy tftp startup-config
routeA#show flash
routeA#copy flash tftp
routeA#copy tftp flash

-----------------------------------------------------------------------

破解密码
routeA#reload
路由器在一开始时按Ctrl+Break,输入o/r 0x2142
输入 I (重新启动)

routeA#config terminal
routeA(config)#config-register 0x2102

-----------------------------------------------------------------------
routeA#show hosts
routeA#terminal monitor
routeA#terminal 192.168.0.12
切换路由(Ctrl+shift+6)然后放开,按下X键返回自己的路由器]
routeA#resume 11 (把挂起来的路由切换回来)

-----------------------------------------------------------------------

routeA#show sessions
routeA#config terminal
routeA(config)#ip hosts router 192.168.0.23
routeA(config)#ip domain-name 192.168.0.23
routeA(config)#interface serial 0
routeA(config-if)#ip default-gateway 192.168.0.1
routeA(config-if)#full-duplex
routeA(config-if)#half-duplex
routeA(config-if)#exit
routeA(config)#ip dhcp-server 192.168.0.2
routeA(config)#ip subnet-zero
routeA(config)#exit
routeA#show controllers

------------------------------------------------------------------------
让路由器充当DHCP SERVER

routeA#config terminal
routeA(config)#ip dhcp pool yirehe
routeA(dhcp-config)#network 192.168.0.0 255.255.255.0
routeA(dhcp-config)#default-router 192.168.0.1
routeA(dhcp-config)#dns-server 202.106.0.20
routeA(dhcp-config)#netbios-name-server 192.168.0.5
routeA(dhcp-config)#lease 8
routeA(dhcp-config)#lease infinite
routeA(dhcp-config)#exit
routeA(config)#exit
routeA(config)#ip dhcp excluded-address 0.1-0.3(排除IP)
routeA#write memory
routeA#show ip dhcp binding

-----------------------------------------------------------------------
路由发现

routeA#config terminal
routeA(config)#cdp run
routeA(config)#no cdp run
routeA(config)#interface serial 0
routeA(config-if)#cdp enable
routeA(config-if)#no cdp enable
routeA(config-if)#exit
routeA(config)#exit
routeA#write memory
routeA#show cdp neighbors
routeA#show cdp traffic

-----------------------------------------------------------------------

静态路由

routeA#config terminal
routeA(config)#ip route 172.16.0.0 255.255.255.0 61.10.2.26
routeB(config)#ip route 192.168.0.0 255.255.255.0 202.106.0.25
routeA#ping 172.168.0.1
!!!
routeB#ping 192.168.0.1
!!!
routeB#show ip route
routeA(config)#no ip route 172.16.0.0 255.255.255.0 61.10.2.26
routeB(config)#no ip route 192.168.0.0 255.255.255.0 202.106.0.25

缺省路由
routeA(config)#ip route 0.0.0.0 0.0.0.0 202.106.0.25
routeB(config)#ip route 0.0.0.0 0.0.0.0 61.10.2.26
routeA#ping 172.168.0.1
!!!
routeB#ping 192.168.0.1
!!!
routeA(config)#no ip route 0.0.0.0 0.0.0.0 202.106.0.25
routeB(config)#no ip route 0.0.0.0 0.0.0.0 61.10.2.26

-----------------------------------------------------------------------

RIP

路由器选择协议(距离矢量协议)矢量代表的是方向,以跳数来寻址。
它更新相邻的路由器,RIP也是有缺点的。
是它的收敛问题 意思是说当它了解了整个网络的状况。当把路由器接口
no shutdown时,则自动更新路由表,60秒。第二次更新达到学习。收敛
的速度慢。解决方法,时间变短,采用触发更新,其实这样也有它的不好之处
如果说一个路由器收敛的时间的速度是10秒,则另一个路由器是60秒,这
将会不同步。
1 以跳数来解决这个问题。RIP默认支持16跳。过了这个跳数是不可到达
的。其生效只有15跳。也就是说到了第15跳的时候,就是不可到达的。
RIP支持有分类的(没有变动的子网掩码)
2 环路问题解决方法,水平分割(把广域网的接口阻塞,就不能广播)。方法
:routeA#config terminal
  routeA(config-router)#passive-interface serial 0

rip 有两个版本,RIP1和RIP2 。RIP1支持有类地址。 RIP2 是混合协议特点可
支持可变长的子网掩码。它比RIP1多了个认证功能,

routeA#config terminal
routeA(config)#router rip 
routeA(config)#ip class
routeA(config-router)#network 192.168.0.0
routeA(config-router)#network 202.106.0.0

routeB#config terminal
routeB(config)#router rip 
routeB(config-router)#network 172.16.0.0
routeB(config-router)#network 61.10.2.0

routeA#ping 172.168.0.1
!!!

routeB#ping 192.168.0.1
!!!
routeA#show router rip

C说明直连R说明协议是RIP
S说明是缺省

本文转自 yirehe 51CTO博客,原文链接:http://blog.51cto.com/yirehe/16949,如需转载请自行联系原作者

CISCO 路由器(1)相关推荐

  1. Cisco路由器安全配置必用10条命令

    当谈到配置一台新的cisco路由器,多数配置依赖于路由器的类型以及它将服务的用途.然而,每位管理员都有其自己的"正确"配置每台路由器的命令列表.笔者将和你分享他自己配置路由器的十条 ...

  2. cisco路由器与QOS技术

    1 前言 随着因特网的普及,网络和人们生活的关系愈加密切,多样化的业务(数据.语音.视频等)应运而生.通常,这些业务对于通信条件的要求各不相同:数据业务对传递的可靠性要求非常高,误码率是最重要的指标, ...

  3. Cisco路由器的安全配置简易方案

    Cisco路由器的安全配置简易方案 Author: BluShin Auditor: Amy E-mail:Yangtonguang@163.com Version 1.0 Date: 2002-12 ...

  4. cisco+路由器+固定外网IP与NAT+设置

    Cisco 接入宽带配置方法浅析 电信宽带为2M, 分配给的固定IP地址:202.249.11.101 子网掩码:255.255.255.248 网关:202.249.11.20 局域网规划地址范围为 ...

  5. Packet Tracer 5.0配置cisco路由器详细说明

      花费了几天的时间写了这篇博文,关于配置cisco路由器的命令在教程上都写的比较清楚,可是好多命令记住了未必能够得心应手的运用于企业的实际网络中,我在这篇博文了介绍了运用终端设备如何登录到cisco ...

  6. 在cisco路由器上实现DHCP功能实例

    对在widows server上实现DHCP一定都非常熟悉,现在我们来简单看下如何在cisco路由器上实现 一.        DHCP得操作过程: 1.        客户机向一个本地得Cisco ...

  7. CISCO路由器TELNET和SSH远程登录配置实例

    一.TELNET远程登录配置 1.配置CISCO路由器上登录账号.口令.账号级别,如下所示,账号名abc.口令为abc123.账号级别为15(最高级别) R1#configure terminal R ...

  8. CISCO路由器安全配置

    这是一篇关于CISCO路由器安全配置的文章,挺不错的,转过来跟大家一起分享. 一.路由器访问控制的安全配置 1.严格控制可以访问路由器的管理员.任何一次维护都需要记录备案. 2.建议不要远程访问路由器 ...

  9. Cisco路由器故障诊断技术

    Cisco路由器故障诊断技术   1 引言 作为网络工程师,在网络环境出现故障时,及时定位故障并解决故障是十分重要的.本文以CISCO路由式网络为基础,介绍使用诊断工具对Cisco路由器进行故障诊断的 ...

  10. CISCO路由器产品配置手册

    CISCO路由器产品配置手册 第一章 路由器配置基础2 一.基本设置方式2 二.命令状态2 三.设置对话过程3 四.常用命令5 五.配置IP寻址6 六.配置静态路由8 第二章 广域网协议设置10 一. ...

最新文章

  1. 深蓝学院第二章:基于全连接神经网络(FCNN)的手写数字识别
  2. Tensorflow—CNN应用于MNIST数据集分类
  3. Linux下gcc编译生成动态链接库*.so文件并调用它
  4. [设计模式原则]第五回:迪米特原则
  5. jzoj4815-ksum【堆】
  6. redis 超时失效key 的监听触发
  7. HTML5-Tab标签
  8. python3.7安装pyqt4_Windows下PyQt4的安装(本文已过期)
  9. jetty java 工程_jetty启动java web工程报错
  10. C语言练习——数据加密
  11. unity3d贪吃蛇游戏源码,支持安卓+IOS双端 unity2019 C#语言开发
  12. echar 常用单词
  13. 二、GAMIT解算之数据准备
  14. 2个步骤,让人才成为组织进化的发动机
  15. mac下安装破解版adobe photoshop cs6
  16. 三个有用的Switch命令:spanning-tree portfast、switchport host、smartport
  17. Python list 列表方法
  18. 与或树的盲目搜索和启发式搜索
  19. 微信公众号新手运营指南——四种类别如何选择
  20. 理解ViT(结合代码)

热门文章

  1. Duplicate keys detected: ‘checks‘. This may cause an update error. found in
  2. python统计图像灰度直方图_python 对一幅灰度图像进行直方图均衡化
  3. python3.5中文手册chm_python3.5.2官方帮助文档 参考手册(CHM版)
  4. c语言单片机常用函数,C51单片机C语言函数编辑 -单片机-电子工程世界网
  5. android 移除泛型中元素_Android 代码混淆 混淆方案
  6. lombok链式调用_翻车!记一次使用 Lombok 造成的事故!
  7. 水凝胶 静电纺丝_【再生医学前沿】Nature子刊:静电纺丝玩出新花样!静电射流偏转的超快3D打印亚微米结构...
  8. python用程序说爱你_用python写一个聊天小程序!和女朋友的专属聊天工具!
  9. ubunntu安装php7.0_乌班图Ubuntu 16.04下安装PHP 7过程详解
  10. springboot怎么返回404_自定义SpringBoot REST API 404返回信息