题干:

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. 
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

题目大意:

T组样例,每组八个值,前四个值描述一条直线上的两个点,剩下的同理。

解题报告:

套个模板就可以了。

AC代码:

#include<iostream>
#include<algorithm>
#include<queue>
#include<cstdio>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define ll long long
#define pb push_back
#define pm make_pair
#define fi first
#define se second
using namespace std;
const double eps = 1e-8;
int sgn(double x) {if(fabs(x) < eps)return 0;if(x < 0) return -1;return 1;
}
struct Point {double x,y;Point(){}Point(double x,double y):x(x),y(y){}Point operator -(const Point &b)const {return Point(x - b.x,y - b.y);}double operator ^(const Point &b)const {return x*b.y - y*b.x;}double operator *(const Point &b)const {return x*b.x + y*b.y;}
};
struct Line {Point s,e;Line(){}Line(Point s,Point e):s(s),e(e){}pair<Point,int> operator &(const Line &b)const {Point res = s;if(sgn((s-e)^(b.s-b.e)) == 0){if(sgn((b.s-s)^(b.e-s)) == 0)return make_pair(res,0);//两直线重合else return make_pair(res,1);//两直线平行}double t = ((s-b.s)^(b.s-b.e))/((s-e)^(b.s-b.e));res.x += (e.x - s.x)*t;res.y += (e.y - s.y)*t;return make_pair(res,2);//有交点}
};
double xmult(Point p0,Point p1,Point p2) { //p0p1 X p0p2return (p1-p0)^(p2-p0);
}
bool Seg_inter_line(Line l1,Line l2) { //判断直线l1和线段l2是否相交,注意是直线!!如果是线段,还需要判断另一组!!return sgn(xmult(l2.s,l1.s,l1.e))*sgn(xmult(l2.e,l1.s,l1.e)) <= 0;
}
double dist(Point a,Point b) {return sqrt((b - a)*(b - a));
}
int main()
{int t;cin>>t;double x1,x2,x3,x4,y1,y2,y3,y4;puts("INTERSECTING LINES OUTPUT");while(t--) {scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3,&x4,&y4);Line l1 = Line(Point(x1,y1),Point(x2,y2));Line l2 = Line(Point(x3,y3),Point(x4,y4));pair<Point,int> p = l1&l2; if(p.se == 1) puts("NONE");else if (p.se == 0) puts("LINE");else printf("POINT %.2f %.2f\n",p.fi.x,p.fi.y);}puts("END OF OUTPUT");return 0 ;
}

【POJ - 1269 】Intersecting Lines (计算几何,直线间的位置关系)相关推荐

  1. POJ 1269 Intersecting Lines(求直线交点)

    http://poj.org/problem?id=1269 求交点见zhhx课件 #include<iostream> #include<cstdio> #include&l ...

  2. POJ - 1269 Intersecting Lines(计算几何 + 叉积 + 跨立实验)

    链接 Intersecting Lines 题意 给出两条线段,判断是否共线,平行,或者相交,如果相交输出交点: 思路 如何判断共线: 我们知道两个向量叉积为 000,两向量共线: 所以我们只需要判断 ...

  3. poj 1069 Intersecting Lines

    POJ 1269 Intersecting Lines 解题报告 (2010-05-07 19:10) 一.问题描述 http://acm.pku.edu.cn/JudgeOnline/problem ...

  4. 直线与圆位置关系的c语言,直线与圆的位置关系教学设计范文

    直线与圆的位置关系教学设计范文 教学目标: (一) 教学知识点: 1. 了解直线与圆的三种位置关系. 2. 了解圆的切线的概念. 3. 掌握直线与圆位置关系的性质. (二) 过程目标: 1. 通过多媒 ...

  5. POJ1269 Intersecting Lines 计算几何 C语言

    题目:http://poj.org/problem?id=1269 题目大意:给出四个点确定两条直线.如果是一条线输出"LINE",如果平行输出"NONE", ...

  6. 【POJ 1269】判断两直线相交

    题 利用叉积解方程 #include <cstdio> #define MAX 1<<31 #define dd double int xmult(dd x1,dd y1,dd ...

  7. 直线与圆位置关系的c语言,直线和圆的位置关系说课稿

    直线和圆的位置关系说课稿 作为一名老师,通常需要用到说课稿来辅助教学,说课稿是进行说课准备的文稿,有着至关重要的作用.写说课稿需要注意哪些格式呢?以下是小编收集整理的直线和圆的位置关系说课稿,仅供参考 ...

  8. 暑期集训3:几何基础 练习题C: POJ - 1269

    2018学校暑期集训第三天--几何基础 练习题B --  POJ - 1269 Intersecting Lines We all know that a pair of distinct point ...

  9. poj 1269 直线相交情况

    链接:http://poj.org/problem?id=1269 题意:给两条直线,判断它们是重合.平行还是相交,相交则求交点. #include<iostream> #include& ...

最新文章

  1. 科研助力|计算机科学方向一对一科研项目
  2. Serverless 在大厂都怎么用?
  3. 【EventBus】EventBus 源码解析 ( 注册订阅者总结 | EventBus 注册订阅者流程梳理 )
  4. android attrs获取_Android 常用侧滑栏实现
  5. 无孔不入的微软---史前恐龙
  6. hashmap面试问题
  7. Matlab常用快捷键
  8. Linux 的 ‘sort’命令的14个有用的范例(一)
  9. 五十二 常用第三方模块 图形界面
  10. Funcode实现黄金矿工
  11. OpenCV人脸识别
  12. Win10设置屏保时间
  13. thinkphp出现FILE: D:\www\zhao01\ThinkPHP\Library\Think\Dispatcher.class.php 解决方案
  14. 网页直播源码IM即时通讯协议
  15. jcp jsr_Oracle提交了第三次JCP改革JSR,以提高透明度
  16. Java学习——File类
  17. 各大AI 开放平台一览
  18. 一台主机连接两台显示器单独分开工作
  19. Word 任意页插入页码
  20. 比尔·盖茨:现在比任何时候都需要新的救命工具,向CEPI再捐1.5亿美元加速疫苗研发...

热门文章

  1. 数据结构一—— 数组
  2. python变量生命周期_python 变量定义及变量生命周期
  3. 计算机怎样辅助英语听力教学方法有哪些,计算机辅助教学在英语听力中的运用.doc...
  4. php表格js特效,JavaScript表格隔行变色和Tab标签页特效示例【附jQuery版】
  5. threejs中坐标系转换和实现物体跟随鼠标移动
  6. linux2.6内核Makefile详解
  7. Linux C 中字符串化操作符#
  8. C/C++ 通过初始化列表和构造函数内赋值初始化成员变量的区别
  9. 在哪个Linux发行版上运行python,怎么在linux上运行python
  10. 【转】PF_RING开发指南