题意翻译

给你一串数列a.对于一个质数p,定义函数f(p)=a数列中能被p整除的数的个数.给出m组询问l,r,询问[l,r]区间内所有素数p的f(p)之和.

题目描述

Recently, the bear started studying data structures and faced the following problem.

You are given a sequence of integers x1,x2,...,xn x_{1},x_{2},...,x_{n} x1​,x2​,...,xn​ of length n n n and m m m queries, each of them is characterized by two integers li,ri l_{i},r_{i} li​,ri​ . Let's introduce f(p) f(p) f(p) to represent the number of such indexes k k k , that xk x_{k} xk​ is divisible by p p p . The answer to the query li,ri l_{i},r_{i} li​,ri​ is the sum: , where S(li,ri) S(l_{i},r_{i}) S(li​,ri​) is a set of prime numbers from segment [li,ri] [l_{i},r_{i}] [li​,ri​] (both borders are included in the segment).

Help the bear cope with the problem.

输入输出格式

输入格式:

The first line contains integer n n n (1<=n<=106) (1<=n<=10^{6}) (1<=n<=106) . The second line contains n n n integers x1,x2,...,xn x_{1},x_{2},...,x_{n} x1​,x2​,...,xn​ (2<=xi<=107) (2<=x_{i}<=10^{7}) (2<=xi​<=107) . The numbers are not necessarily distinct.

The third line contains integer m m m (1<=m<=50000) (1<=m<=50000) (1<=m<=50000) . Each of the following m m m lines contains a pair of space-separated integers, li l_{i} li​ and ri r_{i} ri​ (2<=li<=ri<=2⋅109) (2<=l_{i}<=r_{i}<=2·10^{9}) (2<=li​<=ri​<=2⋅109) — the numbers that characterize the current query.

输出格式:

Print m m m integers — the answers to the queries on the order the queries appear in the input.

输入输出样例

输入样例#1: 复制

6
5 5 7 10 14 15
3
2 11
3 12
4 4

输出样例#1: 复制

9
7
0

输入样例#2: 复制

7
2 3 5 7 11 4 8
2
8 10
2 123

输出样例#2: 复制

0
7

首先可以线性筛筛出 1e7 里面所有的素数;对于每一个x[i] ,我们记录其次数,然后类似于埃筛的做法,对于每个素数,用 sum [ i ] 来累计有该素数因子的数的个数;最后用前缀和维护;
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<set>
#include<vector>
#include<queue>
#include<bitset>
#include<ctime>
#include<deque>
#include<stack>
#include<functional>
#include<sstream>
//#include<cctype>
//#pragma GCC optimize("O3")
using namespace std;
#define maxn 10000005
#define inf 0x3f3f3f3f
#define INF 9999999999
#define rdint(x) scanf("%d",&x)
#define rdllt(x) scanf("%lld",&x)
#define rdult(x) scanf("%lu",&x)
#define rdlf(x) scanf("%lf",&x)
#define rdstr(x) scanf("%s",x)
typedef long long  ll;
typedef unsigned long long ull;
typedef unsigned int U;
#define ms(x) memset((x),0,sizeof(x))
const long long int mod = 1e9 + 7;
#define Mod 1000000000
#define sq(x) (x)*(x)
#define eps 1e-3
typedef pair<int, int> pii;
#define pi acos(-1.0)
const int N = 1005;
#define REP(i,n) for(int i=0;i<(n);i++)
typedef pair<int, int> pii;
inline ll rd() {ll x = 0;char c = getchar();bool f = false;while (!isdigit(c)) {if (c == '-') f = true;c = getchar();}while (isdigit(c)) {x = (x << 1) + (x << 3) + (c ^ 48);c = getchar();}return f ? -x : x;
}ll gcd(ll a, ll b) {return b == 0 ? a : gcd(b, a%b);
}
ll sqr(ll x) { return x * x; }/*ll ans;
ll exgcd(ll a, ll b, ll &x, ll &y) {if (!b) {x = 1; y = 0; return a;}ans = exgcd(b, a%b, x, y);ll t = x; x = y; y = t - a / b * y;return ans;
}
*/ll qpow(ll a, ll b, ll c) {ll ans = 1;a = a % c;while (b) {if (b % 2)ans = ans * a%c;b /= 2; a = a * a%c;}return ans;
}int n;
int x[maxn];
int m;
int cnt[maxn];
int prime[maxn];
int tot = 0;
int sum[maxn];
bool vis[maxn];void init() {vis[1] = 1;for (int i = 2; i < maxn; i++) {if (!vis[i])prime[++tot] = i;for (int j = 1; prime[j] * i < maxn; j++) {vis[prime[j] * i] = 1;if (i%prime[j] == 0)break;}}
}int main()
{//ios::sync_with_stdio(0);rdint(n);for (int i = 1; i <= n; i++)rdint(x[i]), cnt[x[i]]++;init();for (int i = 1; i <= tot; i++) {for (int j = 1; j*prime[i] < maxn; j++) {sum[i] += cnt[j*prime[i]];}}for (int i = 1; i <= tot; i++)sum[i] += sum[i - 1];rdint(m);while (m--) {int l, r; rdint(l); rdint(r);int pos1 = upper_bound(prime + 1, prime + 1 + tot, r) - prime - 1;int pos2 = lower_bound(prime + 1, prime + 1 + tot, l) - prime - 1;
//      cout << pos1 << ' ' << pos2 << endl;cout << sum[pos1] - sum[pos2] << endl;}return 0;
}

转载于:https://www.cnblogs.com/zxyqzy/p/9972287.html

CF385C Bear and Prime Numbers 数学相关推荐

  1. CF385C Bear and Prime Numbers

    思路: 需要对埃氏筛法的时间复杂度有正确的认识(O(nlog(log(n)))),我都以为肯定超时了,结果能过. 实现: 1 #include <bits/stdc++.h> 2 usin ...

  2. codeforces 385C Bear and Prime Numbers

    题意:给你一个数列,和m个询问,求 数组种 l -r 中所有质数的的倍数的个数和. 解题思路:变形筛法.注意细节 解题代码: 1 // File Name: 385c.cpp 2 // Author: ...

  3. Codeforces 385 C Bear and Prime Numbers

    题目链接~~> 做题感悟:这题属于想法题,比赛时直接做的 D 题.可是处理坐标处理的头晕眼花的结果到最后也没AC. 解题思路: 由于查询的时候仅仅考虑素数,so~我们仅仅考虑素数就能够,这就须要 ...

  4. Codeforces A - Bear and Prime 100(交互题)

    A - Bear and Prime 100 思路:任何一个合数都可以写成2个以上质数的乘积.在2-100中,除了4,9,25,49外都可以写成两个以上不同质数的乘积. 所以打一个质数加这四个数的表: ...

  5. Sum of Consecutive Prime Numbers POJ - 2739(线性欧拉筛+尺取法)

    题意: 一些正整数可以由一个或多个连续质数的总和表示.给定一个的正整数n,问满足条件的有多少种情况? 题目: Some positive integers can be represented by ...

  6. 7-24 First 50 Prime Numbers (10 分)

    7-24 First 50 Prime Numbers Your program reads one natural numbers n in, and prints out the sum of t ...

  7. poj 2739 Sum of Consecutive Prime Numbers

    悲剧,如此水题,竟搞了许久.唉,只因题目没看清. 准确的说:应该是准备工作没做好就开始敲代码了!! 下次一定要想的很清楚了再code ing ! //144K 63MS #include <st ...

  8. HOJ 1015 Nearly prime numbers

    代码 //Nearly prime number is an integer positive number for which it is possible  //to find such prim ...

  9. codeforces 679A Bear and Prime 100 交互

    第一次交互题,记录一下吧 #include <cstdio> #include <iostream> #include <ctime> #include <v ...

最新文章

  1. html input type=file 的属性及api
  2. android 动态 修改图标,android-动态更改ActionBar中的图标
  3. 89. a^b【快速幂模板】
  4. 图形界面终端下打印内核调试信息
  5. Flask 项目布局
  6. java 实现支持向量机
  7. 李天平×××作诞生记——《亮剑.NET:.NET深入体验与实战精要》
  8. 有这样的开发,产品经理跪着帮你擦汗!
  9. 数据库树形结构,EasyUI Tree 树
  10. 【实践】BiLSTM上的CRF,用命名实体识别任务来解释CRF(1)
  11. 《高级无线网络—4G技术》——2.3 正交频分复用
  12. 转载:《TypeScript 中文入门教程》 17、注解
  13. 《Conditional BERT Contextual Augmentation》论文笔记
  14. 如何通过编程打开一个网页
  15. 算法笔记(七)扩大感受野SPP/ASPP/RBF
  16. Csdn富文本编辑器中使用Emoji表情包
  17. 绑定变量窥视 oracle,不均衡分区和绑定变量窥视导致的查询计划错误
  18. matlab中ode45用法,ode45(ode45用法举例)
  19. Python使用numpy获取列表行数与列数
  20. 统计建模与R软件-第三章习题答案

热门文章

  1. 基于MM2的跨IDC kafka热备多活方案
  2. 【官方速报】Pika3.0正式发布
  3. sublime text 3 插件推荐?
  4. oracle case套case,,套用when case
  5. SpringBoot自动配置实现原理及源码解析(2.3.x)
  6. Java运行时内存工作过程
  7. 在Sping Boot logback的使用
  8. kafka消息确认机制
  9. springbatch导出mysql数据到外部文件
  10. Springboot+Spring-Security+JWT 实现用户登录和权限认证