//启动接口,分配IP地址:
router>
router> enable
router#
router# configure terminal
router(config)#
router(config)# interface Type Port
router(config-if)# no shutdown
router(config-if)# ip address IP-Address Subnet-Mask
router(config-if)# ^z

//配置RIP路由协议:30秒更新一次
router(config)# router rip
router(config-if)# network Network-Number //通告标准A,B,C类网
router(config-if)# ^z

//配置IGRP路由协议:90秒更新一次
router(config)# router igrp AS-Number //AS-Number范围1~65535
router(config-if)# network Network-Number //通告标准A,B,C类网
router(config-if)# ^z

//配置Novell IPX路由协议:Novell RIP 60秒更新一次
router(config)# ipx routing [node address]
router(config)# ipx maximum-paths Paths //设置负载平衡,范围1~512
router(config)# interface Type Port
router(config-if)# ipx network Network-Number [encapsulation encapsulation-type] [secondary] //通告标准A,B,C类网
router(config-if)# ^z

//配置DDN:
router(config)# dialer-list Group-Number protocol
Protocol-Type permit [list ACL-Number]
router(config)# interface bri 0
router(config-if)# dialer-group Group-Number
router(config-if)# dialer map Protocol-Type
Next-Hop-Address name Hostname Telphone-Number
router(config-if)# ^z

//配置ISDN:
router(config)# isdn swith-type Swith-Type //配置ISDN交换机类型,中国使用basic-net3
router(config-if)# ^z

//配置Frame Relay:
router(config-if)# encapsulation frame-relay [cisco | ietf ]
router(config-if)# frame-relay lmi-type [ansi | cisco | q933a ]
router(config-if)# bandwidth kilobits
router(config-if)# frame-relay invers-arp [ Protocol ] [dlci ]
router(config-if)# ^z

//配置标准ACL:
router(config)# access-list Access-List-Number [ permit | deny ] source [ source-mask ] //Access-List-Number 范围:1~99标准ACL;100~199扩展ACL;800~899标准IPX ACL;//900~999扩展IPX ACL;1000~1099 IPX SAP ACL;600~699Apple Talk ACL
router(config)# interface Type Port
router(config-if)# ip access-group Access-List-Number [in | out ]
router(config-if)# ^z

//配置扩展ACL:
router(config)# access-list Access-List-Number [permit | deny] [Protocol | Protocol-Number] source source-wildcard [ Source-Port ] destination destination-wildcard [Destination-Port] [ established ]
router(config)# interface Type Port
router(config-if)# ip access-group Access-List-Number [ in | out ]
router(config-if)# ^z

//配置命名ACL:
router(config)# ip access-list [ standard | extended ] ACL-Name
router(config [ std- | ext- ] nacl)# [ permit | deny ] [ IP-Access-List-Test-Conditions ]
router(config [ std- | ext- ] nacl)# no [ permit | deny ] [ IP-Access-List-Test-Conditions ]
router(config [ std- | ext- ] nacl)# ^z
router(config)# interface Type Port
router(config-if)# ip access-group [ACL-Name | 1~199 ] [ in | out ]
router(config-if)# ^z

//配置DCE时钟:
router# show controllers Type Port //确定DCE接口
router(confin-if)# clock rate 64000 //进入DCE接口设置时钟速率
router(config-if)# ^z

//配置PPP协议:
router(config)# username Name password Set-Password-Here //验证方建立数据库
router(config)# interface Type Port
router(config-if)# encapsulation ppp //启动PPP协议
router(config-if)# ppp outhentication [ chap | chap pap | pap chap | pap ] //选择PPP认证
router(config-if)# ppp pap sent-username Name password Password //发送验证信息
router(config-if)# ^z
//PAP单向认证配置实例:
//验证方:
router-server(config)# username Client password 12345 //验证方建立数据库
router-server(config)# interface serial 0
router-server(config-if)# encapsulation ppp
router-server(config-if)# ppp authentication pap //选择使用PAP实现PPP认证
router-server(config-if)# ^z
//被验证方:
router-client(config-if)# encapsulation ppp
router-client(config-if)# ppp pap sent-username Client password 12345 //发送验证信息
router-client(config-if)# ^z

//PAP双向认证配置实例:
//路由器 A:
routerA(config)# username B password 12345
routerA(config)# interface serial 0
routerA(config-if)# encapsulation ppp
routerA(config-if)# ppp authentication pap
routerA(config-if)# ppp pap sent-username A password 54321
routerA(config-if)# ^z
//路由器 B:
routerB(config)# username A password 54321
routerB(config)# interface serial 1
routerB(config-if)# encapsulation ppp
routerB(config-if)# ppp authentication pap
routerB(config-if)# ppp pap sent-username B password 12345
routerB(config-if)# ^z

//CHAP单向认证配置实例:
//验证方:
router-server(config)# username router-client password 12345
router-server(config)# interface serial 0
router-server(config-if)# encapsulation ppp
router-server(config-if)# ppp authentication chap
router-server(config-if)# ^z
//被验证方:
router-client(config-if)# encapsulation ppp
router-client(config-if)# ppp authentication chap
router-client(config-if)# ppp chap hostname router-client
router-client(config-if)# ppp chap password 12345
router-client(config-if)# ^z

//CHAP双向认证配置实例:
//路由器 A:
routerA(config)# username routerB password 12345
routerA(config)# interface serial 0
routerA(config-if)# encapsulation ppp
routerA(config-if)# ppp authentication chap
routerA(config-if)# ppp chap hostname routerA
routerA(config-if)# ppp chap password 54321
routerA(config-if)# ^z
//路由器 B:
routerB(config)# username routerA password 54321
routerB(config)# interface serial 1
routerB(config-if)# encapsulation ppp
routerB(config-if)# ppp authentication chap
routerB(config-if)# ppp chap hostname routerB
routerB(config-if)# ppp chap password 12345
routerB(config-if)# ^z

//Telnet使用:
routerA# terminal monitor //可以传回在远端主机执行Debug命令的结果
routerA# telnet IP-Address [ Router-Name ] //Telnet到指定的地址或名字的主机
routerB# [ exit | logout ] ///退出Telnet
routerA# show sessions //显示当前所有Telnet的信息,包括Connect-Number
routerA# Connect-Number //返回指定的Telnet连接
routerA# disconnect IP-Address [ Router-Name ] //断开指定地址或名字的主机的连接
routerA# show user //显示Telnet到本机的连接信息
routerA# clear line [ 0 | 1 | 2 | 3 | 4 ] //断开指定Telnet到本机的连接

//禁止任何Telnet到本路由器:
router(config)# line vty 0 4
router(config-line)# access-class ACL-Number //通过ACL禁止任何Telnet到该路由器
router(config)# ^z

//设置主机名:
router(config)# hostname Set-Hostname
router(config)# ^z

//设置用户模式密码:
router(config)# line console 0
router(config-line)# login
router(config-line)# password Set-Password
router(config-line)# ^z

//设置Telnet密码:
router(config)# line vty 0 4
router(config-line)# login
router(config-line)# password Set-Password
router(config-line)# ^z

//设置特权模式密码:
router(config)# enable password Set-Password //不加密的密码,明码
router(config)# enable secret Set-Password //经过加密的密码
router(config)# ^z

//给所有密码加密:
router(config)# service password-ancryption
router(config)# no service password-ancryption //取消加密
router(config)# ^z

//设置登录Banner:
router(config)# banner motd 分隔符 Set-Banner-InFORMation-Here 分隔符 //前后分隔符一定要一致

//设置接口的描述信息:
router(config-if)# description Set-Port-InFORMation-Here
router(config)# ^z

//CDP的控制:
router(config-if)# cdp enable //在指定端口启用CDP,缺省
router(config-if)# no cdp enable //在指定端口关闭CDP
router(config)# cdp run //使所有端口启用CDP
router(config)# no cdp run //使所有端口关闭CDP

//Ping的使用:
router# ping IP-Address
router# ping //扩展Ping命令
Protocol [ip]:[ Protocol-Type ] //选择协议类型
Target IP address:IP-Address //输入测试地址
Repeat count [5]: //选择发送的ICMP包数量
Datagram size [100]: //选择每个包的大小
Timeout in seconds [2]: //设置每个包的超时时间
Extended commands [n]:y //使用扩展Ping命令
Sweep range of sizes [n]:

//Trace的使用:
router# trace IP-Address [ Host-Name ]

//为Cisco 4000路由器指定媒体类型:
router(config-if)# media-type 10baset //使AUI(默认)失效,改为使用RJ-45
router(config-if)# ^z
//更改路由器启动顺序:
router(config)# boot system flash IOS-FileName
router(config)# boot system tftp IOS-FileName TFTP-IP-Address
router(config)# boot system rom
router(config)# ^z

//修改寄存器数值:
router(config)# config-register value
//Cisco出厂默认value=0x2102,value范围:0x2100(进入ROM监视器),0x2101(使//系统从ROM启动),0x2102~0x210F(使系统从NVRAM启动)。0x1=0x2101,从
//最小位开始改变

//在ROM监视器中更改寄存器数值:
> o/r value

//路由器密码的恢复:
冷关机,然后再开机并在60秒内按< Ctrl>+进入ROM监视器模式
> o/r 0x2142 //25xx型路由器
或 > confreg 0x2142 //26xx型路由器
router> I
router> n
router> enable
router# copy startup-config running-config //备份路由器的配置文件
router# configure terminal
router(config)# enable secret New-Password
router(config)# config-register 0x2102
router(config)# ^z
router# copy running-config startup-config
router# reload

//配置名称-主机入口:
router(config)# ip host Set-Name [ TCP-Port-Number ] IP-Address [ IP-Address 2 ]...
router(config)# ^z

//定义DNS主机:
router(config)# ip name-server Server-Address [ Server-Address 2 ]...
router(config)# ^z

//禁用DNS:
router(config)# no ip domain-lookup
router(config)# ^z

//配置水平分割:
router(config-if)# ip split-horizon
router(config-if)# no ip split-horizon
router(config-if)# ^z

//配置静态路由:
router(config)# ip route IP-Address Subnet-Mask [ Next-Hop-Address | Local-Out-Port ] [Distace ] //Distance范围:1~255,相当于优先权,越小越好。RIP=120;DSPF=110;IGRP=100;//EIGRP=90
router(config)# ^z

//配置缺省路由:
router(config)# ip defoult-network IP-Address //动态缺省路由
router(config)# ip route 0.0.0.0 0.0.0.0 [ Next-Hop-Address | Local-Out-Port ] [Distace ] //静态缺省路由
router(config)# ^z

//其它命令:
router# show version
router# show running-config
router# show startup-config
router# show flash
router# show interface [ Type Port ]
router# show buffers
router# show protocol
router# show mem
router# show stacks
router# show processes
router# show cdp entry [ Device-Name ] //显示指定邻居三层信息
router# show cdp neighbors
router# show cdp neighbors detail //显示所有邻居三层信息
router# show ip router
router# show ipx router
router# show host
router# show ip protocol
router# show ip interface Type Port
router# show ipx interface Type Port
router# show ipx servers
router# show ipx traffic
router# show access-lists [ ACL-Number ]
router# show isdn status
router# show dialer //查看ISDN拨号信息
router# show isdn active
router# show frame-relay pvc
router# show frame-relay map
router# show frame-relay lmi
router# erase startup-config
router# reload
router# setup
router# copy running-config startup-config
router# copy startup-config running-config
router# copy tftp running-config
router# copy running-config tftp
router# debug ipx routing activity
router# debug ipx sap
router# debug isdn q921
router# debug isdn q931
router# debug dialer
router# debug ip rip
router# clear interface bri

转载于:https://blog.51cto.com/robin5188/23146

Cisco 路由配置语句汇总相关推荐

  1. Cisco路由配置命令

    交换机命令总结 交换机口令设置: switch>enable    进入特权模式        switch#config terminal    进入全局配置模式 switch(config) ...

  2. Linux下备份cisco路由配置

    TFTP (普通文件传输协议或一般文件传输协议) 大家一定记得在2003年8月12日全球爆发冲击波(Worm.Blaster)病毒,这种病毒会监听端口69,模拟出一个TFTP服务器,并启动一个***传 ...

  3. 【OSPF路由配置命令汇总大全】面面俱到

    1.单区域配置OSPF路由 先配置好IP地址信息: #物理接口 interface GigabitEthernet0/0/0ip address 10.0.123.2 255.255.255.0 ## ...

  4. 《Cisco路由器配置与管理完全手册》(第二版)前言和目录

    史上最具人气.最受好评的网络设备图书领域"四大金刚"的全新升级版本再现江湖了,他们分别是:<Cisco交换机配置与管理完全手册>(第二版).<H3C交换机配置与管 ...

  5. CISCO路由器配置手册--第五章 虚拟局域网(VLAN)路由

    一.虚拟局域网(VLAN) 当前在我们构造企业网络时所采用的主干网络技术一般都是基于交换和虚拟网络的.交换技术将共享介质改为独占介质,大大提高网络速度.虚拟网络技术打破了地理环境的制约,在不改动网络物 ...

  6. Cisco路由交换基础配置

    一.基础知识 在Cisco中字母大小没区别,但是正则表达式需要注意大小写 路由表查询机制:1.最长匹配原则.2.递归查询 路由器开始键入no/yes,no是进入用户模式,yes是进入初始化配置 1.模 ...

  7. 思科为计算机配置ip命令,Cisco常用配置:IP配置,静态、默认、浮动路由配置,网关等简单配置...

    很多朋友对于思科配置命令不是很熟悉,尤其是一些常用到的指令,作为一名合格网管,以下命令是必须懂得配置的,详见: 怎么给路由器配置IP? router(config)#interface fasteth ...

  8. linux系统rc路由配置_详解CentOS 6.4 添加永久静态路由所有方法汇总

    CentOS添加永久静态路由,具体如下: 在使用双网卡,同时使用2个网关的时候就需要加一条静态路由了.当然还有很多时候会需要加路由. 操作系统版本centos-6.4 64bit 一:使用route ...

  9. 交换机端口聚合 VTP 端口安全 交换机路由器静态路由配置 Cisco

    1:配置要求 使用静态路由和多层交换网络技术完成如下要求的网络配置,通过网络配置,使所有计算机都能连通,要求: 1.使两台核心交换机之间形成一根聚合了两条物理链路的TRUNK聚合虚拟链路: 2.交换机 ...

最新文章

  1. 计算机中音乐设备数字接口,一种计算机用声卡封存装置的制作方法
  2. 独家 | 对抗图像和攻击在Keras和TensorFlow上的实现
  3. Tomcat内存溢出解决办法
  4. 【Linux】17_计划任务
  5. pytorch torch.from_numpy()(从numpy数组创建一个张量,数组和张量共享相同内存)
  6. java开发学不会_JAVA学不会,快期末了,怎么办?
  7. 双目立体放大!谷歌刚刚开源的这篇论文可能会成为手机双摄的新玩法
  8. android自学之旅——layout资源文件
  9. linux内网发现登录设备,LINUX 内网设备将服务映射到公网地址
  10. 打造创新电磁诊疗技术平台,睿笛生物获比邻星创投、三捷资本数千万元投资...
  11. c语言实现linux下的top命令来获取cpu利用率_Linux性能调优之CPU性能优化
  12. Win7-64bit下MapX的安装和使用
  13. 《我和PIC单片机:基于PIC18》——导读
  14. 混频器的噪声来源与抑制方法
  15. cents7安装docker并部署nginx、mysql容器
  16. android 摇晃工具箱
  17. Spark开发实例(编程实践)
  18. 2020移动apn接入点哪个快_为什么别人的4g网总比你快? 手机这个设置没开启, 难怪网络差...
  19. android 悬浮窗口禁止横屏显示,悬浮窗强制设置屏幕方向|App开发交流区|研发交流|雨滴科技技术论坛 - Powered by Discuz!...
  20. SX1268 SX1262中文数据手册

热门文章

  1. HDLBits 系列(40)如何写 TestBench 文件?
  2. 【 Notes 】WLLS Algorithm of TOA - Based Positioning (include the two - step WLS estimator)
  3. MVC ---- DBHelper.ttinclude
  4. ViewPager,TabLayout,Fragment实现tabs滑动
  5. .ccz 批量转换为 .png
  6. 数据中心电气及自动化(一)
  7. C++网络编程(一)
  8. RS485,RS232,USB,Ethernet 传输速度分别是多少
  9. 学生用计算机2ndf,手机计算器2ndf键在哪 等同于INV键
  10. 根据经纬度批量计算多个点到多个点之间的距离