作者:水泊梁山 东方龙
我们假定读者对IP协议有一定程度的了解(不了解IP协议永远无法维护一个IP网络),比如至少懂得IP地址的结构、类别和子网、子网掩码的概念,并且具有一定的计算机基础知识。在配置路由器时,只要将计算机的串口通过路由器自带的专用电缆接到Console口,使用诸如超级终端或者Netterm之类的软件即可。

  网络中的只有一块网卡(一个IP地址)任何一台主机只能直接访问本子网内的机器。而路由器相当于一台由多个网卡的主机,每一块网卡可以直接与一个子网通信。根据上图我们知道,两个网络相连主要是通过在其间建立一个广域网互联子网来进行。这个子网中只有两台机器,即两边的路由器,当然它的子网掩码就是255.255.255.252。只要路由器A、B的Seiral口在同一个子网,由于它们的Ethernet口分别属于A、B两网,我们就在A、B网之间建立了一条通道。网络A中的主机只要将网关设为路由器A,其信息即可通过路由器A、B转发到B网。
我们在例子中使用的是应用最广泛的Cisco 2501路由器,这种路由器物理结构简单,网络接口只有两个Serial口和一个Ethernet口,却支持完整的路由功能。采用的协议为TCP/IP,因为现在使用其他诸如IPX、Netbeui之类的协议已经是非常的不合时宜。
实例1:通过Cisco 2501连接A局域网与B局域网
--------------------------------------------------------------------------------
假设实验条件如下:
A网:202.96.199.0——202.96.199.255
B网:202.97.76.0——202.97.76.31
DNS Server:202.96.199.2(主),202.96.199.3(备)
所属域:xxx.com
广域网互联:需要一个包含4个IP地址(2个可用IP)的子网,
定为:202.98.0.0——202.98.0.3,其中202.98.0.1给A网,202.98.0.2给B网
互联专线速率:128kbps

具体网络参数分配表如下:
项目
A网
B网
网络号 202.96.199.0 202.97.76.0
子网掩码 255.255.255.0 255.255.255.224
所属域 xxx.com yyy.com
以太网地址 202.96.199.1 202.97.76.1
互联地址 202.98.0.1 202.98.0.2
专线速率 128kbps 同左
域名服务器 主:202.96.199.2
备:202.96.199.3
同左
首先进入路由器:将你的计算机串行口连接到路由器的Console口,使用Netterm或者超级终端之类的软件登录。

Router>en:
passwd:******(输入超级口令)

全局配置:(A、B网相同)

Router#conf terminal(切换到配置状态)
Router(config)#enable secret my-root-password(定义超级口令)
Router(config)#ip host Router-A(定义路由器名,B网为Router-B)
Router(config)#ip domain-name xxx.com(定义所属域名称,B网为yyy.com)
Router(config)#nameserver 202.96.199.2(定义主域名服务器)
Router(config)#nameserver 202.96.199.3(定义备域名服务器)
Router(config)#ip classless
Router(config)#line vty 0 4
(定义5个telnet虚终端,即可以同时有5个人登录本路由器)
Router(config-line)#password my-telnet-password(定义telnet口令)
Router(config-line)#exit
Router(config)#exit

地址和路由配置:
/****** A网路由器 ******/
Router-A#conf t(切换到配置状态)
Router-A(config)#int e0(配置Ethernet 0口)
Router-A(config-if)#description the LAN port link to my local network(端口说明)
Router-A(config-if)#ip add 202.96.199.1 255.255.255.0
(定义以太网IP地址,子网掩码表示为C类网络)
Router-A(config-if)#no shutdown(激活端口)
Router-A(config-if)#exit
Router-A(config)#int s0(配置Serial 0口)
Router-A(config-if)#description the WAN port link to Router-B(端口说明)
Router-A(config-if)#ip add 202.98.0.1 255.255.255.252(定义互联广域网IP地址)
Router-A(config-if)#bandwidth 128(定义端口速率,单位:kbps)
Router-A(config-if)#no shutdown(激活端口)
Router-A(config-if)#exit
Router-A(config)#ip route 202.97.76.0 255.255.255.224 202.98.0.2
(定义静态路由,通过网关到达对端局域网络,IP为对端广域网IP地址)
Router-A(config)#exit
Router-A#wr m(保存配置)
/****** B网路由器 ******/
Router-B#conf t
Router-B(config)#int e0
Router-B(config-if)#description the LAN port link to my local network(端口说明)
Router-B(config-if)#ip add 202.97.76.1 255.255.255.224
(定义以太网IP地址,子网掩码表示为拥有32个地址的子网)
Router-B(config-if)#no shutdown
Router-B(config-if)#exit
Router-B(config)#int s0
Router-B(config-if)#description the WAN port link to Router-A(端口说明)
Router-B(config-if)#ip add 202.98.0.2 255.255.255.252
Router-B(config-if)#bandwidth 128
Router-B(config-if)#no shutdown
Router-B(config-if)#exit
Router-B(config)#ip route 202.96.199.0 255.255.255.0 202.98.0.1
(定义静态路由,通过网关到达对端局域网络,IP为对端广域网IP地址)
Router-B(config)#exit
Router-B#wr m(保存配置)

  配置完成。

  这里是A网、B网路由器配置清单。
Router A:
Router-A#sh run
Building Configuration...
Current configuration
version 11.2
service udp-small-servers
service tcp-small-servers
hostname Router-A
enable secret test-a
ip subnet-zero
interface Ethernet0
description the LAN port link to my local network
ip address 202.96.199.1 255.255.255.0
interface Serial0
description the WAN port link to Router-B
ip address 202.98.0.1 255.255.255.252
bandwidth 128
interface Serial1
no ip address
shutdown
ip domain-name xxx.com
ip name-server 202.96.199.2
ip name-server 202.96.199.3
ip classless
ip route 202.97.76.0 255.255.255.224 202.98.0.2
line con 0
line aux 0
line vty 0 4
password telnet-a
login
end
Router-A#
Rouer B:
Router-B#sh run
Building Configuration...
Current configuration
version 11.2
service udp-small-servers
service tcp-small-servers
hostname Router-B
enable secret test-b
ip subnet-zero
interface Ethernet0
description the LAN port link to my local network
ip address 202.97.76.1 255.255.255.224
interface Serial0
description the WAN port link to Router-A
ip address 202.98.0.2 255.255.255.252
bandwidth 128
interface Serial1
no ip address
shutdown
ip domain-name yyy.com
ip name-server 202.96.199.2
ip name-server 202.96.199.3
ip classless
ip route 202.96.199.0 255.255.255.0 202.98.0.1
line con 0
line aux 0
line vty 0 4
password telnet-b
login
end
Router-B#
实例2:通过Cisco 2501将你的局域网接入Internet

--------------------------------------------------------------------------------
假设实验条件如下:
本网IP地址为:202.96.199.0——202.96.199.255
DNS Server:202.96.202.96(主),202.96.96.202(备)
ISP分配的广域网互联IP地址为202.98.0.2

具体网络参数分配表如下:
项目
用户网络
ISP网络
网络号 202.96.199.0  
子网掩码 255.255.255.0  
所属域 xxx.com  
以太网地址 202.96.199.1  
互联地址 202.98.0.2 202.98.0.1
专线速率 128kbps 同左
域名服务器 主:202.96.202.96
备:202.96.96.202
 
我们已经有了上例的经验,则很容易根据相同的原理配置这个路由器。

首先进入路由器:
Router>en:
passwd:

全局配置:
Router#conf t
Router(config)#ip host Router
Router(config)#nameserver 202.96.202.96
Router(config)#nameserver 202.96.96.202
Router(config)#exit
其他项目同“例一”。

地址配置:
Router#conf t
Router(config)#int e0
Router(config-if)#description the LAN port link to my local network(端口说明)
Router(config-if)#ip add 202.96.199.1 255.255.255.0
Router(config-if)#no shutdown(激活端口)
Router(config-if)#exit
Router(config)#int s0
Router(config-if)#description the WAN port link to Internet(端口说明)
Router(config-if)#ip add 202.98.0.2 255.255.255.252
Router(config-if)#no shutdown(激活端口)
Router(config-if)#exit

路由配置:
Router(config)#ip route 0.0.0.0 0.0.0.0 202.98.0.1
(定义默认静态路由,所有的远程访问通过网关,IP为对端广域网IP地址)
Router(config)#exit
Router#wr m

  配置完成。

  这里是本网路由器配置清单。
Router#sh run
Building Configuration...
Current configuration
version 11.2
service udp-small-servers
service tcp-small-servers
hostname Router
enable secret test
ip subnet-zero
interface Ethernet0
description the LAN port link to my local network
ip address 202.96.199.1 255.255.255.0
interface Serial0
description the WAN port link to Internet
ip address 202.98.0.2 255.255.255.252
bandwidth 128
interface Serial1
no ip address
shutdown
ip domain-name xxx.com
ip name-server 202.96.202.96
ip name-server 202.96.96.202
ip classless
ip route 0.0.0.0 0.0.0.0 202.98.0.1
line con 0
line aux 0
line vty 0 4
password telnet
login
end
Router#
实例3:使用Cisco路由器对大型网络(例如ISP网络)进行扩容

--------------------------------------------------------------------------------
当然,设计管理大型网络的路由非常复杂,一般都是由经过高级培训的专业人士进行。而且,大型网络一般都采用像Cisco 7507这样的高档路由器。在这里顺便简单讲述,主要是让大家开阔一下视野,了解一下其他的路由协议。
这时,与例2唯一的不同就是路由配置,不能采用静态路由协议而应该相应地采用非常优秀的OSPF动态路由协议并结合RIP协议。
假设具体网络参数如下:
项目 本地网络
网络号 202.96.199.0
子网掩码 255.255.255.0
OSPF编号 100
OSPF域 202.96.192.0——202.96.207.255,16个C
那么应该这样配置:
Router(config)#router ospf 100(配置OSPF路由)
Router(config-router)#summary-address 202.96.199.0 255.255.255.0
Router(config-router)#redistribute connnected metric-type 1 subnets
Router(config-router)#redistribute static(通过OSPF协议广播静态路由)
Router(config-router)#network 202.96.192.0 0.0.15.255 area 0.0.0.0
Router(config-router)#area 0.0.0.0 authentiication message-digest
Router(config-router)#exit
Router(config)#router rip(配置RIP路由)
Router(config-router)#redistribute ospf 100 metric 1(通过RIP协议广播OSPF路由)
Router(config-router)#passive-interface Serial 0(不在Serial 0上使用)
Router(config-router)#network 202.101.199.0(定义本网络)
Router(config-router)#exit
Router(config)exit

同时,采用OSPF协议时应该在广域网端口上加入授权机制:
Router(config)#int s0
Router(config-if)#ip ospf message-digest-key keyword
Router(config-if)#exit
Router(config)#exit
Router#wr m

更大型的网络会采用BGP边缘路由协议,假设具体网络参数如下:

项目 本地网络 远程网络
AS(自治域) 20000 4000
本地BGP网络 202.96.192.0——202.96.207.255,16个C
202.97.0.0——202.97.15.255,16个C
202.98.128.0——202.98.159.255,32个C
 
互联地址 202.100.4.2 202.100.4.1
则本地路由器配置方法为:
Router(config)#router bgp 20000(定义本BGP管理的AS--自治域编号)
Router(config-router)#no synchronization
Router(config-router)#network 202.96.192.0 mask 255.255.240.0
(定义本AS--自治域包含的网络)
Router(config-router)#network 202.97.0.0 mask 255.255.240.0
Router(config-router)#network 202.98.128.0 mask 255.255.224.0
Router(config-router)#neighbor 202.100.4.1 remote-as 4000
(定义到远端AS--自治域的网关IP)
Router(config-router)#exit
Router(config)#exit
Router#wr m

  配置完成。

实用技术

--------------------------------------------------------------------------------
一、使用口令加密机制:
Router(config)#service password-encryption(路由器密码将以暗码显示)
二、配置http server,以便从浏览器访问路由器:
Router(config)#ip http server
三、访问控制:

Router(config)#access-list 101 permit ip 10.150.0.0 0.0.255.255 any
  (允许10.150.0.0——10.150.255.255访问)

Router(config)#access-list 101 deny ip 10.151.0.0 0.0.255.255 any
  (禁止10.151.0.0——10.150.255.255访问)

四、负载分担:

要实现负载分担必须使用动态路由协议,以OSPF为例,只要将两条路由的代价(cost)设为相等,即可自动实现。

默认的OSPF代价为广域网线路64,局域网线路30,设置路径代价的命令为:
  Router(config-if)#ip ospf cost xx。

五、常用命令:
Router#help/?(获得帮助)
Router#sh run(显示路由器当前配置)
Router#sh int Xn(接口名称,例如Ethernet 0、Serial 1等,显示接口状态)
Router#sh ip route(显示当前路由)
Router#wr m(储存配置,以便下次重启时使用)
Router#reload(重启路由器)
Router#ping ip-address(测试与其他主机的连接)
Router#telnet host(登录其它主机)

转载于:https://blog.51cto.com/luton/42727

结合实例讲解广域网路由基本技术相关推荐

  1. 10 个 PHP 常见安全问题(实例讲解)

    2020相对于其他几种语言来说, PHP 在 web 建站方面有更大的优势,即使是新手,也能很容易搭建一个网站出来.但这种优势也容易带来一些负面影响,因为很多的 PHP 教程没有涉及到安全方面的知识. ...

  2. java实现页面高效刷新_selenium高效应对Web页面元素刷新的实例讲解

    当我们在页面上进行selenium.type()或者selenium.click()操作的时候,往往需要需要等待一个元素的出现,对于一般的网页,当我们进入一个新页面的时候,往往会使用selenium. ...

  3. php 返回一个json对象,PHP给前端返回一个JSON对象的实例讲解

    解决问题:用php做后台时,如何给前端发起的AJAX请求返回一个JSON格式的"对象": 说明:我本身是一个前端,工作久了之后发现要是不掌握一门后端开发语言的话,总感觉有点无力.最 ...

  4. python简易版实例_Python3之简单搭建自带服务器的实例讲解

    WEB开发,我们先从搭建一个简单的服务器开始,Python自带服务模块,且python3相比于python2有很大不同, 在Python2.6版本里,/usr/bin/lib/python2.6/ 目 ...

  5. 手摸手教你数据可视化!(附实例讲解)

    ↑↑↑关注后"星标"Datawhale 每日干货 & 每月组队学习,不错过 Datawhale干货 作者:CrescentAI,华南理工大学,Datawhale优秀学习者 ...

  6. 【Python基础】手把手教你数据可视化!(附实例讲解)

    点击上方"小白学视觉",选择加"星标"或"置顶" 重磅干货,第一时间送达 作者:CrescentAI,华南理工大学,Datawhale优秀学 ...

  7. php脚本函数,PHP执行系统命令函数实例讲解

    命令注入 命令注入(Command Injection),对一些函数的参数没有做过滤或过滤不严导致的,可以执行系统或者应用指令(CMD命令或者 bash 命令)的一种注入攻击手段. 常见的执行系统命令 ...

  8. 实例讲解之校园网病毒该如何铲除

    实例讲解之校园网病毒该如何铲除 转载于:https://blog.51cto.com/wilsondy/163994

  9. httpclient 调取接口_使用HttpClient调用接口的实例讲解

    一,编写返回对象 public class HttpResult { // 响应的状态码 private int code; // 响应的响应体 private String body; get/se ...

最新文章

  1. 漫谈 ClickHouse 在实时分析系统中的定位与作用
  2. transform: scale(x,y)
  3. ios 工具大全,最全框架
  4. Firefox扩展开发 Hello World!
  5. 32.C#--方法中使用out参数做登录判断
  6. Bean 在 Spring 中代表什么含义,为什么这样命名?
  7. QT之QHash简介
  8. python中acosh_acosh()函数以及C ++中的示例
  9. Tip: 强制 Outlook 用户使用缓存模式
  10. ccf小明种苹果(续)
  11. 【学术】CCF推荐的A类、B类、C类中文科技期刊目录
  12. 在网页上添加可爱的Live 2D模型
  13. 公司-人人网:人人网
  14. 经济学实证论文写作经验分享
  15. excel单元格斜线_如何在Excel中使用斜线,并在表格的标题中使用单斜线或双斜线...
  16. 微信公众平台开发-消息管理-发送客服消息
  17. 我们为什么来到这个世界上?
  18. 组合拳砸来:55位权威专家论剑股市!
  19. Android 刘海屏适配全攻略
  20. Java的编程之旅——idea上新建文件

热门文章

  1. angular中集中页面传参(我只是知识的搬运工)
  2. php学习day9---数据库的基本知识
  3. 注册Github账户过程
  4. Cacti 自定义脚本监控
  5. C#创建一个Windows Service
  6. css border制作小三角形状及应用(兼容IE6)
  7. yii required 字段去除*号
  8. .net core vs java_VS Code 1.19.3调试.net core 2并始终满足“只能调试64位进程”
  9. python处理心电图_ECG心电信号处理:使用WFDB对MIT-BIH数据集进行读取(Python)
  10. python图像验证码识别_python 简单图像识别--验证码