poj——2771    Guardian of Decency
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 5916   Accepted: 2458

Description

Frank N. Stein is a very conservative high-school teacher. He wants to take some of his students on an excursion, but he is afraid that some of them might become couples. While you can never exclude this possibility, he has made some rules that he thinks indicates a low probability two persons will become a couple:

  • Their height differs by more than 40 cm.
  • They are of the same sex.
  • Their preferred music style is different.
  • Their favourite sport is the same (they are likely to be fans of different teams and that would result in fighting).

So, for any two persons that he brings on the excursion, they must satisfy at least one of the requirements above. Help him find the maximum number of persons he can take, given their vital information.

Input

The first line of the input consists of an integer T ≤ 100 giving the number of test cases. The first line of each test case consists of an integer N ≤ 500 giving the number of pupils. Next there will be one line for each pupil consisting of four space-separated data items:

  • an integer h giving the height in cm;
  • a character 'F' for female or 'M' for male;
  • a string describing the preferred music style;
  • a string with the name of the favourite sport.

No string in the input will contain more than 100 characters, nor will any string contain any whitespace.

Output

For each test case in the input there should be one line with an integer giving the maximum number of eligible pupils.

Sample Input

2
4
35 M classicism programming
0 M baroque skiing
43 M baroque chess
30 F baroque soccer
8
27 M romance programming
194 F baroque programming
67 M baroque ping-pong
51 M classicism programming
80 M classicism Paintball
35 M baroque ping-pong
39 F romance ping-pong
110 M romance Paintball

Sample Output

3
7

Source

Northwestern Europe 2005
题目大意:

题意:现在有一个老师想带领他的学生出去郊游,但是他非常担心在郊游的过程中有些学生会发生恋爱关系,而他认为发生恋爱关系的可能性比较小的判断标准有以下四个,如果满足四个条件中的任何一个,即被他认为可能发生恋爱关系的可能性比较小:

            1>两人身高的差距超过40cm;
            2>两人性别相同;
            3>两人所喜欢的音乐风格不同;
            4>两人最喜爱的运动相同;

现在给出n个学生,并给出每个学生的信息(信息为:身高 性别 所喜欢的音乐风格 喜爱的运动),要求求解最大可以带出去郊游的学生数.

思路:
由于两个女生一定不会发生恋爱关系(此处我们不考虑性取向有问题的情况(ORZ)),所以我们可以以该同学的性别为根据来建立二分图。
然后我们在判断两边的同学是否满足上述情况,若满足则连边。然后对于我们建出的这个图在求最大匹配。这样我们就转化成了裸地匈牙利算法。最多可以带的学生数=总学生数-最大匹配数。
注意:char不能用==直接比,这样比出来的只是第一个字符,而非全部,我们这里要用strcmp比较两个字符的大小,这两个字符的字典序如果相同则返回0,如果第一个字符的字典序大返回1,反之,返回-1。
代码:
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#define N 510
using namespace std;
char ch;
bool vis[N];
int t,n,x,ans,gnum,bnum,pre[N],map[N][N];
struct nn
{int h;char fm[10000];char fs[10000];
}girl[N],boy[N];
int read()
{int x=0,f=1;char ch=getchar();while(ch<'0'||ch>'9'){if(ch=='-') f=-1; ch=getchar();}while(ch<='9'&&ch>='0'){x=x*10+ch-'0'; ch=getchar();}return x*f;
}
void add_edge()
{for(int i=1;i<=bnum;i++)for(int j=1;j<=gnum;j++)if(!strcmp(boy[i].fm,girl[j].fm)&&strcmp(boy[i].fs,girl[j].fs)&&abs(boy[i].h-girl[j].h)<=40)map[i][j]=1;
}
int find(int x)
{for(int i=1;i<=gnum;i++)if(!vis[i]&&map[x][i]){vis[i]=true;if(pre[i]==0||find(pre[i])){pre[i]=x;return 1;}}return 0;
}
int main()
{t=read();while(t--){ans=0;bnum=0,gnum=0;memset(boy,0,sizeof(boy));memset(girl,0,sizeof(girl));memset(pre,0,sizeof(pre));memset(map,0,sizeof(map));n=read();for(int i=1;i<=n;i++){x=read(); scanf("%c",&ch);if(ch=='F') {girl[++gnum].h=x;cin>>girl[gnum].fm;                 cin>>girl[gnum].fs;}else {boy[++bnum].h=x;cin>>boy[bnum].fm;cin>>boy[bnum].fs;}}add_edge();for(int i=1;i<=bnum;i++){memset(vis,0,sizeof(vis));if(find(i)) ans++;}printf("%d\n",n-ans);}return 0;
}

转载于:https://www.cnblogs.com/z360/p/7107170.html

poj——2771 Guardian of Decency相关推荐

  1. POJ-2771 Guardian of Decency 最大独立子集

    不能恋爱问题. 代码如下: #include <cstdlib>#include <cstdio>#include <cstring>using namespace ...

  2. UVA - 12083 Guardian of Decency (二分匹配)

    题意:有N个人,已知身高.性别.音乐.运动.要求选出尽可能多的人,使这些人两两之间至少满足下列四个条件之一. 1.身高差>40  2.性别相同  3.音乐不同  4.运动相同 分析: 1.很显然 ...

  3. poj 2771 有点难度最大独立集

    题意:一个老师要带一些学生去旅游 , 下面任意两个学生至少要满足下面一个条件: 1.身高相差要超过40cm 2.性别相同 3.最喜欢的音乐属于不同类型 4.最喜欢的体育比赛相同 解 法:我们首先这样来 ...

  4. 【转载】图论 500题——主要为hdu/poj/zoj

    转自--http://blog.csdn.net/qwe20060514/article/details/8112550 =============================以下是最小生成树+并 ...

  5. 【HDOJ图论题集】【转】

    1 =============================以下是最小生成树+并查集====================================== 2 [HDU] 3 1213 How ...

  6. 一系列图论问题[转]

    =============================以下是最小生成树+并查集====================================== [HDU] 1213 How Many ...

  7. 图论练习题(存起来练)

    =============================以下是最小生成树+并查集======================================  [HDU]  1213 How Man ...

  8. ACM比赛经验、刷题记录及模板库总结(更新中)

    前言 本文所提及的部分题目代码,可以在我的Github上找到 第一部分 经验分享及感受 第二部分 刷题记录 一.基础算法&程序语言 //strlen()函数的复杂度是O(n)要小心 //截取字 ...

  9. 网络流题集【夏天的风】

    [HDU] 1532Drainage Ditches(基础)    [最大流] 3549 Flow Problem(基础)    [最大流] 3572 Task Schedule    [最大流]任务 ...

最新文章

  1. mysql主从以及读写分离(科普)
  2. python简单的小程序_初学python的一些简单程序(1)
  3. git--分支管理:创建、合并、冲突解决
  4. 阿里P7/P8学习路线图——技术封神之路
  5. linux sed 测试文件夹,测试开发笔记二(Linux与Shell脚本)
  6. [BUUCTF-pwn]——pwnable_orw   (ORW)
  7. jsp导入jstl标签库_EE JSP:使用JSTL标记库生成动态内容
  8. 第二十期:核心交换机的链路聚合、冗余、堆叠、热备份
  9. linux普通用户发送信号,Linux信号发送与作业控制
  10. 私有云为先 ZStack还在谋划一个更大的混合云世界
  11. 关键字Restrict
  12. linux之yum下载rpm包离线安装
  13. 6.3交换器(Exchangers)
  14. 小D课堂 - 零基础入门SpringBoot2.X到实战_第8节 数据库操作之整合Mybaties和事务讲解_34、SpringBoot整合Mybatis实操和打印SQL语句...
  15. 真的神了~无意中发现1500道的2021LeetCode算法刷题pdf笔记
  16. JAVA语言基础——基本语法
  17. 全国各主要省市经纬度
  18. matlab如何定义dmod函数,matlab中的dmod函数
  19. 前端面试题整理—ES6篇
  20. RE|Nginx-安装与配置(1)

热门文章

  1. 系统开出出现问题~~~\WINDOWS\SYSTEM32\CONFIG\SYSTEM 损坏或丢失无法开机
  2. c语言 strlower 将所有的字母转化为小写字母
  3. Asp.net 随记 Part1 (1- 30)
  4. 再谈HTTP2性能提升之背后原理—HTTP2历史解剖
  5. I.MX6 Android 5.1 纯Linux、U-Boot编译
  6. tar 解压缩命令详解
  7. 制作最小Linux系统并且让其在新的虚拟机上运行
  8. There is no isNullOrEmpty for collections in Guawa
  9. Linux 命令小汇总
  10. iOS load方法和initialize方法的异同