一、拓扑及IP配置

二、配置清单

R1#show run
Building configuration...

Current configuration : 1449 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
ip cef
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
memory-size iomem 0
archive
 log config
  hidekeys
!        
!
crypto isakmp policy 10
 encr 3des
 hash md5
 authentication pre-share
 group 2
 lifetime 5000
crypto isakmp key cisco123 address 192.168.2.2
!
!
crypto ipsec transform-set set1 ah-sha-hmac esp-3des esp-md5-hmac
!
crypto map map1 11 ipsec-isakmp
 set peer 192.168.2.2
 set transform-set set1
 match address 111
!
   
interface Tunnel0
 ip address 192.168.100.1 255.255.255.0
 tunnel source 192.168.2.1
 tunnel destination 192.168.2.2
 crypto map map1
!
interface FastEthernet0/0
 ip address 192.168.2.1 255.255.255.0
 duplex full
 crypto map map1
!
interface FastEthernet1/0
 ip address 192.168.1.1 255.255.255.0
 duplex full
!
router rip
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.100.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
access-list 111 permit gre host 192.168.2.1 host 192.168.2.2
access-list 111 permit ip any any
!
control-plane
!
mgcp fax t38 ecm
!
gatekeeper
 shutdown
!        
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
end

R1#

-----------------------------------------------------------------

R2#show run
Building configuration...

Current configuration : 1539 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
memory-size iomem 0
archive
 log config
  hidekeys
!        
!
crypto isakmp policy 10
 encr 3des
 hash md5
 authentication pre-share
 group 2
 lifetime 5000
crypto isakmp key cisco123 address 192.168.2.1
!
!
crypto ipsec transform-set set1 ah-sha-hmac esp-3des esp-md5-hmac
!
crypto map map1 11 ipsec-isakmp
 set peer 192.168.2.1
 set transform-set set1
 match address 111
!    
interface Tunnel0
 ip address 192.168.100.2 255.255.255.0
 tunnel source 192.168.2.2
 tunnel destination 192.168.2.1
 crypto map map1
!
interface FastEthernet0/0
 ip address 192.168.2.2 255.255.255.0
 duplex full
 speed auto
 crypto map map1
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.3.1 255.255.255.0
 duplex full
!
router rip
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.100.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
access-list 111 permit gre host 192.168.2.2 host 192.168.2.1
access-list 111 permit ip any any
!
control-plane
mgcp fax t38 ecm
!
gatekeeper
 shutdown
!
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
end

R2#

--------------------------------------------------------

R5#show run
Building configuration...

Current configuration : 586 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
no ip routing
!
!
no ip cef
!        
interface FastEthernet0/0
 ip address 192.168.1.2 255.255.255.0
 no ip route-cache
 speed auto
 full-duplex
!
ip default-gateway 192.168.1.1
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

R5#

----------------------------------------------------

R6#show run
Building configuration...

Current configuration : 586 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
no ip routing
!
!
no ip cef
!
interface FastEthernet0/0
 ip address 192.168.3.2 255.255.255.0
 no ip route-cache
 speed auto
 full-duplex
!
ip default-gateway 192.168.3.1
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

R6#

-------------------------------------

转载于:https://blog.51cto.com/hongguang/707579

配置隧道模式的IPSec.×××相关推荐

  1. IPsec 实操配置(隧道模式)

    文章目录 目录 文章目录 前言 一.实验环境 二.实验步骤 1.配置全网可达 2.配置ACL识别兴趣流 3.配置安全提议 进入AR1和AR3分别配置安全提议(AR1与AR3需做相同的配置) 4.创建安 ...

  2. DCN-2655 gre隧道 vpn 嵌入IPSec配置:

    DCN-2655 gre隧道 vpn 嵌入IPSec配置: RT1配置: Ip route 183.203.10.128 255.255.255.252 183.203.10.2 Interface ...

  3. IPsec ACL隧道模式的路由设置

    针对这个拓扑来进行讲解 1.去往对端隧道接口的路由 这个毋庸置疑,因为隧道双方都要进行隧道相关协商报文的传递,所以去往对端隧道接口的路由是是必须的 2.去往对端内部网络的路由 对于隧道模式来说,当相关 ...

  4. LVS——TUN隧道模式(负载均衡)

    1.什么IP隧道技术? 简单来说IP隧道技术就是将 [IP数据包] 的上面再封装一层[IP数据包], 然后路由器根据最外层的IP地址路由到目的地服务器,目的地服务器拆掉最外层的IP数据包,拿到里面的I ...

  5. 配置×××服务器使用L2TP/IPSEC协议

    配置×××服务器使用L2TP/IPSEC协议<?XML:NAMESPACE PREFIX = O />     在ISA2006中配置了×××地址池,选择了×××协议,创建了防火墙策略,检 ...

  6. lvs负载均衡之配置lvs-tun模式的httpd负载集群

    文章目录 Lvs简介 体系结构 LVS管理工具 Ipvsadm核心功能 LVS工作模式及原理 LVS调度算法 配置lvs-tun模式的httpd负载集群 Lvs简介 LVS(Linux Virtual ...

  7. LVS的Tun模式(隧道模式)的实现

    1.TUN模式的工作原理 TUN模式简称隧道模式,隧道模式就是修改请求报文的首部IP,再加一层IP报头 优点:DS和RS不需要在同一网段,可以实现不同网络之间的访问 数据流向如下 数据包从客户端发往D ...

  8. 华为 USG6000防火墙配置镜像模式双机热备

    网络拓扑 要求: 企业前期是一台防火墙,为了提高网络可靠性,并且在不影响原先防火墙配置情况下,新增一台防火墙做双机热备.两台FW的业务接口都工作在三层,下行为三层核心交换机.上行为二层交换机连接运营商 ...

  9. LVS IP隧道模式(IP Tunneling)

    一. IP隧道模式 ip隧道是一个将ip报文封装到另一个ip报文的技术,这可以使得目标为一个ip地址的数据报文被封装和转发到另一个ip地址.ip隧道技术也成为ip封装技术. 它和NAT模式不同的是,它 ...

最新文章

  1. idea查看ruby代码_Ruby实现命令行中查看函数源码的方法
  2. android 利用类的同名方法欺骗jni调用(一)
  3. R语言 非中心化F分布
  4. ECS 选款利器!PTS助您快速上云!
  5. php实现中间件6,说一说ThinkPHP6中五花八门的中间件_PHP开发框架教程
  6. vmware中centos6.4突然无法进入图形界面解决方法
  7. android fragment中引入自定义view_厉害了,用Android自定义View实现八大行星绕太阳3D旋转效果...
  8. 两台服务器建立信任关系(root,普通用户)
  9. 100c之29:求具有abcd= ( ab + cd )^2 性质的四位数
  10. 【Vue】—数据的双向绑定v-model
  11. java操作oracle数据库 代码案例
  12. 基于python的tensorflow_Python深度学习:基于TensorFlow
  13. 再问:支付宝即时到账集成接口!
  14. 超薄计算机的HDMI接口,机身轻薄两面观 笔记本接口变化趋势解析
  15. VPS搭建HTTP代理
  16. 数学期望方差 expectationvariance
  17. 高性能消息中间件 NSQ 解析-应用实践
  18. 如何对客户行为进行数据分析?
  19. OutMan——Foundation框架中的NSString类和NSMutableString类
  20. Leo个人MSN简明使用手册

热门文章

  1. Word 2013无法发布文章到博客园
  2. 聊一聊javascript执行上下文
  3. 如何让网页不受电信114劫持
  4. 京东方剑指物联网领域
  5. 冒泡 MS Azure 不便宜。。。
  6. 企业架构研究总结(39)——TOGAF架构能力框架之架构委员会和架构合规性
  7. Ubuntu 10.04 LTS 网站权限不够
  8. 压力变动力,存储追求高效率
  9. C++向量类模板(支持实数向量与复数向量的各种运算)
  10. 使用Wireshark进行DNS协议解析