案例拓扑图

思科(3640)实现

Step 1:A路由器的基本配置

A(config)#do sho run

Building configuration...

Current configuration : 1410 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname A

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

!

!

ip cef

no ip domain lookup

ip domain name lab.local

!

crypto isakmp policy 1

authentication pre-share

crypto isakmp key 123 address 61.130.132.1

crypto isakmp key 123 address 61.130.133.1

!

!

crypto ipsec transform-set ***c ah-md5-hmac esp-des esp-md5-hmac

crypto ipsec transform-set ***b ah-md5-hmac esp-des esp-md5-hmac

!

crypto map ***-set 100 ipsec-isakmp

set peer 61.130.132.1

set transform-set ***b

match address 110

crypto map ***-set 200 ipsec-isakmp

set peer 61.130.133.1

set transform-set ***c

match address 120

!

!

!

!

!

interface Loopback0

ip address 192.168.1.254 255.255.255.0

!

interface FastEthernet0/0

ip address 61.130.131.1 255.255.255.252

duplex auto

speed auto

crypto map ***-set

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 61.130.131.2

!

!

access-list 110 permit ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255

access-list 120 permit ip 192.168.1.0 0.0.0.255 192.168.3.0 0.0.0.255

!

!

control-plane

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

login

!

!

End

Step 2:路由器B的配置

B(config)#do sho run

Building configuration...

Current configuration : 1125 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname B

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

!

!

ip cef

no ip domain lookup

ip domain name lab.local

!

crypto isakmp policy 1

authentication pre-share

crypto isakmp key 123 address 61.130.131.1

!

!

crypto ipsec transform-set ***a ah-md5-hmac esp-des esp-md5-hmac

!

crypto map ***-set 100 ipsec-isakmp

set peer 61.130.131.1

set transform-set ***a

match address 110

!

!

!

!

interface Loopback0

ip address 192.168.2.254 255.255.255.0

!

interface FastEthernet0/0

ip address 61.130.132.1 255.255.255.252

duplex auto

speed auto

crypto map ***-set

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 61.130.132.2

!

!

access-list 110 permit ip 192.168.2.0 0.0.0.255 192.168.1.0 0.0.0.255

!

!

control-plane

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

login

!

!

End

Step 3:路由器C的配置

C(config)#do sho run

Building configuration...

Current configuration : 1125 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname C

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

!

!

ip cef

no ip domain lookup

ip domain name lab.local

!

crypto isakmp policy 1

authentication pre-share

crypto isakmp key 123 address 61.130.131.1

!

!

crypto ipsec transform-set ***a ah-md5-hmac esp-des esp-md5-hmac

!

crypto map ***-set 100 ipsec-isakmp

set peer 61.130.131.1

set transform-set ***a

match address 110

!

!

!

!

interface Loopback0

ip address 192.168.3.254 255.255.255.0

!

interface FastEthernet0/0

ip address 61.130.133.1 255.255.255.252

duplex auto

speed auto

crypto map ***-set

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 61.130.133.2

!

!

access-list 110 permit ip 192.168.3.0 0.0.0.255 192.168.1.0 0.0.0.255

!

!

control-plane

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

login

!

!

End

Step 4:ISP配置,核心配置就是三个接口地址

interface FastEthernet0/0

ip address 61.130.131.2 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 61.130.132.2 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet2/0

ip address 61.130.133.2 255.255.255.252

duplex auto

speed auto

!

Step 5:测试

从路由器A使用扩展PING,ping 路由器B

从路由器A使用扩展PING,ping 路由器C

转载于:https://blog.51cto.com/wnqcmq/1180931

网络安全性——IPSEC(续思科设备实现)相关推荐

  1. 网络篇 思科设备的登陆方式07

    目录 一.前言 二.设备的管理方式 三. 访问思科路由器与交换机的方法 四.实现思科路由器与交换机的访问 1.通过Console端口直接访问配置思科设备: 2.通过Telnet访问配置思科设备: 3. ...

  2. 【网络通信】【电信运营商实战工程师】思科设备篇-网络工程师必备基础知识

    电信运营商实战工程师系列文章. 思科设备篇-网络工程师必备基础知识. 文章目录 1. 电信运营商网络设备机房 2. 认识并管理运营商网络设备 3. GNS3 安装与配置 4. IPv4地址及子网划分 ...

  3. 网工知识角|华为网络工程师,华为、华三、思科设备三层交换机如何使用三层接口?命令敲起来

    华为.华三.思科三层交换机如何使用三层接口你知道吗? 三层交换机我们都很熟悉,它有二层交换技术和三层路由技术,实现了很多强大的功能. 不管是思科设备.h3c设备还是华为设备,都是支持三层端口和二层端口 ...

  4. 【网络通信】【电信运营商实战工程师】思科设备篇-思科设备企业网实战

    电信运营商实战工程师系列文章. 思科设备篇-思科设备企业网实战. 文章目录 1. 思科设备基本开局配置 2. ARP协议.交换机工作原理及广播风暴问题 3. 思科设备 VLAN 及单臂路由实战 4. ...

  5. 【思科设备命令最全合集,快快收藏!】

    01 思科交换机巡检命令 1.show interface stats:查看交换机所有接口当前接口流量 2.show running-config:查看当前设备配置 3.show version:查看 ...

  6. 思科服务器查看生成树协议,生成树协议、CDP思科设备发现协议、SSH协议

    线路冗余->交换机成环 交换机成环导致: 1 广播风暴 2 mac地址表震荡 一个mac在一台交换机上只能对应一个接口,但一个接口可以对应多个mac 3 重复帧拷贝 生成树协议: 802.1D. ...

  7. 网络协议 — IPSec 安全隧道协议族

    目录 文章目录 目录 IPSec 安全隧道协议族 封装协议 Authentication Header 协议 Encapsulating Security Payload 协议 封装模式 Transp ...

  8. 演示:思科设备基于物理接口帧中继(fame-relay)的配置

    演示:思科设备基于物理接口帧中继(fame-relay)的配置 对应的教学录像在:http://edu.51cto.com/lecturer/user_id-7648423.html 9.9发布,待管 ...

  9. 【转】一文掌握 Linux 性能分析之网络篇(续)

    [转]一文掌握 Linux 性能分析之网络篇(续) 在上篇网络篇中,我们已经介绍了几个 Linux 网络方向的性能分析工具,本文再补充几个.总结下来,余下的工具包括但不限于以下几个: sar:统计信息 ...

最新文章

  1. Dependency Walker PE模块依赖性分析工具
  2. 线性结构(顺序存储和链式存储)和非线性结构的特点及区别
  3. 计算机科学技术的教育应用论文,浅谈计算机科学技术在计算机教学中的应用论文...
  4. 虚拟机的网络连接模式
  5. Docker搭建便捷的开发者环境
  6. loadrunner 录制java_LoadRunner脚本录制流程
  7. java入学测试_算法历练之路——入学考试(JAVA)
  8. Linux之tr命令
  9. 使用AWS DMS 升级Postgre 10到12
  10. 知乎热议的Deep Peak2模型究竟是什么?答案都在这里
  11. 华为路由GRE隧道搭建
  12. HDU 2122 Ice_cream’s world III
  13. 刑事案件鉴定意见常用质证要点
  14. mysql数据库之基本函数,列属性,数据库管理
  15. HTML入门笔记8-上脚注和下脚注标签
  16. Codeforces Global Round 12 B. Balls of Steel 曼哈顿距离
  17. 爬虫--爬取单张图片
  18. 高中数学40分怎么办_新高一第一次考试数学只考了40分,还有救吗?
  19. LPspice 电路仿真软件
  20. 读取文件,解析json报错,解析Unquotted string ''

热门文章

  1. 2019华为性格测试题_小红书达人力荐!华为 Mate20 Pro红蓝新色最懂女人心
  2. 【 MATLAB 】ppval 函数介绍(评估分段多项式)
  3. spring mvc -@RequestMapping注解详解
  4. SQLServer2008/2005 生成数据字典语句
  5. Visual Studio 2013 在使用 razor无智能提示的解决办法
  6. C# SQL封装(一)
  7. 隐式类型转换和整型提升
  8. 常用Intent调用(摘自网络)
  9. Interpreter - 解释器模式
  10. 最近开发老遇到莫名其妙的问题,dialog自定义大小,setAttributes这个方法没反应是肿么一回事...