配置完OSPF后一直报错。

*Aug  4 03:18:38.935: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.5.254 on Tunnel0 from EXCHANGE to DOWN, Neighbor Down: Adjacency forced to reset
*Aug  4 03:18:39.655: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Tunnel0 from LOADING to FULL, Loading Done
Hub(config-router)#
*Aug  4 03:18:43.787: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Tunnel0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
*Aug  4 03:18:44.011: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.5.254 on Tunnel0 from EXSTART to DOWN, Neighbor Down: Adjacency forced to reset
*Aug  4 03:18:44.603: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Tunnel0 from LOADING to FULL, Loading Done
Hub(config-router)#
*Aug  4 03:18:53.567: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Tunnel0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
*Aug  4 03:18:53.779: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.5.254 on Tunnel0 from EXCHANGE to DOWN, Neighbor Down: Adjacency forced to reset
*Aug  4 03:18:54.387: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Tunnel0 from LOADING to FULL, Loading Done

拓扑如下

hub:

interface tunnel 0

ip ospf network broadcast

ip ospf priority 255

spoke (R4 R5) 配置如下

interface tunnel 0

ip ospf network broadcast

ip ospf priority 0

完美解决,这是因为tunnel默认为point-point端口类型,tunnel的邻居超过两个,导致邻居关系一直UPDOWN。这也是OSPF 基础知识点啦。

附完整配置:(本实验SPOKE1为穿越NAT的客户1,SPOKE2为标准客户2。即模拟了标准的DM×××+OSPF,又结合了NAT穿越的场景。使用用户能更好的掌握相关技能。)

HUB:

crypto isakmp policy 10
 authentication pre-share
crypto isakmp key test address 0.0.0.0 0.0.0.0
!
!        
crypto ipsec transform-set test esp-3des esp-md5-hmac
 mode transport
!
crypto ipsec profile testprofile
 set transform-set test

!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 192.168.1.254 255.255.255.0
 ip ospf network point-to-point
!
interface Tunnel0
 ip address 172.16.1.100 255.255.255.0
 no ip redirects
 ip nhrp authentication cisco
 ip nhrp map multicast dynamic
 ip nhrp network-id 10
 ip nhrp cache non-authoritative
 ip nhrp redirect
 ip ospf network broadcast
 ip ospf cost 255
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel protection ipsec profile testprofile

interface FastEthernet0/0
 ip address 10.0.12.1 255.255.255.0
 duplex auto
 speed auto

router ospf 1
 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 192.168.1.0 0.0.0.255 area 0
!
ip route 0.0.0.0 0.0.0.0 10.0.12.2
no ip http server
no ip http secure-server

NAT1:

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.23.3 255.255.255.0
 ip nat outside
 ip nat enable
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.35.3 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto

ip route 0.0.0.0 0.0.0.0 10.0.23.2
ip route 172.16.1.1 255.255.255.255 10.0.35.5
ip route 192.168.5.0 255.255.255.0 10.0.35.5
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface FastEthernet0/0 overload

SPOKE1(R5)

crypto isakmp policy 10
 authentication pre-share
crypto isakmp key test address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set test esp-3des esp-md5-hmac
 mode transport
!
crypto ipsec profile testprofile
 set transform-set test

interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface Loopback5
 ip address 192.168.5.254 255.255.255.0
 ip ospf network point-to-point
!        
interface Tunnel0
 ip address 172.16.1.1 255.255.255.0
 no ip redirects
 ip nhrp authentication cisco
 ip nhrp map multicast 10.0.12.1
 ip nhrp map 172.16.1.100 10.0.12.1
 ip nhrp network-id 10
 ip nhrp nhs 172.16.1.100
 ip nhrp cache non-authoritative
 ip nhrp shortcut
 ip ospf network broadcast
 ip ospf priority 0
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel protection ipsec profile testprofile
!
interface FastEthernet0/0
 ip address 10.0.35.5 255.255.255.0
 duplex auto
 speed auto
!

router ospf 1
 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 192.168.5.0 0.0.0.255 area 0
!
ip route 0.0.0.0 0.0.0.0 10.0.35.3

spoke(R4):

crypto isakmp policy 10
 authentication pre-share
crypto isakmp key test address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set test esp-3des esp-md5-hmac
 mode transport
!
crypto ipsec profile testprofile
 set transform-set test

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface Tunnel0
 ip address 172.16.1.2 255.255.255.0
 no ip redirects
 ip nhrp authentication cisco
 ip nhrp map multicast 10.0.12.1
 ip nhrp map 172.16.1.100 10.0.12.1
 ip nhrp network-id 10
 ip nhrp nhs 172.16.1.100
 ip nhrp cache non-authoritative
 ip nhrp shortcut
 ip ospf network broadcast
 ip ospf priority 0
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel protection ipsec profile testprofile
!
interface FastEthernet0/0
 ip address 10.0.24.4 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.46.4 255.255.255.0
 duplex auto
 speed auto

router ospf 1
 log-adjacency-changes
 network 10.0.46.0 0.0.0.255 area 0
 network 172.16.1.0 0.0.0.255 area 0
!
ip route 0.0.0.0 0.0.0.0 10.0.24.2
no ip http server
no ip http secure-server

R6:

interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface Loopback6
 ip address 192.168.6.254 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 10.0.46.6 255.255.255.0
 duplex auto
 speed auto

router ospf 1
 log-adjacency-changes
 network 10.0.46.0 0.0.0.255 area 0
 network 192.168.6.0 0.0.0.255 area 0

转载于:https://blog.51cto.com/ringwater/1841525

DM***时使用OSPF时邻居不断UPDOWN相关推荐

  1. 配置OSPF时需要注意的几点

    1 在FR 里面配置NBMA时,要手工指定邻居在中心点上,并在两个非中心点的位置的接口下 写IP OSPF PRI 0 保证中心成为DR. 2 看题目的要求,若要是有能自己PING通自己的时候,只要在 ...

  2. OSPF 形成邻居 关系的条件

    TCP/IP路由技术卷一上写道: When a router receives a Hello from a neighbor, it will verify that the Area ID, Au ...

  3. 【Android APT】编译时技术 ( 编译时注解 和 注解处理器 依赖库 )

    文章目录 一.编译时注解和注解处理器 二.创建 编译时注解 和 注解处理器 三.添加 编译时注解 和 注解处理器 依赖库依赖 四.博客资源 一.编译时注解和注解处理器 上一篇博客 [Android A ...

  4. [Android1.6]继承BaseAdapter为GridView设置数据时设置setLayoutParams时注意

    一.问题代码     public View getView(int position, View convertView, ViewGroup parent) {         if (conve ...

  5. php核销次数,人人商城记次时商品核销时展示剩余积分 - YangJunwei

    人人商城记次时商品有很多二开方案,有一客户就要求在核销时,扣除相应的积分.今天我们在记次时商品核销时展示剩余积分. 我们打开如下文件 ewei_shopv2/core/mobile/verify/ve ...

  6. nameof() 到底是编译时还是运行时行为?

    咨询区 Gigi: 在 C#6.0 中,可以用 nameof() 直接获取变量或者类型的名字,请问这是一个 编译时 还是 运行时 行为? 回答区 Faris Zacina: 可以肯定的说,它是一种 编 ...

  7. 进程共享(读时共享写时复制)

    父子进程之间在刚fork后.父子相同处: 全局变量..data..bbs..text.栈.堆.环境变量.用户ID.宿主目录(进程用户家目录).进程工作目录.信号处理方式等等,即0~3G的用户空间是完全 ...

  8. c++输入错误重新输入_C程序-根据时长和时薪计算工资1.3(解决输入非数字选项退出的bug)...

    程序内容: 提供五种工资菜单,用户自行选择,读取用户输入的工作时长,计算工资和净收入,及其缴纳的税金.(C Primer Plus 第7章 第8题) 程序更新:解决输入非数字选项后退出程序的bug. ...

  9. 欧洲杯推动夜间消费发展 便利蜂晚20时-凌晨2时服务人次创新高

    6月21日消息,随着欧洲杯的开幕,中国消费者,尤其是球迷们,同样进入了"夏季狂欢季",并推动了部分城市的"夜经济"发展. 据便利蜂发布的数据显示,晚间20时-凌 ...

最新文章

  1. bootstrap 标题居中加颜色_BootStrap从基础到项目实战_第1季_03章_01_CSS样式之栅格布局...
  2. 《微服务设计》读书笔记
  3. pytorch 加载不对齐预训练
  4. 测量角速度_锡膏的粘度如何正确鉴别和精确测量?
  5. OO-ALV标准工具栏按钮
  6. 青岛旅游学校计算机证书,【我和我的旅校】青岛旅游学校优秀毕业生郭千瑜
  7. 分页插件PageHelper的使用方法
  8. uniapp ---- 添加分页
  9. 南阳理工ACM111
  10. oracle多次发运,EBS 发运管理操作实例11——延迟交货(Backorder)
  11. Linux 3.x 的platform
  12. Stderr: VBoxManage.exe: error: VT-x is not available (VERR_VMX_NO_VMX) VBoxM
  13. (转)如何动手打造属于自己的智能家居
  14. 惊了,Python 民俗社会科学项目,看看能否预测【面向哪里写BUG少】
  15. HTTPSConnectionPool(host=‘***‘, port=443): Read timed out.
  16. 国内银行应用软件项目外包模式探讨(转)
  17. FutureTask源码解析
  18. 1:什么是空指针?区分 NULL、0 和 ‘\0‘
  19. 亚马逊商城评论数据分析与可视化(KNN预测评分,绘制云图)
  20. Python Basic - readlines()方法

热门文章

  1. 项目中基于Rest的Wcf服务发布以及iBatisNet框架的使用(下)
  2. 苹果裁撤自动驾驶项目员工200余人
  3. Python中fnmatch模块的使用
  4. 汉得宣布开源:基于容器的企业级应用 PaaS 平台
  5. Base64的解码和编码
  6. 深度学习的异构加速技术(一):AI 需要一个多大的“心脏”?
  7. 4星|《高手》:会讲故事的科学家的经管社科书读书笔记
  8. 005_系统运维之SLA与SLO的关系
  9. PHP根据IP获取当前所在地地址
  10. VTK与Qt整合的示例